[R350] [PPC] totem, vlc hang playing movies using xv extension on power g5

Bug #239564 reported by Sergey V. Udaltsov on 2008-06-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Medium
Tormod Volden

Bug Description

I am using various media players on power g5 for watching movies. Every so often X hangs badly (along with the kernel) in the middle of the movie. The screen turns blank. The sound of movie changes to single tone.

lspci -nn reports:
0000:f0:10.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon R350 [Radeon 9800 Pro] [1002:4e48]

> Does ctrl+alt+f1 take you to a console?
No
> Does ctrl+alt+backspace restart X?
No
> Does mouse pointer still move?
No
> Does the keyboard LED come on when hitting the CAPSLOCK key?
No
> Can you ssh into the system from another computer?
No

Unfortunately I cannot backtrace - it hangs really bad.

Did I miss anything?

PS This is a dupe of the closed bug, the previous attempt did not have enough info. Hopefully this one will go better.

Tormod Volden (tormodvolden) wrote :

Thanks for your report. Can you please try intrepid with the newest -ati driver? Here you can also try Option "AccelMethod" "XAA". Which is the duplicate bug?

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
status: New → Incomplete

Since this is powerpc architecture, I am very cautios in relation to upgrade to unstable version. But I am planning to do that early in September - then I'll try. BTW, would it make sense to build just latest ati driver without full upgrade to intrepid? Does ubuntu apply many patches?

Changing to XAA - I will give it a try.

Hi Sergey,

Ubuntu does not carry a lot of patches against -ati, so building it against your current install would probably be okay.

Hi Bryce

Anyway, I am on intrepid now. Testing...

Tormod Volden (tormodvolden) wrote :

Hmm, I think I meant Option "AccelMethod" "EXA" because XAA is the default. You may also try Option "AGPMode" "1", since kernel crashes often are related to AGP trouble.

Bryce Harrington (bryce) wrote :

I've cherrypicked a recent Xv fix from upstream, and built this deb for testing:

http://www.bryceharrington.org/ubuntu/Ati/
 xserver-xorg-video-ati_6.9.0+git20080826.a3cc1d7a-2ubuntu4~bwh2_i386.deb

I do not think it fixes this issue, since the issue it fixes is display corruption, not a kernel lockup. However it would be helpful to rule it out, if you wouldn't mind testing it?

You mentioned the kernel is hung when this happens - how are you determining this? If the kernel is hanging, we probably ought to refile this bug against 'linux' and ask ogasawara to look.

Tormod's suggestion of testing AGPMode settings is also a very good recommendation. That option takes values 1, 2, 4, 8. Checking with Option "AccelMethod" "EXA" would also be worthwhile, although I don't think we're ready to switch to EXA over XAA as the default for -ati yet, but if it solves the issue it would be good to know.

So far, intrepid with XAA works ok. I will keep testing. If it does not help, I'll check your .deb Bryce, thanks!

Just yesterday I got it hang again.

Section "Device"
        Identifier "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
        Driver "ati"
        BusID "PCI:240:16:0"
        Option "UseFBDev" "false"
        Option "XAANoOffscreenPixmaps"
        Option "AccelMethod" "EXA"
        Option "AGPMode" "4"
        Option "DRI" "true"
        Option "AddARGBGLXVisuals" "true"
EndSection

Bryce: unfortunately I cannot use your deb, since my machine is power g5 ;)

Also, I have _impression_ (but I am not 100% sure) it happens on 2nd and subsequent movies played within same X session. If I make it hang on the first movie, I'll report.

Additional info (got using ssh): after the screen gets blank, the monitor switches to "no signal" state, Xorg takes almost all of CPU. Cannot be killed (even with -9).

Bryce Harrington (bryce) on 2008-11-04
Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Hi Sergey,

Have you experimented with different AGPMode settings? There are some known issues relating to AGP incompatibilities between the video driver and the host bridge which can cause problems similar to your symptoms. See https://wiki.ubuntu.com/X/Quirks/#ATI AGP Mode Quirk for details.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Hi Bryce

No I did not. Currently it is 4. I will set it to 2 and wait for another hang.

Set AGPMode to 2. X hang (screen and kbd). CPU is busy. It took some while to get to the system using ssh and reboot.

Bryce Harrington (bryce) on 2009-02-18
Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
status: Incomplete → Confirmed

AGPMode 1 is a disaster. X server takes 233% CPU (on 2-CPU box:), the mouse cursor is moving very slowly, 1/3 (upper) of the screen is black... It took some patience to ssh, change xorg.conf back.

So, it seems only AGPMode 4 makes sense for me now. At least with EXA, DRI enabled.

Bryce Harrington (bryce) wrote :

Okay, thanks for confirming that. 4 is the default so I guess a quirk is unnecessary.

Next I'd like to send this bug upstream for Alex to look at, since I'm out of clue, but he'll want to see the issue reproduced on 6.11.0, so we'll wait until you have a chance to reproduce it on jaunty. Alpha-5 will be released within a couple days and will have 6.11.0 so that would be worth testing against if you just wanted to test a livecd.

When you do get a chance to test again, please attach a fresh Xorg.0.log we can use when forwarding it upstream.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

A small update. I cannot really test this fully on jaunty because of #345651. movie players seem to work but somewhat slow...

Bryce Harrington (bryce) on 2009-05-14
summary: - [PPC] [R350 9800 pro] [Hardy] totem, vlc hang playing movies using xv
+ [R350 9800 pro] [PPC] [Hardy] totem, vlc hang playing movies using xv
extension on power g5
Bryce Harrington (bryce) on 2009-05-15
tags: added: freeze
tags: added: videoplayback
Bryce Harrington (bryce) on 2009-06-26
summary: - [R350 9800 pro] [PPC] [Hardy] totem, vlc hang playing movies using xv
- extension on power g5
+ [R350] [R350 9800 pro] [PPC] [Hardy] totem, vlc hang playing movies
+ using xv extension on power g5
Bryce Harrington (bryce) on 2009-06-26
summary: - [R350] [R350 9800 pro] [PPC] [Hardy] totem, vlc hang playing movies
- using xv extension on power g5
+ [R350] [PPC] [Hardy] totem, vlc hang playing movies using xv extension
+ on power g5
Bryce Harrington (bryce) on 2009-08-12
tags: added: ppc
Bryce Harrington (bryce) on 2009-08-13
tags: added: hardy
Robert Hooker (sarvatt) on 2010-03-22
summary: - [R350] [PPC] [Hardy] totem, vlc hang playing movies using xv extension
- on power g5
+ [R350] [R350] [PPC] [Hardy] totem, vlc hang playing movies using xv
+ extension on power g5
Robert Hooker (sarvatt) on 2010-03-22
summary: - [R350] [R350] [PPC] [Hardy] totem, vlc hang playing movies using xv
- extension on power g5
+ [R350] [PPC] totem, vlc hang playing movies using xv extension on power
+ g5
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Does it make sense to test it with non-released natty (there is no official ISO for PPC)?

Tormod Volden (tormodvolden) wrote :

Yes, if it is not too much trouble that would be nice. There is no official Ubuntu support, and this issue should probably be forwarded upstream, which will require testing of latest versions.

I will test it once I get bootable 11.04. Currently it is not bootable because of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/720911

Bryce Harrington (bryce) on 2012-02-04
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Jonatã Bolzan Loss (jbopen) wrote :

Issue still present in Ubuntu 14.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments