[R480] Login and default panels don't utilize full resolution

Bug #230818 reported by Forage on 2008-05-15
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

After installing Ubuntu 8.04, or running it from the live CD for that matter, the top and bottom panels don't utilize the maximum resolution. The same goes for the login screen. While the bottom panel can be dragged to the bottom of the screen, resulting in a maximized width panel, I've found no way to achieve the same for the top panel. Applications, on the other hand, can be maximized to the full screen resolution. When prompted for the password for admin actions, only the small resolution is being grayed out.

Attached you'll find three images, illustrating the issue.

How can I fix the issue? I'd like to have everything working on the full desktop resolution.

Specs:
OS: Ubuntu 8.04 (all updates installed)
Graphics card: ATI Radeon X850 (default Ubuntu drivers)
Screen: Eizo FlexScan S1931 (1280x1024)

Forage (forage) wrote :
Forage (forage) wrote :
Forage (forage) wrote :
Forage (forage) wrote :
Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Can you add /var/log/Xorg.0.log and the output of 'lspci -vvnn' ?
Seems related with bug 200805.

Forage (forage) wrote :

I should add that after installing the restricted ATI drivers the problem was gone. Because of the changes I'm not sure if the first log is still useful. Let me know if this is the case, I could boot the live CD to reproduce the same effect if that on creates a log as well.

Forage (forage) wrote :
Changed in xserver-xorg-video-ati:
status: Incomplete → New
Tormod Volden (tormodvolden) wrote :

Please attach the output from "xrandr -q" and if possible from the live CD.

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
status: New → Incomplete
Forage (forage) wrote :

Here's the output of the installed system. Live CD output comming up

Forage (forage) wrote :

Here's the output of the Live CD

Let me know if you need any more info

Tormod Volden (tormodvolden) wrote :

The driver thinks there is something connected to the S-video output, using 800x600, and uses "clone" mode for the two screens:

S-video connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600 59.9*+ 60.3

Can you please try the command: xrandr --output S-video --off"

It sounds pretty much like bug #156550.

Bryce Harrington (bryce) wrote :

156550 seems to have been an xscreensaver issue; I suspect this one to be different.

Prodoc, could you please re-test with the Intrepid Alpha-4 (or newer) LiveCD and attach your /var/log/Xorg.0.log? If the issue can still be reproduced there, we can probably forward this upstream.

Changed in xserver-xorg-video-ati:
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Hi Prodoc, it's been some time since we last heard from you - are you still interested in this bug? If so, it'd be great if you could re-test it against intrepid, and provide the info mentioned above. Otherwise, we'll close this as expired.

Forage (forage) wrote :

Bryce Harrington: Yes, I'm still willing to help out even though I don't have the issue any more myself after installing the ATI drivers, it might be useful for others. Sorry for the delay I didn't have the time to look into it when you last posted a reply and forgot all about it after that. Can you tell me where I can download this Intrepid live cd? I had a look at several mirrors but on all of them the Intrepid folder was empty.

Tormod Volden: There is something connected to the S-video output, my TV through the DVD player/recorder. I forgot to mention this in my initial post (I don't use it a lot). This, however, shouldn't be a reason for Ubuntu to just assume that that resolution should be used in clone more.

Bryce Harrington (bryce) wrote :

Sure, ISO's can be found at http://cdimage.ubuntu.com/daily/current/. Thanks ahead of time.

Bryce Harrington (bryce) on 2008-11-04
Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Tormod Volden (tormodvolden) wrote :

Yes, the driver assumes that all connected screens should be used, and will set up clone mode. If you want it to ignore one specific output, associate outputs to a monitor section and use the ignore option (see links on http://wiki.x.org/wiki/Projects/XRandR).

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
Forage (forage) wrote :

I'm, again, terribly sorry for the long delay. I've been working my ass off lately and I didn't even get round to buy some new empty discs to burn the image on, until now. I've tested it with the stable Ubuntu 8.10 release and it, luckily, works like a charm now. I.e. this bug can be closed.

@Tormod: Thanks for the XRandR hint, looks interesting, I'll have a look at it.

Tormod Volden (tormodvolden) wrote :

Thanks, that's good to hear. Get yourself a USB memory stick so that you don't have to burn all those CDs :)

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers