can't get dual monitor to work on toshiba laptop ati radeon mobility M6

Bug #221404 reported by Xavi on 2008-04-24
8
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

I had never been able to use dual monitor on Linux with this laptop, but it works out of the box on windoze

Boot on linux, once upgraded to 8.04 Beta5.

I Plugged an external monitor to the latop (toshiba satellite 1900-102)

I went to System > Preferences > Screen resolution, unclicked to clone mode, pressed on detect monitors, set the postion of external screen to the right, applied changes, and still cloning the screen, and not extending desktop as I expected.

I send two images: the effect I report (picture of both screens), and a screenshot of the full screen, showing that in fact the computer takes the screen bigger than it is (but not enough to extending the desktop on the external screen?)

Xavi (xavidp) wrote :

the picture of both screens next to each other showing cloned screen, even if config. was set to avoid cloning and thus extending desktop

Castracipolla (johannesgambari) wrote :

Hello there!
I am using a Toshiba Satellite L30-101 with Ubuntu 8.04 and I am also unable to extend my desktop on external screen. Any ideas?

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

I installed the latest xubuntu, because my laptop has a centrino processor
and runs better with the xface configuration. I update it regularly.

I tried the dual screen in it a while ago. It still did not work. I tired it
a while ago in 8.04 . I still have the same problem. I used to have Vista
home edition (it is thanks to that operating system that I discovered
ubuntu) the only thing is that with Vista home edition I could have the dual
monitor configuration no problem.

Thank you for your reply.

Johannes

On Tue, Sep 23, 2008 at 9:30 PM, Jean-Baptiste Lallement <
<email address hidden>> wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? Can you try with latest Ubuntu release? Thanks in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> --
> can't get dual monitor to work on toshiba laptop ati radeon mobility M6
> https://bugs.launchpad.net/bugs/221404
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu: Incomplete
>
> Bug description:
> I had never been able to use dual monitor on Linux with this laptop, but it
> works out of the box on windoze
>
> Boot on linux, once upgraded to 8.04 Beta5.
>
> I Plugged an external monitor to the latop (toshiba satellite 1900-102)
>
> I went to System > Preferences > Screen resolution, unclicked to clone
> mode, pressed on detect monitors, set the postion of external screen to the
> right, applied changes, and still cloning the screen, and not extending
> desktop as I expected.
>
> I send two images: the effect I report (picture of both screens), and a
> screenshot of the full screen, showing that in fact the computer takes the
> screen bigger than it is (but not enough to extending the desktop on the
> external screen?)
>

Dimitrios Symeonidis (azimout) wrote :

assigning to xserver-xorg (generic) until we know the specific graphics unit
could you please attach the output of "lspci -vvnn"?
also, ubuntu 9.04 includes some radical changes to multiple monitors (xorg 1.6). could you try the latest jaunty alpha and tell us if the issue is fixed for you?
thank you, and good luck

Bryce Harrington (bryce) wrote :

@Dimitrios, thanks for triaging this. Btw also make sure to always ask for Xorg.0.log with X bugs, as we'll need it in addition to lspci -vvnn to determine which video driver they're using.

Xavi, please attach your /var/log/Xorg.0.log from after reproducing the issue.

If you're using the -fglrx driver (which is what I'd guess based on the laptop model and symptoms), note that it did not support xrandr in Hardy, and thus you need to use ati's config tools, not the Screen Resolution capplet. This issue was fixed in gutsy, as -fglrx now has xrandr support.

Anyway, so my guess is that this is a fixed issue, but please attach your Xorg.0.log from testing on 8.04. If you can test against Jaunty, that would determine it for sure.

Bryce Harrington (bryce) on 2009-04-02
Changed in xorg (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2009-04-02
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Xavi (xavidp) wrote :

Hey! It's working on Ubuntu 8.10 Intrepid!
Brilliant, after 6 years of trying it with this pentium 4 laptop, I can finally use GNU/Linux with a dual monitor environment!
Comments: I went first to "System > Admin > Multiple monitors", which opened GRandr, but I couldn't set the dual monitor properly there (it was complaining about that the screen resolution was set to a higher value than allowed by the hardware, even if it was 1074x768 60Hz, which is supported by the laptop and the external monitor.

Then I went to "System > Preferences > Screen resolution", and I could set up easily the dual monitor config. already at the first attempt. All default value detected by the program, extend desktop, save changes, and restart x . Done!

Great work to those of you who improved xorg, ubuntu, grandr or whatever made this thingy work under GNU/Linux.

Thanks

P.S. I could provide those files you requested to you if needed. I understand it's not necessary since it's working fine. If needed for whatever reason, I will send you those files, or whatever you need from my config.

Dimitrios Symeonidis (azimout) wrote :

Ok then, marking as fix released. I'm glad it works for you. No, the files asked are no longer necessary.
Good luck!

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Johannes

Johannes Gambari
Research Fellow at Centre for Quantum Technologies
Singapore

Confirm that you know Johannes Gambari:
https://www.linkedin.com/e/8hh7sp-gxx30l8i-1d/isd/5681815265/NSBqXihe/?hs=false&tok=3hjB8cH-p1F541

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/8hh7sp-gxx30l8i-1d/qwddmaxrrP97l3p28fpqk5lrDY5aooVp-pX36Mf/goo/221404%40bugs%2Elaunchpad%2Enet/20061/I1977088917_1/?hs=false&tok=16hfU7qhp1F541

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers