[Mobility 9200] [Needs AGPMode quirk] Kubuntu live CD (and install) hangs during boot on Vaio PCG-K215Z

Bug #221329 reported by SteveH on 2008-04-24
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

The live CD hangs during boot.

I've removed the quiet and splash boot options and just before the "Black screen of death", I see:

Starting K Display manager ....
Starting Avahi ...

Running on Sony Vaio PCG-K215Z laptop

Note. This has an ATI Mobility Radeon 9200 graphics card, which caused problems when I upgraded to Gutsy. I eventually fixed by downgrading the driver (xserver-xorg-video-ati) to the Fiesty version: 1:6.6.3-2ubuntu6.

Obviously no such option is available when booting from a Live CD.

[quirk]
AGPMode needed: 1
Model: Vaio PCG-K215Z,
Host Bridge: [1002:cbb2] ATI Technologies Inc RS200/RS200M AGP Bridge [IGP
340M] (rev 02)
Graphics Card: [1002:5c61] ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200
(AGP)] (rev 01)
Card subsystem: [104d:8175] Sony Corporation Device
HW changes: ram & hdd replaced
BIOS: (unknown)

SteveH (steve-systemax) wrote :

This is also a problem when Hardy is installed.

And because of a package conflict, xserver-xorg-video-ati can't be downgraded to the 1:6.6.3-2 version.

at this stage there appears to be no way to upgrade to Hardy.

Timo Aaltonen (tjaalton) wrote :

Does it boot if you use the failsafe option (or similar, don't remember what it was called)? It should use the vesa driver then.

Changed in xorg:
status: New → Incomplete

Hi,

No. I just tried (Kubuntu 8.04.1): "Safe Graphics Mode" twice and it still
locks up.

When I have a spare 15 minutes, I'll give OpenSuse 11 a go (in "safe" mode). I
know it doesn't work in "normal" mode.

Steve H.

On Thursday 31 July 2008 08:19:34 Timo Aaltonen wrote:
> Does it boot if you use the failsafe option (or similar, don't remember
> what it was called)? It should use the vesa driver then.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Sourcepackagename: xorg => xserver-xorg-video-ati
> Status: New => Incomplete

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

SteveH (steve-systemax) wrote :

Hi,

OpenSuse 11 LiveCD (in Failsafe mode) works.

In sysinfo it shows Driver: radeon. I'm not sure if this is what is being used
or what it believes should be used.

Steve H.

On Thursday 31 July 2008 08:19:34 Timo Aaltonen wrote:
> Does it boot if you use the failsafe option (or similar, don't remember
> what it was called)? It should use the vesa driver then.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Sourcepackagename: xorg => xserver-xorg-video-ati
> Status: New => Incomplete

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

I am experiencing a similar problem, also with an ATI 9200. LiveCD hangs on startup (I only can see a big white square). It gets solved adding the "xforcevesa" option.

When I install it, it dispays KDM login properly, and I can even start a session in failsafe console mode. But when I start a normal session, it shows the splah screen (without the messages, just the graphics: no fonts), and then the big white square. Sometimes it appears what looks like the edge of an enormous font. This makes me think the problem has something to do with font rendering.

If I login in failsafe console and select vesa screen driver, it works, but obviously I cannot take advantage of the graphic card's features.

I can help posting the logs, if somebody tells me what log can be useful.

Best regards. Juan.

I get a little further with the xforcevesa boot option. The desktop is
displayed (rather than nothing!) but it still hangs.

Steve H.

On Monday 04 August 2008 12:17:11 Juan Miguel Corral wrote:
> I am experiencing a similar problem, also with an ATI 9200. LiveCD hangs
> on startup (I only can see a big white square). It gets solved adding
> the "xforcevesa" option.
>
> When I install it, it dispays KDM login properly, and I can even start a
> session in failsafe console mode. But when I start a normal session, it
> shows the splah screen (without the messages, just the graphics: no
> fonts), and then the big white square. Sometimes it appears what looks
> like the edge of an enormous font. This makes me think the problem has
> something to do with font rendering.
>
> If I login in failsafe console and select vesa screen driver, it works,
> but obviously I cannot take advantage of the graphic card's features.
>
> I can help posting the logs, if somebody tells me what log can be
> useful.
>
> Best regards. Juan.

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

After installing with xforcevesa, you can try the following:

- Log in through kdm in failsafe console mode (by choosing it on the "Sessions" menu)
- Then type "kwin &". Now you have a window manager.
- Type "kcontrol"
- Open the X display configurator, and set the driver to "VESA".
- Restart.

Your graphic card should work now, but in VESA mode, so no 3D accel.

Install hangs.

The first Ubiquity screen (Welcome/choose language) is OK.

When I click on "Forward", the next screen (Where are you/choose
city/country/time zone) displays - but hangs as soon as I click on the
Selected City selection box. No mouse or keyboard - not even Caps Lock.

I gave it about 5 minutes before giving up (as I know it can be slow), but
there was no further activity on CD or HD.

Steve H.

On Wednesday 13 August 2008 14:18:45 Juan Miguel Corral wrote:
> After installing with xforcevesa, you can try the following:
>
> - Log in through kdm in failsafe console mode (by choosing it on the
> "Sessions" menu) - Then type "kwin &". Now you have a window manager.
> - Type "kcontrol"
> - Open the X display configurator, and set the driver to "VESA".
> - Restart.
>
> Your graphic card should work now, but in VESA mode, so no 3D accel.

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

I have also been encountering problems trying to install xubuntu (hardy heron) on a Sony K215Z. The installation process would hang shortly after the graphical environment came up.

After reading https://bugs.launchpad.net/xserver-xorg-driver-ati/+bug/220345 and http://ubuntuforums.org/showpost.php?p=4963984&postcount=24 I tried adding the following kernel options

nohz=off
highres=off

This got me through the installation.

I will report back on overall system stability.

Bryce Harrington (bryce) wrote :

Can you ssh into the system and retrieve the /var/log/Xorg.0.log while it's hung? The error message may be shown there. (So far we don't have enough information to begin troubleshooting on this issue.)

Changed in xserver-xorg-video-ati:
status: Incomplete → New
status: New → Incomplete

Here's the log. It's from Mint Linux KDE, since I don't have access to a Kubuntu installation, but I have tried Kubuntu 8.04.1 in the past on the same machine and happened the same bug.

I can't see anything wrong in the log.

--- El jue, 28/8/08, Bryce Harrington <email address hidden> escribió:
De: Bryce Harrington <email address hidden>
Asunto: [Bug 221329] Re: Kubuntu Hardy 8.04 live CD (and install) hangs during boot
Para: <email address hidden>
Fecha: jueves, 28 agosto, 2008 11:04

Can you ssh into the system and retrieve the /var/log/Xorg.0.log while
it's hung? The error message may be shown there. (So far we don't
have
enough information to begin troubleshooting on this issue.)

** Changed in: xserver-xorg-video-ati (Ubuntu)
       Status: Incomplete => New

** Changed in: xserver-xorg-video-ati (Ubuntu)
       Status: New => Incomplete

--
Kubuntu Hardy 8.04 live CD (and install) hangs during boot
https://bugs.launchpad.net/bugs/221329
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Correo Yahoo!
Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
Regístrate ya - http://correo.yahoo.es

Bryce Harrington (bryce) on 2008-09-12
Changed in xserver-xorg-video-ati:
status: Incomplete → Triaged

Hi Alex, how did you manage to add those 2 kernel options to enable the hardy installation?

Bryce Harrington (bryce) wrote :

Hi SteveH,

Could you please test against Intrepid? A number of improvements have been made to the -ati driver since hardy, and it would be worthwhile to see if you can reproduce the issue there. You can obtain an Intrepid ISO from http://cdimage.ubuntu.com/releases/intrepid/ . Thanks ahead of time.

Changed in xserver-xorg-video-ati:
status: Triaged → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati:
status: Incomplete → Invalid
Bryce Harrington (bryce) wrote :

Sorry, a script misfired and closed this bug incorrectly. I've reopened it.

Changed in xserver-xorg-video-ati:
status: Invalid → Incomplete

Hi,

I've already tried Intrepid (Beta & RC) and neither solved the problem. I'll
give the final release a try in the next day or so.

Steve H.

On Wednesday 29 October 2008 22:42:07 Bryce Harrington wrote:
> Hi SteveH,
>
> Could you please test against Intrepid? A number of improvements have
> been made to the -ati driver since hardy, and it would be worthwhile to
> see if you can reproduce the issue there. You can obtain an Intrepid
> ISO from http://cdimage.ubuntu.com/releases/intrepid/ . Thanks ahead of
> time.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Triaged => Incomplete

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

Bryce Harrington (bryce) on 2008-11-04
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Incomplete → Confirmed

Thanks for providing the Xorg.0.log. It looks like your monitor is providing invalid EDID:

(II) RADEON(0): EDID vendor "XXX", prod id 0
(II) RADEON(0): DDCModeFromDetailedTiming: Ignoring tiny 1x1 mode
(II) RADEON(0): Using EDID range info for horizontal sync
(II) RADEON(0): Using EDID range info for vertical refresh
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)

Notice prod id 0, and the x0.0 refresh rate in the modeline there. Looks like it's using some sort of NULL'd edid. Weird.

Please collect the output from the following commands:

 # ddcprobe
 # get-edid | parse-edid
 # xrandr --verbose

As well, test setting this in xorg.conf:

 Section "Device"
      ...
      Option "IgnoreEDID" "1"
 Section

It would also be useful to see the xorg.conf and the Xorg.0.log from your OpenSuSE failsafe session.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

I will try the things you say as soon as I can (I have recently changed my monitor, so I'll have to plug the old one). But I would like to tell you a couple of things that may be of interest:

- I don't use a Vaio laptop, but a generic desktop PC with a cheap generic Radeon 9250 card and a cheap generic TFT Monitor.

- On the same machine that fails Kubuntu Hardy, Ubuntu Hardy works perfectly, and the screen resolution is properly set to 1280x1024 by default. Actually, I think Kubuntu also sets the resolution OK, but the desktop is unusable.

Maybe the bug I am experiencing is different from the one reported by Steve. But I will try what you say, and send you the info.

Ugnius S (ugnius40) wrote :

Hi,

I've got same model laptop and was not able to install any recent Linux distribution on it due to this bug. Some of my findings:
X/K/Ubuntu 8.04.1 froze at random place on Live CD bootup splash screen (nohz=off highres=off helps to get through this).
Ubuntu 8.10 same as Hardy (with nohz=off ...) lock at point where X should start (mouse cursor works, keyboard does not respond.
I am able to boot and install if acpi=off parameter is passed (but then wireless card does not work).
I was able to boot live cd into recovery mode, and "init 5" to get X running. Haven't tried installing though.

When in Live CD recovery mode I was not able to do:
# ddcprobe
# get-edid | parse-edid
no required packages installed and apt-get does not find them.

Next week i'll probably be able to do more testing.

Ugnius S (ugnius40) wrote :

Sending xrandr --verbose output when in Live CD recovery mode + init 5.

Sorry but now I am not able to install Ubuntu 8.10 on this computer and test IgnoreEDID option, probably next week.

I do not know how to get Xorg.log when laptop halts when booting normally (will try to connect CAT5 cable and ssh to it if possible, next week also).

Ugnius S (ugnius40) wrote :

Just ssh'ed to machine when booting normally (during black screen) got Xorg.0.log,
also did ddcprobe, get-edid | parse-edid

xrandr --verbose returned:
Can't open display
of course.

Ugnius S (ugnius40) wrote :

Also adding
get-edid | parse-edid

Forgot to mention I'm using Ubuntu 8.10, fresh install & updates.

Ugnius S (ugnius40) wrote :

And ddcprobe result,

by the way, adding IgnoreEDID 1 did not change anything, it still hangs.

Also strange thing, I rebooted computer via ssh "reboot", computer seems to have rebooted but screen was still blank, no bios splash, nothing, had to turn it off using power button.

Also there is new bug (seems to be the same problem, id 288614) report open against KUbuntu 8.10, should I also post my findings there?

Bryce Harrington (bryce) wrote :

@Jaun, yeah, based on the number of differences between your setup and Steve's, I suspect you have some unrelated problem and should file a new bug on it. We'll focus on SteveH's issue (and presumably Ugnius' since he has the same HW).

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2008-12-19
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Okay, after investigating how NULL EDID is handled a bit more thoroughly (for #288807), I think I understand what is happening.

In general monitors are supposed to provide either EDID or DDC data about their capabilities. Various monitors don't do this, or do this so improperly that they may as well not be doing it. Old model Vaio laptops seem to be particularly afflicted by this. I can imagine that many off-brand monitors do as well.

In the case of laptops, I can think of a couple ways to hardcode our way around the problem (see proposed solutions on bug #288807).

For desktop systems, well I think there is no way to automatically configure these systems reliably enough, so xorg.conf's will just have to be created in this case. As a better longer term solution for this we're considering an xorg.conf display configuration tool (ref. Alberto Milone's screen-configuration-ui blueprint), but that's going to be in the Jaunty+1/+2 timeframe, and it's going to require user involvement to specify monitor type and so on. Those desperate for a GUI-based solution could look at displayconfig-gtk (there are debs available from one of the reporters on bug #288807), but for a variety of reasons we no longer support that tool in Ubuntu proper.

Bryce Harrington (bryce) on 2009-01-15
Changed in xserver-xorg-video-ati:
status: Triaged → In Progress
Bryce Harrington (bryce) on 2009-02-11
Changed in xserver-xorg-video-ati:
assignee: nobody → bryceharrington

I think SteveH's issue is AGP related and Juan has a completely different issue. SteveH, can you please have a look at https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk ? Juan, please file a new bug.

My Sony laptop had a hardware failure, and I replaced it. So, unfortunately,
I'm unable to help any more. Now running Kubuntu 8.10 on an Acer Aspire and
it's working great.

However, bearing in mind, I couldn't get through the install, I'm not sure
how I could have tried changing AGPMode settings.

Regards,
Steve H.

On Saturday 28 February 2009 16:58:38 Tormod Volden wrote:
> I think SteveH's issue is AGP related and Juan has a completely
> different issue. SteveH, can you please have a look at
> https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk ? Juan, please
> file a new bug.

________________________________________________________________________
Misco is a division of Systemax Europe Ltd. Registered in Scotland Number 114143. Registered Office: Caledonian Exchange, 19a Canning Street, Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

Ugnius S (ugnius40) wrote :

On Monday 02 March 2009 08:57:04 SteveH wrote:
> My Sony laptop had a hardware failure, and I replaced it. So,
> unfortunately, I'm unable to help any more. Now running Kubuntu 8.10 on an
> Acer Aspire and it's working great.
>
> However, bearing in mind, I couldn't get through the install, I'm not sure
> how I could have tried changing AGPMode settings.
Hi, I still do have a laptop (though need to find new hdd for it), & same
problem, will try to install and test with AGPMode #, thanks for not closing
this bug yet.

Ugnius

>
> Regards,
> Steve H.
>
> On Saturday 28 February 2009 16:58:38 Tormod Volden wrote:
> > I think SteveH's issue is AGP related and Juan has a completely
> > different issue. SteveH, can you please have a look at
> > https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk ? Juan, please
> > file a new bug.
>
> ________________________________________________________________________
> Misco is a division of Systemax Europe Ltd. Registered in Scotland Number
> 114143. Registered Office: Caledonian Exchange, 19a Canning Street,
> Edinburgh EH3 8EG. Telephone +44 (0)1933 686000.

Ugnius S (ugnius40) wrote :

On Saturday 28 February 2009 16:58:38 Tormod Volden wrote:
> I think SteveH's issue is AGP related and Juan has a completely
> different issue. SteveH, can you please have a look at
> https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk ? Juan, please
> file a new bug.
Hi,

I've installed Ubuntu 8.10 Intrepid Ibex using acpi=off kernel switch,
adding 'Option "AGPMode" "1"' to Device section of xorg.conf seems to have
fixed the problem, ubuntu boots normally I can use wireless card and other
devices now, thank you very much for a hint. I've tested with other AGPMode
settings (2, 4, 8) but with no luck, 1 seems to be the only one which works.
Some info:
AGPMode needed: 1
Model: Vaio PCG-K215Z,
Host Bridge: [1002:cbb2] ATI Technologies Inc RS200/RS200M AGP Bridge [IGP
340M] (rev 02)
Graphics Card: [1002:5c61] ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200
(AGP)] (rev 01)
Card subsystem: [104d:8175] Sony Corporation Device
HW changes: ram & hdd replaced
BIOS: (unknown)

Thanks again,
Ugnius

description: updated
Changed in xserver-xorg-video-ati:
assignee: bryceharrington → tormodvolden
Tormod Volden (tormodvolden) wrote :

http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=c39ca66a7e216b7492fc5e3680ac535831cfb9a1

The needed quirk is already included in Jaunty. For Intrepid packages, see my PPA.

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers