[RV280 9200] Freeze with ati driver during boot on 8.04

Bug #214105 reported by Walldorf2000 on 2008-04-08
6
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

My system freezes during start up. The monitor switches off and even the keboard does not react etc on caps lock any more.

Changing driver from ATI to VESA fixed the problem but system is awfully slow.

System worked fine with 3D acceleration etc. on 7.04. Then I upgraded to 7.10 and the system freezed.

I tried the 7.10 boot CD and the system freezed with the same symptoms, too.

I tried booting with my still installed 7.04 kernel, but no change.

Thus I upgraded to 8.04 but with exactly the same result.

When I dual boot to Win98 SE everything works still fine. Thus I guess my customizing is not relevant and the system does not have a hardware issue.

This is what I tried so far without any change in the symptoms:
- use 7.04 kernel from my previously running system
- update to the new driver from 04/04/2008 from here https://wiki.ubuntu.com/XorgOnTheEdge
- delete xorg.conf or use old xorg.conf
- start in recovery mode and used the fix option for xorg
- remove the higher screen resolutions from my monitor settings
- ati driver options in xorg.conf
    - Option "BusType" "PCI"
    - Option "LVDSBiosNativeMode" "FALSE"

ProblemType: Bug
Architecture: i386
Date: Tue Apr 8 20:10:42 2008
DistroRelease: Ubuntu 8.04
Package: xserver-xorg-video-ati 1:6.8.0+git20080404.5f5e21bb-0ubuntu0tormod~hardy
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.24-15-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Walldorf2000 (walldorf2000) wrote :
Tormod Volden (tormodvolden) wrote :

Thanks for your clear and informative report. Can you please provide an Xorg.0.log? Try also Option "DRI" "off".

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
status: New → Incomplete
Walldorf2000 (walldorf2000) wrote :

Thank you for your fast response.

Option "DRI" "off" does make a difference. The system still boots to a blank screen but the system does not freeze. Thus I can use Ctrl+Alt+F1 to use the command shell.

Tormod Volden (tormodvolden) wrote :

Your log is from running with the "vesa" driver. Can you get one with the "ati" driver?

Walldorf2000 (walldorf2000) wrote :
Walldorf2000 (walldorf2000) wrote :
Tormod Volden (tormodvolden) wrote :

Can you please also get a log with Option "BusType" "PCI" ?

Walldorf2000 (walldorf2000) wrote :

Now with both options active:
   "BusType" "PCI"
   "DRI" "off"

Same symptoms as before. System shows blank screen after boot but does not freeze. I can switch to TTY1 for a command prompt.

Walldorf2000 (walldorf2000) wrote :

Is there any chance for a workaround to get the ATI driver running again?

Tormod Volden (tormodvolden) wrote :

Can the blank (but not frozen) screen be due to the resolution that is picked?
(II) RADEON(0): Output VGA-0 using initial mode 1440x900

All similar symptoms reported has been AGP trouble. Your case is also failing with PCI, so I don't really know. Or maybe you have two issues, one with the monitor/blank screen, and another with AGP freezing up. Any chance you can try another monitor?

Walldorf2000 (walldorf2000) wrote :

Yes maybe I'm hit by two different problems at the same time. At least one of them is a clear regression.

I'm willing to help to triage the problem even we find a work around. The 8.04 installation CD should be able to start a X server like 6.10 and 7.04. When you think I should file another bug for one of the problems, I will do that.

Unfortunately I do not have a monitor which can display 1440x900. I've got a 19" LCD with 1280x1024 and two different 17" CRT which can both also display.1280x1024 (but not in a good quality).

Highest resolution in xorg.conf is 1152x864. This is the resolution I used. Actually I don't know where the resolution values are stored in modern xrandr times?!

How can I change the initial mode?

Tormod Volden (tormodvolden) wrote :

Can you please run:
 xrandr -q -d :0 > xrandr.txt 2>&1
on a console after switching from the black screen and attach xrandr.txt

Walldorf2000 (walldorf2000) wrote :

xrandr -q -d :0 > xrandr.txt 2>&1

delivers in xrandr.txt:
No protocol specified
Can't open display :0

Tormod Volden (tormodvolden) wrote :

Can you get a log with this option in the device section?
 Option "ModeDebug" "true"

Tormod Volden (tormodvolden) wrote :

Thanks. I forgot to answer your question: You should be able to define initial mode with for instance this in the Monitor section:
 Option "PreferredMode" "1152x864"
Or you can set a small "Virtual" size so that it limits the highest resolution.

Walldorf2000 (walldorf2000) wrote :

Thank you very much. System does now boot with radeon driver and direct rendering on.

Thus I have a good workaround. I did not check which of the two options "PreferredMode" Virtual did make the job. When you would like to have any additional tests or information I would be pleased to help you.

Relevant xorg.conf part now looks like (i.e. no BusType odr DRI off option needed):

Section "Device"
 Identifier "Radeon 9250 128MB"
        Driver "ati"
EndSection

Section "Monitor"
 Identifier "Standardbildschirm"
 Option "DPMS"
 HorizSync 28-80
 VertRefresh 43-85
        Option "PreferredMode" "1024x768"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Radeon 9250 128MB"
 Monitor "Standardbildschirm"
 DefaultDepth 24
 SubSection "Display"
  Depth 24
  Modes "1152x864" "1024x768" "800x600" "640x480"
                Virtual 1024 768
        EndSubSection
EndSection

Walldorf2000 (walldorf2000) wrote :

Unfortunately it is not true what I wrote. Size is not enough, the PC does freeze on boot up.

I added "BusType" "PCI".and this works.

Tormod Volden (tormodvolden) wrote :

It seems then you have encountered two independent bugs:

1. The monitor reports that it can do 1440x900 and the driver happily gives it 1440x900 to chew on. The driver (or more correctly, the Xorg server) will pick the highest resolution possible (or the next to highest, I am not sure any longer). The monitor fails.

The frequency ranges in your xorg.conf, where do they come from? The monitor manual?

2. AGP makes the computer freeze, a very common problem (see for instance bug #133192). Can you try the AGPMode option? Older cards can be 1,2 or 4 and the newer ones 4 or 8. Please check the BIOS to see if there's an AGP speed setting.

Walldorf2000 (walldorf2000) wrote :

1. xorg.conf was built up in 7.04 with a Xorg reconfigure. As far I remember I choosed the resolutions there from the offered list.

I can't find 1440x990 in xorg.conf and I have never choosen this resolution. Where does it come from?

HorizSync VertRefresh where manually reduces from me in the hope to get rid of the blank screen. Originally it was
 HorizSync 28-86
 VertRefresh 43-100

2. Option "AGPMode" "4"
works and is much faster, hurray!

Tormod Volden (tormodvolden) wrote :

I am glad you got that AGP thing sorted out!

The 1440x990 is just one of the resolutions reported by the monitor. Can you please run:
 sudo ddcprobe > ddcprobe.txt 2>&1
on a virtual console and attach ddcprobe.txt?

See also more info on https://help.ubuntu.com/community/DebuggingXAutoconfiguration

Tormod Volden (tormodvolden) wrote :

And please rerun
 xrandr -q > xrandr.txt 2>&1
now that you have X working.

Created an attachment (id=15942)
Xorg.0.log with ModeDebug, BusType PCI and DRI off

Reported in Ubuntu Hardy using -ati driver from git 2008-04-04 and xorg-server 2:1.4.1~git20080131-1ubuntu6, https://bugs.launchpad.net/bugs/214105

At start-up an initial mode of 1440x900 is selected, which makes the monitor go black. ddcprobe does not list this resolution, but it appears in the "probed modes".

ATI Radeon 9250 5960 (AGP). (DRI was turned off in the attached log, since the AGP speed mismatch would freeze the computer.)

Created an attachment (id=15943)
ddcprobe output

Yes, AGP thing is sorted out for me, but I'm still convinced that the installation CD should not lock up the complete system while 7.04 and other distros just worked fine.

if your xorg.conf has a monitor section please remove it..

Tormod Volden (tormodvolden) wrote :

Yes, absolutely, that lock-up is not a nice welcome to Ubuntu. Unfortunately we are fumbling in the dark with this AGP setting, and several tries have been made to fix it, but it's always broken for _some_ people. "Other distros" probably use the older version, like the one in 7.04. Can you please attach the log from 7.04? Or, install the old .deb from 7.04 and see if it works without any options in xorg.conf.

And the resolution detection seems certainly broken. ddc does not return 1440x900 so I am not sure why that was chosen, maybe it just fits with the frequency ranges and such. I have filed a bug upstream for this: https://bugs.freedesktop.org/show_bug.cgi?id=15526

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Tormod Volden (tormodvolden) wrote :

Upstream asks you to try without any "Monitor" section, can you please try it? Normally it should work best without any xorg.conf at all, but you'll need a minimal one with the AGPMode option.

Walldorf2000 (walldorf2000) wrote :

How should I built up the xorg.conf? Is the following method appropriate?

I can boot in recovery mode and use the X server recovery function which creates a rudimentary xorg.conf.

Then I replace the "Device" part with
Section "Device"
  Identifier "Radeon 9250 128MB"
  Driver "ati"
  Option "AGPMode" "4"
EndSection

And use the Identifier "Radeon 9250 128MB" in the screen action.

Walldorf2000 (walldorf2000) wrote :

Sorry I did overlook your request for the 7.04 test. I don't have 7.04 on that machine any more. What should I do there?

Boot from 7.04 CD and post Xorg.0.log or something else?

And thank you for all your help so fare. You are doing a great support job here.

Thanks, removing the Monitor section did the trick. How does it work? Is another way of selection done if monitor frequencies are specified? Is the ddc probing then ignored?

If there is no monitor section we just believe the monitor, if there is a monitor section we check the modes against the constraints of the monitor section, which means the timings in the monitor section constrain the modes wrongly.

Walldorf2000 (walldorf2000) wrote :
Walldorf2000 (walldorf2000) wrote :

I created a new xorg.conf with Xfix and updated it as mentioned above.

System boots in 1024 x 768 @ 75 HZ without a problem.

Thus it was a incompatibility between the old xorg.conf and the current Xorg.

Walldorf2000 (walldorf2000) wrote :

Since the old xorg.conf was not heavily customized but created with the former standard tool, I guess upstream should still have a look into it, right?

Tormod Volden (tormodvolden) wrote :

Thanks for the extra info. What I was looking for in the 7.04 log is this:
(II) RADEON(0): [agp] Mode 0x0f000201 [AGP 0x1022/0x7006; Card 0x1002/0x5960]
which tells that AGP x1 was used. And now you need x4. This is not easy to understand...

About the Monitor section, well, upstream doesn't look back :) and doesn't care too much about upgrades. That's our problem. Ideally the Ubuntu upgrade should remove the Monitor section, but it's tricky since some people don't like their xorg.conf to be messed with. But we should document it better.

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
status: Incomplete → Confirmed
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released

Thanks for taking the time to report this bug and helping to make Ubuntu better. In the development cycle for Intrepid there have been some vast improvements in the open source ati video driver and we could use your help testing them. Could you please download the latest Alpha CD image of Intrepid and test this particular bug just using the Live CD? You can find the latest image at http://www.ubuntu.com/testing . Your testing can help make Ubuntu and the open source ati driver even better! Thanks in advance.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Walldorf2000, -ati now ships with "4" as the default value for AGPMode for most hardware, so it would be worth testing Intrepid with either the stock xorg.conf, or no xorg.conf, and check that it picks it up correctly and runs properly.

This AGP setting is a common issue across a LOT of -ati bugs. I've coded up a patch to allow us to quirk specific hardware to set the setting. So, if the defaults *don't* work for you in Intrepid, we can put in a quirk for your hardware. This will make the live cd "just work" for you (and hopefully others with your same hardware combo).

Possible values for AGPMode include 1, 2, 4, 8. You can see what it's currently set to by looking in /var/log/Xorg.0.log. It's worthwhile to test all four values even once you find one that works. If this takes care of it for you, we may be able to establish a quirk to set it for your hardware combo, if you can provide the following data:

  * AGPMode value(s) that work
  * Make/Model of laptop or motherboard
  * Output of lspci -vvnn
  * Is the system all factory hardware, or have any parts been replaced?
  * Is there an AGP Mode in the system BIOS?
    - If so, is it set to the factory default?

For more details on this, please see the "ATI AGP Mode Quirk" section at https://wiki.ubuntu.com/X/Quirks

Walldorf2000 (walldorf2000) wrote :

I'm just downloading the LiveCD and will test it.

@Bryce:
Can I get these information with Hardy? Or can I get all this information with the LiveCD e.g. how can I test all the AGPModes?

The system is build from all kind of left over hardware I found. It is not a ready made PC by a vendor. I try to find out the correct name of the motherboard and check the BIOS this evening.

Bryce Harrington (bryce) wrote :

You can get all the info with an Intrepid LiveCD. Boot it up (either into graphic mode or some recovery mode) and then edit the xorg.conf to set the AGPMode and restart X.

Since it's a hand-built system, don't worry about the questions about factory stuff. But BIOS settings are quite relevant here.

Walldorf2000 (walldorf2000) wrote :

All AGP related settings in Bios I found are (on factory defaults):
 - AGP Aperture Size (MB) - Value is 64
 - AGP ISA Aliasing - Enabled
 - Init Display First - AGP

I booted from the current image from 9th Sep. When I start the "test ubuntu" option the system ends in a terminal with a (initramfs) prompt?

I tried the "install Ubuntu" option but with the same result.

Walldorf2000 (walldorf2000) wrote :

Others have similar problems with the LiveCD.

Maybe it is related with my Adaptex Controller
   https://bugs.launchpad.net/ubuntu/+source/linux/+bug/262294

Bryce Harrington (bryce) on 2008-10-01
Changed in xserver-xorg-video-ati:
status: Incomplete → Triaged
nanotube (nanotube) wrote :

hi,
just to post an update here: i have tried booting the intrepid livecd, and it does a completely hard freeze just after showing the desktop and cursor (but before showing the desktop background).

safe graphics mode works fine, though
video card is ati mobility radeon 9000 (rv250) 64mb

the machine runs feisty just fine, but gutsy, hardy, and now the intrepid livecds all have caused the hard freeze on bootup when using the ati driver, but ran fine in safe graphics mode.

i have yet to try the "agpmode" option to see if it makes things any better, will report when i do. but for now just writing to let you know that the problem still persists in the current release of the intrepid livecd.

here's a link to the ubuntuforums thread on this same issue, for reference:
http://ubuntuforums.org/showthread.php?p=6126016#post6126016

nanotube (nanotube) wrote :

update: ok, so when i tried the agpmode option, it worked with agpmode 1, but not with agpmode 2 or 4.

for the record, lspci shows the following on the video card:

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon R250 [Mobility FireGL 9000] [1002:4c66] (rev 02) (prog-if 00 [VGA])

Tormod Volden (tormodvolden) wrote :

nanotube, please open a new bug and report the information needed as described on https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk . Thanks in advance.

nanotube (nanotube) wrote :

Hi Tormod,

Thanks for your response! I have posted a new bug with all the info, here:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/296617

Please feel free to request any additional information, if you need it.

Bryce Harrington (bryce) wrote :

Okay, well as I mentioned in #37 the default AGPMode is now 4 so I'm pretty sure this issue is taken care of now. If you do get a chance to test on Jaunty and find it still occurs please feel free to reopen with the information we discussed above. Thanks again.

Changed in xserver-xorg-video-ati:
status: Triaged → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.