x-server freezes after startup (mobility radeon 9700) [Needs AGPMode 1]

Bug #203007 reported by kede on 2008-03-16
8
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

Hello,
I used an older alpha of hardy alpha (i think it was alpha 4) some weeks ago and it worked. After some weeks (and updates) it was broken (x-server crashed).

Now I tried out Hardy alpha 6, the x-server freezes while using the live-cd, so installation is impossible.
So I used the alternate install cd, but when starting into gdm after installation, it crashes.
As it also happens with kde4, it has nothing to do with gnome.

Sometimes I can move the mouse cursor, sonetimes I get a broken picture (strange lines or flickering).

I can shutdown the computer by pressing the power-button or by using ssh. But I can't kill the Xorg process, which takes 100% cpu-usage.
Capslock does not respond, I cant't switch to another terminal or restart the xserver.

I didn't touch xorg.conf. Deleting it has no effect.

My computer is an Acer Travelmate 4001lmi with ati mobility radeon 9700/64MB.

kede

kede (kede) on 2008-03-16
description: updated
description: updated
kede (kede) on 2008-03-16
description: updated
Adam Niedling (krychek) wrote :

The wiki page of your laptop is outdated. Please update it if you'd like.

https://wiki.ubuntu.com/LaptopTestingTeam/AcerTravelmate4001LMi

and

https://wiki.ubuntu.com/LaptopTestingTeam/Acer

Thanks.

kede (kede) wrote :

I took the xorg.conf file from gutsy. It's now working with "vesa" (both gnome and kde4).

Another thing I noticed: Shortly before starting gnome oder kde4, a corrupted picture can be seen for about a half second.
For example, if I used Windows XP before and rebooted, I can see a corrupted version of the XP-shutdown-screen.

Installing the proprietary ati-driver (fglrx), the system freezes, too. (Now it freezes completely, not only x).

aidave (aidave) wrote :

I find if "Xinerama" is enabled, Ubuntu will hang at startup.

Check your (old) xorg.conf for that.

kede (kede) wrote :

I have only one "Device", "Monitor" and "Screen" defined and no Xinerama.
I only use the internal screen of the laptop.

kede (kede) wrote :

I edited
~/gconf/desktop/gnome/applications/window_manager/%gconf.xml
end changed /usr/bin/compiz to /usr/bin/metacity
This disables desktop-effects.

It now works with all open source and proprietary drivers.

I noticed that the fan of my notebook stays off now.
Before, it was active without any reason.

kede (kede) wrote :

running glxinfo gives "name of display: :0.0
After that the system freezes.

I tried hardy beta. Installation only works with the alternate install cd.

The normal installation cd showed a corrupted picture after starting x (see attached file first-boot_hardybeta.jpg).
The mouse-cursor was displayed correctly and moved

I rebooted and it looked fine now, but crashed (attatched file next-boot_hardybeta.jpg. It shows a frozen menu which does not respond to mouse activity).
The mouse worked, too.

Before freezing, the gui seamed to slow down.
The cpu-fan indicates load.

kede (kede) wrote :

second attachment.

kede (kede) wrote :

Today's update seams to solve the issue.
It now works with the proprietary fglrx driver.

I didn't test the free driver because when I enable desktop effects, it installs the proprietary driver.

Problem returned some weeks ago after updating.

filing this against xorg, maybe someone with more experience has a look at it then...

Bryce Harrington (bryce) wrote :

Hi kede,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xorg:
status: New → Incomplete
kede (kede) wrote :

Hi,

a temporary solution for my problem is to force AGP 1x mode because that prevents it from freezing.
With Windows XP, it runs fine on AGP 4x even with fastwrite enabled.
I discribed it here:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/195051

Output of lspci -vvnn:
http://launchpadlibrarian.net/17352321/lspci_travelmate4001lmi.text

kede (kede) wrote :

Here is the my Xorg.0.log.

I removed the AGP 1x Option and it crashed again with the following:
1.) Xorg has 99% load, cursor is slow and it does not accept inputs or SysRQ-Keys.
2.) LCD goes black while backlight remains aon
3.) LCD is switched of, picture slowly turns to white (tn-panel). Backlight stays on.
4.) Picture suddenly divides in two parts which are not at the right place on the screen.

I also tried Exa with the same results.

Why is the card reported as "ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] rev 0"?
It should be a mobility 9700 / 64 MB.

kede (kede) wrote :

Besides, I hat the same problem with suse and i read many threads where people have similar problems.

kede (kede) wrote :

Same with Knoppix 5.3 (didn't test current 5.3.1)

Bryce Harrington (bryce) on 2008-10-24
Changed in xorg:
status: Incomplete → Confirmed
kede (kede) wrote :

Hi!

I installed Jaunty alpha today.

While typing my name at the login, gdm freezed. It's the same bug as in the previous ubuntu versions...
I was even unable to switch to a console because I got a completely crashed picture with weird colors.

I managed to install ssh without seeing a picture.
After logging in, ich did dpkg-reconfigure xserver-xorg to create a xorg.conf file (the original one was emty).
I added Option "AGPMode" "1" to the device session and now it works.

kede

Created an attachment (id=20618)
mobility_9600_quirk.patch

Another bug report needing an AGPMode quirk:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/203007

Notice we're seeing a pattern with the 82852/82855 host bridge / Mobility 9600 M10 RV350 combination. Maybe it should be quirked for any subsystem vendor.

Bryce Harrington (bryce) wrote :

Hi kede,

We can quirk the AGPModes now. However what we need is the output from `lspci -vvnn`, which doesn't seem to have been posted earlier. Mind collecting and attaching it here?

For reference, this quirk is discussed further at https://wiki.ubuntu.com/X/Quirks/#ATI AGP Mode Quirk

kede (kede) wrote :

Hi Bryce, thank you for your fast response!

With Windows XP, it runs perfectly with AGP 4x and even fastwrite so I'm not sure a quirk would be a final solution.

I already reported this problem (for hardy and intrepid) here and attached the output of lspci.
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/203007/comments/13

Bryce Harrington (bryce) wrote :

Oops, thanks missed that lspci link.

Aha, you have a 82855 hostbridge - I've seen 3 other people with that exact model hostbridge that also needed AGPMode 1. In at least one case, the user also reported that AGPMode 4 worked ok in windows, just not under ubuntu. You may be right that a more involved fix than a quirk is needed. I'll let upstream know.

Bryce Harrington (bryce) wrote :

Interesting, in those 3 cases, all three also had Mobility 9600 M10 RV350 cards like you (but from differing vendors).

Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Confirmed → Triaged
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed

committed:
fe73d9a7dfe8ec5c8f1a8dc08e14b4e138aa9276

Thanks!

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
kede (kede) wrote :

Hi Bryce, thank you for your help!

I just stumbled across this one:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/220345

So I removed the Option "AGPMode" "1", plugged in a mouse with usb and restarted. I seems not to crash anymore!
But 3d performance is very bad. I will test more in a few weeks when there's more time.

Bryce Harrington (bryce) wrote :

Should be included now in jaunty.

Changed in xserver-xorg-video-ati:
status: Triaged → Fix Released
Yves Glodt (yglodt) wrote :

I use the radeon driver version 6.10.99.0-1ubuntu1 and my graphics card is:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

I removed agpmode 1 from xorg.conf and it still freezes on X startup, some seconds after kdm startup in fact.

zeycus (zeycus) wrote :

THANK YOU!

I am a newbie, I installed Ubuntu some weeks ago and everything went smoothly... except for the graphic support. I had exactly the problems reported in this thread, and I could only install Ubuntu in Safe Graphic Mode. Later, nor the open-source drivers nor the fglrx seemed to improve the situation.

Until today, when following your advice I tried the AGPMode 1 option. I still have no clue what this is, but everything is working perfectly now :-). Even 3D games seem to work quite fast.

So, thanks again!

--
zeycus

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.