Screen blinks often; "invalid EDID" and "NAK bailout" messages - Radeon 3000

Bug #1811486 reported by Rugart Fertsch on 2019-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

The monitor screen blinks quite often, and syslog is crowded with these messages:
[drm:radeon_vga_detect [radeon]] *ERROR* VGA-1: probed a monitor but no|invalid EDID
i2c i2c-0: sendbytes: NAK bailout
The "VGA-1: probed a monitor but no|invalid EDID" message appears about every 10 seconds, and the other message much more often.
These messages also flood the virtual terminals, making them unusable.
This is Kubuntu 18.04 LTS 64 bits, kernel 4.15.0-43-generic. But the bug was present in Kubuntu 16.04 64 bits as well, except for the blinking screen. So it got worse now.
Kubuntu 13.10 32 bits, with xserver-xorg-video-radeon 1:7.2.0-0ubuntu10, and kernel 3.11.0-12-generic, using the "nomodeset" kernel boot parameter, didn't have any of these problems.
The video driver/module in use is "radeon", the default one. The package is xserver-xorg-video-radeon 18.0.1-1 .
The onboard video card is a Radeon 3000 .
lspci reports
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000]
Editing /usr/share/X11/xorg.conf.d/10-radeon.conf to force the use of the "fbdev" driver/module doesn't make the blinkings nor the error messages disappear, but when additionally using "nomodeset" at the Kernel command line, both the blinkings and the error messages go away. But then the 640x480 resolution is the only one available.
I'm attaching a text file generated with the command
ubuntu-bug --save xserver-xorg-video-radeon_apport-bug-report.txt xserver-xorg-video-radeon
Please make the solution available for Kubuntu 18.04 LTS.
Thanks in advance.

This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers