ATI driver update causes Display Corruption on Radeon IGP 330M/340M/350

Bug #180343 reported by Daniel du Preez on 2008-01-04
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

Using Xubuntu Hardy Alpha (latest as available from apt). Updated my system last night (3 January 2008) and an update to xserver-xorg-video-ati (to version 6.7.197) has resulted in X displaying a completely "garbled" display. Nothing is readable, nothing responds (even to ctrl+alt-backspace or switching to a virtual terminal). The mouse cursor still displays fine and responds to input, but nothing else works.

Changing driver to vesa in /etc/X11/xorg.conf allows X to start.

lspci reports: 00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

Xorg.0.log is at

The machine affected is an HP/Compaq NC4010.

Given that this is my first bug report, I hope I've not left out any pertinent information

marktechey (marktechey) wrote :

I have the same problem. Using Ubuntu Hardy, when xserver-xorg-video-ati is updated I get a black screen when X is started. It can only be fixed by switching to vesa. My video card is reported as 'ATI Technologies Inc Radeon Mobility 9200 IGP' by lspci. Although my card is really 9000 IGP and not 9200 IGP I haven't had this problem ever in the past.

marktechey (marktechey) wrote :

I was able to fix this by getting the leading edge of the ati driver from here
https://wiki.ubuntu.com/XorgOnTheEdge

Romana Challans (timelady) wrote :

NC4000, same issue as first post/bug submitter. tried the solution proposed of installing driver from : https://wiki.ubuntu.com/XorgOnTheEdge
Same issue. Retrying just in case (ok, I hate Vesa)

Daniel du Preez (flibberdys) wrote :

The OnTheEdge driver doesn't fix the issue for me either.

Romana Challans (timelady) wrote :

OnTheEdge driver has same issue. Tried using previous drivers for gutsy and feisty, as you can imagine, the amount of issues it would cause makes this, so far, prohibitive. This is killing my eyes - the NC4000 is a 12"laptop, and 640x480 is truly evil on it.

Hi,

I confirm this behaviour in Kubuntu Hardy Heron (pre-release) on my PC. After upgrading my pc using aptitude dist-upgrade yesterday, my PC totally freezes/locks up when starting Xorg using the ati or radeon open source drivers. It directly crashes once the Xorg window appears and BEFORE seeing the kdm login window. However, when using the fglrx driver, I can still successfully start up the Xorg server and log into kdm just fine. I use an ATI Radeon 9500 AGP video card. My xorg.conf file has not changed these past few months, but since yesterday, X crashes....

New bug in Xorg? Or in ati or radeon driver?

Regards,

Mark Rijckenberg

Hi,

I went to https://wiki.ubuntu.com/XorgOnTheEdge
Then I went to https://launchpad.net/~tormodvolden/+archive.
I added the following to my sources.list:

deb http://ppa.launchpad.net/tormodvolden/ubuntu hardy main
deb-src http://ppa.launchpad.net/tormodvolden/ubuntu hardy main

Did aptitude update and then aptitude dist-upgrade. Rebooted pc. Still not working.

Then I rebooted Kubuntu in recovery mode. Renamed my /etc/X11/xorg.conf to xorg.confOLD.

Ran X -configure to force X to create a new xorg.conf file. xorg.conf creation failed. Logfile for this is "X-configure-errors"

Currently, my Xorg still only works when using the ATI fglrx drivers.

I now did the following dangerous upgrade:

ulysses@desktop-pc:/data/downloads$ sudo dpkg -i --force-all xserver-xorg-video-ati_6.7.197+git20080108.fa3e2055-0ubuntu0tormod_i386.deb
dpkg: regarding xserver-xorg-video-ati_6.7.197+git20080108.fa3e2055-0ubuntu0tormod_i386.deb containing xserver-xorg-video-ati:
 xserver-xorg-core conflicts with xserver-xorg-video-1.0
  xserver-xorg-video-ati provides xserver-xorg-video-1.0 and is to be installed.
dpkg: warning - ignoring conflict, may proceed anyway !
(Reading database ... 310923 files and directories currently installed.)
Preparing to replace xserver-xorg-video-ati 1:6.7.197+git20071227.bfa22d-0ubuntu0tormod1 (using xserver-xorg-video-ati_6.7.197+git20080108.fa3e2055-0ubuntu0tormod_i386.deb) ...
Unpacking replacement xserver-xorg-video-ati ...
Setting up xserver-xorg-video-ati (1:6.7.197+git20080108.fa3e2055-0ubuntu0tormod) ...
ulysses@desktop-pc:/data/downloads$

Will reboot pc and let you know if it helped. Fingers crossed ;-)

Mark

Hi,

After reboot, the situation was even worse. So I used aptitude dist-upgrade again to automatically downgrade the ATI driver to xserver-xorg-video-ati 1:6.7.197+git20071227.bfa22d-0ubuntu0tormod1, which also does not work.

Any other idea's?

Mark

Timo Aaltonen (tjaalton) on 2008-01-09
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Hi Mark,

ATI Technologies Inc R300 AD [Radeon 9500 Pro] rev 0

This is your card as identified in the X log you sent. This is a different chip than the one this bug is reported on; I would recommend that you open a separate bug report for your problem.

Timo Aaltonen (tjaalton) wrote :

Mark: the conflict is there for a purpose. Gutsy version of the driver was built against an older xserver, so it won't work with hardy which has xserver 1.4.

This might be fixed upstream, I'll ask them.

Created separate bug report, as requested: Bug #181602, first reported 0 seconds ago by Mark Rijckenberg
ATI driver update causes Display Corruption on ATI Radeon 9500 AGP

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/181602

Timo Aaltonen (tjaalton) wrote :

Attached is a radeon_drv.so compiled from git master. Please try that out by copying it in /usr/lib/xorg/modules/drivers and report back if it works then. Thanks!

Timo Aaltonen (tjaalton) wrote :

I've already got one confirmation that the new driver works. The patch to fix it pretty simple.

Daniel du Preez (flibberdys) wrote :

Above driver does not fix the issue for me. Instead of a corrupted output the monitor appears to switch off (i.e no display, not even a backlight) This is with both "ati" and "radeon" specified as the driver. I've attached my Xorg.0.log from the last failed attempt.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:6.7.197-1ubuntu1

---------------
xserver-xorg-video-ati (1:6.7.197-1ubuntu1) hardy; urgency=low

  * 100_fix_igp_pci_ids.diff: Make sure all old IGP chips have
    HasSingleDac set. Refresh the patch for this release (LP: #180343).

 -- Timo Aaltonen <email address hidden> Thu, 10 Jan 2008 00:41:31 +0200

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
Romana Challans (timelady) wrote :

Where can we get this fixed ati driver from? apt-get update provides no new ati drivers.
I am using 1:6.7.197+git20011227.bfa22d-0ubuntutormod1. ati still exactly teh same - unusable, with no terminals accessable.

Romana Challans (timelady) wrote :

Ok, found it here:
https://launchpad.net/ubuntu/hardy/i386/xserver-xorg-video-ati/1:6.7.197-1ubuntu1

installed.

failed.

attached was the xorg,conf used with the ati. now i am bback to vesa. my system is as up to date as the mirrors can get:)

Romana Challans (timelady) wrote :

Oh, and the radeon driver patch above failed too, same issues of black screen as described.

Timo Aaltonen (tjaalton) wrote :

Then your bug is different. Try forcing the AGPMode:

Option "AGPMode" "4"

and if that works, it's bug 181602.

Romana Challans (timelady) wrote :

You, sir, are a genius:) I had forgotten how NICE the graphics could be.

All working, attached is my xorg.conf for benefit of anyone with same card. The new package at https://launchpad.net/ubuntu/hardy/i386/xserver-xorg-video-ati/1:6.7.197-1ubuntu1 , with the added Option "AGPMode" "4", was the key. Very very nice:)

Timo Aaltonen (tjaalton) wrote :

Apparently the confirmation was not quite accurate, so I'm reopening this bug. Maybe bug 181602 should be marked as a dupe then :)

Changed in xserver-xorg-video-ati:
status: Fix Released → Triaged
Daniel du Preez (flibberdys) wrote :

Adding AGPMode 4 to my xorg.conf and the above posted radeon_drv.so has fixed the problem on this PC. Thanks for the help.

Timo Aaltonen (tjaalton) wrote :

NOTE:

The new driver file I attached earlier does not help this bug, no need to install that.

This issue is known upstream, and a new release should be on its way soon.

jtlb (jt-lb) wrote :

Option "AGPMode" "4" fixes the bug for me too, thank you! I also noticed that blender is now working! with the previous versions of this driver it was crashing in the dri module.

Tormod Volden (tormodvolden) wrote :

It seems like all these bugs are duplicates of bug #133192. In that bug it is an AGP version 3 card (4x or 8x) that the driver defaults to 8x, but it needs 4x to work. In the other cases it is AGP version 2 cards (1x, 2x or 4x) that default to 1x but need 4x.

Tom Imhof (tomimhof) wrote :

Just to confirm: adding Option "AGPMode" "4" works for me as well - thanks for the hint!!!

AndyAirey (aairey) wrote :

just fyi
& for the people where "AGPMode" "4" did not work, because it was _very_ hard to find this..

After 2 days of searching I finaly found the solution for my compaq 2140EA!
This topic helped me: http://ubuntuforums.org/showthread.php?t=310018

So now there IS 3D Acceleration available for this laptop!
/me goes to edit this wiki right away -> https://wiki.ubuntu.com/LaptopTestingTeam/CompaqPresario2100

AndyAirey (aairey) wrote :
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers