Invalid command stream with Radeon driver

Bug #1789071 reported by Iuga Marian Silviu on 2018-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lubuntu Artwork
Invalid
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Lubuntu 18.10 daily 08-25

I have a Pentium 4 SL7E8, 512 MB of RAM in a PT800CE-A from ECS and an ATI Radeon HD 4650 on AGP.

The live CD boots up well to the Desktop, but then when I open an application, the part of the screen where the application should be hides the mouse cursor when I hover it, the Desktop background picture remains.

Pressing screen 2, 3, 4 the hovering cursor is not hidden any more and pressing screen 1 the cursor is hidden again.

When pressing screen 2, 3, 4 the screen button indicator remains on 1.

I did a CTRL+ALT+F2 and lubuntu ENTER and:

dmesg |tail -50

made a photo with my phone and attached it here.

I am ready to run other commands you want after boot and attach the photo of the output here.

I am sorry if this is not the right place for this bug.

Iuga Marian Silviu (iugamarian) wrote :

Do you have the same problem with other flavors of Ubuntu? What about
other versions of Lubuntu?

 status incomplete

Changed in lubuntu-artwork:
status: New → Incomplete

i386 Ubuntu CD's are fewer.
I will try today from http://iso.qa.ubuntu.com/qatracker/milestones/390/builds
and report back on the other i386's I see there:

Xubuntu Desktop i386
Ubuntu Base i386

Walter Lapchynski (wxl) wrote :

and make sure to try already released versions of Lubuntu rather than
just dailies.

On Lubuntu 18.04.1 i386 from lubuntu.me I have kernel panic on try and install, verified torrent, attached photo.
On Lubuntu 18.04 i386 from lubuntu.net it works very well.
On Xubuntu 18.10 i386 daily build 08-26 it works very well.

Iuga Marian Silviu (iugamarian) wrote :

On Lubuntu 18.10 daily build 08-26 the bug is the same, attached photo with proof.

Iuga Marian Silviu (iugamarian) wrote :

Forget the kernel panic - I dd the stick again and left it for some time in the USB port.
18.04.1 from lubuntu.me works very well.

Walter Lapchynski (wxl) wrote :

Since you had problems with the verified torrent, perhaps you should
ensure that you have no such problems with with the daily build. Make
sure you have verified the download, make sure you `dd` it, and make
sure you run "Check disc for defects" at the boot menu.

If you still see the same problem, please attach a comparison of what
I should see. It's not obvious to me in that picture that something
is wrong. It might be because you are taking this with your phone. I
would advise using ScreenGrab to take an actual screenshot. For 18.04
and before on Lubuntu, that would be the `scrot` command line tool.

Also it would be helpful to include /var/log/syslog and
/var/log/Xorg.0.log. The results of `lsmod`, too. Please include one
for Xubuntu 18.10 and one for Lubuntu 18.10.

Downloading ISO's:
wget -c http://cdimage.ubuntu.com/lubuntu/daily-live/20180827/cosmic-desktop-i386.iso
mv cosmic-desktop-i386.iso cosmic-desktop-i386-lubuntu-0827.iso
wget -c http://cdimage.ubuntu.com/xubuntu/daily-live/20180827/cosmic-desktop-i386.iso
mv cosmic-desktop-i386.iso cosmic-desktop-i386-xubuntu-0827.iso
mkdir lubuntu
mkdir xubuntu

For Lubuntu 18.10 0827:
lsblk
umount /dev/sdb1
sudo dd if=cosmic-desktop-i386-lubuntu-0827.iso of=/dev/sdb bs=1M && sleep 10
Boot i386, Check disk for defects, No errors found
Reboot i386, CTRL+ALT+T, mouse cursor at the edge of invisible terminal,
type blindly: scrot [ENTER], CTRL+ALT+F2, lubuntu, sudo -s
scp 2018*.png :~/lubuntu, scp syslog :~/lubuntu, scp Xorg.0.log :~/xubuntu

For Xubuntu 18.10 0827:
lsblk
umount /dev/sdb1
sudo dd if=cosmic-desktop-i386-xubuntu-0827.iso of=/dev/sdb bs=1M && sleep 10
Boot i386, Check disk for defects, No errors found
Reboot i386, CTRL+ALT+T, scp syslog :~/xubuntu, scp Xorg.0.log :~/xubuntu

The scrot image comes out as black, attached here. The other files in new posts.

Lubuntu 18.10 0827 /var/log/syslog

Lubuntu 18.10 0827 /var/log/Xorg.0.log

Xubuntu 18.10 0827 /var/log/syslog

Xubuntu 18.10 0827 /var/log/Xorg.0.log

Xubuntu 18.10 0827 lsmod

Walter Lapchynski (wxl) wrote :

I need a screenshot from both the system that works and the one that
doesn't with a clear indication of what's wrong.

On phone proof picture see [ ->| ] mouse cursor at invisible right edge of invisible terminal window.

Does it help if I make a Youtube video showing Lubuntu booting problem and Xubuntu booting and put the link here ? - I have Logitech C910. Would take a day or two to finish.

Can't make screenshot in Lubuntu (black image from scrot), Xubuntu looks fine.

Thank you.

Initially the lxqt-powermanagement message does not appear. After I press CTRL+ALT+T in Lubuntu 18.10, the entire desktop flickers and the lxqt-powermanagement message appears and the mouse cursor dissapears, when I move the mouse cursor it reappears at the edges of the desktop and dissapears to the center of the desktop. Tested in virtualbox on another computer with settings 512 MB RAM and PAE enabled and works very well there.

Walter Lapchynski (wxl) wrote :

Use ScreenGrab to take the screenshot in Lubuntu 18.10. Screenshooter in
Xubuntu. Grainy phone pics and YouTube videos are really not helping.

I can let you ssh into the Lubuntu 18.10 live cd at a specified UTC time if the ram can accomodate installing openssh-server, can install additional 256MB ram but it's at 333Mhz not 400 Mhz. I tested port forwarding on router ssh working from another location.

Tommorow I will post the screenshots if I discover how to do them.

Walter Lapchynski (wxl) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

While I can't exactly see the problem, I can parse those files you
attached. I find something interesting:

Aug 27 17:17:19 lubuntu kernel: [ 41.607050] radeon 0000:01:00.0:
texture bo too small ((1024 768) (64 1) 1 26 0 -> 3145728 have 4096)
Aug 27 17:17:19 lubuntu kernel: [ 41.607057] radeon 0000:01:00.0:
alignments 1024 64 1 256
Aug 27 17:17:19 lubuntu kernel: [ 41.607136] [drm:radeon_cs_ioctl
[radeon]] *ERROR* Invalid command stream !

This occurs shortly after sddm loads. There'a a bug that results in some
updates to the radeon driver that mentions sddm:
https://bugs.freedesktop.org/show_bug.cgi?id=105381

I can only presume this is some sort of interaction between sddm and
that bug. That said, I would encourage you to check out Kubuntu and see
if you have problems with it. My guess is that you do.

Meanwhile, that fix is coming soon, but hasn't landed yet. Looking at
the Debian changelog "glamor: Use GBM for BO allocation when possible"
is found in version 1:18.0.1-2 while we are on 1:18.0.1-1build1.

In any case, we can be certain that the issue is not Lubuntu artwork!

 status invalid
 affects ubuntu/xserver-xorg-video-ati
 status fixcommitted
 summary "Invalid command stream with Radeon driver"
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJbhHyJAAoJEItXpIvE8gUaRfwP+wQ1RapV1IpayTb8EDmnBxud
w8SIva90w7NkXOiQ2T9YF3YmJxJQR0zPD3O2HY50Evf7ix5T9h4Dfsb9jGzVUWxF
fGh44ILYBZ0lqhiX/PemGygmtZbCr4Dvw55aWJIsu03PLuut3Gu0NJ574FRYXBAM
j2EK8k8twbH7vfVKmnkENEb19M6JnZ6A1BuMtQri1QvihMm6Jqpx70CfZq2t626U
UfFzSfVeOORXEbjzsBk2WyhkJVXS/WDrSPCnieFNi5I+zr3KP1AqZbjS/kBqdEX5
hyZE7sRTfYVBMCi48DmIr6YLRPOWiWTz3w3F+tb4odAHvo/FTM6Sj7IneztwEt0U
scGfMFFReEPBWCBTh1smp8CYfiBlGmfw5jHFgxgKEpCTC82/6rNvPMHazlbUo3oE
/INApkhSyjxWm6bbCin5QwhJvzyR0rLwewc9qn9Vex1yRZ3HFI/aEo7E7/fFsMMI
w/ZYCFWifKg8Rz3a6TZfCmqSbL0wGc0UVKbpd16KvcMYjE44n9XEASVB2BhZz0S3
zeAnBNCEiOKz9kfinV/sFKHTt69cl4kxyhn5ZoAqHIVfIuu8HetyansZTCObJR9h
dUDXJI1wF/Y2Um3PTgyXZoxOXla/8QgamHnm0U0m6pzTJ+un/uS6daIqb0N1g0VZ
HxvVemalwx/+RfiUdRA4
=Dbt6
-----END PGP SIGNATURE-----

summary: - Lubuntu 18.10 i386 daily 08-25 open application not seen on display
+ Invalid command stream with Radeon driver
Changed in lubuntu-artwork:
status: Incomplete → Invalid
Walter Lapchynski (wxl) wrote :

One more thing. The corrected version is actually in proposed:
https://launchpad.net/ubuntu/+source/xserver-xorg-video-ati/1:18.0.1-2

I do not recommend enabling proposed in general, especially for
something so crucial to the whole system. However, since it seems you're
doing testing and not on a production system, it might be worthwhile to
enable proposed and get the likely solution:
https://wiki.ubuntu.com/Testing/EnableProposed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.