[radeon] [amdgpu] Display settings

Bug #1785393 reported by Stefan Rankovic on 2018-08-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

I can't change resolution and I installed newest AMD GPU driver from AMD's website. I have only one resolution available and it is not monitor's native resolution.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CompositorRunning: None
Date: Sat Aug 4 14:16:57 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus: amdgpu, 18.20-606296, 4.15.0-29-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Venus LE [Radeon HD 8830M] [1002:682b] (rev 87) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Venus LE / Tropo PRO-L [Radeon HD 8830M / R7 M465X] [1043:7250]
InstallationDate: Installed on 2018-08-03 (0 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=1
Renderer: Software
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/10/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1503
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: A68HM-K
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1503:bd03/10/2016:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnA68HM-K:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Sat Aug 4 13:54:08 2018
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 Screen 0 deleted because of no matching config section.
 Screen 0 deleted because of no matching config section.
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.6-1ubuntu4

Stefan Rankovic (stifmeister) wrote :
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
summary: - Display settings
+ [radeon] [amdgpu] Display settings
Timo Aaltonen (tjaalton) wrote :

we don't support external drivers

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Invalid
no longer affects: xserver-xorg-video-amdgpu (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers