[Needs AGPMode quirk] messy screen on radeon 9200SE

Bug #164972 reported by Denis_AeC on 2007-11-25
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

My PC works perfectly with Feisty and win XP. I started a graphical upgrade to Gutsy that was performed in 3h without problem. At reboot, grub was OK and so was the (splash ?) screen while Ubuntu starts (with the progress bar). Then my session started ... and the screen became messy : vertical sync was there, as I can "see" top and bottom menu bars (but not the icons), but horiz sync was not there : my background image, icons and all are mixed and video lines are running through the screen ...
When I boot from grub to windows, it's OK, win is there and my screen is perfect.
I tried in recovery session "dpkg-reconfigure xserver-xorg" : no enhancement.
I tried then to boot on Gutsy Livecd, using different screen resolutions (including 640*480 !) : same problem as soon as the session is started.

My video card is ATI RV280 Radeon 9200 SE
Flat screen is Hyundai L70S+ 1280*1024

I am now back on Feisty, using partimage file (after having done a Gutsy partimage).

Any idea of the problem, a solution ?

Thanks in advance

Denis

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt. Thanks in advance.

Hi Tormod,

Not an easy task ;-) :

Back on Gutsy with previous partimage
Boot in normal mode : crazy video => reset
Boot in recovery mode : save xorg.conf & /var/log/Xorg.0.log as "..._G0" in other partition
                                       move xorg.conf as "...Gutsy"
Boot in normal mode : crazy video => reset
Boot in recovery mode : save /var/log/Xorg.0.log as "..._G1" in other partition, no xorg.conf

Back on Feisty with partimage

Another comment :
I think that on Feisty, I never installed the ATI driver, as the "normal" driver was correctly working, including with 3D effects and Compiz (that I don't use anymore).

Tormod Volden (tormodvolden) wrote :

Please try:
 Option "BusType" "PCI"
in the Device section.

If that doesn't work, try installing the Feisty -ati driver on your Gutsy: https://launchpad.net/ubuntu/+source/xserver-xorg-video-ati/1:6.6.3-2ubuntu6

On Gutsy now :-))

It was not without problems and tests :

- Back on Gutsy with partimage . I put "BusType" "PCI" in xorg.conf as you required.
- Boot on Gutsy : I got a popup saying Ubuntu on low resolution mode. There I tried to "configure" what I could (card, screen) : but no success, so I canceled configuration and let Ubuntu start.
- Ubuntu started on 800*600 resolution, better than previous state !
- I tried to configure resolution (using graphic tools) but was unable to change it only 640*480 & 800*600 ...
- Then I installed the Feisty driver "dpkg - i xserver-xorg-video-ati_6.7.195-1ubuntu2_i386.deb" that I got after having followed your link and searched for an installable file.
   * At that point, I replaced the xorg.conf with the one from feisty and rebooted : as worse as after Gutsy install !!!
   * Reboot on recovery mode, put back the "gutsy" xorg.conf and reboot : all is good. It may stay some problems, like a strange and bad screen during ubuntu start, and no more "splash" screen showing the Ubuntu logo and some icons during session start.

I will now reboot, to see if all is OK.

Thanks for your help. Do you want any other information or file ?

Tormod Volden (tormodvolden) wrote :

There is an issue with the graphical user interface "Screens and Graphics" so it doesn't work very well with the new Gutsy ati driver. As you could see, it worked well with the old driver.

I would however recommend you to install the newest Gutsy driver again, and make a new, clean xorg.conf by running: sudo dpkg-reconfigure -phigh xserver-xorg
Then add the "PCI" option as before. Please attach the new xorg.conf and the Xorg.0.log from running with this.

You can also try the newest test driver from https://wiki.ubuntu.com/XorgOnTheEdge

Tormod Volden (tormodvolden) wrote :

Also note that the Feisty driver that I suggested should be 6.6.3 and not 6.7.195 like you wrote. Maybe you are already using the newest Gutsy driver in fact.

Bad idea !

I ran "sudo dpkg-reconfigure -phigh xserver-xorg" and added the "PCI" option as before, then i rebooted ... and got the "ubuntu in low res" message, and I am now in 800*600 res !

I join the xorg.conf after dpkg-reconfigure, rhe xorg.conf and the log after reboot.

As I made a partimage when Gutsy was OK, I can go back to it ;-)

Back on Feisty ...

I reinstalled the Gutsy that was supposed to be OK, but that doesn't function anymore : another problem with H sync on video ??? May be that some Gutsy upgrades proposed by ubuntu that have been applied have modified something, or maybe that my personnal settings (files .*) pose problem.

Tormod Volden (tormodvolden) wrote :

The problem is that the "failsafe" mode kicks in and restarts the server using the "vesa" driver. Your log is from the vesa driver. Can you please attach Xorg.0.log.old which hopefully will be from the ati/radeon driver?

You can also try the "xorg.conf before reboot" but remove these two lines:
 HorizSync 28-64
 VertRefresh 43-60

Back on Gutsy ;-) ...

Started again from the "beginning" : my Gutsy partimage, with messy video, just from Feisty upgrade.
Before booting on this Gutsy :
- saved the xorg.conf as ... initial
- modified xorg.conf to add BusType PCI, and remove 2 lines for HorizSync & VertRefresh

Boot on Gutsy : video in 800*600, impossible to modify during setting or under normal session (I probably succeeded at that point in changing the monitor as Hyunday 17")
Change to driver "dpkg -i xserver-xorg-video-ati_6.6.3-2ubuntu6_i386.deb" that I finally found, instead of the 6.7.195 version. No change in user session, still 800*600. May be changed to 17" Hyundai at that point (or previously ?).
Reboot : Gutsy is OK ! 1280*1024 / 60 Hz . Hyundai DeLuxe17" (instead of L70s as before), 6.6.3 driver in Synaptic

I will now perform a partimage from this Gutsy, in case of ...

Anything else (like the "dpkg-reconfigure -phigh xserver-xorg" ... or 6.7.195 driver) ?

Tormod Volden (tormodvolden) wrote :

"impossible to modify during setting or under normal session"
I am not sure what you mean by this. I already mentioned that the GUI can not be used with the new driver.

Your "Current Xorg log, gutsy running" shows that you are using the vesa driver.

I would like you to do what I asked in comment 9 plus remove the two sync lines. Then take a copy of this xorg.conf and attach it here later. Then I have to see the log from running with it (with the ati/radeon driver) to see what goes wrong. This should be Xorg.0.log.old after reboot, since the server will crash and restart in "failsafe mode" with "vesa" and then write that session to Xorg.0.log.

Still on Gutsy ????

I did what you requested and Gutsy booted "normally" but in low res (800*600) :

- Boot on Gutsy with vesa driver, 1280*1024 : OK
- upgrade driver to 6.7.195 version,
- run dpkg-reconfigure -phigh xserver-xorg
- in xorg, add BusType PCI & remove H & V sync
- reboot & pray ...

Gutsy started with a quite normal video but in low resolution, and no mean to change it : the GUI doesn't work. Curiously, I did not get the messy video without V or H sync ???

Any possibility to change resolution ? (except back to working Gutsy with partimage)

Tormod Volden (tormodvolden) wrote :

That was unfortunately the wrong log again: It has lots of (VESA) lines. The one I am interested in has a lot of (RADEON) lines. I thought it would be Xorg.0.log.old

No "radeon" more in log than in the other : 3. This is surpring as the xorg.conf defines an ati driver ...

I can no more go back to my partimage with messy video and perform any other test ... Sorry for that. But I can still boot on Gutsy CD (and get a messy video) : if you have any action that could bring a way to get xorg conf or log ? <ctl> <alt> F1 ???

Tormod Volden (tormodvolden) wrote :

You can do ctrl-alt-F1 and log in to a console, then turn off the auto-starting X:
 sudo /etc/init.d/gdm stop
(Maybe you need to switch with ctrl-alt-F1 again now)
Edit xorg.conf and make sure xorg.conf is using "ati":
 nano /etc/X11/xorg.conf
Then run X manually:
 startx
If needed, kill it with ctrl-alt-backspace. Make a copy of the log:
 cp /var/log/Xorg.0.log Xorg.0.log-startx.txt

Strange things happen in Gutsy world ... ;-)

All the following operations have been done using Gutsy Install LiveCd :
- boot on cd => bad video as "usual" when session opens.
- ctl-alt-F1 : "standard" video in 640*480 mode
- sudo -s -H to stay in sudo mode (otherwise, most operations are refused ... except adding sudo of course)
- make a mount point in /media to mount a partition on which I can save files
- save in CD1 directory xorg.conf and its log
- stop gdm : OK
- look at xorg.conf : "ati" was there : OK
- starx : erreur, server is already active for display 0 ...
- (probably ctl-C to kill the command ?)
- remove file like /tmp/.X0.lock (I don't remember the exact name)
- startx : graphic start with message like "you are running in root mode, continue ?" Yes, of course.
From that point the session was OK in graphic mode and I copied current xorg.conf and logs in CD2 directory.

Tormod Volden (tormodvolden) wrote :

The two xorg.conf files are identical. The difference between the two runs is that the second time, DRI is disabled because of:
 [drm] drmSetBusid failed (7, pci:0000:01:00.0), Permission denied

So if I understand correctly, you can boot the Gutsy CD and disable DRI:
 sudo /etc/init.d/gdm stop
 sudo nano /etc/X11/xorg.conf
And add to Device section: Option "DRI" "off"
 sudo rm /tmp/.X0-lock
 sudo /etc/init.d/gdm start

Does this work? If so, repeat it but this time use instead: Option "BusType" "PCI"

(Alternatively, you can boot the Gutsy CD with the extra "single" boot parameter. Then in single user mode, edit xorg.conf and press ctrl-D to continue full boot.)

I finally succeeded prforming all that ;-)

1°) Boot in single mode, add Option "DRI" "off" and start : OK ! Gutsy boots normally, video is OK. Just a problem when session is started, a popup opens "internal error : failed to initialize HAL". Another problem occurs when clicking on exit icon : the system freezes for 2 mn before exit poup opens ????

2°) Boot in single mode, add Option "BusType" "PCI" and start : OK, like in previous step, same video OK, same problems.

3°) A question : when I boot on Gutsy Livecd, I get the messy video when the session starts ... but how the arrow icon for the mouse can appear, be moved arround the screen while all the rest is mixed and runs through the screen ? How can be this mouse icon independant of th rest of the screen concerning the video ???

Tormod Volden (tormodvolden) wrote :

Why didn't you mention the normal cursor before? :)

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
status: Incomplete → Confirmed

"Why didn't you mention the normal cursor before? :) " : I think I were more upset by the 99,9% of my desktop scrambling through the screen than pleased by the tiny cursor arrow moving accordingly with my hand ;-))

I searched for related bugs before creating mine and did not see anyone looking like my problem. Can you please add "9200" in title of other bug ?

Anyway, thanks for your help !

(I am currently trying to help another people with "same" problem on french forum, but he does not read english, so I can't give him the links !)

Tormod Volden (tormodvolden) wrote :

One reason I don't put 9200 in the title is that it is not limited to 9200 cards.

Tormod Volden (tormodvolden) wrote :

I think the default AGPMode is wrong for your video card/motherboard combination. Please see https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk and include the requested information here.

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
status: Confirmed → Incomplete

AGPMode needed: 4 (on Hardy)
  Model: (Unknown) tower
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
 Subsystem: C.P. Technology Co. Ltd Device 2073
 Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 11
 Memory at c0000000 (32-bit, prefetchable) [size=256M]
 I/O ports at c800 [size=256]
 Memory at dfef0000 (32-bit, non-prefetchable) [size=64K]
 Expansion ROM at dfec0000 [disabled] [size=128K]
 Capabilities: [58] AGP version 3.0
 Capabilities: [50] Power Management version 2
 Kernel modules: radeonfb

  Card Subsystem: ?
  HW changes: ?
  BIOS: ?

Tormod Volden (tormodvolden) wrote :

Thanks. As explained on the wiki page, we will need the output from:
 lspci -nn | grep 00:00.0
 lspci -nnvv | grep -A1 "VGA compatible controller"

 lspci -nn | grep 00:00.0
00:00.0 Host bridge [0600]: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge [1106:3189] (rev 80)

 lspci -nnvv | grep -A1 "VGA compatible controller"
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV280 [Radeon 9200 SE] [1002:5964] (rev 01)
 Subsystem: C.P. Technology Co. Ltd Device [148c:2073]

Not a lot of differences, anyway !

Tormod Volden (tormodvolden) wrote :

The devil is in the details ;) We needed those hex numbers in brackets. Thanks again.

Changed in xserver-xorg-video-ati:
status: Incomplete → In Progress
Tormod Volden (tormodvolden) wrote :

This was fixed upstream 2009-01-07 http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=14d29a223028c183ba11e717a3737285d0ac8de1 - that is just after the 6.10.0 release. The jaunty package in my PPA includes this.

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
status: In Progress → Fix Committed
Bryce Harrington (bryce) wrote :

Included in the 6.10.99.0 upload today to jaunty.

Changed in xserver-xorg-video-ati:
status: Fix Committed → Fix Released

Good news : it's OK on Jaunty alpha 5

After the boot from liveCD, the session screen is correctly displayed and I can run applications without problem.

I just forgot to check wether 3D was present or not. Probably for next time ... (boot from cd is so looooooooooooooooooong !)

Till 2 months to wait for Jaunty !

Thank you for your help !

Denis

To post a comment you must log in.