[M6] terminal display error when reading PDF files

Bug #163044 reported by leotunas on 2007-11-16
2
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Low
xserver-xorg-video-ati (Ubuntu)
Low
Rolf Leggewie

Bug Description

When using Evince or Adobe Reader 8 to read PDF files, "Alt+Tab" to gnome-terminal, by chance of 1/10 I can find display error in terminal. The error is like this: a rectangular area of terminal is covered by one block of the pdf file or some other applications, and the position of the error area is exactly where the block is displayed. It's never found when evince and adobe reader 8 are both closed.

My OS is ubuntu7.10 (upgraded from 7.04) with GNOME 2.20.1, evince 2.20.1,
VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
Driver for graphic card: "ati-ATI Mach8, Mach32, Mach64, and Rage..."

leotunas (leotunas) wrote :

For example, evince is opened, "man find" in terminal, press "f" or "b" to turn pagedown or pageup, the error appears, not every page, but sometimes, by chance of about 1 in 10. When press "j" to scroll down, the display return to normal.

leotunas (leotunas) wrote :
leotunas (leotunas) wrote :
leotunas (leotunas) wrote :
leotunas (leotunas) wrote :
description: updated
TerryG (tgalati4) wrote :

Thanks for your bug submission. It certainly looks like a compositing or rendering error with your ATI graphics card. Since it happens with both evince and acroread, I've punted this report to xorg. ATI drivers are improving. Try running envy to get better drivers:

>sudo envy

Marking as Confirmed due to reporter's efforts at documenting behavior. I don't have similar hardware to verify.

Bryce Harrington (bryce) wrote :

Could you please attach your /var/log/Xorg.0.log?

Changed in xorg:
importance: Undecided → Low

Hi,
Its size is about 60K. Do I have to attach whole this file? Or just part
of it?
Thanks.

On Sat, 2008-04-19 at 07:25 +0000, Bryce Harrington wrote:
> Could you please attach your /var/log/Xorg.0.log?
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Sourcepackagename: xorg => xserver-xorg-video-ati
> Importance: Undecided => Low
>

leotunas (leotunas) wrote :
Bryce Harrington (bryce) on 2008-04-23
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged

Thanks for taking the time to report this bug and helping to make Ubuntu better. In the development cycle for Intrepid there have been some vast improvements in the open source ati video driver and we could use your help testing them. Could you please download the latest Alpha CD image of Intrepid and test this particular bug just using the Live CD? You can find the latest image at http://www.ubuntu.com/testing . Your testing can help make Ubuntu and the open source ati driver even better! Thanks in advance.

Changed in xserver-xorg-video-ati:
status: Triaged → Incomplete

Forwarding this bug from Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/163044

"When using Evince or Adobe Reader 8 to read PDF files, "Alt+Tab" to gnome-terminal, by chance of 1/10 I can find display error in terminal. The error is like this: a rectangular area of terminal is covered by one block of the pdf file or some other applications, and the position of the error area is exactly where the block is displayed. It's never found when evince and adobe reader 8 are both closed.

For example, evince is opened, "man find" in terminal, press "f" or "b" to turn pagedown or pageup, the error appears, not every page, but sometimes, by chance of about 1 in 10. When press "j" to scroll down, the display return to normal."

http://launchpadlibrarian.net/10436857/Screenshot1.png
http://launchpadlibrarian.net/13834985/Xorg.0.log

Does it still happen with newer versions of xserver and xf86-video-ati? With EXA?

P.S. Please attach files here instead of referencing to external sites.

Bryce Harrington (bryce) wrote :

Hi leotunas,

I've gone ahead and forwarded this bug upstream. Can you please subscribe to this upstream bug report in case the developers need further information or wish for you to test something? Thanks ahead of time.

https://bugs.freedesktop.org/show_bug.cgi?id=17216

Also, if possible it would be great if you could re-test for this problem on Intrepid, as it has a very recent snapshot of this video driver, and the latest xserver.

Changed in xserver-xorg-driver-ati:
importance: Undecided → Unknown
status: New → Unknown
Changed in xserver-xorg-video-ati:
status: Incomplete → Triaged
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
leotunas (leotunas) wrote :

Hi,

I tried Intrepid alpha4 LiveCD but it failed when booting, with errors like
"
end_request: I/O error, dev sr0, sector *******
Buffer I/O error on device sr0, logical block ******
......
......
"

I will try earlier alpha LiveCD.

Let's return to our ait-driver rendering bug under discussion. It never appears after I upgraded to Ubuntu 8.04. Maybe it has been fixed in the default driver in 8.04 ?

The user is experiencing some boot issues with the newer alpha-4 cd but will try with an earlier alpha.

Bryce Harrington (bryce) wrote :

Thanks, and thanks for joining the upstream bug discussion.

If you can get one of the alpha CD's booted, you can upgrade the X driver via `sudo apt-get install xserver-xorg-video-ati`, let it install any pre-requisites, and then log out and log back in (without rebooting). After you do this, please post your /var/log/Xorg.0.log to the upstream bug report. Thanks ahead of time.

Dhoombot (amex-udaff) wrote :

1

The person who had this problem originally reported that ever since Hardy things are working fine for him.

Rolf Leggewie (r0lf) wrote :

I have the same graphics chip and don't experience this issue in Karmic.

I was wondering if this is something that is still bothering you. After all, it's been a while.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Triaged → Incomplete

Thanks for your feedback!
This problem never appears after I upgraded the OS from 7.10 to 8.04 :)

On Mon, Jul 27, 2009 at 6:28 PM, Rolf Leggewie <launchpad.net@
rolf.leggewie.biz> wrote:

> I have the same graphics chip and don't experience this issue in Karmic.
>
> I was wondering if this is something that is still bothering you. After
> all, it's been a while.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Triaged => Incomplete
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Assignee: (unassigned) => Rolf Leggewie (r0lf)
>
> --
> [M6] terminal display error when reading PDF files
> https://bugs.launchpad.net/bugs/163044
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Rolf Leggewie (r0lf) wrote :

Cool. Closing as fix released, then.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Fix Released
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Low
Changed in xserver-xorg-driver-ati:
importance: Low → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.