[Mobility M7 7500] Screen resolution issues in Hardy unless NoDDC specified

Bug #160871 reported by grahams1 on 2007-11-08
8
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

I'm running Gutsy on a Compaq n610c
The graphics chip is a ATI 7500
lspci :
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

I'm using the built lcd laptop screen and I can not change resolution from the native 1400x1050. The "Screens and Graphics" tools shows my screen as "plug and play" and offers no other resolutions. I have tried upgrading the ATI driver to 8.42.1, but same issues.

Games like xgalaga will not correctly show in full screen mode (they are much smaller).

Everything worked fine in feisty

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xorg.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add your '/etc/X11/xorg.conf' file and your '/var/log/Xorg.0.log' file as attachments to your bug report? Thanks in advance.

Changed in xorg:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

Do you use the binary fglrx driver?

Thanks

I wasn't sure which package is causing to issue. There are no error messages, but there is a regression in functionality from 7.04 i.e. not being able to change screen resolution.

I recenltly tried 7.10 on a newer IBM t60 laptop and the resolution could be changed. This may be that the older Compaq n610 hardware not being recognized correctly.

Brian Murray <email address hidden> wrote: Thank you for taking the time to report this bug and helping to make
Ubuntu better. This bug did not have a package associated with it,
which is important for ensuring that it gets looked at by the proper
developers. You can learn more about finding the right package at
https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this
bug as a bug in xorg.

** Changed in: xorg (Ubuntu)
Sourcepackagename: None => xorg

--
Screen resolution issues in Gutsy
https://bugs.launchpad.net/bugs/160871
You received this bug notification because you are a direct subscriber
of the bug.

grahams1 (gps1539) wrote :

Sorry, I reinstalled 7.04 on this machine due to the usability issues. However the same issue happens with the 7.10 LiveCD

Brian Murray <email address hidden> wrote: Thank you for taking the time to report this bug and helping to make
Ubuntu better. Could you please add your '/etc/X11/xorg.conf' file and
your '/var/log/Xorg.0.log' file as attachments to your bug report?
Thanks in advance.

** Changed in: xorg (Ubuntu)
       Status: New => Incomplete

--
Screen resolution issues in Gutsy
https://bugs.launchpad.net/bugs/160871
You received this bug notification because you are a direct subscriber
of the bug.

Booted the Hardy alpha4 live CD and the same problem occurs i.e. it is impossible to change the screen resolution on this machine.

lspci :
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

I don't believe the Live CD uses the restricted driver, fglrx, by default so I am changing the package to xserver-xorg-video-ati. However, it would still be quite helpful grahams1 if you could provide the log files , /etc/X11/xorg.conf and /var/log/Xorg.0.log , that we asked for earlier. Preferably you would do this using the latest Alpha release which is Alpha 5 at this point in time. Thanks in advance.

grahams1 (gps1539) wrote :

I'm attaching the xorg.conf and the var logs

grahams1 (gps1539) wrote :
Nazim Aghabayov (nazim-aga) wrote :

Hello friends!
I have a same problem on Compaq n610c with kubuntu gutsy. Screen resolution is always 1400x1050. I've tried to import the 1024x768 ModeLine string from Kubuntu Dapper's config, but X returns to 1400x1050. Also, tried to change the driver from ati to radeon but got the same result. Log and config are attached below.

# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

Thanks!

grahams1 (gps1539) wrote :

Is there anything else we can do to help fix this bug? It has been reproduced on another ati 7500 system. Should this be raised against xorg instread?

premavilas (premavilas) wrote :

Hello there,
I have the same problem with a Thinkpad T41 with a ATI Radeon Mobility 7500.
Compiz ist not working at all.
No Desktop-effect is working.
With 7.10 all these things worked very well...
Greetings,
prema

Connor Imes (ckimes) wrote :

premavilas,
I wrote a short HowTo with explanation on the Ubuntu Forums, you can access it here: http://ubuntuforums.org/showthread.php?t=764633

grahams
With the older ATI cards, you cannot be using the fglrx drivers, they only work for the 9500 and newer I believe. You need to be using the open source ati drivers.

As per the original bug report, I believe the Screen and Graphics function does not exist in the final release of Hardy Heron. You need to change resolution from System->Preferences->Screen Resolution

There is a program built into Hardy called xrandr. I heard about a GUI for it, I think it's called grandr and is available in the repositories. You can try downloading and installing that to see if it help with the resolution problems.

grahams1 (gps1539) wrote :

Hi Rocket2Dmn

I'm using the open source driver (fglrx doesn't support this older chip).

I got compiz working fine on Hardy with a similar workaround as to your well written howto. My issue is just with screen resolution.

System->Preferences->Screen Resolution doesn't offer any resolutions other than the native 1400x1050 for the laptop screen.

To troubleshot this a little further I borrowed an external monitor. Hardy had no problem identifying it and offering different resolutions, but still would not offer more than the native 1400x1050 on the laptop. The issue is limited to the internal laptop screen (which works fine on feisty).

I'm guessing there is a handshake when monitors are attached and the screen on this laptop either doesn't respond correctly or Hardy doesn't recognize the monitor type.

I've tried to force the resolution by manual edit of xorg.conf, but it is always overwritten. I will try grandr, next time I try the live CD.

Connor Imes (ckimes) wrote :

The support offered by the open source ati drivers is incomplete. I know for a fact that dual head does not work on my Mobility Radeon 9000, the most I can do is duplicate to an external monitor/projector what's on the screen, I cannot set true dual head or fiddle with resolutions with that setup.

However, you should be able to control the screen resolution when only your laptop monitor is enabled. The new version of X in Hardy is a little different, so I am still trying to figure out how to effectively tweak it. For those using Gutsy, you could follow this guide to have the correct screen resolution options: http://ubuntuforums.org/showthread.php?t=690760 (be sure to select your max resolution AND everything less). Because of the new version of X, that guide will not work in Hardy since it won't prompt for video driver or screen resolutions.

grahams, the best advice I can offer you right now is to manually edit your xorg.conf.
I will post my xorg.conf since, to my surprise, it did not change from the Gutsy setup during the upgrade to Hardy. Here is the most important excerpt:

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Modes "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection

You can manually edit xorg.conf, first make a backup

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
gksudo gedit /etc/X11/xorg.conf

After your changes - save and close, log out and log back in, or kill X with CTRL+ALT+BACKSPACE
If you have to recover your xorg.conf from a tty, run

sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

or just auto-reconfigure X (which you may consider trying anyway to help solve the problem) with

sudo dpkg-reconfigure xserver-xorg -phigh

grahams1 (gps1539) wrote :

Thanks, tried editing xorg.conf before, tried again after booting final hardy CD and I still can not change the resolution.

Even if I only list lower resolutions like "1280x1024" it is still fixed at 1400x1050.

grahams1 (gps1539) wrote :

BTW. anyone know if other OSes using xorg 7.3 have the same issue and how to submit bugs to xorg?

Nazim Aghabayov (nazim-aga) wrote :

Hi Graham

I'm going to test my Compaq n610c with a FreeBSD 7.0, because it using X.Org 7.3. I'll let you know about the results.

grahams1 (gps1539) wrote :

Thanks Nazim, interested to see how FreeBSD works.

btw. I found fedora 9 alpha which uses X.Org 7.4 does allow me to change the resolution, so we have some hope.

Bryce Harrington (bryce) wrote :

(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1400x1050"x0.0 108.00 1400 1448 1560 1688 1050 1051 1054 1068 -hsync -vsync (64.0 kHz)
(II) RADEON(0): DDC Type: 4, Detected Monitor Type: 2
(II) RADEON(0): EDID data from the display on connector: Proprietary/LVDS ----------------------
(II) RADEON(0): Manufacturer: HTC Model: 17b0 Serial#: 420189172
...
(II) RADEON(0): First detailed timing not preferred mode in violation of standard!(II) RADEON(0): redX: 0.590 redY: 0.340 greenX: 0.320 greenY: 0.560

Looks like it's using DDC instead of EDID, and DDC is only returning the one resolution. Perhaps using option NoDDC would change it? If not, maybe the monitor needs quirked. Try setting NoDDC first, and let me know.

Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
status: Incomplete → Triaged
grahams1 (gps1539) wrote :

fantastic !!

adding
Option "NoDDC"
to xorg.conf and it did the trick.

Bryce Harrington (bryce) on 2008-05-10
Changed in xserver-xorg-video-ati:
status: Triaged → In Progress

Magic! Option "NoDDC" works!

Thank you All for your help.

Bryce Harrington (bryce) on 2008-05-24
Changed in xserver-xorg-video-ati:
assignee: nobody → bryceharrington

Several Ubuntu users are reporting this issue:

https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/160871

With an ATI 7500, the lcd screen shows 1400x1050, but xrandr offers no other resolutions, although several are supported.

http://launchpadlibrarian.net/12221450/xorg.conf
http://launchpadlibrarian.net/12221452/Xorg.0.log

(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1400x1050"x0.0 108.00 1400 1448 1560 1688 1050 1051 1054 1068 -hsync -vsync (64.0 kHz)
(II) RADEON(0): DDC Type: 4, Detected Monitor Type: 2
(II) RADEON(0): EDID data from the display on connector: Proprietary/LVDS ----------------------
(II) RADEON(0): Manufacturer: HTC Model: 17b0 Serial#: 420189172
...
(II) RADEON(0): First detailed timing not preferred mode in violation of standard!(II) RADEON(0): redX: 0.590 redY: 0.340 greenX: 0.320 greenY: 0.560

Looks like it's using DDC instead of EDID, and DDC is only returning the one resolution.

Adding Option "NoDDC" to xorg.conf fixes the issue.

Bryce Harrington (bryce) on 2008-08-20
Changed in xserver-xorg-driver-ati:
importance: Undecided → Unknown
status: New → Unknown
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed

Thanks for both of you confirming that - I've forwarded the bug upstream for them to take a look at. Could both of you please subscribe yourselves to this upstream bug, in case the developers need further info or need you to test something? Thanks ahead of time.

https://bugs.freedesktop.org/show_bug.cgi?id=17215

Changed in xserver-xorg-video-ati:
assignee: bryceharrington → nobody

Thanks Bryce

I added my email address to the cc list.

Graham

On Tue, Aug 19, 2008 at 7:05 PM, Bryce Harrington
<email address hidden> wrote:
> Thanks for both of you confirming that - I've forwarded the bug upstream
> for them to take a look at. Could both of you please subscribe
> yourselves to this upstream bug, in case the developers need further
> info or need you to test something? Thanks ahead of time.
>
> https://bugs.freedesktop.org/show_bug.cgi?id=17215
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Assignee: Bryce Harrington (bryceharrington) => (unassigned)
>
> --
> Screen resolution issues in Hardy with Radeon Mobility 7500 unless NoDDC specified
> https://bugs.launchpad.net/bugs/160871
> You received this bug notification because you are a direct subscriber
> of the bug.
>

It's using DDC (Display Data Channel) to get the EDID (Extended Display Identification Data). DDC is the method by which an EDID is obtained.
The EDID is list of supported modes and features from the monitor. Generally LVDS panels only support one resolution: the native mode of the panel. Other modes are supported by scaling a non-native mode to the native mode of the panel using the scaling hardware. In the cases where a monitor provides an EDID, we use that data since it should contain the monitor's preferred modelines. In monitors without an EDID, we attempt to add the modes in the display subsection of screen section of the config.

You can add new modes at run time using xrandr:
xrandr --newmode 1024x768 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
xrandr --addmode LVDS 1024x768

Ah, thanks for the explanation!

But why does NoDDC make it work for these guys? I'd have expected the opposite based on this description.

Also, if EDID only gives one resolution and the scaler should be used for the others, why aren't scaled resolutions provided through xrandr in this case?

Created an attachment (id=18465)
Always add the screen modes to LVDS

(In reply to comment #2)
> Ah, thanks for the explanation!
>
> But why does NoDDC make it work for these guys? I'd have expected the opposite
> based on this description.

Because in that case the driver ignores the edid and just adds the modes defined in the screen section which may include non-native modes.

>
> Also, if EDID only gives one resolution and the scaler should be used for the
> others, why aren't scaled resolutions provided through xrandr in this case?
>

We rely on the EDID unless it's not available. The question is which modes should we add by default? 800x600? 1024x768? 1152x864? I suppose we could always add the screen modes even when an EDID is present (maybe just for LVDS). I'm not sure what the best solution is. The attached patch always adds the modes specified in the screen section to LVDS outputs.

Note that users can still add new modes at runtime using xrandr:
xrandr --newmode 800x600 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
xrandr --addmode LVDS 800x600

Bryce Harrington (bryce) wrote :

Seems that this was really a hardware limitation, so I'll go ahead and mark it fixed.

You can add resolutions manually using xrandr - see this guide:
https://wiki.ubuntu.com/X/Troubleshooting/Resolution#Problem:%20%20The%20LCD%27s%20maximum%20resolution%20is%20detected%20automatically,%20but%20lower%20resolutions%20are%20not%20available

There's been some improvements to how this is handled in Jaunty, so if after testing that you still feel there are some problems needing to be investigated, feel free to reopen.

Regarding the problem that Screen Resolution doesn't provide a way to add additional resolutions, feel free to file a wishlist bug against gnome-control-center if there isn't already a bug report for that.

Changed in xserver-xorg-video-ati:
status: In Progress → Fix Released

Not sure I agree with this being a hardware limitation. There were no
issues on older versions of the code and I believe this is a common
ATI controller. Not a big deal as the work around is easy.

I will try 9.04 in a few weeks and report back.

On 2/20/09, Bryce Harrington <email address hidden> wrote:
> Seems that this was really a hardware limitation, so I'll go ahead and
> mark it fixed.
>
> You can add resolutions manually using xrandr - see this guide:
> https://wiki.ubuntu.com/X/Troubleshooting/Resolution#Problem:%20%20The%20LCD%27s%20maximum%20resolution%20is%20detected%20automatically,%20but%20lower%20resolutions%20are%20not%20available
>
> There's been some improvements to how this is handled in Jaunty, so if
> after testing that you still feel there are some problems needing to be
> investigated, feel free to reopen.
>
> Regarding the problem that Screen Resolution doesn't provide a way to
> add additional resolutions, feel free to file a wishlist bug against
> gnome-control-center if there isn't already a bug report for that.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> [Mobility M7 7500] Screen resolution issues in Hardy unless NoDDC specified
> https://bugs.launchpad.net/bugs/160871
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from my mobile device

grahams1 (gps1539) wrote :

Upgraded to 9.04 and have no issues changing the resolution.

This has been fixed for a while.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.