xserver-xorg-video-ati 1:6.7.195-1ubuntu1 causes blank screen

Bug #150370 reported by Curtis Lee Bolin on 2007-10-07
10
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

xserver-xorg-video-ati 1:6.7.195-1ubuntu1 causes blank screen without any errors in xorg log. 1:6.7.194-1ubuntu1 had no problems.

My hardware:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

If you have any questions, I would be happy to give any needed information.

Thank You For Your Time

jritch (jritch77) wrote :

I am having the same problem. Same hardware. As soon as system boots screen goes blank.

I did find some errors in Xorg.0.log. These are not found when using xserver-xorg-video-ati 1:6.7.194.

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.

(EE) AIGLX: Screen 0 is not DRI capable

Timo Aaltonen (tjaalton) wrote :

curtlee2002: do you have a log with .194 for comparison? ('grep wrapper /var/log/Xorg.0.log.old' if not sure)

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Timo Aaltonen (tjaalton) on 2007-10-07
Changed in xserver-xorg-video-ati:
importance: Undecided → High

Sorry, I do not have a log for .194. I tried to startx to many times. If you could tell me how to get .194, I would gladly re-install it and post its log. I am new to ubuntu, but I have been using gentoo for about 5 years. I would be glad you to help.

I ran:
wget http://mirror.anl.gov/pub/ubuntu/pool/main/x/xserver-xorg-video-ati/xserver-xorg-video-ati_6.7.194-1ubuntu1_i386.deb
dpkg -i xserver-xorg-video-ati_6.7.194-1ubuntu1_i386.deb

Now I have a log for .194

Changed in xserver-xorg-video-ati:
status: Incomplete → New
little jo (littel-jo) wrote :

I have the same problem...

Timo Aaltonen (tjaalton) wrote :

Please test the latest package (1ubuntu1tja2) available here:

http://ppa.launchpad.net/tepsipakki/ubuntu/pool/main/x/xserver-xorg-video-ati/

once it is built..

Changed in xserver-xorg-video-ati:
status: New → Incomplete

Hi guys,
I have a Dell Latitude C640 with an ATI Radeon Mobility 7500 graphic card.
I'm experiencing problems with the last update of the ati driver: when X starts, gdm login screen is very corrupted...it seems that the monitor is out-of-sync. I just tried to lower the screen resolution down to 1024x768 without success.
This is a regression since i had no problems at all with 1:6.7.194-1ubuntu1
Timo, I will test your package as soon as possible!

Timo Aaltonen (tjaalton) wrote :

Jarvis: thanks for testing!

curtlee2002, I believe that it is fixed for you too, so please test that version :)

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Committed

It also fix here! THANKS!

2007/10/8, Timo Aaltonen <email address hidden>:
>
> Jarvis: thanks for testing!
>
> curtlee2002, I believe that it is fixed for you too, so please test that
> version :)
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Incomplete => Fix Committed
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Target: None => ubuntu-7.10-rc
>
> --
> xserver-xorg-video-ati 1:6.7.195-1ubuntu1 causes blank screen
> https://bugs.launchpad.net/bugs/150370
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-ati (1:6.7.195-1ubuntu2) gutsy; urgency=low

  * debian/patches:
    02_add_option_for_lvds_mode.diff
    - Add an option for using LVDS mode (default: on), setting false
      enables CVT-mode (LP: #150278, #150370, #150497)

 -- Timo Aaltonen <email address hidden> Mon, 8 Oct 2007 14:59:18 +0300

Changed in xserver-xorg-video-ati:
status: Fix Committed → Fix Released

Yes problem is solved. Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers