GUTSY. No video output firing up X.

Bug #144011 reported by Paolo C. on 2007-09-22
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

As reported here:
http://ubuntuforums.org/forumdisplay.php?f=238

I cannot use X anylonger after an update I did on the 19th of September.

" I did an update two hours ago, problem is still present.
If i use the radeon driver the lcd monitor reports "no video input" when x is starting up, ìf i use the fglx driver x star in failsafe mode, i can select monitor and video card and then the "no video" problem occours again.
What do you suggest? "

WinXP reports my graphic card as an "ATI RADEON 7200 series"

Paolo C. (paolo.ciarrocchi) wrote :

I tried:
- Booting without the xorg.conf file
- disabling glx in the xorg.conf file

Nothing changed.

Timo Aaltonen (tjaalton) wrote :

Could you try installing the package available here:

http://ppa.launchpad.net/tormodvolden/ubuntu/pool/main/x/xserver-xorg-video-ati/xserver-xorg-video-ati_6.7.194-1ubuntu1tv_i386.deb

and also attach /var/log/Xorg.0.log.

On 9/26/07, Timo Aaltonen <email address hidden> wrote:
> Could you try installing the package available here:
>
> http://ppa.launchpad.net/tormodvolden/ubuntu/pool/main/x/xserver-xorg-
> video-ati/xserver-xorg-video-ati_6.7.194-1ubuntu1tv_i386.deb

I just tried, no changes.

> and also attach /var/log/Xorg.0.log.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Sourcepackagename: None => xserver-xorg-video-ati
> Status: New => Incomplete

attached.

Paolo C. (paolo.ciarrocchi) wrote :

Is there any further information that I should provide?

This is a blocking issue for me.

Tormod Volden (tormodvolden) wrote :

The crash which I can see in your log (in RADEONInitDispBandwidth) is maybe fixed in the -tv5 package (http://ppa.launchpad.net/tormodvolden/ubuntu/pool/main/x/xserver-xorg-video-ati/). Please try it.

Paolo C. (paolo.ciarrocchi) wrote :

Tormod,
package downloaded, installed, reboot without a xorg.conf file and everything is working fine.

Problem solved.

Thanks!!

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Committed
Tormod Volden (tormodvolden) wrote :

Probably fixed by upstream (freedesktop.org) commit 0ca184c3c35032df39ea7ce5d2d4aba1a97b6426
"RADEON: fix RADEONInitDispBandwidth() on single crtc cards"

Timo Aaltonen (tjaalton) on 2007-10-05
Changed in xserver-xorg-video-ati:
importance: Undecided → Critical
importance: Critical → High
Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-ati (1:6.7.194-1ubuntu2) gutsy; urgency=low

  [ Timo Aaltonen ]
  * Add some patches from git master which fix a number of important
    bugs. Also add a new patch (10) which has not yet been merged
    upstream.

  [ Tormod Volden ]
  * debian/patches/02_mode_code_cleanup.diff:
    - Prerequisite for patch 03.
    "RADEON: more clean up of mode code"
    (fd.o commit 21593d04d222b05dbba9abd31eaa3bfb91d999b6)
  * debian/patches/03_LVDS_mode_validation.diff:
    - Prerequisite for patch 07.
    "RADEON: more work on LVDS mode validation and fixups"
    (fd.o commit 99ceaefa18c6e07b55106cca0ea8996fa73667be)
  * debian/patches/04_remove_cruft.diff
    - Removes two unused functions.
    "RADEON: remove cruft"
    (fd.o commit dcc376e2d2a13329dd03f1bc4b471329757a6f5f)
  * debian/patches/05_ext_tdms_table.diff
    - Prerequisite for patch 09.
    "RADEON: add support for ext tmds table and ext tmds chip init"
    (fd.o commit 22519fde1e002f28d6036d448fcd18452d00f1bb)
  * debian/patches/06_initdispbandwidth.diff:
    "RADEON: fix RADEONInitDispBandwidth() on single crtc cards"
    (LP: #86072, #144011)
    (fd.o commit 0ca184c3c35032df39ea7ce5d2d4aba1a97b6426)
  * debian/patches/07_sort_out_LVDS_modes.diff:
    - Prerequisite for patch 09.
    "RADEON: Finally sort out LVDS modes"
    (fd.o commit cc0c2d8e61600652b1f9cb3dc49db2ef62b1e40d)
  * debian/patches/08_disable_dri_rc410.diff:
    "rc410: disable DRI by default due to it not working"
    (LP: #144297)
    (fd.o commit d808781d48adf01e80b5bb476bae2d2f599030f1)
  * debian/patches/09_mode_and_output_fixes.diff:
    "RADEON: final fix for RMX/LVDS"
    (LP: #132716)
    (fd.o commit 597dffce9bdc200003d0be880235258386a0bdd7)
    "RADEON: minor fixes for external TMDS"
    (fd.o commit bfede412b3a3cd11769a580b167c528734146096)
    "RADEON: remove RADEONSaveMode()"
    (fd.o commit 5f5c4e6ad61c45c24f1443b91b4bc5375efdebc0)
    "RADEON: more fixes for single crtc chips"
    (fd.o commit b6bda79f72df5e5bf9c6b71fa3298e765da506bd)
    "RADEON: remove some cruft"
    (fd.o commit 3a958ba136c3fae5a4ddd56373ac7cd47046f10e)
  * debian/patches/10_disable_dri_rs485.diff
    - disable DRI on RS485 (the driver mistakenly lists it as RS482)
      (LP: #139241)

 -- Timo Aaltonen <email address hidden> Sat, 6 Oct 2007 01:52:08 +0300

Changed in xserver-xorg-video-ati:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers