ubuntu MATE 15.04 PPC/Lubuntu 15.04 PPC Xorg: Only black screen with blink cursor after update

Bug #1434036 reported by Christian Zigotzky on 2015-03-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-fbdev (Ubuntu)
Undecided
Unassigned

Bug Description

Hi All,

We updated ubuntu MATE 15.04 and Lubuntu 15.04 on our PowerPC computers (Power Mac G5 Quad and AMIGA one X1000) last week. Synaptic told us that it want to remove xserver-xorg-video-radeon and xserver-xorg-video-ati. But there are new versions available (xserver-xorg-video-radeon 1:7.5.0-1ubuntu2 and xserver-xorg-video-ati 1:7.5.0-1ubuntu2). Synaptic removed both old packages and Xorg didn't work after that. I selected both new packages and updated them manually. After a restart I had a black screen with a blink cursor. There aren't any error messages in the log file '/var/log/Xorg.0.log' but I found some error messages in the log file '/var/log/syslog':

    . Exiting.
    Mar 19 11:45:41 ubuntu systemd[1]: lightdm.service: main process exited, code=exited, status=1/FAILURE
    Mar 19 11:45:41 ubuntu systemd[1]: Unit lightdm.service entered failed state.
    Mar 19 11:45:41 ubuntu systemd[1]: lightdm.service failed.
    Mar 19 11:45:41 ubuntu systemd[1]: lightdm.service holdoff time over, scheduling restart.
    Mar 19 11:45:41 ubuntu systemd[1]: Starting Light Display Manager...
    Mar 19 11:45:41 ubuntu systemd[1]: Started Light Display Manager.
    Mar 19 11:45:41 ubuntu lightdm[20218]: initctl: Verbindung zu Upstart nicht möglich: Failed to connect to socket /com/ubuntu/upstart: Verbindungsaufbau abgelehnt
    Mar 19 11:45:42 ubuntu systemd[1]: Started Session c109 of user lightdm.
    Mar 19 11:45:42 ubuntu systemd[1]: Starting Session c109 of user lightdm.
    Mar 19 11:45:42 ubuntu lightdm[20218]: ** (lightdm:20218): WARNING **: Error using VT_WAITACTIVE 7 on /dev/console: No such device or address
    Mar 19 11:45:43 ubuntu kernel: lightdm-gtk-gre[20251]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
    Mar 19 11:45:44 ubuntu org.gtk.vfs.Daemon[20250]: A connection to the bus can't be made
    Mar 19 11:45:44 ubuntu org.gtk.vfs.Daemon[20250]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    Mar 19 11:45:44 ubuntu systemd[1]: lightdm.service: main process exited, code=exited, status=1/FAILURE
    Mar 19 11:45:44 ubuntu systemd[1]: Unit lightdm.service entered failed state.
    Mar 19 11:45:44 ubuntu systemd[1]: lightdm.service failed.
    Mar 19 11:45:44 ubuntu systemd[1]: lightdm.service holdoff time over, scheduling restart.
    Mar 19 11:45:44 ubuntu systemd[1]: Starting Light Display Manager...
    Mar 19 11:45:44 ubuntu systemd[1]: Started Light Display Manager.
    Mar 19 11:45:44 ubuntu lightdm[20381]: initctl: Verbindung zu Upstart nicht möglich: Failed to connect to socket /com/ubuntu/upstart: Verbindungsaufbau abgelehnt
    Mar 19 11:45:45 ubuntu systemd[1]: Started Session c110 of user lightdm.
    Mar 19 11:45:45 ubuntu systemd[1]: Starting Session c110 of user lightdm.
    Mar 19 11:45:45 ubuntu lightdm[20381]: ** (lightdm:20381): WARNING **: Error using VT_WAITACTIVE 7 on /dev/console: No such device or address
    Mar 19 11:45:46 ubuntu kernel: lightdm-gtk-gre[20414]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
    Mar 19 11:45:46 ubuntu org.gtk.vfs.Daemon[20413]: A connection to the bus can't be made
    Mar 19 11:45:46 ubuntu org.gtk.vfs.Daemon[20413]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0)

------------------------------------------------------------------------------

I installed Upstart again but unfortunately it didn't solve the problem with the black screen and the blink cursor.

The temporary solution is to downgrade Xorg:

sudo dpkg -i xserver-xorg-core_1.16.0-1ubuntu1.3_powerpc.deb
sudo dpkg -i xserver-xorg-video-radeon_7.4.0-2ubuntu2_powerpc.deb
sudo dpkg -i xserver-xorg-video-ati_7.4.0-2ubuntu2_powerpc.deb

I created a package with all debs and Mesa libs for the downgrade last week.

Download: http://www.xenosoft.de/Xorg_and_unofficial_Mesa_for_ubuntu_MATE_15.04_AMIGA_one_X1000.tar.gz

Further information: http://ubuntuforums.org/showthread.php?t=2264322

PLEASE help us.

Thanks in advance.

Cheers,

Christian

affects: nux (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
description: updated

Another user has a similar problem with fbdev. He had to downgrade:

xserver-xorg-video-fbdev
xserver-xorg-core

Link: http://ubuntuforums.org/showthread.php?t=2264322&page=16&p=13254875#post13254875

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1434036

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-fbdev (Ubuntu):
status: New → Confirmed
Herminio (herminio-hernandezjr) wrote :

I can get to MATE but the DE crashes. It pops up with a blank error box then goes in and out. I am attaching my logs and a screenshot.

Herminio (herminio-hernandezjr) wrote :

Here are the rest of my logs

Herminio (herminio-hernandezjr) wrote :
Herminio (herminio-hernandezjr) wrote :
Adam Smith (adamsmith) wrote :

There are a lot of unhandled signal 11 errors in those logs - could you confirm if you all have those so we're talking about the same error? If downgrading the xorg packages fixes those errors, then what was the last working xorg package(s)?

For me:

xserver-xorg-core_1.16.0-1ubuntu1.3_powerpc.deb
xserver-xorg-video-radeon_7.4.0-2ubuntu2_powerpc.deb
xserver-xorg-video-ati_7.4.0-2ubuntu2_powerpc.deb

I tested the ubuntu MATE 15.04 beta2 PowerPC live DVD in a virtual QEMU/KVM machine. Xorg starts but unfortunately some colors are wrong on the ubuntu MATE desktop. I can't use the mate-panel. If I click on the panel (menu, icons etc) then nothing happens. The mate panel and the mate taskbar starts again and again. The beta 1 live DVD works without these problems in a virtual QEMU/KVM machine. On my AMIGA one X1000 PowerPC the beta 2 works very well with the old Xorg packages and Upstart. The temporary solution for QEMU and Power Macs is, to try to install ubuntu MATE 15.04 with the Ubuntu Server ISO or with the netboot CD. The installer runs only in text mode. If you installed it, then you could install the ubuntu MATE packages and the OpenSSH server. After that you could downgrade Xorg via SSH.

Christian could you post your dmseg and kenel logs before you made you work around? It would be interesting to see if we are having the same type of errors.

Adam Smith (adamsmith) wrote :

The last working versions for me were xserver-xorg-core_1.16.2.901-1ubuntu4 and xserver-xorg-video-radeon_7.5.0-1ubuntu1

1.17 introduced the problem.

Adam Smith (adamsmith) wrote 19 hours ago:

-- There are a lot of unhandled signal 11 errors in those logs - could you confirm if you all have those so we're talking about the same error? If downgrading the xorg packages fixes those errors

Yes, the downgrade fixes the signal 11 errors. I figured out that I have a lot of signal 11 error messages with systemd. With Upstart I have only 4 signal 11 errors:

[ 9.371697] lightdm-gtk-gre[2731]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 14.367464] lightdm-gtk-gre[3000]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 20.591891] lightdm-gtk-gre[3219]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 26.831432] lightdm-gtk-gre[3533]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001

With systemd, X11 starts again and again with a white screen. With Upstart I have a black screen with a blink cursor.

Created attachment 114809
dmesg with the latest Xorg packages and with systemd

Hi All,

Xorg 1.17 doesn't start on PowerPC computers (Power Macs, NG Amigas etc). I figured out that I have a lot of signal 11 error messages with systemd. With Upstart I have only 4 signal 11 errors:

[ 9.371697] lightdm-gtk-gre[2731]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 14.367464] lightdm-gtk-gre[3000]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 20.591891] lightdm-gtk-gre[3219]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001
[ 26.831432] lightdm-gtk-gre[3533]: unhandled signal 11 at 00000000 nip 6f4e61c4 lr 6f4e619c code 30001.

With systemd, X11 starts again and again with a white screen. With Upstart I have a black screen with a blink cursor.

The temporary solution is to downgrade Xorg:

sudo dpkg -i xserver-xorg-core_1.16.0-1ubuntu1.3_powerpc.deb
sudo dpkg -i xserver-xorg-video-radeon_7.4.0-2ubuntu2_powerpc.deb
sudo dpkg -i xserver-xorg-video-ati_7.4.0-2ubuntu2_powerpc.deb

I created a package with all debs and Mesa libs for the downgrade three weeks ago.

Download: http://www.xenosoft.de/Xorg_and_unofficial_Mesa_for_ubuntu_MATE_15.04_AMIGA_one_X1000.tar.gz

Further information:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1434036
http://ubuntuforums.org/showthread.php?t=2264322
http://forum.hyperion-entertainment.biz/viewtopic.php?f=35&t=2840
http://forum.hyperion-entertainment.biz/viewtopic.php?f=35&t=2847

PLEASE help us.

Thanks in advance.

Cheers,

Christian

Created attachment 114810
kern.log with the latest Xorg packages and with systemd

Created attachment 114811
Xorg.0.log with the latest Xorg packages and with systemd

Created attachment 114812
syslog with the latest Xorg packages and with systemd

Created attachment 114813
dmesg with the latest Xorg packages and with Upstart

I created a bug report on freedesktop.org today.

Link: https://bugs.freedesktop.org/show_bug.cgi?id=89862

I also am have the same issue on my iBook G4. Here are my logs as well.

Created attachment 114814
my dmseg log

Created attachment 114815
my kern.log

Created attachment 114816
my Xorg.0.log

Created attachment 114817
my syslog

I added to the bug report

There's no sign of a crash in the attached Xorg.0.log files. Are you sure it's Xorg that's crashing, not e.g. lightdm?

Adam Smith (adamsmith) wrote :

It is not the xorg that is crashing, but it is causing other programs to crash with the unhandled signal error. If you are using an installed system then lightdm-gtk-gre may give the error, if you are using a live iso then mate-panel etc will give an endless loop of errors as the mate session restarts.

 I found the following in the lightdm log:

rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/lightdm.log |grep 1482
[+18.98s] DEBUG: Session pid=1482: Started with service 'lightdm-autologin', username 'ubuntu-mate'
[+19.25s] DEBUG: Session pid=1482: Authentication complete with return value 0: Success
[+19.28s] DEBUG: Session pid=1482: Running command /usr/sbin/lightdm-session mate-session
[+19.28s] DEBUG: Session pid=1482: Logging to .xsession-errors
rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/lightdm.log |grep -e WARN
[+19.79s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: No such device or address
rican-linux@ibookG4-MATE:~$

and this in the xsession-error log

rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/xsession-errors.log |grep -i error
TypeError: argument of type 'NoneType' is not iterable
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
 I am post the entire logs for both.

I found the following in the lightdm log:

rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/lightdm.log |grep 1482
[+18.98s] DEBUG: Session pid=1482: Started with service 'lightdm-autologin', username 'ubuntu-mate'
[+19.25s] DEBUG: Session pid=1482: Authentication complete with return value 0: Success
[+19.28s] DEBUG: Session pid=1482: Running command /usr/sbin/lightdm-session mate-session
[+19.28s] DEBUG: Session pid=1482: Logging to .xsession-errors
rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/lightdm.log |grep -e WARN
[+19.79s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: No such device or address
rican-linux@ibookG4-MATE:~$

and this in the xsession-error log

rican-linux@ibookG4-MATE:~$ cat /media/rican-linux/Lexar/xsession-errors.log |grep -i error
TypeError: argument of type 'NoneType' is not iterable
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
 I am post the entire logs for both.

Created attachment 114834
lightdm log

Created attachment 114835
xessions-error log

(In reply to Christian Zigotzky from comment #0)
> [ 9.371697] lightdm-gtk-gre[2731]: unhandled signal 11 at 00000000 nip
> 6f4e61c4 lr 6f4e619c code 30001

Actually, it says right here that the crashing process is lightdm-gtk-gre, not Xorg. Please file a bug against lightdm.

Artyom Nikolaev (artyom-q) wrote :

Same for me on PowerBook6,5 after upgrade from 14.04 to 15.04 as well as on live 15.04-beta2 boot.
Error messagebox appers after Mate start and then X restarting in a cycle.

I installed the display manager "slim". It started and I could login. But I have the same errors with the MATE desktop like on QEMU. Some colors are wrong on the ubuntu MATE desktop. I can't use the mate-panel. If I click on the panel (menu, icons etc) then nothing happens. The mate panel and the mate taskbar starts again and again. And there is a blank error message in the middle of the desktop. I installed lightdm again and I downgraded the Xorg packages again. Everything works without any problems again.

Quote Adam Smith (ubuntu MATE google+)

Since downgrading the xorg fixes it, then surely that makes it an xorg issue? Since a lot of applications are giving the same unhandled signal error then it has to be a common library or something else in common so again that points to the xorg.

Quote end

I installed the display manager "slim". It started and I could login. But I have the same errors with the MATE desktop like on QEMU. Some colors are wrong on the ubuntu MATE desktop. I can't use the mate-panel. If I click on the panel (menu, icons etc) then nothing happens. The mate panel and the mate taskbar starts again and again. And there is a blank error message in the middle of the desktop. I installed lightdm again and I downgraded the Xorg packages again. Everything works without any problems again.

Artyom Nikolaev (artyom-q) wrote on 2015-04-03 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1434036:

Same for me on PowerBook6,5 after upgrade from 14.04 to 15.04 as well as on live 15.04-beta2 boot.
Error messagebox appers after Mate start and then X restarting in a cycle.

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed

This bug is definitely a Xorg bug. It affects all PowerPC machines. Please look in the following thread: http://ubuntuforums.org/showthread.php?t=2264322&page=22&p=13260389#post13260389.

Please help us.

This bug is definitely a Xorg bug. It affects all PowerPC machines. Please look in the following thread: http://ubuntuforums.org/showthread.php?t=2264322&page=22&p=13260389#post13260389.

Please help us.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed

I loaded Ubuntu-MATE 15.04 Beta2 again. This time I added these to my boot parameters drm.debug=14 log_buf_len=14M and pulled the dmesg and journalctl log off. Will be attaching them. Here is a sample of what I am seeing

Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.Accounts.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.ColorManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.RealtimeKit1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.SystemToolsBackends.conf: Error retrieving chunk extents: Operation not supported

I loaded Ubuntu-MATE 15.04 Beta2 again. This time I added these to my boot parameters drm.debug=14 log_buf_len=14M and pulled the dmesg and journalctl log off. Will be attaching them. Here is a sample of what I am seeing

Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.Accounts.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.ColorManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.RealtimeKit1.conf: Error retrieving chunk extents: Operation not supported
Apr 09 15:21:52 ubuntu-mate ureadahead[857]: ureadahead:/etc/dbus-1/system.d/org.freedesktop.SystemToolsBackends.conf: Error retrieving chunk extents: Operation not supported

Created attachment 114988
dmesg-drm_debug

Created attachment 114989
journalctl

Hi All,

I updated ubuntu MATE 15.04 on my AMIGA one X1000 today. And this is unbelievable. Xorg starts with Upstart and systemd. I don't need to downgrade Xorg. But unfortunately some colors are wrong on the ubuntu MATE desktop. I mean I have the same color problems as on QEMU PowerPC. The mate-settings-daemon starts with systemd 10 minutes after the login. With Upstart the mate-settings-daemon works without any problems immediately.

[QUOTE=Martin Wimpress ubuntu MATE google+]
I've pinged some devs. Can you see if 'startx' works and update both the Xorg and LP bugs with the results please?
[/QUOTE]

I stopped lightdm with 'service lightdm stop'. After that I started X11 with 'startx'. But it didn't start with 'startx'. I didn't find any error messages in the file 'Xorg.0.log'. I found some error messages in the file '/var/log/syslog'.

[CODE]
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: Activating service name='org.a11y.atspi.Registry'
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: Successfully activated service 'org.a11y.atspi.Registry'
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Apr 9 23:18:29 ubuntu gnome-session[4528]: x-session-manager[4528]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Apr 9 23:18:29 ubuntu x-session-manager[4528]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: after 21 requests (21 known processed) with 0 events remaining.
Apr 9 23:18:29 ubuntu org.gtk.vfs.Daemon[4532]: A connection to the bus can't be made
Apr 9 23:18:29 ubuntu org.gtk.vfs.Daemon[4532]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
[/CODE]

I installed Upstart with 'apt-get install upstart-sysv' again and then I downgraded Xorg to version 1.16.0. After a reboot all things work without any problems.

Rgds,

Christian

Hi All,

I updated ubuntu MATE 15.04 on my AMIGA one X1000 today. And this is unbelievable. Xorg starts with Upstart and systemd. I don't need to downgrade Xorg. But unfortunately some colors are wrong on the ubuntu MATE desktop. I mean I have the same color problems as on QEMU PowerPC. The mate-settings-daemon starts with systemd 10 minutes after the login. With Upstart the mate-settings-daemon works without any problems immediately.

[QUOTE=Martin Wimpress ubuntu MATE google+]
I've pinged some devs. Can you see if 'startx' works and update both the Xorg and LP bugs with the results please?
[/QUOTE]

I stopped lightdm with 'service lightdm stop'. After that I started X11 with 'startx'. But it didn't start with 'startx'. I didn't find any error messages in the file 'Xorg.0.log'. I found some error messages in the file '/var/log/syslog'.

[CODE]
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: Activating service name='org.a11y.atspi.Registry'
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: Successfully activated service 'org.a11y.atspi.Registry'
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Apr 9 23:18:29 ubuntu gnome-session[4528]: x-session-manager[4528]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Apr 9 23:18:29 ubuntu x-session-manager[4528]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Apr 9 23:18:29 ubuntu org.a11y.atspi.Registry[4569]: after 21 requests (21 known processed) with 0 events remaining.
Apr 9 23:18:29 ubuntu org.gtk.vfs.Daemon[4532]: A connection to the bus can't be made
Apr 9 23:18:29 ubuntu org.gtk.vfs.Daemon[4532]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Apr 9 23:18:29 ubuntu org.a11y.Bus[4532]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
[/CODE]

I installed Upstart with 'apt-get install upstart-sysv' again and then I downgraded Xorg to version 1.16.0. After a reboot all things work without any problems.

Rgds,

Christian

I booted in the current daily live iso. The DE no longer crashes however I am seeing the colors are all off. I am still noticing errors on the logs and will post them to LP and Freedesktop.

I booted in the current daily live iso. The DE no longer crashes however I am seeing the colors are all off. I am still noticing errors on the logs and will post them to LP and Freedesktop.

Created attachment 115017
Xorg-20150410.log

Created attachment 115018
xsession-error-20150410.log

Created attachment 115019
dmesg-20150410

Created attachment 115020
journalctl-20150410

Sounds like the crashes are fixed.

The wrong colours are probably (related to) the well-known Gallium driver endianness bugs.

Upstream consider this bug fixed since X crashing has been resolved. A new bug will be raised for the corrupt colour palette when running on PowerPC.

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-fbdev (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released

Does anyone know why Xorg is trying to load fglrx (propietary radeon) on PowerPC? I did not think this was supported?

163.141] (II) LoadModule: "fglrx"
[ 163.144] (WW) Warning, couldn't open module fglrx
[ 163.144] (II) UnloadModule: "fglrx"
[ 163.144] (II) Unloading fglrx
[ 163.144] (EE) Failed to load module "fglrx" (module does not exist, 0)

To post a comment you must log in.