[UVF] new version, 6.7.192 + fixes from git master

Bug #138987 reported by Timo Aaltonen on 2007-09-11
10
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

In mid-August we uploaded ati-6.6.193 to gutsy, when it was apparent that there would be a new upstream version 6.7 available shortly. Instead, it was decided to skip 6.7 and merge randr-1.2 branch in the driver, and release that as 6.7.191. The reasoning was that the old code base was "a dead duck" maintenance wise...

6.6.193 also introduced some regressions, which are unlikely to be fixed by upstream, so we have asked people to test the 6.7.19x series on the forum:

http://ubuntuforums.org/showthread.php?t=490982
http://ubuntuforums.org/showthread.php?t=544580

There still are some issues, but they need to be sorted out anyway. Upstream is pleased to have active testing, and is planning on releasing a .193 or even 6.8.0 release within a week or two.

I'll add other information tomorrow, hang on.

Timo Aaltonen (tjaalton) wrote :

Going through the bugs reported using this version there are no bugs that don't also affect the current version, or they are EXA related (which is not enabled by default) or other bizarre compiz-related bugs (slowness etc).

Instead, there is at least one long-standing bug which is confirmed being fixed with this release:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/22985

surely there are others too, but asking people to test an unofficial driver outside the distribution is hard, plus it doesn't scale.

Timo Aaltonen (tjaalton) wrote :
Timo Aaltonen (tjaalton) wrote :

From the diffstat you can see that mergedfb is deprecated in favor of randr-1.2. Also, tv-out is a new feature (although no PAL support IIRC).

Timo Aaltonen (tjaalton) wrote :

Attaching the changelog is pointless, since it has the randr-1.2 branch merged in... so the entries are sorted by actual dates, not just appended on top of the old one.

Timo Aaltonen (tjaalton) wrote :

..and the package itself is here:

http://users.tkk.fi/~tjaalton/dpkg/ati

Timo Aaltonen (tjaalton) wrote :

Now there's a new version, merged with experimental (-4ubuntu1).

After discussing with bryce, fine by me. Please upload.

Changed in xserver-xorg-video-ati:
status: New → Confirmed
Martin Pitt (pitti) wrote :

If you test it on some ATI hardware, this is fine for me, too.

Timo Aaltonen (tjaalton) wrote :

This has been tested on the forums quite well already (plus on my r200), but in order to get more widespread testing (more chipsets) it needs to be uploaded.. There is going to be a new release later this week (.193), but I'll upload this first.

Thanks!

Changed in xserver-xorg-video-ati:
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2007-09-19
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments