Ubuntu

Blank screen or distorted image because of wrong default AGPMode value

Reported by Wouter Stomp on 2007-08-17
80
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
High
Bryce Harrington
Declined for Gutsy by Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-ati

Since the updates a few days ago on gutsy, my screen shows horizontal tearing streaks with only the mouse pointer shown normally (see http://launchpadlibrarian.net/9255354/00001.jpg). This is on a radeon 9250.
Usplash is displayed normally, gdm and gnome are scrambled.

This problem was first seen on Gutsy with the upload of the 1:6.6.193-1ubuntu1 ati driver, and worked fine on Feisty and Breezy. Downgrading xserver-xorg-video-ati to feisty's 1:6.6.3-2ubuntu6 fixes the problem for me, so the problem must be in the changes between that version and 1:6.6.193-1ubuntu1.

[Workaround]
Disable 3D (including Desktop Effects) by adding this to your Modules section:

Section "Module"
        ...
        Disable "dri"
EndSection

If the above does not fix the issue for you, then you are not seeing this particular bug, and should report it separately.

UPDATE:

Try setting 'Option "AGPMode" "4"' to the Device section.

Btw, Usplash is displayed normally, gdm and gnome are scrambled

KIAaze (zohn-joidberg) wrote :

I also have this problem with an ATI Radeon IGP 345M on a Compaq Presario 2500 laptop.

My screen is less scrambled (I can recognize the login screen and even log in), but it still makes the system unusable.
The splash screen works normally for me too and the display is normal on an external monitor.

http://ubuntuforums.org/showthread.php?t=526924
http://www.linuxquestions.org/questions/showthread.php?t=577468

Changed in xserver-xorg-video-ati:
status: New → Confirmed
mabovo (mabovo) wrote :

Same to me with ATI Radeon 9600 using ati driver. Solved it replacing by fglrx 8.40.4 driver and reconfiguring Xorg.

This also happens when running from the live cd (tribe 5).

Will Farrington (wcfarrington) wrote :

I can confirm this with the 1.6.7.191 driver on Ubuntu Gutsy with a Radeon 7500.

Possibly the same issue on my Mobility Radeon 7500 in my T40. Gutsy boots fine and shows Gnome no problems. The tearing issue happens when I start playing with display-config-gtk such as changing the driver or configuring a second screen and then hitting Test. Completely jams up the system and only powering off with holding down the power button will shut it down.

I can't use the fglrx driver as it does not support the Radeon Mobility 7500.

raggar (mbaart) wrote :

Have the same issue on my acer aspire 5600 with a x1300 ati card.
I also have trouble with loading the live cd, after booting I get a blank screen. Later on I get a warning that the x server didn't load the driver. So I can't install from the live cd desktop.

mabovo (mabovo) wrote :

Last kernel update 2.6.22.11 using ati driver 6.7.192 and xserver-xorg 12ubuntu4 made a regression on Radeon 9600 cards and continues the status of "Screen displays garbage"

Bryce Harrington (bryce) on 2007-09-12
Changed in xserver-xorg-video-ati:
importance: Undecided → High
Bryce Harrington (bryce) wrote :

I just spoke with Alex Deucher about this, and showed the screenshot. He's aware of the problem but doesn't have an idea about what may be causing it or how to fix it. It seems to have been an issue for a while in the -ati driver. It's probably unrelated to the kernel version (if you can prove otherwise, let us know).

Can people experiencing this problem please do the following tests?

1. Try disabling tiling by adding Option "ColorTile" "false" to your driver section.
2. Try disabling DRI by adding Disable "DRI" in your module section
3. Try both the above together

Also, please attach your /etc/X11/xorg.conf and /var/log/Xorg.0.log in each of the above cases. Also include the output of lspci -vvnn.

More screenshots/photos of screens showing the garbage could also be quite valuable, so please also attach those if you have them.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Tried those 3 tests, none of them fixed the problem (btw. there is no driver section as far as I know, I assume you meant the device section, which is what I tried?).

1 comments hidden view all 135 comments

I don't think this is the same as the linked upstream bug freedesktop-bugs #11399. That bug is reported on breezy and feisty, while I had no problem on these. The problem for me seems to have started since the upload of the 1:6.6.193-1ubuntu1 ati driver (or around that time). Early in the Gutsy release cycle I didn't have the problem. Also on the screenshots in the upstream bug report I don't see the cursor anywhere, while as you can see on my screenshots the cursor is appearing crystal clear against a scrambled background.

Downgrading xserver-xorg-video-ati to feisty's 1:6.6.3-2ubuntu6 fixes the problem for me, so the problem must be in the changes between that version and 1:6.6.193-1ubuntu1.

mabovo (mabovo) wrote :

 I had to downgrade to 6.6.193-1ubuntu1 too.

mabovo (mabovo) wrote :

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AR [Radeon 9600] (prog-if 00 [VGA])
        Subsystem: C.P. Technology Co. Ltd Unknown device 2079
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 1: I/O ports at e000 [size=256]
        Region 2: Memory at fbe00000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fbd00000 [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x8
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon 9600] (Secondary)
        Subsystem: C.P. Technology Co. Ltd Unknown device 2078
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min), Cache Line Size: 64 bytes
        Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Region 1: Memory at fbf00000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

mabovo (mabovo) wrote :

This one I got with new fglrx 841.7 driver.

Changed in xorg-server:
status: Unknown → Confirmed
mabovo (mabovo) wrote :

Ati driver 1.6.7.192-1ubuntu2, xserver-xorg-core 2:1.3.0.0.dfsg-12ubuntu4 and xserver-xorg 1:7.2-5ubuntu9, Compiz works fine with Radeon 8500 on Gutsy "pure fresh install" without additional programs installed.

Radeon 9600 could recover from scratched screen with ati driver 1.6.7.192 following Bryce tips.

mabovo (mabovo) wrote :

I've got the same problem, after an upgrade from feisty to gutsy. i tried it with an empty xorg.conf, and with the two settings mentioned above to no avail. please find attached output from lspci

I did some more experimentation and found that if I disable glx and dri support in the xorg.conf I can start the xserver albeit without 3D graphics support. Hope this indicates where the problem might be.

How do you disable glx support?

Bryce Harrington (bryce) wrote :

You can disable by adding this to your Modules section:

Section "Module"
        ...
        Disable "glx"
        Disable "dri"
EndSection

It's not sufficient to simply comment out the Load lines if they're there; because Xorg now auto-loads modules if not explicitly mentioned.

My symptoms: on my notebook (Dell Inspiron 8600 w/ ATI Mobile Radeon RV350 (M10)), the new driver causes the LCD to be blank, with odd-colored vertical lines appearing somewhat randomly, and the entire screen fading very slowly to white).

Reverting back to xserver-xorg-video-ati_6.6.3-2ubuntu6_i386.deb works 100%.

Disabling ColorTiling, GLX, and DRI did not help anything.

lspci output:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9
600 M10] (prog-if 00 [VGA])
        Subsystem: Dell Unknown device 2001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+ ParErr- Step
ping- SERR+ FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort
- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 1: I/O ports at c000 [size=256]
        Region 2: Memory at fcff0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fc000000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=80 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64
bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x
1
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot
-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

attaching xorg.conf file

Disabling glx in xorg.conf fixes the problem for me.

But desktop effects is not working now when I disable glx, while I had desktop effects working with the 6.6.3 ati driver.

Btw. no need to disable dri, only glx is enough.

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Changed in xorg-server:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

.194 is now uploaded to be included post-beta.

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Committed
Changed in xserver-xorg-video-ati:
status: Fix Committed → Confirmed

Forwarded from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/133192

2007-08-17
Since the updates a few days ago on gutsy, my screen only shows garbage with only the mouse pointer shown normally. This is on a radeon 9250.

(the version which was uploaded mid-August is 6.6.193)

disabling glx makes the problem to go away.

Timo Aaltonen (tjaalton) on 2007-09-26
Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete
Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Changed in xorg-server:
status: Unknown → Incomplete
Changed in xorg-server:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2007-11-26
description: updated
description: updated
Timo Aaltonen (tjaalton) on 2008-01-11
description: updated
55 comments hidden view all 135 comments

Operations :
- boot on live usb hardy alpha 3
- messy screen when session starts
- ctl (?) alt F1 => console session
- look at xorg.conf : not a "classic" one ???
- can not see where to put agpmode !

Normally, the LiveCD is supposed to boot correctly by itself ;-) Users should not have to modify anything in configuration to make it work !

Timo Aaltonen (tjaalton) wrote :

The official word from upstream is that the change to default AGPMode to "1" was a mistake, and it should be changed back to "4", since it seems to be more common. There is no reliable way to automatically get the right mode for those where it fails, so the only option for those is to either modify xorg.conf or play with BIOS settings.

Tormod Volden (tormodvolden) wrote :

Upstream has now changed to just use (as default) the mode that was set up by the firmware/BIOS. Test packages at https://wiki.ubuntu.com/XorgOnTheEdge

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Committed

I tried with xserver-xorg-video-ati - 1:6.7.197+git20080201.bcd59010-0ubuntu0tormod but it doesn't fix the problem.

Tormod Volden (tormodvolden) wrote :

Wouter, so AGPMode 4 fixes the problem, but the new driver does not? Please attach your new Xorg.0.log.

Tormod Volden (tormodvolden) wrote :

Wouter, I just looked at your old log and realized that you have an AGP v3 card (8x or 4x). The upstream change is for v2 cards (4x 2x 1x).

Changed in xserver-xorg-video-ati:
status: Fix Committed → Confirmed
KIAaze (zohn-joidberg) wrote :

It's working! :)
I currently have those installed:
xserver-xorg-video-ati 1:6.7.197-1ubuntu1
xserver-xorg 1:7.2-5ubuntu13
libc6 2.7-5ubuntu2

And my screen works correctly. I didn't even have to change my xorg.conf.
Direct rendering works too.

Desktops effects still can't be enabled (beryl used to work) and I still have some graphical glitches in some openGL games and screenlets with black borders. But I'm not sure if those problems are related to the driver.

To upgrade to the new ATI driver, I just replaced gutsy with hardy in the sources.list and upgraded the 3 mentioned packages without doing a full dist-upgrade.
But I'll probably be reinstalling soon anyway and then I'll do a full upgrade to hardy.

KIAaze (zohn-joidberg) wrote :

Don't know if this is related to this bug directly anymore, but:
After upgrade to hardy:
-display working
-direct rendering working
-Compiz working!!! (never worked before)
-Even some games in wine working that didn't work before (but this might be due to some wine update or other)

Please keep it that way for the final release. :)

So what is the plan for hardy for AGP v3 cards? Could agpmode be set to 4 by default, solving this problem?

Timo Aaltonen (tjaalton) wrote :

Wouter: no, unfortunately there is no way to make it work for everybody, this is confirmed by upstream. Changing it to 4 would break it for others like we've seen during Hardy, before 6.8.0-1

I downloaded alpha5 CD and tested it on my pc : same thing as usual, display doesn't work when booting on cd. On another PC, it's OK. It is frustrating as I had no problem on Feisty. I dropped Gutsy because I didn't succeed in having 3D working, after having difficulties to get a proper video. "My" bug :
https://bugs.launchpad.net/bugs/164972

So what about Hardy ? Can I hope to have a CD working on my PC ? Must I install Hardy and try to modify xorg or other things to have correct display ? Will I succeed in having 3D ?

Timo wrote : "no, unfortunately there is no way to make it work for everybody, this is confirmed by upstream. Changing it to 4 would break it for others like we've seen during Hardy, before 6.8.0-1"
??? Does that mean that there is no way to have a correct display for every PC ? How do others linux distribution perform ? It is the first since many years that a boot CD does not work properly on one of my PCs ...

At least, a list of malfunctionning cards and a clear tutorial on how to get video cards properly working should be widely dispatched. (For me, operations that I did for modifying xorg.conf are clearly linked to sorcery ;-) )

Timo Aaltonen (tjaalton) wrote :

Denis_AeC: maybe I was just confused.. as Tormod said, upstream reverted the change that broke 6.7.197 for some users, and the current driver should be better. Alpha5 did not have 6.8.0.

Timo: then how is it possible it worked fine on feisty and earlier? Or where there similar reports back then?

And was the default ever 4 during Hardy? Before 6.8.0-1? It never worked for me, so that seems odd...

Timo Aaltonen (tjaalton) wrote :

Wouter: not that I know of, but you should just try a daily livecd to find out if it works :)

I know how to try and I regularly do so, but it was never fixed. What was the situation during feisty and earlier? Where there any bug reports bag then for agpv3 cards? And is it known exactly which configurations are affected by this problem?

Timo Aaltonen (tjaalton) wrote :

I don't know the history.

Have you tried the latest hardy or not? 6.8.0 was uploaded after alpha5. If you have tried, please attach your Xorg.0.log as was requested.

Hardy : not OK on Beta, but ...
As soon as Hardy Beta appeared, I downloaded it and gave it a try on my PC :
- boot on liveusb : crazy video as "usual" when session starts
- ctl alt F1, stop gdm, xorg.conf modif, start gdm : fail, try to remove lock : no lock, start gdm again : ok and then correct video, directly in 1280*1024. But when looking in xorg.conf, I saw that I put an erroneous QGPMode ...
So, second test :
- boot on liveusb : crazy video as "usual" when session starts
- ctl alt F1, stop gdm, start gdm : fail, start gdm again : ok and then correct video, directly in 1280*1024. No problem to start applications, download packages from web, ...

So, when booting on CD or liveUSB, if it could immediately be correct, it would be GREAT !

My video card is ATI RV280 Radeon 9200 SE
Flat screen is Hyundai L70S+ 1280*1024
"My" bug : <https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/164972> (marked later as duplicate from this one)

Hardy Beta again , but installed on PC :

After having tested Hardy Beta on LiveUSB (see previous post), I installed it on my home PC. This of course required to perform the steps as described in previous post to have a liveUSB session with a correct display. But then, I started installation that ran without problem up to reboot.

- Reboot after installation : correct up to session start, and then bad video as "usual"
- ctl alt F1, stop gdm, start gdm : no change in video !
- ctl alt F1, stop gdm, xorg.conf modification (adding Option "AGPMode" "4") start gdm : OK, video correct. And then, application installation, grub & fstab modifications, reboot, ... and now, compiz activation with cube and effects : no problem !

So, Hardy is OK for me, but installation is not as good as expected and this video problem will probably block some (many ?) people.

Timo Aaltonen (tjaalton) wrote :

Denic_AeC: try forcing the AGPMode from BIOS, and commit out the option from xorg.conf. Upstream thinks that the driver cannot be made to work right for everyone, and the only choice is to force it from BIOS.

chkur (chkur) wrote :

I get this problem on Ubuntu 8.04 and LinuxMint 5 on my ATI IGP 320. When I try to boot normally from LiveCD, I get blank screen. When I boot in "compatibility mode" I get resolution 1280x1024x60Hz instead of 1024x768x85Hz. If I change resolution to 1024x768 I get picture as described here. When I installed Ubuntu on hard drive I get the same. I tried to disable dri and glx in xorg.conf but problem is still here. My videocard is integrated so I can't force AGPMode to make a problem go away. I shall attach my xorg.conf and Xorg.0.log from LiveCD - booting in normal and compatibility mode.

Bryce Harrington (bryce) on 2008-07-30
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged
4 comments hidden view all 135 comments

Apparently quite a few people with a variety of ATI video cards are affected by this. Is there any data on which configurations would working and broken with which setting of the agpmode? And how many people use these?

Bryce Harrington (bryce) wrote :

Hi Wouter and everyone,

I talked with upstream a bit about this AGPMode issue. It seems extremely hardware-specific as to what AGP Mode to use. So I coded up a quirk system that will let us build a table in the driver of ATI video cards vs. host bridges, and the AGP Mode they need. The data on the configurations I need for setting this is:

  * AGPMode value needed
  * Make/Model of laptop or motherboard
  * Output of lspci -vvnn
  * Is the system all factory hardware, or have any parts been replaced?
  * Is there an AGP Mode in the system BIOS?
    - If so, is it set to the factory default?

You can test various values of AGPMode by setting the option in your xorg.conf's Device section like this:

Section "Device"
   ...
   Option "AGPMode" "2"
EndSection

Possible values are 1, 2, 4, and 8.

For more details about this issue and the quirk, I've written a section about it in this page: https://wiki.ubuntu.com/X/Quirks

Thanks for again looking into this! My motherboard died a few days ago and I decided to buy a new computer, so I won't be able to provide much more additional information. But the things you asked:

ATI Radeon 9250 AGP 128mb, Model name: 9250AD128BY
Motherboard: ASRock K7VT4A+ (printed on the motherboard itself it says AGP 8X)
AGP Mode needed to function: 4
lspci output is in one of the first comments of this bug
All factory hardware, nothing replaced
There are some agp settings in the bios, never touched them.
Because of the broken motherboard I won't be able to do more testing.

There are several more reports in the forums about this, where setting the agp mode fixed the problem, it might be worthwhile to request feedback there as well.

Bryce Harrington (bryce) wrote :

Wouter, ok great thanks for letting me know that data. I'll put in a quirk for it.

If you wouldn't mind posting about this to the forums, that could be helpful. See my comment #109 for the info required.

Bryce Harrington (bryce) on 2008-09-05
Changed in xserver-xorg-video-ati:
assignee: nobody → bryceharrington
status: Triaged → In Progress
1 comments hidden view all 135 comments
KIAaze (zohn-joidberg) wrote :

Everything is working fine for me now. No more scrambled screen. (this bug) No more multiple loading bars and unaccessible virtual terminals. (bug #245849 & bug #253243).
And direct rendering is still there.

I haven't tried out different AGP settings yet. AGP mode 4 works well for me.
Here's my system info:

* ubu #133192
  AGPMode needed: 4
  Model: Compaq Presario 2500
  Host Bridge: [0600]: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] [1002:cbb2] (rev 02)
  Graphics Card: [0300]: ATI Technologies Inc Radeon IGP 330M/340M/350M [1002:4337]
  HW changes: None (except some added RAM)
  BIOS: (Unknown)

KIAaze (zohn-joidberg) wrote :

Just in case, here's my xorg.conf & other info too.

uname -a:
Linux my-laptop 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

apt-cache policy xserver-xorg-video-ati
xserver-xorg-video-ati:
  Installed: 1:6.9.0+git20080802.1f3eee36-1ubuntu1
  Candidate: 1:6.9.0+git20080802.1f3eee36-1ubuntu1
  Version table:
 *** 1:6.9.0+git20080802.1f3eee36-1ubuntu1 0
        500 http://de.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

JW (arch0njw) wrote :

AGPMode value needed
>>> not using one -- will test modes later and see if that changes anything.

Make/Model of laptop or motherboard
>>> HP Pavilion ZE5500

Output of lspci -vvnn
>>> attached

Is the system all factory hardware, or have any parts been replaced?
>>> Added memory to take it to 1GB (was 512MB)

Is there an AGP Mode in the system BIOS?
>>> No. I have also not upgraded the BIOS as it is a pain in the butt under Linux -- maybe a new version of the BIOS would have this.

JW (arch0njw) wrote :

Following suit, here is my xorg.conf -- which works for me at this point.

Steve Langasek (vorlon) wrote :

freeze exception granted for the agp quirk mode patch, please upload.

In 1:6.9.0+git20080826.a3cc1d7a-2ubuntu1 the quirk patch was included, can anybody confirm this fixes the problems here?

Bryce Harrington (bryce) wrote :

Wouter, the uploaded fix probably would only fix your issue (or anyone else with identical hardware to you).

Anyway, I'm going to go ahead and assume it's fixed. You can reopen if it reoccurs.

Changed in xserver-xorg-video-ati:
status: In Progress → Fix Released

if this is still an issue with the driver from git, we can add a quirk for your card/gpu combo.

Michal Suchanek (hramrach) wrote :

I have lockups with recent Debian testing on a K8 board with Radeon 9250.

Earlier the card had to be run in 4x mode although the only option in BIOS is to run 8x.

I just removed the card to save myself the headache.

The mainboard BIOS probably sucks.

Tormod Volden (tormodvolden) wrote :

Many bugs were marked as duplicates of this bug, but apparently not all the reported issues have been fixed - this is because we need to add a workaround for each card/motherboard combination.

If you still need to specify AGPMode manually on your system, please see https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk and file a new bug with "Need AGPMode quirk" in the title. If you provide this information, we'll make sure your card combination works out-of-the box in the next release. Thanks in advance.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
status: Confirmed → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 135 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.