AMD Radeon HD 8670A/8670M/8690M[1002:6660] Low-graphic mode with Trusty

Bug #1301839 reported by Po-Hsu Lin on 2014-04-03
90
This bug affects 21 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
Undecided
Alberto Milone
Trusty
High
Maarten Lankhorst
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 * An explanation of the effects of the bug on users and

 * justification for backporting the fix to the stable release.

 * In addition, it is helpful, but not required, to include an
   explanation of how the upload fixes this bug.

[Test Case]
* Try to boot to the desktop with 14.04
  - Working: Desktop works fine
  - Bad behavior: You will be ask to run on low-graphic mode, or you will need to add "nomodeset" parameter into grub to boot normally.

[Regression Potential]
 * Low, patches have been taken from upstream. Most likely manifests itself with crash and/or hangs.

[Other info]
Commits c84230d686c078aac1dc98d82153f8b02521b2e1 and cadb6b493942a84bfeb298751dce0dee39257a06 upstream.

[Original bug report]
CID: 201305-13624 - AMD Radeon HD 8670A/8670M/8690M[1002:6660]
CID: 201309-14197 - AMD Radeon HD 8570A/8570M[1002:6663]

This system cannot boot to desktop by "Try Ubuntu" option with liveUSB,
it will ask you to run on low-graphic mode.

Steps:
1. Try to boot to the desktop with 14.04

Expected result
* Desktop works fine

Actual result:
* You will be ask to run on low-graphic mode, or you will need to add "nomodeset" parameter into grub to boot normally.

This bug exists in 12.04.4, and it's fixed in Trusty dailylive 11-Mar-2014 07:51, also the Trusty beta 2 image, but it's now broken again. You can refer to bug 1290745

0a:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] [1002:6660]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-video-radeon 1:7.3.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
.tmp.unity.support.test.1:

ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 3 05:44:12 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus: fwts-efi-runtime-dkms, 14.03.01, 3.13.0-20-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:2162]
   Subsystem: Hewlett-Packard Company Device [103c:2162]
InstallationDate: Installed on 2014-04-03 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140401)
MachineType: Hewlett-Packard HP Pavilion TS 14 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-20-generic root=UUID=8fdb7584-0c55-43ae-923f-b24b1286a592 ro rootdelay=60 quiet splash nomodeset initcall_debug
Renderer: Software
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/27/2013
dmi.bios.vendor: Insyde
dmi.bios.version: B.09
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 2162
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 29.0A
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrB.09:bd05/27/2013:svnHewlett-Packard:pnHPPavilionTS14NotebookPC:pvr089C100000000010000630100:rvnHewlett-Packard:rn2162:rvr29.0A:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion TS 14 Notebook PC
dmi.product.version: 089C100000000010000630100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.11+14.04.20140328-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Apr 3 05:36:25 2014
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.0-1ubuntu7

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) on 2014-04-03
tags: added: 201305-13624 blocks-hwcert taipei-lab
Ara Pulido (apulido) on 2014-04-03
tags: added: regression-proposed
tags: added: regression-release
removed: regression-proposed
tags: added: blocks-hwcert-enablement
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

Po-Hsu: please boot without the "nomodeset" parameter and upload your /var/log/gpu-manager.log

Alberto Milone (albertomilone) wrote :

BTW, this seems to me like a problem with the intel driver.

Alberto Milone (albertomilone) wrote :

and please also attach the output of dmesg without the "nomodeset" parameter

Ara Pulido (apulido) wrote :

Marking as Incomplete, as we are waiting for some debug logs

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

I am also affected with this problem (8690M) and could provide my logs if that can be of any help

Here is my gpu-manager.log without nomodeset

and dump of dmesg

Po-Hsu Lin (cypressyew) wrote :

Hello Alberto, here is the gpu-manager.log without nomodeset

Po-Hsu Lin (cypressyew) wrote :

dmesg without nomodeset

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Alberto Milone (albertomilone) wrote :

Also please attach your /var/log/Xorg.0.log and /var/log/Xorg.0.log.old (if any) with nomodeset

Po-Hsu Lin (cypressyew) wrote :

Note: I re-installed the Trusty dailylive (2014 Apr.7) on it
after the previous version of dailylive I installed fails to boot with fglrx-updates

Alberto Milone (albertomilone) wrote :

sorry, there was a typo, I meant to say "please attach your /var/log/Xorg.0.log and /var/log/Xorg.0.log.old (if any) without nomodeset"

Po-Hsu Lin (cypressyew) wrote :

Xorg.0.log without nomodeset

Alberto Milone (albertomilone) wrote :

@Po-Hsu: that log shows that "nomodeset" is still in use:

Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic.efi.signed root=UUID=e9552b0e-0694-4ff5-92a8-a7830ab61feb ro quiet splash nomodeset

Po-Hsu Lin (cypressyew) wrote :

Oops, must grabed a wrong usb stick

Po-Hsu Lin (cypressyew) wrote :
Alberto Milone (albertomilone) wrote :

I don't see anything wrong in the X log.

As a side note, using fglrx should work again if you update ubuntu-drivers-common to 1:0.2.91.2.

Maarten Lankhorst (mlankhorst) wrote :

More logs are in /var/log/lightdm/ or dmesg

Alberto Milone (albertomilone) wrote :

@Po-Hsu: please attach the logs as Maarten suggested (keep booting without the "nomodeset" parameter)

Po-Hsu Lin (cypressyew) wrote :

For dmesg without nomodeset, please find attachment in comment #11
lightdm.log without nomodeset attached.

Alberto Milone (albertomilone) wrote :

@Po-Hsu: I think we need the whole directory

Po-Hsu Lin (cypressyew) wrote :

Sure thing, sorry about some translated text in x-0-greeter.log
I use this system to test localization as well

Maarten Lankhorst (mlankhorst) wrote :

Seems to be a dupliate of bug #1218456

Do you guys need my logs too, or is what cypressyew provided enough ? Just let me know. For now, I cannot test Ubuntu Trusty at all due to this low-graphics issue, which is quite frustrating.

Alberto Milone (albertomilone) wrote :

@Ghislain: I think we have enough information now, thanks.

Po-Hsu Lin (cypressyew) wrote :

Hi Ghislain,
you could still test it with "nomodeset" if you want.

Maarten Lankhorst (mlankhorst) wrote :

Yeah nomodeset is useless though. The backtrace from the other bug is kind of useless, can you create a new one yourself? install xserver.*dbg and libdrm.*dbg, then run Xorg in gdb and hope it breaks. :)

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

@Maarten
so as you set this bug to Incomplete, should I install xserver.*dbg and libdrm.*dbg, then run Xorg in gdb on 201305-13624?

@Maarten:
I'd be happy to try it too, but would need more verbose explanation regarding the debugging process as this is pretty foreign to me.

Po-Hsu Lin (cypressyew) wrote :

Double checked with the 14.04 image that released today, this issue still exist, therefore I will modify the title of this bug.

Also affects 201309-14197 HP 242 G2
 8086:0416 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
 1002:6663 AMD Radeon HD 8570A/8570M

summary: AMD Radeon HD 8670A/8670M/8690M[1002:6660] Low-graphic mode with Trusty
- dailylive
tags: added: 201309-14197
description: updated
Pali (pali) wrote :

I solved this problem with upgrading kernel to 3.14; intel & radeon xorg driver, libdri, mesa from git.

Could someone post a step-by-step guide for how to solve this problem?
Notebook HP Pavilion 17-e026sr, Ubuntu 14.04.

@Pali: I am glad it worked for you, but this is not an acceptable solution for less technical users who just want Ubuntu to work straight after boot.

I currently dual boot with Debian unstable, which is running kernel 3.13, mesa 10.1, xorg 1.15 and GNOME 3, and I have none of these problems. Both the opensource and proprietary drivers worked painlessly.

I don't know whether the probblem comes from Unity itself or the patched kernel that Ubuntu runs, but, as of today, I cannot use the opensource driver because of this bug and cannot use the proprietary driver because Unity refuses to load (same as reported here: http://www.phoronix.com/forums/showthread.php?93838-Ubuntu-14-04-Kernel-3-13-and-AMD-Catalyst-issue). The only option that works is with nomodeset (Unity running software acceleration), great !

Maarten Lankhorst (mlankhorst) wrote :

Could you triage please what fixed things for you?
1. Was it updating kernel?
2. Was it updating the radeon driver?
3. Was it updating the radeon driver?
4. Was it updating libdrm and mesa to git?

~Maarten

Pali (pali) wrote :

@Maarten: everything, kernel 3.14, intel & radeon xorg driver, libdrm and mesa.

Maarten Lankhorst (mlankhorst) wrote :

That's not useful. Surely at least one of those components don't need to be updated to fix this crash?

Pali (pali) wrote :

There is some dependency, xorg radeon & intel drivers needs new version of libdrm and radeon driver needs new version of mesa for glamor support... And when I updated only intel xorg driver it did not worked... Thats what I tested.

Maarten Lankhorst (mlankhorst) wrote :

You could still minimize it slightly, is the update of the xorg radeon driver needed? is using linux 3.14 needed?

Pali (pali) wrote :

yes, update of both intel & radeon xorg drivers from git were needed at least for me.

It works on Kernel 3.13 for me (current version in Debian Sid), so the updated kernel is probably not needed.

xorg 1.15.1 stable, xf86-video-ati, glamor, mesa, etc. from relatively recent git.

Two GPUs in my laptop:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wimbledon XT [Radeon HD 7970M] (rev ff)

Demo: http://www.pouet.net/prod.php?which=62853

Runs fine but slow on intel graphics, immediately crashes X on radeonsi. Other things run fine currently.

I don't see a backtrace written to Xorg.0.log which is weird. Later I'll maybe try to get a backtrace with gdb but this seems to be easily reproducable, so other people can try too.

Seems to work fine here with xserver Git.

If there's no backtrace in Xorg.0.log, take a look at the X server stderr output, which should be captured in a display manager log file if you're using one.

Hm. This seems to be it:

X: ../include/privates.h:122: dixGetPrivateAddr: Assertion `key->initialized' failed.

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.14.0-4-ARCH x86_64
Current Operating System: Linux c-l 3.15.0-1-mainline #1 SMP PREEMPT Mon Apr 21 01:47:32 CEST 2014 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux-mainline root=UUID=650b9f2f-d077-48e9-9fc2-7b6f2294599a rw
Build Date: 14 April 2014 08:39:09AM

Current version of pixman: 0.32.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Apr 24 09:43:42 2014
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(II) [KMS] Kernel modesetting enabled.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
X: ../include/privates.h:122: dixGetPrivateAddr: Assertion `key->initialized' failed.
xterm: fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) or KillClient on X server ":1"
xinit: connection to X server lost

Created attachment 97880
bt and bt full, but not complete debug symbols

Latest glamor and xf86-video-ati from git with debug symbols, but xorg server without debug symbols yet.

Created attachment 97881
full backtrace

Ah, what the hell, here's a full backtrace. Doesn't give too much more information, but maybe it helps-

Created attachment 97883
Handle PRIME for source drawable as well

Does this xf86-video-ati patch help?

(In reply to comment #5)
> Created attachment 97883 [details] [review]
> Handle PRIME for source drawable as well
>
> Does this xf86-video-ati patch help?

Yes, with the patch it works fine.

Shawn Fike (shawnfike) wrote :

I was able to resolve this with the following steps on a Dell Lattitude E6440 (Radeon HD 8670a):
I did a full update (sudo apt-get update, sudo apt-get dist-upgrade) and installed Gnome (sudo apt-get install gnome), selecting GDM as the display manager.

It occasionally gets stuck on a reboot but other than that it works great. Hope this helps.

Yang Kun (YK) (dayangkuncn) wrote :

@Po-Hsu Lin , can you help to test a few things and answer the questions in comment #37 ? we cannot reproduce it here, we need to understand what component that is so that we can backport the fix.

thanks
-YK

commit c84230d686c078aac1dc98d82153f8b02521b2e1
Author: Michel Dänzer <email address hidden>
Date: Fri Apr 25 09:17:51 2014 +0900

    dri2: Handle PRIME for source buffer as well in radeon_dri2_copy_region2

Po-Hsu Lin (cypressyew) wrote :

14.04 on 201305-13641, AMD hybrid graphic system.
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8610G] [1002:990f]
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] [1002:6660]
This issue might not relvant to Intel driver, since this system still affected and it does not have an Intel graphic chipset.

This issue:
CANNOT be fixed by using the v3.15-rc3-utopic mainline kernel
CAN be fixed by using the latest xf86-video-ati (ddx) from git
(following this guide http://www.x.org/wiki/radeonBuildHowTo/ )

For the last step to get xf86-video-ati (ddx) work, I need to create the xorg.conf file in /etc/X11/ (there is no such file when this happens)

After reboot, the display is back to normal, so I didn't go on with the following packages in that guide.

Output from nux:
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD ARUBA
OpenGL version string: 3.0 Mesa 10.1.0

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: yes

Will double check on another Intel + AMD system

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:7.3.0-1ubuntu4

---------------
xserver-xorg-video-ati (1:7.3.0-1ubuntu4) utopic; urgency=low

  * Add upstream patches to fix hybrid mode with prime. (LP: #1301839)
    - fix-key-initialized-crash.patch
    - fix-0-crtc-crash.patch
 -- Maarten Lankhorst <email address hidden> Tue, 29 Apr 2014 14:26:00 +0200

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: New → Invalid
description: updated
Changed in xserver-xorg-video-ati (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
eumetaxas (eumetaxas) wrote :

Hi,

installed xserver-xorg-video-ati_7.3.0-1ubuntu4_amd64.deb but problem not solved.
Installed latest driver from ubuntu amd catalyst app, released Apr 17.

I have
AMD/ATI Radeon HD 8670A/8670M/8690M
Ubuntu 14.04 clean install
Linux Kernel: 3.13
X-Server version: 1.15

It was fixed after installing the previous driver from the ubuntu amd catalyst app but broke after some updates.

Thanks,

Hello Po-Hsu, or anyone else affected,

Accepted xserver-xorg-video-ati into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-ati/1:7.3.0-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: hw-specific
Changed in xserver-xorg-video-ati (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Po-Hsu Lin (cypressyew) on 2014-05-06
tags: added: 201305-13641
Po-Hsu Lin (cypressyew) wrote :

TEST CASE:
1. Install 14.04 on 201305-13641
2. Boot to make sure this issue exist.
3. Reboot with "nomodeset" parameter in grub, enable proposed, upgrade.
4. Reboot without "nomodeset" parameter in grub

VERIFICATION DONE

Expected result:
* You won't be asked to enter the low-graphic mode after step 4

Actual result:
* Display works fine after step 4 (with internal error reported on Xorg, look into the log, I think Radeon driver is the cause)
[ 29.628] (EE) RADEON(G0): [XvMC] Failed to initialize extension.

For this bug itself, I think it has been fixed. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:7.3.0-1ubuntu3.1

---------------
xserver-xorg-video-ati (1:7.3.0-1ubuntu3.1) trusty-proposed; urgency=medium

  * Add upstream patches to fix hybrid mode with prime. (LP: #1301839)
    - fix-key-initialized-crash.patch
    - fix-0-crtc-crash.patch
 -- Maarten Lankhorst <email address hidden> Tue, 29 Apr 2014 14:26:00 +0200

Changed in xserver-xorg-video-ati (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-ati has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Veiokej (veiokej) wrote :

This bug seems to be half fixed. After a fresh 14.04 install, I do "sudo apt-get update" followed by "sudo apt-get upgrade". Then, the desktop is usable. However, it appears to have low color density because the default purple background shades are all stair-stepped and dithered. I'm positive it's not the Ubuntu desktop background that's at fault, because it looks great on a much older machine. Perhaps there's a workaround through the command line, but this should not be the default behavior.

Po-Hsu Lin (cypressyew) wrote :

Also affects 201401-14498 Dell Optiplex 3030
with device [1002:6664]

tags: added: 201401-14498
Daniel Manrique (roadmr) on 2014-06-13
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Pablo (pablo-petzen) wrote :

Still cant get working my amd radeon hd 8850 with the fglrx drivers - its aways enter in low graphic mode.
The unity just start with the open-source standard driver.

Config intel i7 4th generation + amd radeon hd 8850m 2gb gddr5.
Notebook dell latitude 3540.

Albert Pool (albertpool) wrote :

Also affecting Lenovo G500. The update to xserver-xorg-video-radeon fixes it. Thanks.

Joeri Feyen (jfeyen) wrote :

We have a Dell Latitude E6540 with AMD 8790M and the same issue.
How did you guys fix this or install the bugfix?

Po-Hsu Lin (cypressyew) wrote :

Hi Joeri,
it's fixed in xserver-xorg-video-ati, normally you just need to run update on your system could get it fixed.
Or you could run "sudo apt-get update; sudo apt-get dist-upgrade" command in your terminal (Ctrl + Alt + t).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.