RadeonHD Southern Islands text rendering glitch

Bug #1247043 reported by Jussi Pakkanen on 2013-11-01
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Low
Unassigned

Bug Description

3D rendering landed recently for Southern Islands cards. However there are some rendering glitches that happen rarely.

The most common of these is text rendering glitch in Firefox. What happens is that every now and then a letter is drawn incorrectly. It may be drawn as (semi)random pixels or a zoomed part of some other piece of text. On redraw (triggered by e.g. pgup + pgdown) the text is drawn correctly.

Attached is an image showing the corruption. It is taken with a camera, because trying to do a screengrab forces a redraw which clears the error.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Nov 1 12:09:23 2013
DistUpgraded: 2013-08-08 13:45:48,588 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.16, 3.11.0-11-generic, x86_64: installed
 virtualbox, 4.2.16, 3.11.0-12-generic, x86_64: installed
 virtualbox, 4.2.16, 3.11.0-13-generic, x86_64: installed
 virtualbox, 4.2.16, 3.11.0-8-generic, x86_64: installed
 virtualbox, 4.2.16, 3.11.0-9-generic, x86_64: installed
DpkgLog:

ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750] [1002:683f] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:0459]
InstallationDate: Installed on 2013-05-20 (165 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-3.11.0-13-generic root=UUID=7dd49803-456a-4327-aeb5-7ea47105ef3e ro rootflags=subvol=@ quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: Upgraded to saucy on 2013-08-08 (84 days ago)
dmi.bios.date: 05/16/2013
dmi.bios.vendor: Intel Corp.
dmi.bios.version: EBH7710H.86A.0101.2013.0516.1649
dmi.board.name: DH77EB
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG39073-304
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrEBH7710H.86A.0101.2013.0516.1649:bd05/16/2013:svn:pn:pvr:rvnIntelCorporation:rnDH77EB:rvrAAG39073-304:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Fri Nov 1 09:39:25 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech Logitech USB Keyboard KEYBOARD, id 8
 input Logitech Logitech USB Keyboard KEYBOARD, id 9
 input Logitech USB-PS/2 Optical Mouse MOUSE, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.3-3ubuntu2
xserver.video_driver: radeon

Jussi Pakkanen (jpakkane) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Michael Murphy (mmstick) wrote :

I get this issue with pretty much all of my radeon cards.

Jussi Pakkanen, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-ati REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Anirban Ghosh (anirban-ninja) wrote :

I am facing the same issue with ATI 7770 and Intel i7 processor in ubuntu 13.10.

Anirban Ghosh, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

madbiologist (me-again) wrote :

There are changes in the 3.13 kernel that make Radeon HD 7xxx hardware faster and more stable. Ubuntu 14.04 "Trusty Tahr" currently has the 3.13.0-12.32 kernel. Are you able to test it?

Also, the upstream 3.14 kernel has this commit (which has also been ccd to the stable kernel series) which eliminates the display corruption some people have had with recent kernels:

author Alex Deucher
committer Alex Deucher
commit 6d8ea7de3f5035610f3bfacbe35e7b71ad1e4663
tree 215fe5cacbd723866e8515ae41734d56dc547bd6
parent 78b035101999d8d071781778c019c387dc8bebb2

drm/radeon: fix display tiling setup on SI

Apply the same logic as CI to SI for setting up the display tiling parameters. The num banks may vary per tiling index just like CI.

Bugs: https://bugs.freedesktop.org/show_bug.cgi?id=71488
https://bugs.freedesktop.org/show_bug.cgi?id=73946
https://bugs.freedesktop.org/show_bug.cgi?id=74927
Signed-off-by: Alex Deucher
Cc: stable

A PPA of the 3.14.1 kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

Also the upstream 3.15-rc2 kernel will add support for newer memory controller microcode on your Cape Verde PRO GPU, which "May fix stability issues".

madbiologist (me-again) wrote :

Oops, copy and paste error. Ubuntu 14.04 "Trusty Tahr" currently has the 3.13.0-24.46 kernel.

Noah Kalish (noah-b-kalish) wrote :

I'm experiencing the same error on 14.04.

Noah Kalish, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.