Ubuntu

Screen edges are in the middle of the screen! AMD Radeon HD7570M

Reported by Kalsan on 2013-04-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Low
Unassigned

Bug Description

The right screen edge and the left one are merged towards the middle of the screen. To go from the left to the right edge, I need to exit the physical screen to the right and the mouse will enter it at the left again. Unity doesn't start. Please check the attached pictures.
I had the same problem with 12.10 (not out-of-the-box but after installing updates for the first time). Under 13.04, it works on a Live-USB-Key, but then stops working after a fresh install. Upgrading the system to lastest version doesn't help.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Apr 26 16:37:26 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: fglrx, 9.010, 3.8.0-19-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Thames [Radeon 7550M/7570M/7650M] [1002:6841] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:17a9]
InstallationDate: Installed on 2013-04-26 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Hewlett-Packard HP EliteBook 8570p
MarkForUpload: True
ProcEnviron:
 LANGUAGE=de_CH:de
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=a58c60f0-e44f-4679-931c-56760466062d ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/05/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68ICF Ver. F.32
dmi.board.name: 17A7
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 42.32
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68ICFVer.F.32:bd12/05/2012:svnHewlett-Packard:pnHPEliteBook8570p:pvrA1029D1103:rvnHewlett-Packard:rn17A7:rvrKBCVersion42.32:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8570p
dmi.product.version: A1029D1103
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Fri Apr 26 16:37:14 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: fglrx

Kalsan (info-kalsan) wrote :
Kalsan (info-kalsan) wrote :
bugbot (bugbot) on 2013-05-02
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)

Looks like you have proprietary driver installed. Did you tried to uninstall it and use FOSS driver instead? (Uninstall fglrx package, remove /etc/X11/xorg.conf and reboot.)
You also may try to update fglrx driver http://wiki.cchtml.com/index.php/Ubuntu_Raring_Installation_Guide and if this doesn't help contact with AMD technical support: http://emailcustomercare.amd.com/

Kalsan (info-kalsan) wrote :

Thank you for your anwer.
-> The bug report above contains catalyst because I was unable to get to a working GUI without it (and when I try to send bug report from console, it logs in with wrong information and I don't know how to change that).
-> emailcustomercare just says that their driver comes "as-is" and that's it :-(

Following your instructions:
I uninstalled the driver following the instructions under Removing Catalyst/fglrx of your cchtml link.
-> First reboot: Everything works great
-> Second reboot: Same problems again, this time even 2x complete system hang (NumLock and CapsLock not responding, Ctrl+Alt+Backspace and Ctrl+Alt+Delete not working).
-> Choosing Advanced Ubuntu Options -> Recovery mode -> Resume boot, I finally succeeded getting to a working GUI (GNOME Fallback). I created an error report with the actual problem situation (no catalyst installed) and marked it as a duplicate of this bug. Link: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1176053

I will now install catalyst manually, following your instructions.

Kalsan (info-kalsan) wrote :

Manual catalyst installation done, no errors. When I have two screens connected, everything works fine (even skype loads). However, when I disconnect a screen and reboot, the desktop and all windows are highly distorted and the mouse doesn't point where it seems to. I attached a picture. The system is not usable like that. I will return to 13.4 from http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx (it is the driver that causes the least problems)

In brief,
-> open source driver still not working
-> catalyst works for either two screens (manual installation described above) or one screen (amd 13.4 driver)
=> There is still no solution that allows to connect / disconnect a screen without completely reinstalling the driver :-(

Simos Xenitellis (simosx) wrote :

I get screen corruption and general problems as well.
Tried both free and proprietary drivers, 12.04.2 and 13.04.

The nasty workaround for me is to connect an external HDMI monitor, which helps /fix/ the problem.
When Ubuntu tries to clone the laptop screen, this ends up fixing the screen corruption, when using the fglrx driver (For both the HDMI display and the laptop screen). I can then disconnet the HDMI display and the laptop screen continues to work well.
When I use the radeon (free) driver, the HDMI display works find, however the laptop screen shows artifacts (either 'split' screen or flickering).

Since both the free and proprietary drivers exhibit similar behaviour, it does look like a common kernel issue.
Will try newer kernels.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Simos Xenitellis (simosx) wrote :

There is a report, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1123024
that talks about the issue.

I think that this report should be marked as duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1123024
and have the summary at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1123024 updated with more descriptive information.

Kalsan, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-ati REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Kalsan (info-kalsan) wrote :

Problem was solved in an update under Ubuntu 13.04 and doesn't happen in 13.10 anymore either.

Kalsan, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1173217/comments/12 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.