X freezes when compiz is enabled on ATI X300

Bug #108527 reported by tamagoji on 2007-04-21
96
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Obsolete Junk
Invalid
Undecided
Unassigned
xf86-video-ati
Confirmed
Critical
xserver-xorg-video-ati (Fedora)
Expired
Medium
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Hardy
High
Unassigned

Bug Description

i just installed the new ubuntu 7.4 on my laptop toshiba m40x with ati x300.
i've enabled desktop effects with no window wobbling and with cube rotation.
it works quite well but sometime, without any clear reason, the desktop freezes completely (happened simply moving the mouse on an icon or opening a new application):
the mouse moves but can't interact with the desktop
no chance to ctrl-alt-bksp, or to change console (ctrl-alt-f1), keyboard is not responding
i have to shout down the computer from the power button. (restarting everything works again but occasionally some new bugs appear)
Don't know how to give more informations.

there are a number of other minor but annoying bugs correlated, i don't know if they have to be posted here or in the compiz bugsite.
they happen quite frequently and are:
after maximizing a window it is not possible to unmaximize from the title bar icon (only from the bottom panel)
the number of workspaces resets to 1 and the cube is not able to rotate
some windows are not refreshed and the content is not visible (as bug 91810)
some windows are visible in every workspace
and more..

[Note]
There are numerous unrelated -ati errors that can cause freezes in X that are particular to specific hardware or usage scenarios. The original bug reporter's specific issue was resolved, so if you are also experiencing an X freeze it is probably unrelated to this bug. PLEASE REPORT YOUR ISSUE AS A SEPARATE BUG. Don't reopen or add confirmations onto this one.

Description of problem:
After enabling "desktop effects", display experiences random lockups during
display of said effects, and occasionally compiz will fail to start upon login.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.3-1.fc6

How reproducible:
Just about every time.

Steps to Reproduce:
1. Buy a Lenovo ThinkPad T43p (http://www.thinkwiki.org/wiki/Category:T43p for
hardware specifications, I have the 15" 1600x1200 TFT).
2. Enable desktop effects using the xorg radeon driver.
3. Use desktop for a while, possibly log out and back in again.

Actual results:
On login, compiz will *sometimes* fail to start; disabling and then re-enabling
desktop effects fixes this. However, after several minutes to several hours of
use, the desktop will eventually hang (always in the middle of displaying a
fade, wobble, or other effect).

Expected results:
The same stability I got out of the non-AIGLX desktop. ;-) This was actually a
very stable setup prior to trying out AIGLX, with both the radeon driver and
with fglrx.

Additional info:
Here's the lspci info for my video card (I'll attach the full lspci output in a
moment, along with the xorg.conf I'm using and a relevant Xorg.0.log):

01:00.0 VGA compatible controller: ATI Technologies Inc M24 1T [FireGL M24 GL]
(rev 80) (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 0570
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort+ >SERR- <PERR-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at c0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 3000 [size=256]
        Region 2: Memory at b0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at b0120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <256ns, L1 <4us
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 0
                Link: Latency L0s <256ns, L1 <2us
                Link: ASPM L1 Enabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x16
        Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [100] Advanced Error Reporting

Created attachment 143639
xorg.conf

Created attachment 143640
Xorg.0.log

Log from a typical session that freezes.

Created attachment 143641
lspci -vvv output

Also note that the system itself does not freeze; only the display. When this
happens, I'm able to ssh back into the laptop from another machine and
"gracefully" shut things down, but the screen never returns to normal until the
system is rebooted.

Created attachment 145205
lspci -vvv output

Created attachment 145206
xorg.conf file

Created attachment 145207
Log from aiglx enabled sessions

I see this also. This on a Thinkpad T42. See above attachments. Workaround is
obviously to disable desktop effects however given that it took me a while to
find the (probable) cause I would ask this to be re-prioritised upwards as there
is likely to be a number of folks who are banging their heads into walls/screens
on this one.

Edward,

Could you please test with the latest flash plugin (ie. 9 final) as I believe
this to be the source of our problems.

Regards
Chris

215 comments hidden view all 240 comments
Steph (stephspam) wrote :

I have the same freeze problem with Desktop effects enable (Window & cube) on a Toshiba M40 PSM42 laptop with ATI Mobility Radeon X600 SE.
Very annoying, as described above, the desktop sometimes freeze, the mouse can be moved, but nothing else worked! Keyboard is not responding, impossible to select anything on the screen with the mouse. Only solution, the power button.

Jorge García (jorgegarciar) wrote :

Hi,
     Here is exactly the same. Mine is an Acer Aspire 1652 LMI with an ATI Mobility Radeon X300. I hadn't this problem with Dapper. It's just happening with Feisty Fawn. If I stop Desktop-effects, the problem disapears. I tried to insall Beryl instead of Compiz (current desktop-effects in Feisty) and I get again the same mistake after a while (it can be 5 minutes or a whole day). It's quite anoying... and the only possible solution in press the Shutdown button cause keyboard is not woking at all (even Shift, bloq. shift, ...).

     Any clue?

Thanks.

grumpybuffalo (whozadumbstuff) wrote :

Hello,
      I have a similar problem using beryl. Oftentimes, some/all applications will not redraw, but they have not frozen. This means that if I click on the logout button, it shows nothing happening, but then if I click where the log out button *would* be, it logs out and I can log back in. If only one window is refusing to redraw, I can minimize it and unminimize to redraw it; however the problem will still be there.
      The problems stay the same when I use compiz instead of beryl. I am using an HP compaq nc6000. If anyone can figure this out, please let me know.

      Thanks,
      Grumpy Buffalo

Travis Watkins (amaranth) wrote :

All of these users have an ati card, looks like a driver issue.

Changed in compizsettings:
status: New → Invalid
Bryce Harrington (bryce) wrote :

Can you test if the issues go away when you add the following in your /etc/X11/xorg.conf?

Section "Module"
# Load "dri"
 # Load "glx"
        Disable "dri"
        Disable "glx"
EndSection

Please also attach your /var/log/Xorg.0.log.old file after restarting after experiencing a lockup.

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Erkin Bahceci (cornelius1) wrote :

I have the same random freeze problem with the current gutsy. It happens with desktop effects enabled within 1/2 hour of use. I am using the default "ati" open source driver. This is on an X300 Mobility Radeon. Disabling dri and glx effectively disables desktop effects and "fixes" the problem. But if I want to use compiz, the open source driver is a no go for me, which is pretty bad since fglrx has its own problems (it won't make this laptop suspend). So running compiz is not feasible on gutsy with any driver on this Dell Inspiron 6000 + X300 Mobility.

Travis Watkins (amaranth) wrote :

Can all of you having this problem attach the output of `lspci -n`?

Erkin Bahceci (cornelius1) wrote :

X300 Mobility Radeon here

$ lspci -n
00:00.0 0600: 8086:2590 (rev 03)
00:01.0 0604: 8086:2591 (rev 03)
00:1d.0 0c03: 8086:2658 (rev 03)
00:1d.1 0c03: 8086:2659 (rev 03)
00:1d.2 0c03: 8086:265a (rev 03)
00:1d.3 0c03: 8086:265b (rev 03)
00:1d.7 0c03: 8086:265c (rev 03)
00:1e.0 0604: 8086:2448 (rev d3)
00:1e.2 0401: 8086:266e (rev 03)
00:1e.3 0703: 8086:266d (rev 03)
00:1f.0 0601: 8086:2641 (rev 03)
00:1f.2 0101: 8086:2653 (rev 03)
01:00.0 0300: 1002:5460
03:00.0 0200: 14e4:170c (rev 02)
03:01.0 0607: 1180:0476 (rev b3)
03:01.1 0c00: 1180:0552 (rev 08)
03:01.2 0805: 1180:0822 (rev 17)
03:03.0 0280: 8086:4223 (rev 05)

Travis Watkins (amaranth) wrote :

Sorry, I meant `lspci -vn`.

Erkin Bahceci (cornelius1) wrote :

Here

Erkin Bahceci (cornelius1) wrote :

Did the output help? Is this bug fixed? Is there anything else you need to know?

Thanks.

Sadly, same here...after 1 year of testing, this bug is not yet resolved... X freezes but the laptop is still alive: in fact, I can do a clean reboot with sysrq+alt+S, sysrq+alt+U and sysrq+alt+b
I will enable an ssh server on this laptop so next time I can catch the

However, this bug is really really CRITICAL!
Please blacklist this video card or (better) make up your mind and revert back the decision of leaving compiz on by default!
Just think about all the users who have an Ati Xxxx card: they will think linux (and ubuntu) is not better then windows...

Manufacturer: Acer, inc.
Product Name: TravelMate 8100
Video Card: ATI Technologies Inc Radeon Mobility X700 (PCIE)

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed

Same problem on an IBM t43p with ATI fireGL mobility v3200. One question: to use compiz-fusion i can only rely on open source driver, if i install the restricted closed source driver i cannot use 3d effects; when i try to enable them in appearence prefs pane it says there is no compostion extension... what's wrong ?
thanks

Enryfox, i noticed the same thing: it's clearly a big design flaw...we all know that in order to have compiz working with Ati cards, the only solution is to use the open source driver but restricted manager suggests to install the ATI proprietary driver which breaks compiz!!!
I use ubuntu from warty and I think that gutsy will be the worse release ever because of the insane decision about compiz: what a pity...all the good work done will be obscured by the critical bugs created by compiz.

Technical board, please reply...

I experienced many Hard Locks on my Samsung X20 Notebook (ATI X600 Mobility).
If the opensource driver is used together with compiz-effects (Live-CD configuration), the system freezes completely after some minutes.

Disabling the effects is sufficient for stable use and installation (!) of the Live-CD!

Enryfox (enryfox) wrote :

Things are getting worst ... I have the same freezing if I start internet explorer within crossover Office 6.1. I'm using the fglrx driver latest version (gutsy updated on 1/10/07). I think it is ok if IE6 crashes, but it can't freeze Xorg !

201 comments hidden view all 240 comments

*** Bug 242151 has been marked as a duplicate of this bug. ***

Changed in xserver-xorg-video-ati:
status: Unknown → In Progress
Timo Aaltonen (tjaalton) on 2007-10-07
Changed in xserver-xorg-video-ati:
importance: Undecided → High
201 comments hidden view all 240 comments

I have got the same problem on ThinkPad T43p.

Sorry, I forgot to mention the video card. Its ATI M24GL [Mobility FireGL V3200].

Michael Roy (mikemlp) wrote :

I am also experiencing freezes. See http://ubuntuforums.org/showthread.php?p=3508187#post3508187
Some users have reported that their mouse cursor still moves. Mine does not, so my symptoms appear to be slightly different. Uptime when using compiz ranges from 1 minute to 23 hours. Uptime appears to be unlimited when I use metacity only. I have been using Compiz / Beryl / Fusion for over a year, and have only experienced freezes like this in Gutsy. Will try the steps here: https://wiki.ubuntu.com/DebuggingXorg and report back.

Unlike the OP, I do not experience any of the further bugs, such as not being able to minimize windows. Additionally, I have noticed this bug in Tribe 5. I moved back to Feisty for a while, and found the same bug present in 7.10 Beta.

Limited Specs:
IBM Thinkpad T42
ATI Mobility 9600
AIGLX on Free ATI driver

Please let me know what I can do to help debug.

Michael Roy (mikemlp) wrote :

lspci -vn

So Michael Vogt has just released a new version of compiz package which blacklist some ati mobility cards (X300,X600,X700).
I think this was the right way to go since the problem cannot be easily fixed.
Thank you, Michael

compiz (1:0.6.0+git20071008-0ubuntu1) gutsy; urgency=low
 .
   * New git snapshot:
     - properly fix bug to never stack under the desktop window (LP: #147943)
     - fixes in the internal stack representation, this fixes the issue
       that sometimes windows are put over or under panel windows
   * debian/patches/026_fix_stacking:
     - dropped, now part of upstream
   * debian/patches/028_compiz_manager_blacklist:
     - blacklist ati mobility X300,X600,X700 freezes (LP: #115283)

Erkin Bahceci (cornelius1) wrote :

Just wanted to add that I experienced the same X freeze (where mouse can still move) with the fglrx driver too (v8.37), with compiz enabled.

Ramesh Dharan (rrdharan) wrote :

This happens for me all the time with the Gutsy RC: screen freezes up *except* the mouse cursor, and the machine is still alive but I have to power-cycle it.

I have the same hardware as MikeMLP: T42, Mobility 9600 (M10). I'm running the stock Gutsy configuration, and free/oss ati/radeon driver, with all desktop effects enabled.

I experience the hang quite regularly with both the stock 2.6.22-14 kernel as well as my hand-built 2.6.23.1. I'm happy to run any tests or provide logs or whatever else is needed if it will help resolve this problem.

i also saw that, with moving mouse cursor on a radeon 7000/VE.
since i read about it happening when opening windows (for me it happened several times when switching workspaces, i'm using the wall desktop plugin for that, but maybe also a window was opening in the background, not sure), and since some people mentioned that increasing AGP aperture helped, i thought it might be too little texture memory to store all the windows? I tried increasing my AGP aperture in the BIOS (from 64 to 128Mb), I'll see if it helps.

Ramesh Dharan (rrdharan) wrote :

I very much doubt the AGP aperture has anything to do with it. FWIW, my AGP aperture has been at 256MB the whole time.

The crashes seem to be entirely unpredictable in nature. Several of the times it has happened, I have only had one window open, with no wobbling or cube transitions or anything else crazy going on - e.g. I was just clicking on an OK button, and it would freeze

Jens Gottfried (jug) wrote :

Happens on an X800 as well.
Freezes in different situations: opening/closing/resizing/moving windows, rotating the cube, spontaneous - it's absolutely random and I see no way to reliably reproduce this.

this is the last annoying bug for me in gutsy... ati open source driver with
9700 mobility... i want to help solving this bug, what can i do?

On 10/16/07, jug <email address hidden> wrote:
>
> Happens on an X800 as well.
> Freezes in different situations: opening/closing/resizing/moving windows,
> rotating the cube, spontaneous - it's absolutely random and I see no way to
> reliably reproduce this.
>
> --
> X freezes when compiz is enabled on ATI cards
> https://bugs.launchpad.net/bugs/108527
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Provo un intenso desiderio di rientrare nell'utero. Di chiunque (Woody
Allen)

Darth Vader: The ability to destroy a planet is insignificant next to the
power of the Force.

I have an ATI Mobility Radeon X600. I have been experiencing this problem with Compiz on Feisty - X freezing, except for mouse cursor movement and music continuing to play. Works absolutely fine with effects disabled.

I was hoping that the problem would be solved with Gutsy and Compiz-Fusion, but had my first crash after upgrading yesterday.

Is there really nothing that can be done about this??!!

Michael Roy (mikemlp) wrote :

Since posting, I have had freezes both with and without the mouse cursor still able to move. Usually, the mouse cursor is still able to move, and usually I am able to reboot with alt+sysrq rseiub. My uptime is basically unlimited with effects turned off. Since I've used Compiz for over a year without this problem, my best guess is that the bug that I am experiencing is located within the new version of X in Gutsy. I wish I could help pin it down more though.

Arngren (arngren) wrote :

From the more or less duplicate bug (#115283), I mentioned the animations plugin to be the potential cause. That would make some sense, since having "random animations for all event" enabled means the animations plugin is activated quite offent and can be responsible for these random crashes. Initially I disabled the plugin and experienced no problems, now I have tried to re-enable it and turning off the "focus animation" (by recommendation from Cornelius, thanks!) and is still not seeing any problems :-)

this trick doesn't work for me.. even disabling the focus animation it still
freeze....

On 10/18/07, Arngren <email address hidden> wrote:
>
> >From the more or less duplicate bug (#115283), I mentioned the
> animations plugin to be the potential cause. That would make some sense,
> since having "random animations for all event" enabled means the
> animations plugin is activated quite offent and can be responsible for
> these random crashes. Initially I disabled the plugin and experienced no
> problems, now I have tried to re-enable it and turning off the "focus
> animation" (by recommendation from Cornelius, thanks!) and is still not
> seeing any problems :-)
>
> --
> X freezes when compiz is enabled on ATI cards
> https://bugs.launchpad.net/bugs/108527
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Provo un intenso desiderio di rientrare nell'utero. Di chiunque (Woody
Allen)

Darth Vader: The ability to destroy a planet is insignificant next to the
power of the Force.

i've been using compiz with animations disabled for a couple of hours yesterday and it didnt't crash. earlier there was a crash after about 1 hour of usage. i'll be checking it later and report here.

Hi. I have an IBM Thinkpad T43 with an ATI Mobility Radeon X300 video card. I had this problem in Feisty, and I thought it would be fixed in Gutsy. Sadly, it was not. This is not a big deal to me, because I can live without Compiz.

But I do agree with some people here that it was an error from Ubuntu people to enable Compiz by default in Gutsy.

Yes, I do think Compiz is attractive, but it is too unstable (at least for me) for being enabled by default. It should be disabled by default, with a warning: "Compiz can hangs your system. Use it at your own risk." Allow me to say that it will not be a pleasure to hear people saying "hey, I tried that Ubuntu thing you always talk about, but it just hanged my machine like Windows do!".

I'm sending in the lspci -vn output. Please, let me know if there is anything I can do for help debugging this.

Regards,

Adrovane.

Erkin Bahceci (cornelius1) wrote :

The problem might possibly be caused by the animations plugin as you have observed, since I'm doing stuff (that might be going into some very rare infinite loop) while handling the ConfigureNotify X event, which gets fired on every mouse click. But why this would only happen on this specific group of hardware and only with the open source ati driver, I'll never know (it works fine with fglrx, which was the driver I was using all along). I'll do some debugging to pin down the bug (if it's in my plugin). Luckily I'm on a Mobility X300, and I can observe the freeze.

Giuseppe Pantanetti (sep) wrote :

I have the same problem on a IBM Thinkpad T43 (Model 2668Y3U) with an ATI Radeon Mobility X300 with a fresh install of Gutsy. I had the same problem on Feisty.

I thought it was a GPU temperature issue but this not the case: I reached 67 Celsius during glxgears but I couldn't reproduce the problem. I experienced freezes when CPU and GPU temperatures were under 50 Celsius.

Disabling desktop effects resolves the problem... I'm, sadly, thinking that enabling compiz by default wasn't a brilliant idea...

I've attached my lspci -vn output.

Arngren (arngren) wrote :

In the gutsy beta RC with updates I had not experienced any problems with the Animations plugin, but now with the Gutsy released version I get freezes very often (every 20 min. or so). I have tried to disable most plugins incl. the animations plugin but the freezes persist.

The only thing that seems common in the freeze I experience is that they always seems to happen when some windows or tooltip need to be opened, so I suspect the error could be in some of the windows management plugin, just a guess. I'll try to enable / disable different plugins every time I get a freeze and see if I can pinpoint it further.

ilektron (robotoman) wrote :

I have the same freezing problem on a Dell Inpsiron 6000 with an ATI Mobility x300. Mouse is responsive, ssh still works. alt sysreq works to reboot.

I had compiz-fusion working in feisty and don't recall having these problems.

Tried the gutsy beta and system was unusable. Froze after about 5 minutes each time. The actual release isn't going much better. Think I'll try the fglrx driver. Oh, what a way to dash my hopes when I thought my gpu worked with the open source drivers.

Jens Berke (jensberke) wrote :

IBM Thinkpad R52 with X300: Gutsy Release Candidate, clean install and upgraded to all latest packages as of today.

Freezes appear as well, sometimes pretty quick after a few minutes, but at least after about 20 minutes. I use the ati open source driver. lscpi output is attached.

Remembering that the Gutsy RC *live* system seemed to work pretty well on my laptop with compiz enabled I tried that again today: I started the Gutsy 7.10 Final live system from CD and played around with compiz four more than half an hour. No freeze! Maybe that's a hint for someone?

Jens Berke (jensberke) wrote :

The previous attachment is the "lspci -n" output only. This is the right one now, sorry.

Erkin Bahceci (cornelius1) wrote :

Mine takes hours to freeze, so can someone who gets quick freezes (in less than an hour), try disabling all non-crucial plugins in compiz to see if the problem persists? If it still freezes, then we can look somewhere other than the plugins. If it doesn't freeze, can you systematically enable the plugins enabled by default in gutsy (maybe doing a binary search on the set of plugins :) ) to see which plugin is the root of the problem?
Thanks.

179 comments hidden view all 240 comments

Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Changed in xserver-xorg-video-ati:
status: In Progress → Incomplete

I can confirm the same issue with both Fedora 7 and 8 on a HP Compaq nx8220
laptop. The video card is:
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility
X600]

Enabling desktop effects causes freezes, with them disabled I have no problems
at all...

Could we get please updated X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) attached to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Created attachment 290647
Requested file: xorg.conf

Created attachment 290648
Requested file: Xorg.0.log

Xorg.o.log copied after the freeze, X started with the xorg.conf previously
attached.

Created attachment 290649
Requested file: Xorg.0.log

Xorg.0.log copied after the freeze, X started without any xorg.conf file.

For these tests I enabled desktop-effects and rebooted to make sure AIGLX and
compiz were there from the start.

The first time the screen froze after about 20 minutes of use (the test with the
xorg.conf file in place, as it usually is). The second time (without the
xorg.conf file) it froze after about 5 minutes of use. Both times the screen
froze completely except for the mouse pointer which still moves but can't click
anywhere. The keyboard freezes also.

Logging to the laptop from another machine via ssh works fine, this is how I
copied the logs. Here is some extra info taken after the second freeze:

[root@dragon ~]# uptime
 21:03:10 up 15 min, 3 users, load average: 0.00, 0.10, 0.17
[root@dragon ~]# free
             total used free shared buffers cached
Mem: 1034820 714744 320076 0 36076 301340
-/+ buffers/cache: 377328 657492
Swap: 1048568 0 1048568
[root@dragon ~]# vmstat
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu------
 r b swpd free buff cache si so bi bo in cs us sy id wa st
 0 0 0 320032 36080 301352 0 0 355 32 310 893 9 3 80 8 0

[root@dragon ~]# ps ax | grep comp
 2867 ? S 0:02 compiz --sm-client-id default1 glib gconf
 3799 pts/3 S+ 0:00 grep comp
[root@dragon ~]# strace -p 2867
Process 2867 attached - interrupt to quit
select(5, [4], [], NULL, NULL

Hope it helps...

Changed in xserver-xorg-video-ati:
status: Incomplete → In Progress
Changed in xf86-video-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2008-03-23
description: updated
Bryce Harrington (bryce) on 2008-04-02
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
Blido (inseyn) on 2008-04-23
Changed in xserver-xorg-video-ati:
status: Fix Released → Confirmed

I'm using latest F8 and I tend to get a lot more time before it freezes. I do
have some details though. The problem appears to be in the kernel, or the
interaction between the kernel and the X server.

kernel-2.6.24.4-64.fc8
compiz-0.6.2-3.fc8
xorg-x11-drv-ati-6.8.0-4.fc8

Doing strace on "chvt 1" from an ssh connection hangs at the following point:
open("/dev/tty0", O_RDWR) = 3
ioctl(3, KDGKBTYPE, 0xbfd23c77) = 0
ioctl(3, VIDIOC_G_COMP or VT_ACTIVATE, 0x1) = 0
ioctl(3, VIDIOC_S_COMP or VT_WAITACTIVE <unfinished ...>

Doing strace on X gives endlessly repeating:
ioctl(9, 0x40046457, 0xa3fdff4) = -1 EINTR (Interrupted system call)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn() = ? (mask now [])
ioctl(9, 0x40046457, 0xa3fdff4) = -1 EINTR (Interrupted system call)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn() = ? (mask now [])
ioctl(9, 0x40046457 <unfinished ...>

A gdb backtrace on X gives:
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00609c29 in ioctl () from /lib/libc.so.6
#2 0x04ce549b in drmCommandWrite () from /usr/lib/libdrm.so.2
#3 0x00af833e in ?? () from /usr/lib/dri/r300_dri.so
#4 0x00b269b8 in ?? () from /usr/lib/dri/r300_dri.so
#5 0x0018ab85 in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#6 0x0018a09a in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#7 0x0018eb16 in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#8 0x08150d3e in ?? ()
#9 0x0808881a in Dispatch ()
#10 0x0807054a in main ()

I installed debuginfo packages and this is the result:

#0 0x00110402 in __kernel_vsyscall ()
#1 0x00609c29 in ioctl () from /lib/libc.so.6
#2 0x04ce549b in drmCommandWrite (fd=9, drmCommandIndex=23, data=0xa3aa77c,
    size=4) at xf86drm.c:2227
#3 0x00af833e in radeonWaitIrq (radeon=0xa3aa728) at radeon_ioctl.c:116
#4 0x00b269b8 in _mesa_Finish () at main/context.c:1676
#5 0x0018ab85 in __glXDisp_CopySubBufferMESA (cl=0xa29d098,
    pc=0xc08f1f8 "\201\020\b") at glxcmds.c:1679
#6 0x0018a09a in __glXDisp_VendorPrivate (cl=0xa29d098,
    pc=0xc08f1f8 "\201\020\b") at glxcmds.c:2322
#7 0x0018eb16 in __glXDispatch (client=0xa22b040) at glxext.c:561
#8 0x08150d3e in XaceCatchExtProc (client=0xa22b040) at xace.c:299
#9 0x0808881a in Dispatch () at dispatch.c:457

Bryce Harrington (bryce) on 2008-04-30
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2008-04-30
description: updated
Bryce Harrington (bryce) on 2008-04-30
Changed in xserver-xorg-video-ati:
status: Confirmed → Invalid

After a fresh install of Fedora 9 (only kept /home untouched, formatted
everything else) I am still getting exactly the same behavior. A few minutes
after enabling desktop effects the screen froze.

I just reproduced this on F9 as well. It took a little longer than a few
minutes, but it did eventually happen. I've noticed that it always seems to
happen with a fading effect. In this last case, I was using the Applications
menu and it froze while fading in one of the submenus. Before it has happened
while changing the volume, the volume display is semi-transparent or fades.

My laptop integrated video card is:
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

Does anybody see this on Fedora 9 and lower? (Rawhide doesn't count)

Yes, I said that in comment #22. I tested it again recently and it still happens.

Yes, I also see this in Fedora 9 and saw it before in F8 and F7. I tried several other times since I posted comment #21, after kernel or X.org upgrades with the same behaviour. I haven't tried again after the latest upgrades though. I will try as soon as I can and post the results.

A further note is that it only happens on my laptop with the integrated video. I have two desktop computers with video cards that I've run compiz on with no problems. I do have a couple of desktop computers at home with "RS690 [Radeon X1200 Series]" integrated video that I could test on if that would help. But I'm guessing from the reports in this bug that it's only the X300 with the problem.

Mine is a X600 and has the same problem. My desktop at home has an nvidia card and works fine.

A further data point. One of my desktop systems that doesn't have a problem is an X300 on PCI Express.

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]

I don't know why it has two entries.

There have been bunch of bug fixes

Could you retest with the latest kernel
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270

And with the latest xorg-x11-drv-ati.
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.

The information we've requested above is required in order
to review this problem report further and diagnose or fix the
issue if it is still present. Since it has been thirty days or
more since we first requested additional information, we're assuming
the problem is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED: INSUFFICIENT_DATA". If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested,
please feel free to reopen the bug report.

Thank you in advance.

Changed in xserver-xorg-video-ati:
status: In Progress → Invalid

Now that bug #473307 is fixed, I can turn on desktop effects again and see if this bug is fixed as well.

I've had no hangs so far, so it appears to be fixed.

Changed in xf86-video-ati:
importance: Unknown → Critical
Changed in xf86-video-ati:
importance: Critical → Unknown
Changed in xf86-video-ati:
importance: Unknown → Critical
38 comments hidden view all 240 comments

(In reply to comment #22)
> This usually occurs using compiz when the monitors go into ACPI power save
> mode.

If it only happens at DPMS power save, it's probably not this bug but bug 49761.

(In reply to comment #24)
> Nope, don't think so

Why not? Have you tried the fix for that?

As I said earlier, it happens identically with both fglrx and xorg-video-ati. If a patch to xorg-video-ati fixes a bug while using fglrx, that would be surprising indeed.

(In reply to comment #26)
> As I said earlier, it happens identically with both fglrx and
> xorg-video-ati. If a patch to xorg-video-ati fixes a bug while using fglrx,
> that would be surprising indeed.

Does the patch for xf86-video-ati fix xf86-video-ati?

(In reply to comment #26)
> If a patch to xorg-video-ati fixes a bug while using fglrx, that would be
> surprising indeed.

The component field of this report says Radeon. It's unlikely for fglrx and radeon to be affected by one and the same bug. It's possible that fglrx has a similar bug though.

nfsd (in4mer+launchpad) wrote :

Does not appear to exist in 12.10/3.5.0-21-generic, either using radeon or fglrx.

As I've upgraded, I won't be available for further testing.

BTW, IIRC this issue started at 3.2.0-30, and -29 was okay. HTH. (radeon)

Changed in xserver-xorg-video-ati (Fedora):
importance: Unknown → Medium
status: Invalid → Expired
Displaying first 40 and last 40 comments. View all 240 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.