"No devices detected" radeon regression

Bug #1058641 reported by ojordan on 2012-09-29
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Testing the quantal daily/live ISOs I've noticed a regression with the radeon driver. The last ISO I tested was from the 19th of Sept and that was fine. Yesterdays live/desktop ISO (28/9/2012) fails to start the Xorg server. It reports that no devices are detected. Creating a very simple xorg.conf overcomes the problem:

Section "Device"
Identifier "Card0"
Driver "radeon"
BusID "PCI:0:16:0"
EndSection

I'll attach the Xorg.0.log from running with and without the above xorg.conf.

ojordan (ojordan12345) wrote :
ojordan (ojordan12345) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
ojordan (ojordan12345) wrote :

Just for completeness I'll add the Xorg.0.log using the previous version of the ati/radeon driver. It boots fine without any xorg.conf.

ojordan (ojordan12345) wrote :

Note, in all the logs I've disabled the radeonfb framebuffer (still built in on PowerPC) to allow KMS. You do this either via the video=ofonly or video=radeonfb:off boot parameters on PowerPC.

ojordan (ojordan12345) wrote :

Another thing that is possibly worth a mention is if I don't have the line:

BusID "PCI:0:16:0"

then the computer seems to freeze. (Obviously the value you write is computer dependant)

Walter Lapchynski (wxl) wrote :

I don't have the exact same symptoms. It'll start X, but it looks all 16 bit. There is another solution: boot parameters "video=radeonfb:<xres>x<yres>[-<bpp>][@refresh]" where xres is xresolution, yres is yresolution (use whatever's native to your machine; you can look it up online), bpp is optional, and refresh is optional refresh rate in hertz. example: video=radeonfb:1024x768-32@60

Lars Noodén (larsnooden) wrote :

This works for my machine : video=radeonfb:1280x854-32@60

ojordan (ojordan12345) wrote :

@wxl and lars. You are not understanding this bug report. video=radeonfb:1024x768-32 etc is using the fbdev driver. It is not using the radeon xorg driver.

If you are on PowerPC and you want to test for this bug then you need to turn off radeonfb using the video=ofonly (or video=radeonfb:off).

However, as far as I can tell there should be nothing PowerPC specific about this bug.

2blue (arild-lindseth) wrote :

I have the last iBook G4 with ATI Mobility Radeon 9550 card, and it seems to work all fine when adding video=radeonfb:1024x768-32@60 in the boot stage. I have installed and computer has booted fine the last two days. When using video=offonly nothing works; coarse pixeled screen image and non working installer.

How do you make sure the radeon driver and graphics card are activated, or even check for it?

ojordan (ojordan12345) wrote :

@2blue, the boot parameter is 'video=ofonly', not offonly. The radeon xorg driver will only work in 12.10 on PowerPC if you disable the radeonfb framebuffer.

2blue (arild-lindseth) wrote :

sorry, I have used the correct spelling, video=ofonly , and I`m not sure I understand how the frambuffer enters into it. the framebuffer enters into it? How do I go about the trouble further than "video=ofonly" ? If I understand it correctly, graphic card is not used at all with the video=radeonfb:1024x768-32@60 fix?

ojordan (ojordan12345) wrote :

Please post your Xorg.0.log (in the /var/log directory) when using the video=ofonly parameter.

Ron Mitchell (rm2892) wrote :

my eMac video card is
ATI Radeon 9200
Chipset: ATY RV280
Bus: AGP
32 MB RAM

attached is my Xorg.0.log when using the command <video=ofonly>. That results in a blank screen and what seems to be a frozen system in that I can't even do <cntl-alt-F!> from there to get to a command line.

On the other hand:

video=radeonfb:1024x768-32@60

works for me, and all the graphics appear normal.

Ron Mitchell

Ron Mitchell (rm2892) wrote :

video=radeonfb:off

produces the same result as above, and I am unable to proceed.

Ron Mitchell

2blue (arild-lindseth) wrote :

Radeon 9550

With today`s daily I cannot boot with "live video=ofonly", it haults at

* starting NTP server ntpd
* starting crash report submission deaemon
* starting system V runtime compatibility
* starting
* starting
* stopping

Booting with no parameters added in bootstage I still get the coarse pixeled desktop

arild, please go to vt (ctrl-alt-f1 or rather since you're on a ppc fn-ctrl-alt/option-f1) and use the terminal to get your /var/log/Xorg.0.log and post it here.

easiest way:
1. plug in ethernet
2. sudo ifconfig eth0 up
3. sudo dhclient eth0 (assuming you get your ips from dhcp)
4. sudo apt-get install pastebinit
5. cat /var/log/Xorg.0.log | pastebinit
6. post the resulting url here

2blue (arild-lindseth) wrote :

Sorry, the above is xorg.0.log on my installed system, this is the live CD without anything added in boot stage.

http://paste.ubuntu.com/1259211/

Not sure how log a pastbin page will be up?

ojordan (ojordan12345) wrote :

@Ron thanks that confirms my problem in that the radeon card is not detected and the Xorg server is not starting. It seems for you, additionally, the radeondrmfb is not working correctly (hence the blank screen).

@2blue thanks for trying to help out, but those logs have nothing to do with this bug because you haven't disabled the radeonfb framebuffer in them. When you do use 'video=ofonly' and it appears to be hanging, do you get a black screen or does the text stay on the screen? Can you try 'live video=ofonly radeon.agpmode=-1' to see if that stops the freezing?

For me the regression is definitely in the latest xorg radeon driver, but I note wxl is having similar symptoms with nouveau (KMS)on PowerPC. Hmm...

2blue (arild-lindseth) wrote :

@ojordan

With "video=ofonly" booting haults with the text in the black screen. With "video=ofonly radeon.agpmode=-1" I get : "-1,/vmlinux: Unable to open file, Invalid device"

ojordan (ojordan12345) wrote :

@2blue I don't understand. Either you have mis-typed or there is something weird happening with your foreign keyboard.

2blue (arild-lindseth) wrote :

I get the same what ever do, I burned today's daily, and not change. I am sure there are no errors with typing.

John Makosky (jrm-3) wrote :

@ojordan This looks like the same problem I see with 12.10 on an iMac G5/2.0 20-Inch (ALS) (Identifiers: Ambient Light Sensor - M9845LL/A - PowerMac8,2 - A1076 - 2056) with a Radeon 9600.

I am not sure if it's relevant, but using "video=radeonfb:1680x1050-32@60" does apparently increase the color depth, but glxinfo reports only software rasterization, and unity/compiz fails.

ojordan (ojordan12345) wrote :

@John thanks that's another confirmation of this bug. Unity/compiz won't work with the fbdev xorg driver (...or more correctly it is supposed to work with llvmpipe, but there are still issues....). If you want to try KMS which may work with unity then you can define an xorg.conf like I did https://wiki.ubuntu.com/PowerPCFAQ#How_do_I_configure_an_xorg.conf_file.3F

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1058641

tags: added: iso-testing
tags: added: ppc
AJenbo (ajenbo) wrote :

Lubuntu 14.04
The following all results in a black screen:

video=ofonly
video=radeonfb:off
video=radeonfb:off radeon.modeset=1
video=radeonfb:off radeon.modeset=1 radeon.agpmode=-1

I can usually reboot by blindly pressing ctrl+alt+f1 ctrl+alt+del ctrl+alt+del sot it is not frozen, but no console ever apperas.

I have also tried compiling the kernel with radeonfb as a module but this didn't help either, it just made xorg not work (console did).

AJenbo (ajenbo) wrote :

Ups, for got to mention this was on a eMac with a Radeon 9200

Fritz Hudnut (este-el-paz) wrote :

I believe I'm dealing with this bug on my G4 iBook with radeon driver, I've got about 640 MB RAM??? Now trying to get 14.04 Lu running after having similar "screen freeze" issues with 14.10 . . . in 14.10 using agp.mode got me into a GUI, but then the screen would freeze . . . although mouse is moving. Lars N has a similar bug report and I may post over there as well.

So, back in 14.04 now, tried to read through ojordan's comments, in trying to look at my Xorg.0.log in Terminal . . . shuts the GUI down--frozen in space and time. I ran 'Xorg -configure' . . . and it shows "radeon" and the PCI:0:16:0 . . . but on restart I could open the file manager and got some "folders" to open in the GUI, but when I opened LXTerminal . . . nothing loaded into the Terminal window. . . screen frozen . . . .

I guess next step is to to try to cut the Xorg.conf file down to exactly what ojordan has posted here . . . not expecting that to solve the issue . . . I'll post back when I get that done.

F

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers