[amdgpu] Screen Flickers when it wakes from suspend/sleep.

Bug #1875189 reported by Dhruv Gadhavi on 2020-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-amdgpu (Ubuntu)
Undecided
Unassigned

Bug Description

I got some laptop having optimus/hybrid GPUs setup : AMD Vega 8 ( Raven Ridge ) + Nvidia GTX 1650 GPUs and a display having refresh rate of 120Hz.

Whenever I shut the laptop lid or it auto-suspends it catches screen flickers when it wakes up.

I think it's some kernel issue some deadlock maybe.

I already filed a bug on fedora bugzilla forum for the same aswell.

Here is the link for the same :

https://bugzilla.redhat.com/show_bug.cgi?id=1748042

I hope it gets' fixed this time :)

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
Uname: Linux 5.6.0-7.1-liquorix-amd64 x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun Apr 26 20:33:46 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] [10de:1f91] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. TU117M [GeForce GTX 1650 Mobile / Max-Q] [1043:109f]
 Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Picasso [1043:18f1]
InstallationDate: Installed on 2020-04-26 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: ASUSTeK COMPUTER INC. TUF Gaming FX505DT_FX505DT
ProcKernelCmdLine: audit=0 BOOT_IMAGE=/@/boot/vmlinuz-5.6.0-7.1-liquorix-amd64 root=UUID=c6a5aea4-fe87-480e-9b59-d3b0077d5842 ro rootflags=subvol=@ quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/24/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: FX505DT.310
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: FX505DT
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrFX505DT.310:bd12/24/2019:svnASUSTeKCOMPUTERINC.:pnTUFGamingFX505DT_FX505DT:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnFX505DT:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: TUF Gaming
dmi.product.name: TUF Gaming FX505DT_FX505DT
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Dhruv Gadhavi (nirvanaaa) wrote :
Daniel van Vugt (vanvugt) wrote :

The link provided is a crash in the kernel's SSD code. I don't think it's related to this bug at all.

tags: added: amdgpu flicker
summary: - Screen Flickers when it wakes from suspend/sleep.
+ [amdgpu] Screen Flickers when it wakes from suspend/sleep.
Daniel van Vugt (vanvugt) wrote :

Please try selecting 'Ubuntu on Wayland' on the login screen, then log in and tell us if the problem still occurs there.

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

I also notice you're not using the Ubuntu kernel. Please try the standard Ubuntu kernel (5.4) as well as newer versions like 5.7-rc3 ...

https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=M;O=D

affects: xorg-server (Ubuntu) → xserver-xorg-video-amdgpu (Ubuntu)
Launchpad Janitor (janitor) wrote :

[Expired for mutter (Ubuntu) because there has been no activity for 60 days.]

Changed in mutter (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-amdgpu (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers