[amdgpu] Blank display with Eoan Ermine live DVD on Ryzen 3 2200G

Bug #1848900 reported by Peter D. on 2019-10-20
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
New
Unknown
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-amdgpu (Ubuntu)
Undecided
Unassigned

Bug Description

Regression with Ryzen 3 2200G, UEFI Asrock B450 Pro4 motherboard and 55-75 Hz monitor.

Booting Xubuntu 19.10 live iso with safe graphics options did give a stable desktop display, but

xubuntu@xubuntu:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080 77.00*
xubuntu@xubuntu:~$

The monitor is only supposed to have a maximum vertical refresh rate of 75 Hz. Xrandr reports 77 Hz as the only choice. The monitor reports 60 Hz, not that I trust the monitor.

Swapping monitors and running many reboots the situation seems to be...

Old versions of Ubuntu (Bionic and Dingo) can handle the hardware.
Standard boot sometimes gives a blank screen.
Standard boot sometimes gives a badly pixelated display
(Ctl-Alt-F6, Ctl-Alt-F7 temporarily improves it).
Connecting a 144 Hz monitor convinces something (the firmware?)
that fast refreshes are OK on a slow monitor, or at least it fails to
reread and abide by the slow monitor's limitations when swapping back.
Something, I don't know what, convinces the computer to run the display
at 60 Hz, sometimes.

The motherboard has three video ports; DP, HDMI and VGA (using an onboard
DP? to VGA converter chip). The fast monitor has DP, HDMI and VGA ports,
but I only experimented with the DP connection. The slow monitor has VGA and
DVI-D ports. I experimented with VGA to VGA and HDMI via a passive adapter
to DVI. When running in the badly pixelated mode xorg seems to think that
the VGA port is "DP-1".

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperVersion: 1.427
CompositorRunning: None
CurrentDesktop: XFCE
Date: Sun Oct 20 00:17:34 2019
DistUpgraded: Fresh install
DistroCodename: eoan
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd] (rev c8) (prog-if 00 [VGA controller])
   Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd]
LiveMediaBuild: Xubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed quiet splash nomodeset ---
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/02/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P3.40
dmi.board.name: B450 Pro4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP3.40:bd07/02/2019:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnB450Pro4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
xserver.bootTime: Sat Oct 19 23:52:52 2019
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 Screen 0 deleted because of no matching config section.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.20.5+git20191008-0ubuntu1

Peter D. (0123peter) wrote :
Tom Reynolds (tomreyn) wrote :

I was supporting another Xubuntu 19.10 user on AMD Ryzen 3 2200G (Gigabyte Technology Co., Ltd. B450 AORUS M/B450 AORUS M, BIOS F2 08/08/2018) today, whose log of a failed (standard) boot (to black screen) showed

kernel: WARNING: CPU: 2 PID: 255 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x23d [amdgpu]

which seems to be discussed at https://bugs.freedesktop.org/show_bug.cgi?id=109628

Tom Reynolds (tomreyn) wrote :
summary: - blank display with Eoan Ermine live DVD on Rysen 2200G
+ Blank display with Eoan Ermine live DVD on Ryzen 3 2200G
summary: - Blank display with Eoan Ermine live DVD on Ryzen 3 2200G
+ [amdgpu] Blank display with Eoan Ermine live DVD on Ryzen 3 2200G
affects: xorg (Ubuntu) → xserver-xorg-video-amdgpu (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: amdgpu
Morten Kjeldgaard (mok0) wrote :

I experience the same on a Ryzen 5 2400G APU.

Peter D. (0123peter) wrote :

Workarounds include;
  use an older version of Ubuntu,
  use a faster monitor,
  use a video card (nVidia GT 710),
  use a mainline kernel 5.4.0-050400rc6-generic
    which also reports the VGA port as a VGA port.
But using a mainline kernel and a video card xrandr reports a 77 Hz refresh rate and a lower resolution.

Kai-Heng Feng (kaihengfeng) wrote :
Morten Kjeldgaard (mok0) wrote :

@kaihengfegn I guess I need this one:

  linux-image-unsigned-5.4.0-050400rc7-generic_5.4.0-050400rc7.201911102031_amd64.deb

as well as the corresponding headers and modules.

but what does "unsigned" mean?

Morten Kjeldgaard (mok0) wrote :

Re: "unsigned" I figured it out, however, my boot partition is UEFI, so I probably can't use an unsigned image.

Peter D. (0123peter) wrote :

@Morten

I think that all Ryzen motherboards are going to have UEFI firmware rather than the old BIOS firmware - even though everyone keeps using the old name.

If it is your computer and you know what you are doing you could turn off secure boot. If you don't know, then don't do it.

I grabbed all of these files;

CHECKSUMS
CHECKSUMS.gpg
linux-headers-5.4.0-050400rc7_5.4.0-050400rc7.201911102031_all.deb
linux-headers-5.4.0-050400rc7-generic_5.4.0-050400rc7.201911102031_amd64.deb
linux-image-unsigned-5.4.0-050400rc7-generic_5.4.0-050400rc7.201911102031_amd64.deb
linux-modules-5.4.0-050400rc7-generic_5.4.0-050400rc7.201911102031_amd64.deb

@Kai-Heng

Rc7 is better than rc6, but not a lot.

I might have imagined the part about the VGA port being reported as a VGA port. Sorry. That was probably when I had the graphics card plugged in. The VGA port is being reported as a second Display Port again.

With a fresh install of Eoan Ermine Xubuntu, updates, and rc7;

Standard boot gives a badly pixelated display for menus, moving windows, changing text; xrandr reports reasonable things, then after 10 or 20 minutes the machine locks up.

Booting with safe graphics from the grub menu gives a stable display, but xrandr seems confused and only reports one mode with a 77 Hz vertical refresh rate, and no mention of any ports.

Do you want log files, or anything in particular?

Peter D. (0123peter) wrote :

Correction:

Rc7 sometimes boots in the standard way. Sometimes it goes to a black screen.

Rc7 boots reliably from the *recovery* mode in the grub menu.

Morten Kjeldgaard (mok0) wrote :

My machine is mainly running as file server at the moment and I don't want to play around with kernels. I used to build kernels in the past and I remember how hard it is to get one that works. I'll wait till there's a fix in the main-line kernel. They can't release LTS 20.04 with this bug so it must come soon.

Kai-Heng Feng (kaihengfeng) wrote :

Please file an upstream bug at https://bugs.freedesktop.org/
Product: DRI
Component: DRM/amdgpu

Changed in linux:
status: Unknown → New
Peter D. (0123peter) wrote :

I'm not so sure that it is a kernel problem.
Bionic with the edge kernel 5.3.0-24 seems OK, although it has locked up once or twice.
Eoan with kernel 5.3.0-23 misbehaves.
Could the XFCE desktop be important?

Pierre-Yves (pierreyves-legal) wrote :

I am using xfce4 version 4.14. With the kernel 5.0.0-32-generic, everything is OK.
With more recent kernel (5.3.0-23-generic and 5.3.0-24-generic), I have the display bug. So, I think that it has no link with xfce

Pierre-Yves (pierreyves-legal) wrote :

Well well, I change my mind. It may bug a xfce bug see that everything is Ok with 5.3.0-24-generic kernel and gnome, mate and cinnamon interfaces. No more bug display....

Peter D. (0123peter) wrote :

The bug seems to have "gone away" when using a DVD of an early March beta version of Focal Fossa 20.04. It boots very happily with no obvious display problems.

Sorry that I could not track down exactly what the problem was.

Daniel van Vugt (vanvugt) wrote :

Thanks for the update Peter. That makes this bug apparently closed.

Anyone still experiencing issues should open new bugs of their own.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.