Kinetic 2-finger scrolling no longer works after upgrade to 12.04

Bug #930938 reported by Bruno Girin on 2012-02-12
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

I upgraded to 12.04 yesterday and just realised that kinetic 2-finger scrolling no longer works with my touchpad.

Steps to reproduce:
1. Go to System Setting / Mouse and Touchpad
2. Click on the Touchpad tab
3. Set scrolling to Two Finger Scrolling
4. Close the settings
5. Open a document that requires scrolling (e.g. long web page in Firefox, long text file in Gedit, etc)
6. Scroll through the document using two fingers on the touchpad

Expected behaviour
When scrolling, the page should keep scrolling up or down when the fingers are taken off the touchpad and stop on its own.

Actual behaviour
Scrolling stops dead as soon as fingers are taken off the touchpad, making it quite cumbersome to scroll through long documents.

Alternative expected behaviour
Have an option to enable kinetic scrolling in the touchpad settings.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,vpswitch,snap,imgpng,gnomecompat,mousepoll,place,resize,grid,regex,session,wall,animation,workarounds,expo,fade,ezoom,scale,unityshell]
Date: Sun Feb 12 12:10:27 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-11 (0 days ago)

Bruno Girin (brunogirin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Alex Willmer (alex-moreati) wrote :

At a guess this isn't a Unity bug, but perhaps an xserver-xorg-input-synaptics. I see the same lack of inertial/kinetic in Unity 2D, Gnome, Gnome Classic, XFCE and KDE on 12.04.

Andrea Azzarone (azzar1) on 2012-03-24
affects: unity (Ubuntu) → ubuntu
Martin G Miller (mgmiller) wrote :

For me, I have a regular touchpad with 1 finger edge scrolling. Kinetic scrolling worked in 11.10, but not in 12.04.

Chow Loong Jin (hyperair) wrote :

Scrolling down the Evince thumbnail list seems to have kinetic scrolling, just that it's really slow. Setting CoastingFriction (from synclient) to 0 causes it to continue scrolling at a very slow pace.

affects: ubuntu → gtk+3.0 (Ubuntu)
Chow Loong Jin (hyperair) wrote :

Okay, I thought this was related to Gtk's kinetic scrolling support, but it looks like it's still handled by Synaptics, from what I can observe with xev.

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → xserver-xorg-input-synaptics (Ubuntu)
Chow Loong Jin (hyperair) wrote :

And here's a debdiff.

Changed in xserver-xorg-input-synaptics (Ubuntu):
milestone: none → ubuntu-12.04
Chris Halse Rogers (raof) wrote :

That patch results in an apparently infinite stream of scroll events in the default setup; unsubscribing sponsors, as it's unsuitable in its current state.

Chow Loong Jin (hyperair) wrote :

Here's a fixed patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.5.99.902-0ubuntu5

---------------
xserver-xorg-input-synaptics (1.5.99.902-0ubuntu5) precise-proposed; urgency=low

  * Fix coasting speed on multitouch touchpads (LP: #930938)
    - Add patch 203_fix_coasting_speed.patch
 -- Chow Loong Jin <email address hidden> Fri, 13 Apr 2012 16:14:04 +0800

Changed in xserver-xorg-input-synaptics (Ubuntu Precise):
status: Confirmed → Fix Released
Claude Krantz (puma) wrote :

I sadly created a duplicate of this bug

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/978327

as I couldn't find this older description. This bug affects me as well since upgrade to Precise Pangolin on a Thinkpad T400: Coasting scrolling does not work no matter if I try to trigger it by two-finger touch or by dragging at the edge of the pad, although scrolling itself works fine it both cases.

The feature worked as expected on Oneiric.

Claude Krantz (puma) wrote :

That patch fixed the bug for me. Many thanks hyperair!

Ahmed Shams (ashams) wrote :

Hi Chow,
Just wanted to inform you that someone(Robert Hooker) has opened a task reporting(bug #983614) that the last changes to Property "Synaptics Coasting Speed" is causing to him the Unity dash to "open spuriously with on bcm5974 touchpads with xserver-xorg-input-synaptics 1.5.99.902-0ubuntu5". I couldn't mark it as dup due to difference of symptoms.
Thanks and sorry for subscribing you without asking.

Changed in xserver-xorg-input-synaptics (Ubuntu Precise):
status: Fix Released → Triaged
importance: Undecided → Low
status: Triaged → Fix Released

On 18/04/2012 08:32, Ahmed Shams wrote:
> Hi Chow, Just wanted to inform you that someone(Robert Hooker) has opened a
> task reporting(bug #983614) that the last changes to Property "Synaptics
> Coasting Speed" is causing to him the Unity dash to "open spuriously with on
> bcm5974 touchpads with xserver-xorg-input-synaptics 1.5.99.902-0ubuntu5". I
> couldn't mark it as dup due to difference of symptoms. Thanks and sorry for
> subscribing you without asking.

Thanks for notifying me. You should have just subscribed me to that other bug,
though. ;-)

--
Kind regards,
Loong Jin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers