Comment 20 for bug 896922

Jesse Parnell (jparnell0) wrote :

I have been having a similar issue with ubuntu 12.04 lts on a Compaq Presario v5000. My mouse would randomly either stop working completely (rare) or my ability to click and select objects was completely gone. My annoying bandaid fix was to "sudo rmmod psmouse, and sudo modprobe psmouse" in the terminal whenever the mouse acted up.

I ran into another better bandaid fix that seems to have helped so far (been running fine for the past 2 hours) which was posted on bug #96596 where "RooSoft" mentioned: "so I set i8042.dumbkbd=1 in the kernel parameters and not only did the spurious ACk error disappear but the psmouse lost sync messages too."

After doing the bandaid fix mentioned by RooSoft everything has been running pretty smoothly, my mouse will hiccup every once in a while, throw a it's errors in the system log, but it will never get stuck in a click event.

I hope this works for others out there, it was a big pain I had to deal with for 2 days, and it annoyed me to the point I wanted to trash ubuntu completely. If I run into a true solution ill post it here.