Ubuntu

Drag and Drop in Ubuntu 11.10 is very bad

Reported by Gareth Witty on 2011-10-14
This bug report is a duplicate of:  Bug #859474: Dragging with touchpad unusable. Edit Remove
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Even after changing the settings is the Mouse application. The Drag and Drop is very intermittent. I use the double tap which work perfect in 11.04 but in 11.10 its a bit of a pain. I can of course use the left button below the touchpad but I am so used to the double tap method it would be nice to have this working, apart from that 1st class job on the OS.

affects: ubuntu → unity (Ubuntu)
Andrea Azzarone (andyrock) wrote :

@Gareth
Can you test the drag and drop using gnome shell or unity 2d instead of unity 3d?

Changed in unity (Ubuntu):
status: New → Incomplete
Alti El (el-altiel) wrote :

I have the same problem. Main reason - changing action to start drg'n'drop. In Ubuntu 11.04 it was (Tap)+(Press). But now it is (Tap)+(Press and Drag).
This action is part of xserver-xorg-input-synaptics driver. I try to uninstall it and change driver to xserver-xorg-input-multitach and touchpad Drag'n'Drop but have another problem, because synaptics driver also uninstalling some parts of Xorg libs.
I try work in Unity 2D and Gnome shell - same result.

Changed in unity (Ubuntu):
assignee: nobody → Alti El (el-altiel)
Andrea Azzarone (andyrock) wrote :

Marking as invalid in Unity as previous comment.

Changed in unity (Ubuntu):
status: Incomplete → Invalid
Martin K (caius-n) wrote :

I may have found the source of the problem. I think some of the default settings of the synaptic driver have been changed, and not exactly for the better. Here is what I have changed:

FastTaps = 1 (it was 0 by default)
SingleTapTimeout = 320 (it was 180 by default)

Now it works quite well.

sokai (sokai) wrote :

@caius-n
Wow - thanks a lot!

I came here from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/859474 and now I got a solution from you. :)

One hint:
I also have to set TapAndDragGesture=1 to make "double tap and drag" working.

Thanks again & best regards!

Alti El (el-altiel) on 2011-10-16
Changed in unity (Ubuntu):
assignee: Alti El (el-altiel) → nobody
status: Invalid → Incomplete
Andrea Azzarone (andyrock) wrote :

@Alti Why have you changed the bug status?

Alti El (el-altiel) wrote :

Sorry, I the beginner at launchpad.
I made mistake when assign bug to me, I can't solve it.

Andrea Azzarone (andyrock) wrote :

@Ali don't worry. I asked you because i thinked you had a good reason.

Changed in unity (Ubuntu):
status: Incomplete → Invalid
Stefan Dringenberg (std) wrote :

After reading Kai's posting I solved the problem permanently by adding the following lines to /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertTwoFingerScroll" "1"
        Option "TapAndDragGesture" "1"
        Option "SingleTapTimeout" "320"
        Option "FastTaps" "1"
EndSection

affects: unity (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Invalid → Confirmed
sokai (sokai) wrote :

To sum up my experiences to get "double tap and drag" working with my "ETPS/2 Elantech Touchpad" on Oneiric:

1. I have the following settings with GNOME system settings for my touchpad:
 * "Disable touchpad while typing" = checked
 * "Enable mouse clicks with touchpad" = checked
 * Scrolling -> "Two-finger scrolling" = checked

2. After 1. I have to set the following options with "synclient" (in a terminal):
 TapAndDragGesture=1
 SingleTapTimeout=320

That's it!

3. If you wanna have a "middle click" by tap with two fingers and a "right click" by tap with three fingers you have to change the following options with synclient:
 TapButton1=1
 TapButton2=2
 TapButton3=3

Best regards!

Gareth Witty (garethwitty) wrote :

Tried all the above and still not working? I did install XFCE4.8 and it worked fine for me after that. It seems to be a Unity problem. I will try and install the Gnome Shell only and see what happens.

Gerry (gerry-vaz) wrote :

I have successfully applied the recommendation in post #9 to my Dell Inspiron 11z laptop. Thanks a million.

Gareth Witty (garethwitty) wrote :

Ok I added this to my system and now all works fine.

 /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf

Put this at the end of the file:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertTwoFingerScroll" "1"
        Option "TapAndDragGesture" "1"
        Option "SingleTapTimeout" "320"
        Option "FastTaps" "1"
EndSection

Chad Rehak (crrehak) wrote :

I'm fairly new at linux, but I am still having this issue... I have tried all of the above, but my touchpad is still extremely choppy and not fully functional. Anyone have any further advice or can help me troubleshoot this it would be greatly appreciated because I have to use a USB mouse for the time being. Thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers