Ubuntu

touchpad triple-tap to middle-click stopped working in 11.10

Reported by Jean-Baptiste Mazon on 2011-09-03
142
This bug affects 29 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned

Bug Description

Since I upgraded from 11.04 to 11.10 beta, tapping the touchpad with three fingers at the same time does not double-click anymore. It worked fine before the upgrade.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-input-synaptics 1.4.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Sat Sep 3 19:46:50 2011
DistUpgraded: Log time: 2011-09-03 14:42:11.413838
DistroCodename: oneiric
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
MachineType: ASUSTeK Computer Inc. U52F
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=d65e4109-f028-442d-b1e6-c6356587418d ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-input-synaptics
UpgradeStatus: Upgraded to oneiric on 2011-09-03 (0 days ago)
dmi.bios.date: 07/21/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U52F.208
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U52F
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU52F.208:bd07/21/2010:svnASUSTeKComputerInc.:pnU52F:pvr1.0:rvnASUSTeKComputerInc.:rnU52F:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U52F
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu20
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Jean-Baptiste Mazon (jmazon) wrote :
Jean-Baptiste Mazon (jmazon) wrote :

Oops, mistake in the bug description: it's "middle-click", not "double-click".
A three-finger tap is supposed to emulate a middle button, and used to before the upgrade to 11.10.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Ian Turner (vectro) wrote :

Also seeing this on 11.10 beta. Note that there has been a lot of fighting in the GNOME project over the finger taps; see for example <https://bugzilla.gnome.org/show_bug.cgi?id=598820>.

Ian Turner (vectro) wrote :

I should elaborate on what I'm seeing:
1 finger tap -> left click
2 finger tap -> right click
3 finger tap -> some sort of window manager operation (using scroll gestures here moves the active window)

Middle click is still available by pressing both buttons simultaneously, but this is not available on clickpads, and is more difficult than a two- or three-finger gesture.

NachoR (nachordez-gmail) wrote :

That's not a duplicate of #754000 though related. They talk about triple-click on a clickpad, not triple-tap on a touchpad.

But it seems that the triple-click question is turning down the triple-tap. Please, that's a very important question. I (and many other people) do REALY NEED the third-button-triple-tap emulation. That cannot be changed so uncounsciously!

The synclient -m 100 informs just one finger when there are 3 or 4 (it's right when 1 or 2). That nees to be corrected IMMEDIATELY.

Bryce Harrington (bryce) wrote :

Hey jmazon,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Incomplete
Jean-Baptiste Mazon (jmazon) wrote :

Testing it once again after full updates, a triple tap still does not emulate a middle button click.

Bryce Harrington (bryce) on 2012-02-04
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Confirmed
Benjamin Drung (bdrung) wrote :

This bug is still present in a up-to-date Ubuntu 12.04 (precise) with xserver-xorg-input-synaptics 1.5.99~git20120223-0ubuntu1

Nicolas Delvaux (malizor) wrote :

And still the same problem on an up-to-date precise.

muhalifsirin (alperense) wrote :

I have the same problem on 12.04. Can not do middle clock on a touchpad.

Alex Sytnik (the-smerch) wrote :

thnx to mc4man there is a workaround(http://ubuntuforums.org/showpost.php?p=11701414&postcount=15):

gedit ~/.config/autostart/synclient.desktop

[Desktop Entry]
Type=Application
Exec=synclient LockedDrags=0 TapButton1=1 TapButton2=3 TapButton3=2
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-Delay=5
Name=onetap

Alex Sytnik (the-smerch) wrote :

P.S. make sure that ~/.config/autostart/ directory exists, otherwise you can not save the file.

Maharifu (mail-lmcarvalho) wrote :

Hi, with the method suggested by Alex Sytnik (post #11) your settings are reverted to their defaults after you wake up from suspend.

For these settings to be persistent, you can follow the instructions on: http://tombuntu.com/index.php/2011/11/06/persistent-touchpad-configuration-in-ubuntu-11-10/

I've tested it in Ubuntu 12.04.

shane (shane-animail) wrote :

There are other bugs related to this and all seem to be being completely ignored, marked as "won't fix" or marked as duplicates of other bugs. What exactly is going on?

Haw Loeung (hloeung) wrote :

I'm also seeing this with 12.04, xserver-xorg-input-synaptics-1.6.0-0ubuntu1~precise1.

Andreas E. (andreas-e) wrote :

For me three-finger-tap used to work until 11.10 and stopped since 12.04.

Jean-Baptiste Mazon, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-synaptics REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.