Ubuntu

Mouse stopped moving - touchpad still responds

Reported by Mike on 2011-08-20
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Yes, I know this is mis-filed. Surfing the web to learn the right filing system is a little difficult when my mouse is not working.
Hopefully this contains info about how it happened. It's happened several times before and I restarted X. This time I decided to report a bug. I'm sure it's a dup, so will attempt to link it after my Xorg restart.
What I mean in the description is that I can touch four fingers on the touchpad and the Unity menu opens up. I just can't move the mouse pointer, scroll, or click. Actually I CAN click. So just can't scroll or move the mouse.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.41.06 Mon Apr 18 14:53:56 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Sat Aug 20 10:20:02 2011
DistUpgraded: Log time: 2011-03-21 07:46:42.331157
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-11-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-11-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-10-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00c7]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110312)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
MachineType: Apple Inc. MacBookPro6,2
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=daed62de-fdc0-40f1-b54f-2d6408f18d44 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to natty on 2011-03-24 (148 days ago)
dmi.bios.date: 07/26/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP61.88Z.0057.B0C.1007261552
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22586C8
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro6,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22586C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP61.88Z.0057.B0C.1007261552:bd07/26/10:svnAppleInc.:pnMacBookPro6,2:pvr1.0:rvnAppleInc.:rnMac-F22586C8:rvrMacBookPro6,2:cvnAppleInc.:ct10:cvrMac-F22586C8:
dmi.product.name: MacBookPro6,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.10.2-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Mike (bild85) wrote :
Mike (bild85) wrote :

assigning to synaptics

bugbot (bugbot) on 2011-09-08
affects: xorg (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Bryce Harrington (bryce) wrote :

Hey bild85,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete
Mike (bild85) wrote :

Hi Bryce. I upgraded to Oneiric as soon as beta was released. It still happens, but is extremely rare. However, when it does happen I have no recourse but to force logout, resulting in data loss. It may have happened two times since I upgraded to Oneiric beta. I have not performed a clean install yet.

Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-synaptics (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Expired
Ahmed Shams (ashams) on 2012-01-10
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: Expired → Confirmed
Ivan Zakharyaschev (imz) wrote :

I often encounter a very similar issue in Ubuntu 12.04 for Toshiba AC100 (ARM):

* https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/1037586
* https://bugs.launchpad.net/xserver-xorg-input-synaptics/+bug/1035208

It has an "Elantech" touchpad.

Ivan Zakharyaschev (imz) wrote :

@bild85: instead of "force logout" with losing the data, you could connect an external mouse.

Ivan Zakharyaschev (imz) wrote :

Right now this happened once again for me; I've written about it at https://bugs.launchpad.net/xserver-xorg-input-synaptics/+bug/1035208/comments/11 .

Ivan Zakharyaschev (imz) wrote :

BTW, I've found a workaround: put the system into standby mode, and upon the wakeup, the touchpad is fully working again.

Please tell me:

What to do further to diagnose the source of the error?

Ivan Zakharyaschev (imz) wrote :

Or just switching to the linux console (terminal) (e.g., with Ctrl-Alt-F1) and back to X (with Ctrl-Alt-F7 in my case) fixed the problem in my case: touchpad is working again, nothing to lose.

kroq-gar78 (kroq-gar78) wrote :

Ivan,
I can confirm that this fix works. I'm on a Toshiba NB505.

Ivan Zakharyaschev (imz) wrote :

@kroq-gar78: I'd rather call this (switching to the text linux console) a "workaround" rather than a real fix.

Did you mean this? Or do you know of another real fix for this bug?

I learned it from a comment by Azrael Tod on a similar bug report: https://bugs.launchpad.net/ubuntu/+source/linux-ac100/+bug/1035208/comments/15 .

kroq-gar78 (kroq-gar78) wrote :

No, sorry, I mean this workaround is still fine. I don't have a "fix" :(

Ivan Zakharyaschev (imz) wrote :

Can this be related to pointer "grabbing" discussed in http://unix.stackexchange.com/q/40458/4319 ?

kroq-gar78 (kroq-gar78) wrote :

Ivan, I think I remember trying the key combo on my netbook and laptop and neither worked, so I don't this it's related to grabbing.

Well, good news (I think). On my Toshiba Satellite L655, I pulled up "/var/log/Xorg.0.log", and I seem to have found some source of the error for this. Here are the last few lines of the file:

[343696.707] BUG: triggered 'if (priv->num_active_touches > priv->num_slots)'
BUG: ../../src/synaptics.c:3123 in UpdateTouchState()
[343696.707]
Backtrace:
[343696.707] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7f5de0450886]
[343696.707] 1: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5dda013000+0x2db0) [0x7f5dda015db0]
[343696.707] 2: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5dda013000+0x364f) [0x7f5dda01664f]
[343696.707] 3: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5dda013000+0x61b0) [0x7f5dda0191b0]
[343696.707] 4: /usr/bin/X (0x7f5de02c8000+0x8af37) [0x7f5de0352f37]
[343696.707] 5: /usr/bin/X (0x7f5de02c8000+0xb0d2a) [0x7f5de0378d2a]
[343696.707] 6: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f5ddf5ee000+0xfcb0) [0x7f5ddf5fdcb0]
[343696.707] 7: /lib/x86_64-linux-gnu/libc.so.6 (__select+0x13) [0x7f5dde54b003]
[343696.708] 8: /usr/bin/X (WaitForSomething+0x19b) [0x7f5de044dc6b]
[343696.708] 9: /usr/bin/X (0x7f5de02c8000+0x4e5f2) [0x7f5de03165f2]
[343696.708] 10: /usr/bin/X (0x7f5de02c8000+0x3d7ba) [0x7f5de03057ba]
[343696.708] 11: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7f5dde47f76d]
[343696.730] 12: /usr/bin/X (0x7f5de02c8000+0x3daad) [0x7f5de0305aad]
[343707.298] (II) AIGLX: Suspending AIGLX clients for VT switch

To me, it looks like a stacktrace dump, and it clearly says "BUG" at the top, referring to the file src/synaptics.c, somewhere in Xorg. Frankly, I have no idea how to interpret the condition in the "if" statement.

So, I think this is clearly a bug in Xorg, but I don't really know how to fix this. :(

no longer affects: xserver-xorg-input-synaptics (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Mike, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-synaptics REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

affects: ac100 → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-synaptics (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.