Ubuntu

cannot left click and drag with touchpad (regression)

Reported by Rhys Thomas on 2011-03-17
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
High
Chase Douglas

Bug Description

Binary package hint: xserver-xorg-input-synaptics

Cannot left click and drag on the touch pad of my dell inspiron mini 10 running natty. The bug means that I can't highlight text or move windows. Everything was working fine until a recent upgrade.

Just to add, I can click and drag with the touch pad, just not with the mouse buttons on the touch pad.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAJ5YcFAAAAAAETAQOQFg14CiLAlVZOjiYkUFQAAAABAQEBAQEBAQEBAQEBAQEBihYA2kFYKiAwIDoA330AAAAaihYA2kFYKiAwIDoA330AAAAaAAAA/gBIMDE4VIBIVDEwMTAxAAAAAAAAAAAAAAAAAAEBCiAgAFA=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Mar 16 23:58:27 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-5-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-2-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-1-generic, i686: installed
GraphicsCard:
 Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:02f4]
   Subsystem: Dell Device [1028:02f4]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: Dell Inc. Inspiron 1011
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=761e32b5-5dcb-43d6-90e2-993f67251138 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-input-synaptics
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/29/2009:svnDellInc.:pnInspiron1011:pvrA06:rvnDellInc.:rnCN0Y53:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Inspiron 1011
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Rhys Thomas (e-rhys-thomas) wrote :
description: updated
Bryce Harrington (bryce) wrote :

Confirmed; I can reproduce this behavior on my netbook. But not my laptop (which also has a synaptics touchpad). I'll update both to current natty to see what happens.

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) wrote :

@Chase - is this due to recent touch changes? It seems to have started within the last week or so.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → Chase Douglas (chasedouglas)
assignee: Chase Douglas (chasedouglas) → nobody
Chase Douglas (chasedouglas) wrote :

This is actually a kernel bug. The dell mini netbooks have a special synaptics trackpad that has semi-multitouch capabilities on top of a pair of integrated buttons. Linux 2.6.38 adds support for the semi-multitouch feature.

Before the addition of the multitouch feature, the bottom 1/3 of the trackpad was disabled in the X synaptics driver. Now, we've got touch functionality in the kernel that probably will need to be masked out in the driver. I had been looking into this a few months ago, but I gave the work up to focus on other parts of the stack. I probably should take another look at it now.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Confirmed → Triaged
Rhys Thomas (e-rhys-thomas) wrote :

This is fixed for me now after the recent updates

Aether (raymond-dick) wrote :

Interesting, not so for me - tried a different repo in case mine was out of sync. You can make the touchpad present itself like a ps2 mouse but then you lose the ability to use vertical scrolling. To do this you would do something like sudo echo psmouse proto=exps > /etc/modprobe.d/psmouse.modprobe and reboot. For me I find this worse than the problem as I find vertical scrolling more important (most of the time web browsing)...

Aether (raymond-dick) wrote :

I should point out, the workaround of making sure you are only touching the very most corner of the track pad for clicking works. I guess this works because the Dell mini 10v trackpad actually has left and right mouse buttons under the trackpad where I think others don't incorporate actual physical buttons but just use zones.

Rhys Thomas (e-rhys-thomas) wrote :

This is very strange, its definitely fully working for me now. Is there anything I can post here to help you understand why?

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → In Progress
Chase Douglas (chasedouglas) wrote :

Contrary to what I wrote earlier, this is best described not as a kernel bug but as a deficiency with the X synaptics input module. I made some changes to how it handles multi-finger functionality and I believe it works much better as a result.

However, the changes are larger than I would like this late in the Natty cycle, so testing is important. I uploaded a new version of xserver-xorg-input-synaptics to ppa:utouch-team/unstable. Please test out the package to confirm that it fixes any issues you have and does not introduce any regressions.

The only remaining issue that I see occasionally is a second light touch warping the pointer from one location to another half way across the screen. To get this fixed will require better filtering logic, but the fix will require too large of a change at this point in the Natty cycle. Perhaps we can fix it in Oneiric.

Changed in xserver-xorg-input-synaptics (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
Aether (raymond-dick) wrote :

Thankyou Chase, I've tested this on my machine and it works well. I can now click and drag, tapping and side scrolling still work.

Chase Douglas (chasedouglas) wrote :

I've committed the changes to the packaging tree for xserver-xorg-input-synaptics. After the Beta 1 release we plan to push it into Ubuntu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.3.99+git20110116.0e27ce3a-0ubuntu9

---------------
xserver-xorg-input-synaptics (1.3.99+git20110116.0e27ce3a-0ubuntu9) natty; urgency=low

  * Fix handling for SemiMultitouch trackpads with integrated buttons
    (LP: #736523)
    - Added 119_active_area_touches.patch
    - Added 120_active_touches_num_fingers.patch
    - Added 121_semi-mt_num_fingers.patch
  * Fix spurious right click events on some trackpads (LP: #742213)
    - Added 122_revert_pressure_finger_default.patch
 -- Chase Douglas <email address hidden> Wed, 30 Mar 2011 10:54:50 -0400

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Fix Released
Sérgio Faria (sergio91pt) wrote :

well on a HP dv6-3315 with xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu10 the left click button sends a right click instead. This is a new computer that i just ran ubuntu 10.10 beta on a live usb drive..

Chase Douglas (chasedouglas) wrote :

Hi Sérgio,

This bug is for a very specific type of touchpad that is not available anymore due to defective design :). Please open a separate bug in launchpad for your issue by running:

$ ubuntu-bug xserver-xorg-input-synaptics

Thanks!

Reinhard (reinhard-fink) wrote :

I am using Kubunt 11.04 with xserver-xorg-input-synaptics 1.3.99+git20110116 on a HP dv7 with Synaptics Touchpad (model: 1, fw: 7.4, id: 0x1e0b1).
I can't highlight text or move windows. On the same laptop with Kubuntu 10.10 the touchpad works?

Chase Douglas (chasedouglas) wrote :

Hi Reinhard,

Please open a new bug for your issue by running "ubuntu-bug xserver-xorg-input-synaptics". After creating the bug, please subscribe me (my LP id is chasedouglas).

Thanks!

Aether (raymond-dick) wrote :

It's regressed again in 11.10 Oneiric.

ThierryM (thierry-munoz) wrote :

I confirm this problem under 11.10 Oneiric : new installation in my Laptop ASUS N71V (X77J).
I have installed Synaptics and Pointing Device but no effect : click and drag impossible.
No problem for clicking but impossible to select text too dragging or to move an icon.

Aether (raymond-dick) wrote :

I did a fresh install on my Dell Mini 10v after the release (previous was beta 1 upgrade from 11.04) and all working now.

Must say, its pretty polished - running lubuntu 64bit, 15s to boot into a fully working environment. Working Citrix Receiver, Skype, flash is stable and VPNC even working with Gnome-Network-Manager rather than dropping to command line with some parameter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers