Ubuntu

Synaptics touchpad not enabled for second X display

Reported by Vincenzo Ciancia on 2006-10-26
220
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Debian)
Fix Released
Unknown
xserver-xorg-input-synaptics (Ubuntu)
High
Unassigned
Nominated for Gutsy by unggnu

Bug Description

If I start a new X server by switching user in the logout window, the touchpad does not work on the second server.

in the X server log I find:

Synaptics DeviceOn called
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(WW) Synaptics Touchpad can't grab event device, errno=1022

I can confirm that the touchpad om my Dell 8200 either does not work or behaves oddly when a second user logs on to Ubuntu 6.10.

The ways I have seen the touchpad fail are:
1) The touchpad does not work. The pointer does not move until I log back on to the original account
2) The touchpad works, but behaves oddly. The speed setting is much higher than when the touchpad behaves correctly, and one click with the pad results in two clicks in Gnome.

Vincenzo Ciancia (vincenzo-ml) wrote :

I must add that the behavior I reported does not _always_ happen (but often): sometimes it just works as it should, but eventually logging out and in again the second user stops the mouse from responding.

If traces/logs can assist in diagnosing the problem, please tell med what logs you need, so I can reproduce the symptoms, and attach the log.

Nicolò Chieffo (yelo3) wrote :

I'm also affected by this bug. I'm using feisty.

An addition to my post from 2006-10-29 19:36:32 UTC:
3) The touchpad does not work until I log on the the original account (CTRL+ALT+F7). When I log back on to account number two (CTRL+ALT+F8) the touchpad works as expected.

I also confirm this issue on My Feisty install

Nicolò Chieffo (yelo3) wrote :

Just to inform you... the SHMConfig option does not help (it was just a try)

darren (darrenm) wrote :

Another confirmation from a Feisty user here.

Adi Roiban (adiroiban) wrote :

I can also confirm this problem on Herd5

Changed in xserver-xorg-input-synaptics:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
MeneM (maas-mark) wrote :

It seems previous versions experienced similar issues:
https://launchpad.net/ubuntu/+bug/65785

Which is Ubuntu Dapper.

Confirmed in Feisty for me. I have had the same problem in Dapper and Edgy.

Sometimes, I can sometimes get around the problem by instead of choosing Switch user do the following:
1. Choose Lock Screen
2. Poke the mouse to get rid of screen-saver
3. Click Switch user
4. Log in as normal for that user.

Since this works and the normal switching doesn't, I think it might be something related to the fact that screensaver/locking happens automatically when you switch user and that it might steal the mouse control when the new X server has been started.

MeneM (maas-mark) wrote :

Agreed, I get the same.

When you lock the screen and use that "switch user" button you can indeed relogin with a different user and the mouse works.

Unfortunately, in that case the screen stays blank on the second login.

All these work-arounds are NOT a way this thing should work. In my
opinion it should be fixed properly, so that a novice user can get
expected behavior..

Thanks, Alex.

On 3/28/07, MeneM <email address hidden> wrote:
>
> Agreed, I get the same.
>
> When you lock the screen and use that "switch user" button you can
> indeed relogin with a different user and the mouse works.
>
> Unfortunately, in that case the screen stays blank on the second login.
>
> --
> Synaptics touchpad not enabled for second X display
> https://launchpad.net/bugs/68370
>

Nicolò Chieffo (yelo3) wrote :

well, the touchpad should always work...
Anyway in my case it does not work even after the login. but works if
I ctrl-alt-f7 to the first X session...
Have you got the option SHMConfig on in xorg.conf??

MeneM (maas-mark) wrote :

Yes, but getting there means we need to find out where the problem lies
first.
Fiddling, trying out things narrows it down to where the issue is. THEN we
can focus on that particular thing in the hopes that we can fix it ;-)

On 3/28/07, alex matijaca <email address hidden> wrote:
>
> All these work-arounds are NOT a way this thing should work. In my
> opinion it should be fixed properly, so that a novice user can get
> expected behavior..
>
> Thanks, Alex.

alex matijaca (amatijaca) wrote :

I really don't try to touch xorg.conf --- too scary..

a.m.

On 3/28/07, Nicolò Chieffo <email address hidden> wrote:
>
> well, the touchpad should always work...
> Anyway in my case it does not work even after the login. but works if
> I ctrl-alt-f7 to the first X session...
> Have you got the option SHMConfig on in xorg.conf??
>
> --
> Synaptics touchpad not enabled for second X display
> https://launchpad.net/bugs/68370
>

MeneM (maas-mark) wrote :

With the latest update the "lockscreen and then do switch user" trick suddenly works flawlessly. (?)

Sometimes I need to switch between instances: CTRL-ALT-F7 and back to CTRL-ALT-F9 to get the mouse loose again, but it works!

I have attached my xorg.conf

Henrik Brink (henrikbrink) wrote :

I have the same problem with feisty:
When I do Switch user, the touchpad is not working.

However, if I go back to the old display (using CTRL-ALT-F7), and then back (with F9), it works fine.

Need any files or logs?

Derek (bugs-m8y) wrote :

Same issue on my mom's laptop after recent upgrade to Feisty. Attempting to switch users yields same "Synaptics Touchpad can't grab event device, errno=1022" - although both X processes are identified by fuser as having locks on /dev/input/event1
xorg.conf has been untouched since dpkg-reconfigure

Sylvain Tenier (teksaver) wrote :

I have the same problem on a VAIO S3XP with a clean install of feisty (format of / and new account on /home)

Nils Lorvick (nils-lorvick) wrote :

I've also had this issue on a brand new Dell Inspiron E1505. Clean install of Feisty Fawn. I've noticed there hasn't been any activity on this particular bug in a little white, other than it's been confirmed. Now that Dell will be selling Ubuntu preloaded, I can only assume this will be an issue until it is patched?

Nicolò Chieffo (yelo3) wrote :

I don't really understand why but in some combinations the touchpad is enabled in the second display too...
If I do: switch users the touchpad is not usable at all.
to enable it I must do
ctrl-alt-f7 (back to normal display)
ctrl-alt-f8 (console vt)
alt-f9 (back to the new display, with the touchpad working)

I got the same behavior:
What informations could be useful to find out where this bug is located? DEV? Anyone?
Here is my xorg and my xorg.log while changing to a new user.
Maybe this is usefull to someone out there ;-)

David Noble (david-noble) wrote :

My sad story had a happy ending...

I wanted to use an external monitor for giving presentations with an HP dv4000 laptop running Edgy. The output was extremely wavy with i810switch, so I followed the instructions here:

https://wiki.ubuntu.com/HowtoSetupExternalMonitorForIntel915

The mouse froze when logging in with a cloned display, but otherwise things looked good. When I skipped the screenlock by adding the "-l" option to gdmflexiserver, everything worked great.

That doesn't sound too bad, but it took several hours of chasing down blind alleys and trying things that didn't help.

David Schleef (dschleef) wrote :

The x input driver fails to ungrab the device when switching away from one user's display, making it impossible for the new user's display to grab the device. Patch attached.

Thanks David,

Your patch works great and solves the problem.

The following steps were needed:
1. Download Synaptics source from
http://web.telia.com/~u89404340/touchpad/index.html
2. Extract the files
3. Run 'make'
4. Run 'sudo cp synaptics_drv.so /usr/lib/xorg/modules/input/'
5. Reboot

Have you submitted the patch to the author of Synaptics, so it will be
included in future versions?

Regards
Henrik Steensland

On 7/10/07, David Schleef <email address hidden> wrote:
> The x input driver fails to ungrab the device when switching away from
> one user's display, making it impossible for the new user's display to
> grab the device. Patch attached.
>
> ** Attachment added: "patch"
> http://launchpadlibrarian.net/8354070/patch
>
> --
> Synaptics touchpad not enabled for second X display
> https://bugs.launchpad.net/bugs/68370
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Oh, I forgot the patching step:
1. Download Synaptics source from
http://web.telia.com/~u89404340/touchpad/index.html
2. Extract the files
3. Change eventcomm.c according to the patch
(Run patch, or manually paste the rows in the EventDeviceOffHook method)
4. Run 'make'
5. Run 'sudo cp synaptics_drv.so /usr/lib/xorg/modules/input/'
6. Reboot

Henrik

On 7/20/07, Henrik Steensland <email address hidden> wrote:
> Thanks David,
>
> Your patch works great and solves the problem.
>
> The following steps were needed:
> 1. Download Synaptics source from
> http://web.telia.com/~u89404340/touchpad/index.html
> 2. Extract the files
> 3. Run 'make'
> 4. Run 'sudo cp synaptics_drv.so /usr/lib/xorg/modules/input/'
> 5. Reboot
>
> Have you submitted the patch to the author of Synaptics, so it will be
> included in future versions?
>
> Regards
> Henrik Steensland
>
> On 7/10/07, David Schleef <email address hidden> wrote:
> > The x input driver fails to ungrab the device when switching away from
> > one user's display, making it impossible for the new user's display to
> > grab the device. Patch attached.
> >
> > ** Attachment added: "patch"
> > http://launchpadlibrarian.net/8354070/patch
> >
> > --
> > Synaptics touchpad not enabled for second X display
> > https://bugs.launchpad.net/bugs/68370
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>

Saivann Carignan (oxmosys) wrote :

I can't get the synaptic sources to compile.. the make command gives a lot of errors :

synaptics.c:809: attention : implicit declaration of function «GetTimeInMillis"
synaptics.c: In function «ControlProc":
synaptics.c:1783: erreur: «Success" undeclared (first use in this function)
synaptics.c: In function «SwitchMode":
synaptics.c:1797: erreur: «Success" undeclared (first use in this function)
make: *** [synaptics.o] Erreur 1

Evgeny Kuznetsov (nekr0z) wrote :

I confirm this bug existing on Fujitsu-Siemens Amilo M7400 and Lenovo 3000 N100.

Changed in xserver-xorg-input-synaptics:
importance: Medium → Low
status: Confirmed → Triaged
Changed in xserver-xorg-input-synaptics:
status: Unknown → New
Javier Jardón (jjardon) wrote :

I confirm this bug on DELL Inspiron 510m using Gutsy Tribe4

Nicolò Chieffo (yelo3) wrote :

Now that fast-user-switch-applet is enabled by default, we really need to change the priority of this bug...

Agreed!

On 8/20/07, Nicolò Chieffo <email address hidden> wrote:
> Now that fast-user-switch-applet is enabled by default, we really need
> to change the priority of this bug...
>
> --
> Synaptics touchpad not enabled for second X display
> https://bugs.launchpad.net/bugs/68370
> You received this bug notification because you are a direct subscriber
> of the bug.
>

LEVIS Cyril (atlas95) wrote :

Same problem here !
With my HP Nx9420 :(

NickPeirson (nick-magic-wand) wrote :

Step 5 grabs a couple of dependencies needed to compile it. Might solve the problems Saïvann Carignan is seeing.

1. Download Synaptics source from:
http://web.telia.com/~u89404340/touchpad/index.html
2. Extract the files
3. Change eventcomm.c according to the patch
(Run patch, or manually paste the rows in the EventDeviceOffHook method)
4. Run 'sudo apt-get install libxext-dev libx11-dev'
5. Run 'make'
6. Run 'sudo cp synaptics_drv.so /usr/lib/xorg/modules/input/'
7. Reboot

Nicolò Chieffo (yelo3) wrote :

sorry but, is it possible to substitute step 1 with
apt-get source xserver-xorg-input-synaptics
and step 4 with
sudo apt-get build-dep xserver-xorg-input-synaptics
?

Nicolò Chieffo (yelo3) wrote :

yes it is possible (and easier)
1) apt-get source xserver-xorg-input-synaptics
2) wget http://launchpadlibrarian.net/8354070/patch
3) patch -p0 < patch
4) sudo apt-get build-dep xserver-xorg-input-synaptics
5) cd xserver-xorg-input-synaptics*
6) sudo dpkg-buildpackage
7) cd ..
8) sudo dpkg -i xserver-xorg-input-synaptics*.deb

is it possible to push this patch upstream?

To be honest I know just enough to be able to figure out which packages
were missing when I tried to compile it, based on the instructions in
the comments, and added those in.

I haven't had much cause to experiment with apt-get, so I wasn't aware
of those commands. Using apt-get to get the source and build
dependencies looks like a much better idea, one I'll remember for future!

Nicolò Chieffo wrote:
> sorry but, is it possible to substitute step 1 with
> apt-get source xserver-xorg-input-synaptics
> and step 4 with
> sudo apt-get build-dep xserver-xorg-input-synaptics
> ?
>
>

serola (sami-serola) wrote :

After stage 6 on Nicolò:s guide I got the attached warning. Language is Finnish and it says something about secret key which is not found.

I've already pushed the patch upstream - hence the Debian link at the top of this bug.

The original author has already looked at it and concluded that it doesn't work. It simply delays the contention lock, and doesn't fix it.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=437273#15

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>]On Behalf Of
Nicolò Chieffo
Sent: 25 August 2007 17:45
To: <email address hidden>
Subject: Re: [Bug 68370] Re: Synaptics touchpad not enabled for second
Xdisplay

yes it is possible (and easier)
1) apt-get source xserver-xorg-input-synaptics
2) wget http://launchpadlibrarian.net/8354070/patch
3) patch -p0 < patch
4) sudo apt-get build-dep xserver-xorg-input-synaptics
5) cd xserver-xorg-input-synaptics*
6) sudo dpkg-buildpackage
7) cd ..
8) sudo dpkg -i xserver-xorg-input-synaptics*.deb

is it possible to push this patch upstream?

--
Synaptics touchpad not enabled for second X display
https://bugs.launchpad.net/bugs/68370
You received this bug notification because you are a direct subscriber
of the bug.

Nicolò Chieffo (yelo3) wrote :

ok, but at least it is a temporary fix!

for the warnings, don't worry, I think they are about the pgp
signature that dpkg-buildpackage wants to add to the package.

Jos Dehaes (jos-dehaes) wrote :

the patch does not work for me (ASUS L3800C). The only workaround is to switch again to the first X server, and then back again to the new one.

Saivann Carignan (oxmosys) wrote :

the patch doesn't work for me, still have the same issue and the same Xorg outputs

DeviceOff Called
DeviceOn Called

unggnu (unggnu) wrote :

I can confirm this. It is still present in Gutsy and the only solution is to switch to first X session and move the mouse. I think that this bug priority shouldn't be low since the Gnome "user switcher" is activated by default in panel in Gutsy so many laptop users might think Linux has crashed.

serola (sami-serola) wrote :

I totally agree with Unggnu that priority of this bug should be higher. I believe that using Ubuntu on laptops is becoming quite popular and also the need for multiuser sessions.

martin21 (martin-snell) wrote :

I can confirm that there is also a problem with an HP Pavilion Laptop, running Feisty.
CTRL-ALT-F7 and back to CTRL-ALT-F9 fixes it (I haven't tried the patch).
The bug seems to have been around for a long time now and would encourage it to be fixed. A lap-top at home is often shared with one's partner/spouse.

Adi Roiban (adiroiban) wrote :

this should be a top priority bug. due to this bug I can not fully use my computer.

darren (darrenm) wrote :

I agree this really has to be a target for Gutsy and needs to be critical.

Almost every single laptop user can not switch user without logging out and then back in. How can that not be critical?

I have discovered new and important information about this bug.

It seems that the bug is triggered whenever a window in the other/old session steals focus. This explains why locking the first session before running switch user is a workaround. In that case the focus has been grabbed before the new session starts so the new session does have mouse control.

I discovered this when my wife told me the computer had crashed - it hadn't crashed, just the mouse wasn't working. When I switched to my VT there was an error dialog box waiting for me to click "Okay".

It is possible to verify this behavior by running "sleep 10 && zenity --error" in one session and switching to another session. Using a longer sleep time may be easier for you.

Please verify this conclusion if you can. We should revise the description if it's correct.

wvengen (wvengen) wrote :

1. Logging into main desktop session
2. Switching user
   Result: Touchpad doesn't work
3. Going back to main session with Ctrl-Alt-F7
4. Running "sleep 20 && zenity --error"
5. Switching to 2nd session with Ctrl-Alt-F9
   Result: Touchpad works
6. Wait >20s
   Result: Touchpad works

Did you mean something else?
Note that my external USB mouse does work all the time.

@wvengen

Thanks for trying it. As far as I can tell you did this basically the way I did it. Did you see the error dialog when you went back to VT7 again?

It's curious that you didn't see the same behavior as me as I was able to reproduce it on two machines, one running feisty and one running gutsy (both w/ synaptics touchpads). We may be looking at two different, though similar, bugs if you can't get it to behave the same way but you do have the original bug.

@everyone

Can we get someone else to prove I'm wrong? If so then we really do have two different bugs and I'll open another report.

Thanks!

Saivann Carignan (oxmosys) wrote :

Here's the result of my test on gutsy tribe 6 :

1. Logging to user 1
2. Switching to user 2
    Result: Touchpad doesn't work
3. Going back to user 1 with Ctrl-Alt-F7
4. Running "sleep 20 && zenity --error"
5. Switching to user 2 with Ctrl-Alt-F9
    Result: Touchpad works!
6. Wait >20s
    Result: Touchpad works!

7. Switching back to user 1
    Result: Touchpad works and I have a error message.

Removing the step 4 ( sleep 20 && zenity --error ) doesn't change anything about the touchpad. But thanks a lot Andrew for that clue!!!

Seems that touchpad doesn't work when switching from user 1 to user 2, but will start working again on all users session after switching from user 2 to user 1 using CTRL + ALT + F7. Interesting!

serola (sami-serola) wrote :

What I have noticed is that X seem to stop reading xorg.conf properly when switching users. In Ubuntu, if I try to start graphical interface System>Settings>Touchpad, there's an error displayed: "GSynaptics couldn't initialize.You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics." This is strange since SHMConfig is set true in xorg.conf.

Then just one (stupid?) question: Who will decide the importance of bugs in here?

serola (sami-serola) wrote :

I'm still a newbie but I would like to learn how things work. I was reading this: http://www.x.org/archive/X11R6.8.0/doc/xorg.conf.5.html
and I started to wonder if there are some other copies of xorg.conf -file where I should define 'SHMConfig' 'true'?

The thing is that I had to define 'SHMConfig' 'true' manually when I installed Ubuntu Feisty on my laptop. I did it only in here: /etc/X11/xorg.conf

No, that's the only file affected.
Please check /var/log/Xorg.log.0 which shows messages for your latest X
session if you have problems with shared memory.
I have a Dell laptop and was having problems even though I had SHMConfig set
to true. The problem was that the synaptics driver failed to load, which I
saw in that log file. Some other module was loaded instead which didn't have
that functionality.

On 9/14/07, serola <email address hidden> wrote:
>
> I'm still a newbie but I would like to learn how things work. I was
> reading this: http://www.x.org/archive/X11R6.8.0/doc/xorg.conf.5.html
> and I started to wonder if there are some other copies of xorg.conf -file
> where I should define 'SHMConfig' 'true'?
>
> The thing is that I had to define 'SHMConfig' 'true' manually when I
> installed Ubuntu Feisty on my laptop. I did it only in here:
> /etc/X11/xorg.conf
>
> --
> Synaptics touchpad not enabled for second X display
> https://bugs.launchpad.net/bugs/68370
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Neil Wilson (neil-aldur) wrote :

That is because you are serialising the displays. The reason the mouse
doesn't work is because of parallel contention between the display.
Your workaround stops the contention from happening.

All of it points to a fault in the driver.

On 9/13/07, Andrew Jorgensen <email address hidden> wrote:
> I have discovered new and important information about this bug.

Neil Wilson (neil-aldur) wrote :

Given the level of comments, perhaps the importance of this bug should be re-appraised.

Setting back to confirmed - please reappraise.

Changed in xserver-xorg-input-synaptics:
status: Triaged → Confirmed

Agreed - I can confirm this problem on my Acer laptop. This bug makes multi-user features unusable.

jorno (jorn-odberg) wrote :

I Agree the importance for this bug should be raised, since it's a default feature of Ubuntu these days, and we're all used to do this in Windows also. Therefor, since this affects everyone using Synaptics Touchpad - which AFAIK almost every laptop does, this should be a pretty important feature to fix!

Please raise the importace level for this bug.

Timo Jyrinki (timo-jyrinki) wrote :

I have filed a new bug 144193. I have consistently the problem that the touchpad works on the second X display otherwise, but buttons do not work. If using an external mouse, its buttons still work. Also if I manually switch back to the first session, unlock the screen and switch back, the buttons work for both users.

Toby Bartels (tobybartels) wrote :

I'm writing to make three points:

1) Yes, if whoever sets the Importance rating wants Ubuntu on laptops to spread among the non-geek populace, this really need to be fixed! I am no dummy, but I don't know enough to figure this out on my own, and it took me a couple of months to learn about this as a good place for help.

2) I have a weird behaviour that hasn't been mentioned above: So long as two users are running (even after fixing it by Ctrl-Alt-F7 and Ctrl-Alt-F9), using the trackball will also simultaneously move the mouse up and down. (So you have to move it back up after you've scrolled down a screen, or you'll fall out of the correct frame.) But this only happened once, and I can't reproduce it.

3) I can confirm the behaviour reported by Andrew Jorgensen above (but which wvengen and Saïvann Carignan could not confirm). But it only works that way THE FIRST TIME!

(The rest of this post is details about #3.)

Following Saïvann's steps above (but with more detail and more steps):

1. Logging in to user 1
2. Switching to user 2
    Result: Touchpad doesn't work
3. Going back to user 1 with Ctrl-Alt-F7
4. Unlocking the screen and running "sleep 20 && zenity --error"
5. Switching to user 2 with Ctrl-Alt-F9
    Result: Touchpad works!
6. Wait >20s
    Result: Touchpad FAILS! (<-- different than Saïvann reported)
7. Switching back to user 1 with Ctrl-Alt-F7
    Result: Touchpad works and I have a error message.
8. Running "sleep 20 && zenity --error" again
9. Switching to user 2 with Ctrl-Alt-F9
    Result: Touchpad works!
A. Wait >20s
    Result: Touchpad works! (<-- same as Saïvann reported, but 4 steps later)
B. Switching back to user 1 with Ctrl-Alt-F7
    Result: Touchpad works and I have a error message.

Compare that when I do nothing to steal focus:

1. Logging in to user 1
2. Switching to user 2
    Result: Touchpad doesn't work
3. Going back to user 1 with Ctrl-Alt-F7
4. *** step deleted ***
5. Switching to user 2 with Ctrl-Alt-F9
    Result: Touchpad works!
6. Wait >20s
    Result: Touchpad works!
7. Switching back to user 1 with Ctrl-Alt-F7
    Result: Touchpad works and I have a error message.
8. Running "sleep 20 && zenity --error" (for the first and only time)
9. Switching to user 2 with Ctrl-Alt-F9
    Result: Touchpad works!
A. Wait >20s
    Result: Touchpad works!
B. Switching back to user 1 with Ctrl-Alt-F7
    Result: Touchpad works and I have a error message.

I can also break user 1's Touchpad by having user 2 steal focus. In fact, if I get the timing right, I can even make the act of logging in to user 2 (and quickly switching back) cause user 1 to lose the mouse before I even get a chance to unlock the screen!

Toby Bartels (tobybartels) wrote :

Corrected version to #2 from my previous post:

2) I have a weird behaviour that hasn't been mentioned above: So long as two users are running (even after fixing it by Ctrl-Alt-F7 and Ctrl-Alt-F9), using the trackball will also simultaneously move the mouse up and down. (So you have to move it back up after you've scrolled down a screen, or you'll fall out of the correct frame.) Once the other user logs out, however, then the offending user's mouse is back to normal. (Also, the mouse seems to move too fast while this is happening; others have mentioned this as an occasional behaviour.) This has only happened to me a couple of times, and I can't reproduce it consistently.

Runar Ingebrigtsen (ringe) wrote :

I can't use the mouse on the VT8 after having switched user either.
Running updated Gutsy Tribe 5.

John Vivirito (gnomefreak) wrote :

Im bumping the importance up to medium due to the applet being enabled by default and alot of users with synaptics touchpads, I had a few people today tell me today it should be higher so i read it and after a while decided to raise it for reasons above.

Changed in xserver-xorg-input-synaptics:
importance: Low → Medium
Saivann Carignan (oxmosys) wrote :

Thanks for this!

I don't know if it should be high or medium, because this bug will happens on 100% of laptop computers ( which may represent 50% of all computers ) and will inevitably lead people to think that their computer crashed. I my point of view, that's high!

At least if we keep medium priority, I think that this bug would need to be taken very seriously for the points I mentioned above.

Should be high! Just look at the subscribers list! ;-)
IMHO, it should be in the milestone bugs for rc. This bug is avoiding for 50% of the computers one of the important new features of Gutsy.

On Sat, 2007-10-06 at 08:32 +0000, Milan wrote:
> Should be high! Just look at the subscribers list! ;-)
> IMHO, it should be in the milestone bugs for rc. This bug is avoiding for 50% of the computers one of the important new features of Gutsy.
>

I vote for release critical high priority!

Markus Kienast (elias1884) wrote :

On Sat, 2007-10-06 at 08:32 +0000, Milan wrote:
> Should be high! Just look at the subscribers list! ;-)
> IMHO, it should be in the milestone bugs for rc. This bug is avoiding for 50% of the computers one of the important new features of Gutsy.
>

I personally believe there should be a new scheme to categorize bugs.
This one should be categorized as "embarrassing".

I am not joking, I really believe categories like that would be very
healthy. It would be more easy to identify these kind of bugs if one or
a group of developers where dedicated to get Ubuntu more polished. And I
believe there should be a group of Cannonical devs payed for polishing
the OS.

The easiest way to achieve this would possibly be a community driven
tagging system.

I will file this as a whishlist item in bugs.launchpad.net.

I second "embarrassing".

Markus Kienast (elias1884) wrote :

On Sat, 2007-10-06 at 08:32 +0000, Milan wrote:
> Should be high! Just look at the subscribers list! ;-)
> IMHO, it should be in the milestone bugs for rc. This bug is avoiding for 50% of the computers one of the important new features of Gutsy.
>

I have filed the proposed feature under bug #149775. If any of you think
this would be a great feature for devs and bug reporters, please add
your comment to bug #149775.

I personally believe that it would be easy finding enough people to form
an "OS polishing" team, which would be dedicated to fix that sort of
bugs. All they would need is this feature to know, where they need to
lay their hands on.

Elias

Markus Kienast (elias1884) wrote :

On Sat, 2007-10-06 at 10:14 +0000, Brian Barnes wrote:
> I second "embarrassing".
>
@Brian

Please also add a comment to bug #149775 if you believe tagging or
voting on bugs could be a helpful feature!

Vincenzo Ciancia (vincenzo-ml) wrote :

All of us can already tag (and untag) bugs, and, the embarrassing tag has just born.

Here you can see all bugs with this tag,

https://bugs.edge.launchpad.net/ubuntu/+bugs?field.tag=embarrassing

now just use it wisely and spread the word :) Followup on bug #149775 for a voting system proposal which is external to launchpad.

mexlinux (mcanedo) wrote :

Same problem here:
Dell Inspiron 630m

mexlinux (mcanedo) wrote :

sorry, forgot to tell I'm on Gutsy Beta

using latest update of gusty and having the same prob, either using ctrl+alt+FX or the new user applet.
Changing users will touchpad not work

Just to bump this one a bit more: This is the only major bug that my wife has to deal with fairly often. She calls me to tell me the computer "crashed again" too often.

Do we have a really good idea about what package the bug is in? We should be looking at openSUSE and Fedora to see if this has been fixed elsewhere already.

Matthew East (mdke) wrote :

Given the number of duplicates and subscribers, I'm raising the importance of this bug.

Changed in xserver-xorg-input-synaptics:
importance: Medium → High
Matthew Garrett (mjg59) wrote :

Something is calling XOpenDevice after the VT has been switched away but before the new X server has grabbed it. The easiest workaround is for the driver to check whether the vt semaphore is currently held, and if not then fail the open request.

Fredrik Wendt (fredrik-wendt) wrote :

Confirming this bug and my seven year old son won't switch user to get into his own account (with web filters etc) next time, but use my login or who ever is on ...
The only workaround I've found is to "switch between instances: CTRL-ALT-F7 and back to CTRL-ALT-F9 to get the mouse loose again"

Matthew Garrett (mjg59) wrote :

0.14.6-0ubuntu10 is queued.

Markus Kienast (elias1884) wrote :

On Wed, 2007-10-10 at 20:20 +0000, Matthew Garrett wrote:
> Something is calling XOpenDevice after the VT has been switched away but
> before the new X server has grabbed it. The easiest workaround is for
> the driver to check whether the vt semaphore is currently held, and if
> not then fail the open request.
>
This bug does only apply to synaptics touchpad pointer devices and not
to USB mice. So I suppose if the synaptics driver can be made to act
exactly the same way on VT switches like a USB mouse, everything should
be fine.

Matt Zimmerman (mdz) wrote :

Marking Fix Committed, Matthew indicates there is an upload queued to fix this

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Fix Committed
darren (darrenm) wrote :

Woo hoo. Launchpad does work ;)

The update is still not released. How did you test it?

darren a écrit :
> Woo hoo. Launchpad does work ;)
>
>

Saïvann Carignan wrote:
> The update is still not released. How did you test it?
>
> darren a écrit :
> > Woo hoo. Launchpad does work ;)

I assumed he meant something more like "community works" or "yay
sometimes bugs get fixed!" We haven't tested the fix yet but our voices
were heard.

I also wanted to thank the ubuntu devs for not only taking the bug
seriously and responding to the community's comments but for fixing it
so fast once a good hard look at the bug was taken (can't wait to test
it!). The gutsy release cycle has been the first one where I really
feel like I have been able to make some small difference and have seen
results. Thanks!

Saivann Carignan (oxmosys) wrote :

Oh yes! Thanks A LOT to everybody who worked on this! Launchpad DOES work =)

I'm really happy to see results for the work we all do too, and of course, special thanks to developers who worked hard on this to make ubuntu better.

Matthew Garrett (mjg59) wrote :

xserver-xorg-input-synaptics (0.14.6-0ubuntu10) gutsy; urgency=low

  * Bodge around LP: #68370. Something is opening the device even after
    we've switched away from the VT. The easiest way to handle this is
    to refuse to open unless we're on the current VT.

 -- Matthew Garrett <email address hidden> Tue, 09 Oct 2007 21:08:23 +0100

Changed in xserver-xorg-input-synaptics:
status: Fix Committed → Fix Released
Saivann Carignan (oxmosys) wrote :

Tested on Dell Inspiron 9300 laptop, The fix works! Thanks for this great work!

Fix works on Dell C600. Thanks!

Andrew Jorgensen wrote:
> Fix works on Dell C600. Thanks!

Actually, it looks like this may introduce a new bug where when changing
back to the first VT the mouse moves but no longer clicks. Am
investigating further.

On Fri, 2007-10-12 at 15:13 -0600, Andrew Jorgensen wrote:
> Actually, it looks like this may introduce a new bug where when changing
> back to the first VT the mouse moves but no longer clicks. Am
> investigating further.

Nope, that bug exists with or without this fix :-/
Good to go on this one then. Thanks again!

unggnu (unggnu) wrote :

Fix works fine for me, thanks.

@Andrew Jorgensen
Maybe your mouse problem has something to do with this Bug #138094.

discord (colin.williams) wrote :

having the same trouble on a dell 6400. will try the fix will we see it included in gutsy??

Timo Jyrinki (timo-jyrinki) wrote :

> Nope, that bug exists with or without this fix :-/
> Good to go on this one then. Thanks again!

I separated the bug 144193 now since that was my original problem that clicking does not work, but mouse (touchpad) moves.

Latest upgrades fixed the problem for me!:) Thanks!

murmelhunter (d-drehlich) wrote :

latest update solved the reported for me to, thank you all for the prompt solution

Marco Monteiro (nok) wrote :

The problem still exists in hardy,
And the mouse pointer is not visible.

Marco: Did this bug was fixed for you in Gutsy?

Adi Roiban (adiroiban) wrote :

for me this problem is fixed in Gutsy ... but the synaptic scroll area are not working on the second display

On Friday 07 December 2007 21:40:08 Milan wrote:
> Marco: Did this bug was fixed for you in Gutsy?

Hi Milan.
Actually its me who is experiencing this. since I was offline, i asked Marco to report it.

This is my scenario:
Using Ubuntu Hardy fully updated on Ctrl+Alt+F7.
On Ctrl+Alt+F9 there was a Kubuntu Gutsy (also fully updated) running on chroot, where I'm creating a Kubuntu Remix.
Both session were using GDM and Gnome.
Changing from one session to the other, would make the mouse pointer invisible.

--
BUGabundo :o)
(``-_-´´) http://Ubuntu.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Changed in xserver-xorg-input-synaptics:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.