Ubuntu

Touchpad sends a middle click instead of left click.

Reported by abePdIta on 2010-09-13
138
This bug affects 25 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

[Sorry. I thought it was a Firefox problem. Probably it is not.]
It happens randomly.
I use the left physical button of the touchpad and it fires a middle-click event.
It doesn't happen on lucid using the same hardware.

EDIT: I investigated further.
This happens with any program.
It does not happen when you tap to click, it occurs only when using the toucpad physical button.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Mon Sep 13 01:51:14 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash

abePdIta (abepdita) wrote :
abePdIta (abepdita) on 2010-09-13
summary: - Firefox opens links in tabs when not required and it closes tabs when
- you select them.
+ Touchpad sends a central click instead of left click.
abePdIta (abepdita) on 2010-09-13
description: updated
affects: firefox (Ubuntu) → ubuntu
abePdIta (abepdita) on 2010-09-16
description: updated
summary: - Touchpad sends a central click instead of left click.
+ Touchpad sends a middle click instead of left click.
Simplexion (simplexion) wrote :

Having the exact same problem in 64bit.

Changed in ubuntu:
status: New → Confirmed
abePdIta (abepdita) wrote :

Well, I don't think this is a duplicate.
Bug #633535 is just the opposite. :)

Simplexion (simplexion) wrote :

I think if you solve one it will solve the other. They definitely seem related to me.

tob (tobynbertram) wrote :

I looked at abePdIta's dmesg and I can confirm that the touchpad is not being improperly detected as a Clickpad. Therefore, this is not a duplicate of Bug #633535.

Luca Marra (luca-marra) wrote :

Same problem here. Happens also on tap click.

James Adney (jfadney) wrote :

I also get middle clicks every once in awhile when I use the left button. Middle clicks also are generated while dragging.

Chris Snyder (csnyder) wrote :

I have been experiencing this as well since upgrading to 10.10. I have an HP Pavilion dv9010us, running 10.10 64-bit.

omar (fung-omar) on 2010-10-26
affects: ubuntu → xserver-xorg-input-synaptics (Ubuntu)
Scognito (scognito) wrote :

I have this strange behaviour in 10.10 32-bit.
10.04 didn't have this bug.
I'm using HP Pavilion dv6000 series (dv6299ea special edition).
If you need some log please ask.

Daniel Southern (dansouth) wrote :

I just recently started seeing the same problem. I can also provide any details, not sure what would be most helpful, just ask.

martin (braaart) wrote :

Is this bug related to 582809? I have re-installed 10.04 as 10.10 simply has too many problems (at least for HP Pavilion Laptops) and regressions. 10.04 offers the same functionality without most of the problems.

kruffwuff (mlangmann) wrote :

I had the same problems after fresh Install of 10.10.

I found a solution for the problem in the opensuse forums:
http://forums.opensuse.org/english/get-help-here/hardware/442426-synaptic-touchpad-11-3-strange-behaviour-dragging-middle-click-2.html

I solved the problem temporarily by typing in terminal:

sudo synclient ClickFinger3=1

and for persistence over reboot added

 Option "ClickFinger3" "1"

to the InputClass in

 /usr/share/X11/xorg.conf.d/50-synaptics.conf

Does this help you? Its the first time I write here.

omar (fung-omar) wrote :

ClickFinger3=1 seem to be working for me.

Kipmaster (kipmaster-gmail) wrote :

ClickFinger3=1 seems to work for me as well, thank you kruffwuff!

PS: I also have a HP laptop.

Carlo Bonato (bee-carlo) wrote :

seems to work for me...
thank you kruffwuf!!
hp tablet tx-1000

samcompton (samcompton) wrote :

Thanks kruffwuff. Worked for my HP Pavilion dv6000.

Chris Snyder (csnyder) wrote :

Also seems to have fixed the issue on my HP Pavilion dv9010us. Thanks!

chopstickkk (saintidle) wrote :

Hmmm.

My /usr/share/X11/xorg.conf.d/50-synaptics.conf now looks like this...

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
 Option "ClickFinger3" "1"
EndSection

...but upon reboot I did get a tab closing upon single left click still.

Is it absolutely necessary to perform the "sudo synclient ClickFinger3=1" action?

Cheers,
John.

kruffwuff (mlangmann) wrote :

I used the "sudo synclient ClickFinger3=1" action just for testing and you do not need the sudo. (Can i edit my previous post?)

my 50-synaptics.conf is the same. Unfortunately I don't know more.
maybe this https://wiki.ubuntu.com/DebuggingTouchpadDetection can help you to find "your" bug.

Jeremy Lucier (jrlucier) wrote :

Kruffwuff's suggestion fixed the issue on my Asus U3S.

chopstickkk (saintidle) wrote :

RE: Post #18

I've run a 'synclient ClickFinger3=1' command as well as editing the .conf.

I'm not exactly savvy enough to check if the bug is fixed but I've not had any of the middle click madness since so it seems to me you need both the command and the .conf edit.

tags: added: regression-release

Same issue since Ubuntu 10.10 on a Samsung X20 notebook, with a "classical" standard 2-button synaptics touchpad.
This touchpad worked fine on all previous versions of ubuntu - so I tagged the bug as regression.

The "left click sends a middle click"-issue appears in roughly 10% of the cases and resulted in a terrible usability:
- Imaging using Firefox and a left click on a tab closes the tab in 10% of the cases.
- Or clicking on a link opens a new tab - after 30 minutes of surfing you will end up with 20 tabs opened.
- Same thing in nautilus - tabs randomly opened all over the place.

The workaround suggested by Kruffwuff seem to work for me.

Should this problem reported upstream? Or this this a downstream (Ubuntu+Suse) bug?

In investigated a bit further:

In Ubuntu 10.04 (Lucid) the command
synclient -l
shows the option:
ClickFinger3 = 1

In Ubuntu 10.10 (default) the command
synclient -l
shows the option:
ClickFinger3 = 2

So Ubuntu 10.10 seems to suffer from exactly the same behaviour as Suse (for more information follow the link above).

man synaptics reveals the meaning of the ClickFinger3 option:
"Option "ClickFinger3" "integer"
    Which mouse button is reported when left-clicking with three fingers. Set to 0 to disable. Property: "Synaptics Click Action" "

From this, I conclude that by default, in Ubuntu 10.10, a left-clicking (?) with tree fingers is interpreted as a middle click.

Now - I had this issue when clicking with one finger, and I click the left (pysical) button.

Changing this option should not affect me at all, however if I set the option back to the original value (ClickFinger3 = 1) as suggested by Kruffwuff, then my problems are gone.

vlad (devvlad) wrote :

I have opposite problem: middle button send left click.
On 10.04 was all fine.
HP Compaq 8710p

I try to change behavoir via synclient, but without success:
    ClickFinger1 = 1
    ClickFinger2 = 2
    ClickFinger3 = 3

synclient does not change anything: 1,2 buttons always - left click, 3 - always right click

vlad (devvlad) wrote :

evtest reports about Left button on both left and middle!
please help

@vlad:
If you do not have a ClickPad than disabling ClickFinger completely may help. i.e. ClickFinger1=0 and so on.
It may be worth trying different combinations.

Dagem Tekolla (dagemtekolla) wrote :

have the exact same problem on ubuntu 10.10 but it works fine on ubuntu 10.04.

Gregory Gleason (gsgleason) wrote :

Same issue here for a while. I've been losing my mind. I hope this does it!

aardvark (monguin61) wrote :

I have this same problem, but it occurs very sporadically, so it is very difficult to troubleshoot. I have to try one solution, and then just hope that I remember to pay attention while using the machine for the next few days. Does anybody know of a way to reproduce the bug quickly? I thought about using xdotool to generate many mouseclicks in quick succession, but I figure that tool will probably just send the correct button ID, without interacting with the touchpad driver at all. I have no other ideas.

samotham (samotham) wrote :

ClickFinger3=1 seems to work for me as well, on a Dell Inspiron 1520 laptop

martin (braaart) wrote :

I have no idea whether this is still a bug. I would probably delete it / forget about it.

Simplexion (simplexion) wrote :

This no longer appears to be an issue.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers