Ubuntu

Mouse cursor jumps when two fingers are used

Reported by madmed on 2010-05-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
XOrg-Driver-Synaptics
Unknown
Unknown
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-synaptics

If the user touches the touchpad in two locations, then raises the first finger that touched the pad, the mouse jumps to the location of the second finger as if a full move occurred. This happens on Synaptics touchpads.

To reproduce:
Touch the pad in the upper right and hold
Touch with another finger lower left and hold
Release the finger in the upper right
Mouse jumps to lower left edge of the screen, sometimes selecting text along the way
Sometimes also if the user contacts the touchpad with more than one finger at a time, the cursor "go crazy" and bounce around the screen in an uncontrolled way.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-input-synaptics 1.2.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
CurrentDmesg:
 [ 18.019067] ppdev: user-space parallel port driver
 [ 122.359986] CE: hpet increasing min_delta_ns to 15000 nsec
Date: Mon May 17 11:28:41 2010
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100326)
MachineType: Hewlett-Packard Compaq 610
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=4ca6806f-0fd9-410d-8aba-8072f80edd48 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-input-synaptics
dmi.bios.date: 11/20/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PVU Ver. F.0B
dmi.board.name: 308A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 26.08
dmi.chassis.asset.tag: CNU9431GJQ
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PVUVer.F.0B:bd11/20/2009:svnHewlett-Packard:pnCompaq610:pvrF.0B:rvnHewlett-Packard:rn308A:rvrKBCVersion26.08:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: Compaq 610
dmi.product.version: F.0B
dmi.sys.vendor: Hewlett-Packard
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-22-generic

madmed (medbelh) wrote :
madmed (medbelh) wrote :

I have this bug In three of my laptops: a Compaq 610, MSI wind u160 and Acer 5470G and it's not ubuntu specific.

Gursimran singh (simar) on 2010-06-29
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete
Gursimran singh (simar) wrote :

Hi bug reporter.
First of all Thanks to report the bug and help us to make ubuntu better.

I think your bug is quite confirmed as I and possibly all can reproduce the cursor jump. Although I'm sure that this is infact a bug or not as this probably is in the developers knowledge.Like for example when you enable the circular scroll feature of gsynaptics you have to scroll all through the boundary while the native drivers for synaptics in windows you can make small circles anywhere. So that seems to a limitation rather than a bug. So it could be added in a wishlist rather that filing a bug

Still meanwhile I confirm that it is really a bug you could possibly help developers by including the outputs of following programs

One thing that will help developers to identify the problem is the xev program that capture the input events that the xserver receives.
You can run `xev -geometry 900x100-0+120 > ~/xev.txt`. That will give you a 900 px wide and 100 pixel high window at the right hand side of the screen and events are captured as long as the mouse pointer is inside the window. Close the window with Alt+F4 (in order to not generate more mouse pointer moving events). Take care to not drag the mouse pointer over the window any more than necessary during this, since it will create noise in the log. Upload xev.txt here.
Increase the pixels of the window so the jump is included in the log output and the cursor remains inside the window after the jump. Further try to demonstrate all other issues that you reported in the output.

Second use should also preferably use synclient to get such debugging output files. Use man synclient to use this program. If you are not able to use it report back, I or somebody will help you preferably...

Regards

Bryce Harrington (bryce) on 2010-06-30
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Gursimran singh (simar) wrote :

This is a reminder mail to remind the reportee about the required information that is required to triage the bug and help us to fix it. Please respond or the bug status will be marked as invalid.

madmed (medbelh) wrote :

sorry for being late.

madmed (medbelh) wrote :

Just tell me if there is anything else I can help with.

madmed (medbelh) wrote :
madmed (medbelh) wrote :

I discovered that the "cursor going crazy" thing only happens when I boot into windows and reboot into ubuntu!!!!!!!!!
here the output of the xev command (xev1.txt)?field.comment=I discovered that the "cursor going crazy" thing only happens when I boot into windows and reboot into ubuntu!!!!!!!!!
here the output of the xev command (xev1.txt)

madmed (medbelh) on 2010-07-01
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Confirmed
Gursimran singh (simar) wrote :

madmed Please note that you are the origional reporter of the bug so you yourself cannot change the status of the bug as confirmed.

Gursimran singh (simar) wrote :

It seems the file you uploaded xev.txt the jumpy motion of the cursor is not visible. Did you used your two fingers there and tried to reproduce the bug or not??

Gursimran singh (simar) wrote :

from studying the file xev1.txt the jerky motion of the cursor is evedent.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Incomplete
Gursimran singh (simar) wrote :

Also try to upload your /var/log/Xorg.0.log at times when you could reproduce the bug or not ..

madmed (medbelh) wrote :

Here the output of the xev command with jumpy cursor(normal boot)

madmed (medbelh) wrote :

and here the Xorg.0.log (jumpy cursor)

madmed (medbelh) wrote :

and for the crazy cursor (reboot from windows)

Gursimran singh (simar) wrote :

I not sure that if this is necessary but still consider uploading the output of dmesg as .....

dmesg > dmesg.txt in both jumpy and jerky cursor

Gursimran singh (simar) wrote :

and also this one (not very necessary but still this is not going to cause any harm...)
cat /proc/bus/input/devices > devices.txt

madmed (medbelh) wrote :
madmed (medbelh) wrote :

:jumpy cursor

madmed (medbelh) wrote :

jerky cursor (reboot from windows)

Gursimran singh (simar) wrote :

Your bug is triaged now and is ready to be forwarded upstream...

Thanks for reporting the bug and cooperating in the information that is requested. Our experience with you regarding information collection was awesome. Your bug will now be forwarded upstream and will soon be taken up by a developer.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Confirmed
Gursimran singh (simar) wrote :

madmed This bug report is a duplicate of the bug report 365943 in which you had commented in a back date. This is not a good practise to generate duplicate bug reports. This only makes the process of bug triaging and bug handling more clumsy and delayed. This is in interest of the ubuntu community and its users me and you.

Thanks

Regards :D

madmed (medbelh) wrote :

@Gursimran: the bug #365943 is marked as fixed, I reopened it and Bryce Harrington restored it to fix released and asked me to report a new bug instead of reopening that bug (c.f https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/365943/comments/30). I think this bug report contains more information than the other one and should not be marked as duplicate.
What do you think?

Gursimran singh (simar) wrote :

@madmed

Perhaps in that case people are reproducing the bugs using different means with one finger. Bryce Harrington is refering to that. Since no discussions had taken place on the new issues (new means of reproducing) he's assuming them to be resolved by now.

If not resolved he's advising to report them in a new bug report. However the issues in this bug report are the same in #365943.
Regarding the information contained I think this bug just confirms the motion to be jumpy but the bug #365943 assumes that and focuses on resolving by patches .. However still I will make a comment about this bug in the bug #365943 and advise you to continue your issues there ...

Gursimran singh (simar) wrote :

Still if you still think that the this bug is not duplicate please state with reason..

Refer to https://wiki.ubuntu.com/Bugs/MarkingDuplicate about duplicate bugs..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.