Ubuntu

Two finger scroll not working on all old touchPads (emulation approach).

Reported by Joe Barnett on 2010-04-04
130
This bug affects 21 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-synaptics

The original description of this bug isn't valid now. Although the bug initially was filed for having true multitouch capability but as the majority of subscribers as well as the bug reporter wants to accept and use the emulation workaround, this bug now deals with emulation workaround. This is done just to clean up all the bugs that are filed for multitouch. Now all bugs that deal with two finger scroll on older touchpads(or for any other reason those who want their bug reports should be happy with emulation workaround) should be marked as duplicate of this bug.

If anybody wants to track the status of the bug that deals with true multitouch(hardware based, not using emulation) please subscribe here also bug #308191. All the bug reports that want their bug reports were actually filed for true multitouch should be marked duplicate of that bug.

In any case all bugs related to multitouch should be marked duplicate of either this bug or the later bug(only do if the hardware is synaptics).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-input-synaptics 1.2.2-1ubuntu2 [modified: usr/lib/X11/xorg.conf.d/10-synaptics.conf]
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 3 22:32:45 2010
DkmsStatus: nvidia-current, 195.36.15, 2.6.32-19-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
MachineType: LENOVO 43192PU
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=a1bfc043-8a23-40f2-a7a1-311c657b3df0 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-input-synaptics
dmi.bios.date: 01/20/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6NET46WW (1.09 )
dmi.board.name: 43192PU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6NET46WW(1.09):bd01/20/2010:svnLENOVO:pn43192PU:pvrThinkPadW510:rvnLENOVO:rn43192PU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 43192PU
dmi.product.version: ThinkPad W510
dmi.sys.vendor: LENOVO
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-19-generic

Joe Barnett (thejoe) wrote :
dbosen (daniel-bosen) wrote :

I have the same problem on a thinkpad t400s on karmic and lucid

Abhejit Rajagopal (sirgogo) wrote :

Also on Dell XPS 1640

Vladimir Kulev (me-lightoze) wrote :

Confirm this on ThinkPad R400 with Lucid

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Schmankerl (schmankerl) wrote :

Same situation on T500.
the following defaults have to be changed
$ xinput --set-prop --type=int --format=8 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 0
$ xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 4

dbosen (daniel-bosen) wrote :

The solution in comment 5 worked for me, thanks Schmankerl!

Landon Cheek (lcheek) wrote :

@Schmankerl That worked for me. Thanks. Will this change persist after rebooting?

Schmankerl (schmankerl) wrote :

thats only a temporary solution until reboot. maybe it has to be fixed in xserver-xorg-input-synaptics driver or udev settings.

MichalM (jafa81) wrote :

Same situation on Dell Studio 1557 and #5 helped!

Sal Mazzola (salmaz) wrote :

The change can be made permanent by creating a file /etc/X11/xorg.conf.d/11-synaptics.conf with the following:

Section "InputClass"
        Identifier "touchpad twofinger"
 MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchIsTouchpad "on"
        Driver "synaptics"
 Option "SHMConfig" "true"
 Option "HorizEdgeScroll" "on"
 Option "VertEdgeScroll" "on"
 Option "VertTwoFingerScroll" "on"
 Option "EmulateTwoFingerMinZ" "4"
 Option "HorizTwoFingerScroll" "on"
 Option "CornerCoasting" "on"
 Option "PalmDetect" "on"
 Option "CircularScrolling" "on"
 Option "CircScrollTrigger" "3"
EndSection

I needed to copy the file from /usr/lib/X11/xorg.conf.d/05-evdev.conf into the same directory to prevent the keyboard from not being configured. Not sure why this was necessary.

This was based on discussion in http://ubuntuforums.org/showthread.php?t=1467189.

I think the udev configuration didn't find its way into the new xorg.conf.d based configuration. The gnome setting for two-finger scroll is greyed out, but the two finger scroll works.

Not sure if the SHMConfig does anything since I read elsewhere that it no longer works with Xorg 1.8.

Sal Mazzola (salmaz) wrote :

I should mention the solution above worked on my Acer 1410T, not a Lenovo like the original bug report.

Adam Aviv (aaviv) wrote :

The solution in #5 worked for me on a Lenovo T400s

Adam Aviv (aaviv) wrote :

The solution in #10 did not work on my t400s. I added the xorg input configuration in both /usr/lib/X11/xorg.conf.d and in /etc/X11/xorg.conf.d without effect.

I created a quick bash script using the solution to #5 and have it run on login via the startup applications. That works pretty well.

Simon Hirscher (codethief) wrote :

#5 works for me as well, but there's sometimes some kind of lag resulting in scrolling further although my fingers have already stopped.

Gursimran singh (simar) wrote :

First of all thanks for reporting the bug report and help us to make ubuntu better ... cheers

@dbosen @Schmankerl

Your two finger scroll seemed to work with the workaround but can you see the button 'Two finger Scroll' in your System>Prefrences>Mouse under the Touchpad tab. Is the button active or deactive both before and after the workaround..

This will help us to remove the bug form the next package releases ...

Also upload the following results in separate comments..

Gursimran singh (simar) wrote :

@ Joe You are the origional bug reporter ..

you are requested to include the outputs of following commands ..

1. cat /proc/bus/input/devices >~/devices.txt
2. xinput -list --long >~/xinput.txt
3. cat /var/log/xorg.0.log >~/xorg.0.log

dbosen (daniel-bosen) wrote :

The "Two finger Scroll" button is greyed out before and after applying the workaround.

Schmankerl (schmankerl) wrote :

I confirm #17.
The button is greyed out before and after xinput...

Joe Barnett (thejoe) wrote :

no longer have the thinkpad w510, but seeing the same behavior on an HP Envy 15, with the following requested output :

Joe Barnett (thejoe) wrote :
Joe Barnett (thejoe) wrote :
Gursimran singh (simar) on 2010-07-11
summary: - two finger scroll/multitouch trackpad not working on lenovo thinkpad
- w510
+ two finger scroll/multitouch not working on lenovo thinkpad w510 having
+ SynPS/2 Synaptics TouchPad..
description: updated

Please confirm the change in bug discription ... This is a known bug and is being worked upon by the developers already. In this case you could probably help us in a way if you could upload the files I requested from a laptop having a synaptics touchpad too and whose two finger scroll works ...

John Baptist (jepst79) wrote :

These instructions assume that you are using up-to-date Lucid with a Synaptic touch pad:

1. First make sure that you have a Synaptics touch pad. Execute the command:

xinput list|grep Synaptics

You should see this (or something similar):

⎜ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]

2. Then execute the following command (all on one line) to temporarily enable two-finger scrolling via multitouch emulation:

synclient TapButton2=3 HorizTwoFingerScroll=1 VertTwoFingerScroll=1 EmulateTwoFingerMinZ=29 EmulateTwoFingerMinW=5 JumpyCursorThreshold=200

If the above command produces an error, you don't have a compatible touchpad. If it doesn't produce an error, but two-finger scroll doesn't work either, try adjusting the value of EmulateTwoFingerMinW and EmulateTwoFingerMinZ in the above command and executing it again. A smaller value in EmulateTwoFingerMinW will accept a narrower touch to activate scrolling.

3. To make changes permanent, follow the instructions in the attached file.

Gursimran singh (simar) wrote :

Hi Jeff thanks for the patch you provide,
synclient TapButton2=3 HorizTwoFingerScroll=1 VertTwoFingerScroll=1 EmulateTwoFingerMinZ=29 EmulateTwoFingerMinW=3 JumpyCursorThreshold=200

when I use this and I try to tap right click is invoked even with just one finger or with two fingers. Jeff this is just an emulation and it will work with any touchpad even with the oldest one, provided that should be recognised as a touchpad and synaptics module is loaded. But surely this has a flaw that i is just a emulation and uses that fact that when a person uses two fingers on the touchpad he doesn't use it at the same time these always a time lag between them. This is never perfect too. Inspite this trick cannot be used to emulate pinch zoom etc ...

Gursimran singh (simar) wrote :

These patches are good if it provide a relief to the bug reporter and the affects people but are not the correct FIX. When this touchpad can support multitouch emulation should not be recomended. The bug is in the kernel instead which recognises that the touchpad doesn't support multitouch instead. Still I will talk to developers that where the bug should be categorised instead ...

John Baptist (jepst79) wrote :

Gursimran:

1. If scroll is invoked with one finger, increase the value of EmulateTwoFingerMinW. Yours is 3, which is very small. A value of 5 works well for me, but your number may vary, depending on your touchpad and your fingers.

2. It's not a fix, it's a workaround. A fix would involve a patch to gnome-mouse-properties.

3. This bug is not about multitouch, but about two-finger scroll. Since my workaround allows two-finger scroll, I think it's a valid workaround. There is another bug for multitouch. If a person wants two-finger scroll, what difference does it make if he gets it through multitouch emulation or through real multitouch? I don't understand your complaint.

4. Pinch/zoom via multitouch are features that depend on application support as well, and to the best of my knowledge no applications support for Ubuntu support these gestures, so this is more than a driver issue.

Gursimran singh (simar) wrote :

Jeff this bug is not only about two finger scroll and also asks about other features of multitouch.. So I think atleast we should mark atleast this bug as duplicate of https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/308191 .....

Whats your opinion ??

John Baptist (jepst79) wrote :

Gursimran: Why? What's the point? Even if real multitouch were supported in the driver, the only thing you could do with it is two-finger scroll? Your attitude is baffling.

Sense Egbert Hofstede (sense) wrote :

Jeff: Although your suggestions could indeed provide a reasonably working workaround for some users, it is not the preferred way for fixing this problem.

Although it can indeed by useful for the reporter to work around the problem with the configuration files, we shouldn't consider providing only one feature of multi-touch support via emulation using this configuration. There are two reasons for this:
1) We would have to recognise multi-touch somehow anyway, otherwise we can't enable emulation when it is expected.
2) Using software emulation of a feature that should be supported by the (kernel) driver is not how we want things to work in Ubuntu. This issue should be solved properly, and that means it is indeed a duplicate of bug #308191.

John Baptist (jepst79) wrote :

Sense:

I agree that a more thorough solution is better, and it's not for me to say how Ubuntu should allocate human resources. But for users, like me, who just want to be able to scroll with two fingers, there is a solution today that works, whereas a comprehensive multitouch solution, touching on kernel, drivers, desktop environment, and applications, is months or years away.

Gursimran singh (simar) wrote :

Jeff: Bug reports are not just like forums where users diagnose just their own machines on expert advice but much more. These are used by bug fixers to fully eliminate the problem in future versions of Ubuntu. I truly agree to your point, you have provided your workaround and that could be a big relief to people here but it should be marked as a duplicate for two reasons :

1. Workarounds are not solutions, only temporary relief to user who want to use multitouch on their laptops. But to make Ubuntu better the bug has to be dealt by expert bug fixers. Such duplicate bugs helps them to look at various different hardware configuration where the problem exist.

2. As we group all the possible bug reports together, the bug reporters will themselves look at similar other bug reports and may find a useful solution themselves. This happens many times. This way your solution may also help may others and not just here.

Gursimran singh (simar) wrote :

We should not mark this bug as duplicate, only if the solution of this bug is in a different way. So separate developer will take on this which is not desirable.

 Further Jeff, we wish to provide user all the features that their hardware provide in a best possible way. So if someone is not able to control screen brightness, and files a bug, changing colors from the Nvidia panel may be a temporary relief(which may provide the same effect) but still not solution as this alternative solution consumes more battery power. When hardware vendors introduce features in hardware that has a emulation possible through software, we should trust them, that they did it for the good and surely for the better possible outcome.

John Baptist (jepst79) wrote :

Everyone wants Ubuntu to be as good as it can be. Idealistic notions aside, the fact is that there is a limited amount of manpower to attend to these bugs. So, in the interest of expediting a fix that will be adequate to the largest number of users, I'll compare these bugs:

bug 554980 can be fixed with a simple patch to gnome-mouse-properties. In fact, it was working in Jaunty, and this represents a regression. Multitouch emulation is in the system, it works, and it simply needs a GUI to activate it. This could even be done in lucid-updates.

bug 308191 touches a lot of packages and much of the required code isn't deployed. There is no way this can be done in Lucid and probably not even in Maverick. Even with a far-off, allegedly superior solution that would resolve bug 308191, the user experience would be exactly the same as if we fixed bug 554980. Genuine multitouch and multitouch emulation, at this point, are indistinguishable to an end user. And while "expert bug fixers" are spending time on a more difficult solution, they are neglecting other, far more serious, bugs.

So, we have to choose: if we value a user experience, which enables two-fingered scrolling in the near future, let's fix this bug. If we want to spend years in development creating the ultimate solution, while users get a sub-par operating system, then let's ignore this bug and focus on 308191.

In any case, this is not at all my decision to make. I'm just a user to would like to have a solution that works as soon as possible. If the Ubuntu community decides otherwise, so be it.

That's my last word on the subject.

Gursimran singh (simar) wrote :

Jeff: Everyone who uses Ubuntu is a part of the Ubuntu community and has an equal right to decide things and we aims to provide our users the best possible experience. Regarding the end user experience of the genuine approach and emulation approach, its not true that both are same, otherwise why would have the hardware approach created .

I don't know how can one make a patch(a deb file) which can set variable properties synclient TapButton2=3 HorizTwoFingerScroll=1 VertTwoFingerScroll=1 EmulateTwoFingerMinZ=29 EmulateTwoFingerMinW=5 JumpyCursorThreshold=200 which are different for different touchpads. Jeff another point is that emulation work good for some touchpads while very bad for others.

It is a good idea to make a relief patch until the bug #308191 is resolved but that is not possible as fas my knowledge is concerned. If you or someone can make one, we will be really happy to distribute such a patch which will emulate multitouch for users but if it works on some and not on others and the some users have a bad experience with it, that not good idea, you know. Even if a less general patch that could only correct synaptics touchpad is also accepted, that way two or more patches can be released. But in this case I don't even that is possible, we only have to make a thousand patches for this. Normally in such situations where variable properties has to be set users or developers provide workarounds like you did so someone following that can correct it for themselves. If we get a all 'applicable patch' that could be distributed without thought.

However the duplicate status of this bug will still remain even if the patch is released as the true solution is by bug #308191 even if this happens for many years to come.

as original reporter, don't believe this should be a duplicate, as two finger scroll seems solveable outside the scope of full multitouch gesture support.

we can let bug 308191 handle multitouch, and this bug can be closed as fixed when two finger scroll works out of the box (user perspective: don't care if emulated or not)

summary: - two finger scroll/multitouch not working on lenovo thinkpad w510 having
- SynPS/2 Synaptics TouchPad..
+ two finger scroll not working on SynPS/2 Synaptics TouchPad.
Gursimran singh (simar) wrote :

I consider the majority's demand and I think the emulated approach of the synaptics touchpad seems to be good enough. I see if we could patch the workaround of Joe, we are more than happy, not to suffer the user experience by providing a patch, since this is Ubuntu all about. However the final decision lies with the upstream developers.

Gursimran singh (simar) wrote :

*Jeff* not Joe

Gursimran singh (simar) wrote :

@Jeff

Ubuntu is neither controlled by majority, nor by community however by logic. While discussing this bug in the community, we realise at some point that this bug could be treated as a papercut. At the end I think your effort in this regard did worked and I really enjoyed discussing the treatment of this bug with you. Now if patch is possible, we could probably distribute it.

Cheers

summary: - two finger scroll not working on SynPS/2 Synaptics TouchPad.
+ Two finger scroll not working on SynPS/2 Synaptics TouchPad.
Vetal (vetal1950) wrote :

Post № 23 helped me with multitouch on SynPS/2 Synaptics TouchPad.

Joe Barnett (thejoe) wrote :

only problem i have w/ post 23 is that I can no longer click & drag, as the HP envy 15 i'm using has a "clickpad" style touchpad w/ no distinct buttons -- so the drag gets treated as a 2nd finger -> scroll... not sure if there are some config tweaks that could prevent that?

John Baptist (jepst79) wrote :

@Joe: I have it configured so that two-finger tap equals a right-mouse button click. Try removing the TapButton2 option from the synclient command and the config file.

Gursimran singh (simar) wrote :

A Lot of people, nearly all using a synaptics touchpad face this bug

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
importance: Low → Medium
MichalM (jafa81) wrote :

This bug made it to Ubuntu 10.10 amd64 on DELL Studio 1557.

xserver-xorg-input-synaptics version: 1.2.2-2ubuntu5

workaround (after every startup/wakeup):
xinput --set-prop --type=int --format=8 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 0
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 4

Gursimran singh (simar) on 2010-11-10
summary: - Two finger scroll not working on SynPS/2 Synaptics TouchPad.
+ Two finger scroll not working on all old touchPads (emulation approach).
Gursimran singh (simar) on 2010-11-10
description: updated
Gursimran singh (simar) wrote :

Hi there,

You will happy to know that an experimental version of the 'multitouch protocol' based dkms package is released here in bug #308191 which is providing true multitouch support for people who have touchpads with true multitouch capabilities(like in some latest synaptics touchpad). So if that works for you unsubscribe here and continue there instead..

Dana Goyette (danagoyette) wrote :

Now, why is this other bug, that's talking about getting REAL multitouch on older touchpads, a duplicate of this bug?

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/546697

If we could get real multi-finger, why should we spend any time getting FAKE multi-finger?

Dana Goyette (danagoyette) wrote :

er, we CAN get it... if somebody sniffs out what that Windows driver does to the touchpad.

Simon Hirscher (codethief) wrote :

Interestingly, on my ThinkPad W510 scrolling with two fingers sometimes works, sometimes doesn't since I installed Natty. Previously, it would never work unless I used the workaround.

Soenke (s0enke) wrote :

Thinkpad t410: As of Natty two finger scroll can be enabled via Settings (button has been grayed out before) and works out of the box. Thanks!

Alex Wauck (awauck) wrote :

As of Natty, the Asus EeePC 1201T touchpad has real multitouch support.

Joe Barnett, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/554980/comments/19 regarding you no longer have the originally reported hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers