Dell D600 doesn't see mouse button1 up events

Bug #463067 reported by Glen Ditchfield on 2009-10-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xserver Xorg Input Synaptics
Invalid
Medium
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubiquity

Installing from a USB stick made by usb-creator on a Hardy Heron computer from
http://cdimage.ubuntu.com/kubuntu/daily-live/20091028.5/karmic-desktop-i386.iso

Installing on a Dell Latitude D600, with a trackpad. The installer sometimes does not detect button1-up events on GUI buttons right away. When I press and release button1, the GUI button stays in its depressed visual state until I touch the trackpad again. If keep a finger on the trackpad and press and release button1, the GUI stay depressed until I move the cursor. (I do not have to move the cursor off the GUI button -- a tiny movement within the borders of the button is enough.)

This happened frequently on the first few installer screens, but buttons behaved normally on later screens.

In retrospect, this happened on earlier ISO releases as well. I thought I was imagining things...
---
Architecture: i386
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
InstallationMedia: Xubuntu 10.04.2 "Lucid Lynx" - Release i386 (20110214.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Computer Corporation Latitude D600
Package: xserver-xorg-input-synaptics 1.2.2-1ubuntu4
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   product info: "O2Micro", "SmartCardBus Reader", "V1.0", ""
   manfid: 0xffff, 0x0001
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   5.0V 16-bit PC Card
   Subdevice 0 (function 0) [unbound]
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-33-generic root=UUID=e9508565-b0af-433d-a134-b6ca54df8034 ro quiet splash
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18
Tags: lucid lucid
Uname: Linux 2.6.32-33-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/29/2005
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A16
dmi.board.name: 0G5152
dmi.board.vendor: Dell Computer Corporation
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA16:bd06/29/2005:svnDellComputerCorporation:pnLatitudeD600:pvr:rvnDellComputerCorporation:rn0G5152:rvr:cvnDellComputerCorporation:ct8:cvr:
dmi.product.name: Latitude D600
dmi.sys.vendor: Dell Computer Corporation
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-33-generic

Martin Pitt (pitti) on 2009-10-29
affects: ubiquity (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Glen Ditchfield (gjditchfield) wrote :

I see this bug on the installed system, not just the installer.

I have filed a bug with X.org at https://bugs.freedesktop.org/show_bug.cgi?id=25020

Glen Ditchfield (gjditchfield) wrote :

The upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=25020 has been updated to say that the bug was fixed in evdev 2.3.0.

Any chance of a backport?

affects: xserver-xorg-input-synaptics (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
tags: added: iso-testing
Bryce Harrington (bryce) on 2010-02-25
tags: added: kubuntu
Fabio Marconi (fabiomarconi) wrote :

Hello
Is this problem present with the latest updated Karmic's or Lucid's packages?
Thanks in advance
Fabio

Glen Ditchfield (gjditchfield) wrote :

The kubuntu-9.10-desktop-i386.iso at http://releases.ubuntu.com/kubuntu/9.10/ is dated 2009-10-28, so I suppose it is much the same as the daily build in my initial report and will have the same problem. Is there a more recent ISO?

The D600 is currently running Lucid, completely updated as of right now with linux-image-2.6.32-24-generic installed, and the problem is still present.

tags: added: karmic lucid
Fabio Marconi (fabiomarconi) wrote :

If still present in Lucid there's no need to test in karmic
Fabio

affects: xserver-xorg-input-evdev (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Gursimran singh (simar) wrote :

Hi Glen

I see that the bug was not only during installation but after it also. As the bug is in the fixing mode already, please take your time to report whether the bug has been fixed or not in maverick

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Glen Ditchfield (gjditchfield) wrote :

Button-1 works correctly when I boot the D600 from a USB key made from kubuntu-10.10-desktop-i386.iso, when running a "live" session and during an installation up to the manual partitioning step. (I aborted the installation at that point.)

Gursimran singh (simar) wrote :

Hi again Glen,
Thanks for testing out but why did not you completed the installation to test it completely. Maverick is all new ubuntu ans its recomented for all lucid users to upgrade to maverick to have access to better support and better bug free enviroment.

Glen Ditchfield (gjditchfield) wrote :

I am sticking with Lucid because it is a Long Term Support release.

Are you really advising your Enterprise customers that Maverick is better supported and that they should move up?

Glen, LTS means that you can stick to it for longer time without changing
it, as we will continue to support it for more time. This is because some
enterprise users could not afford to change the setup. However it does not
mean that lucid is better. Ofcourse maverick is better supported. So the
conclusion is that if you could really afford to change(everytime), there is
no reason that you should not. If you want very less changes then we would
recommend that you should upgrade only LTS, next is Natty.

On Sat, Nov 13, 2010 at 4:42 AM, Glen Ditchfield <email address hidden>wrote:

> I am sticking with Lucid because it is a Long Term Support release.
>
> Are you really advising your Enterprise customers that Maverick is
> better supported and that they should move up?
>
> --
> installer doesn't see mouse button1 up events
> https://bugs.launchpad.net/bugs/463067
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-input-synaptics” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: ubiquity
>
> Installing from a USB stick made by usb-creator on a Hardy Heron computer
> from
>
> http://cdimage.ubuntu.com/kubuntu/daily-live/20091028.5/karmic-desktop-i386.iso
>
> Installing on a Dell Latitude D600, with a trackpad. The installer
> sometimes does not detect button1-up events on GUI buttons right away. When
> I press and release button1, the GUI button stays in its depressed visual
> state until I touch the trackpad again. If keep a finger on the trackpad and
> press and release button1, the GUI stay depressed until I move the cursor.
> (I do not have to move the cursor off the GUI button -- a tiny movement
> within the borders of the button is enough.)
>
> This happened frequently on the first few installer screens, but buttons
> behaved normally on later screens.
>
> In retrospect, this happened on earlier ISO releases as well. I thought I
> was imagining things...
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/463067/+subscribe
>

--
Warm Regards,
Gursimran singh Mohar

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → New
Glen Ditchfield (gjditchfield) wrote :
summary: - installer doesn't see mouse button1 up events
+ Dell D600 doesn't see mouse button1 up events
Glen Ditchfield (gjditchfield) wrote :

The bug is not present in Oneiric Beta 2 Kubuntu i386. Button 1 works properly in the installer and the installed system.

Ahmed Shams (ashams) wrote :

This bug report is being closed due to your last comment regarding this being fixed with a release upgrade.
@Glen, Thanks for testing. As it disappeared from Oneiric it might still exist on other order or LTS releases.
@Fabio Marconi: This bug is due to be closed as the original reporter stated it disappeared, if you still afected by this bug please file a new report, to do so, please hit Alt+F2 and type:
ubuntu-bug xserver-xorg-input-synaptics
This will report and document a new bug, from there it can be handled. Please don't be offended by closing this bug if it still affects you, we did so because developers analyze logs from original reporter only(to invistigate 1 case per report) from whom we can not continue get more logs.

Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Invalid
Glen Ditchfield (gjditchfield) wrote :

This bug definitely _does_ still affect other releases, particularly the LTS, which is more suitable for computers of this vintage. Oneiric B2 in particular is unusable for me because of other bugs.

I'm not familiar with your internal work flows, but do you really want me to file new bug reports for Lucid and Maveric, and probably Natty? Won't they just be marked as duplicates of this bug?

Ahmed Shams (ashams) wrote :

Hi Glen,
Thanks for reply, I thought that you've started to use Oneiric, but as you don't let's debug it in your current release, please open your terminal(press: Ctrl+Alt+T) and enter the following commands(preferred one at atime):
apport-collect 463067
xinput test "AlpsPS/2 ALPS DualPoint TouchPad" > ~/xinput-test.log
evtest /dev/input/event7 > ~/evtest.log

the second command will be logging all ButtonPress & ButtonRelease you'll do, so please press and release immediately to check if something delays the ButtonRelease event.

Thanks and sorry for misunderstanding.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Invalid → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :

xev.log contains the output that xev generated when I clicked in its window repeatedly. Note the large time difference between the times of the last ButtonPress and ButtonRelease events. ButtonRelease did not fire until I brushed the touchpad.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → New
bugbot (bugbot) on 2011-09-28
tags: added: xubuntu

On behalf of Glen Ditchfield(Bug Reporter):

Installing on a Dell Latitude D600, with a trackpad. The installer sometimes does not detect button1-up events on GUI buttons right away. When I press and release button1, the GUI button stays in its depressed visual state until I touch the trackpad again. If keep a finger on the trackpad and press and release button1, the GUI stay depressed until I move the cursor. (I do not have to move the cursor off the GUI button -- a tiny movement within the borders of the button is enough.)

This happened frequently on the first few installer screens, but buttons behaved normally on later screens.

In retrospect, this happened on earlier ISO releases as well. I thought I was imagining things...

On behalf of Glen Ditchfield(Original Bug Reporter).

Ahmed Shams (ashams) wrote :

After invistigating the xev log, the bug is confirmed and forwarded upstream.
Thanks Glen :)

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
tags: removed: karmic xubuntu
Changed in xserver-xorg-input-synaptics:
importance: Unknown → Medium
status: Unknown → Confirmed
bugbot (bugbot) on 2011-09-29
tags: added: xubuntu

is this still an issue and if so, can you reproduce it after the install? can you check with evtest if the button event is actually sent by the device or if this is buggy hardware?

http://www.freedesktop.org/wiki/Evtest

The original Launchpad bug report is at https://bugs.launchpad.net/xserver-xorg-input-synaptics/+bug/463067. It contains an evtest run in comment 37, and also xev output in comment showing a long interval between ButtonPress and ButtonRelease events.

The bug was present in installed Lucid and Maverick releases, but went away in Oneiric.

Thanks. Closing as WORKSFORME given that it works now in Oneiric.

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Invalid

Glen Ditchfield, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/463067/comments/44 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.