[regression] rapid pointer movements with touchpad ignored

Bug #405943 reported by max on 2009-07-28
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
High
Alberto Milone
Nominated for Karmic by Marc D.

Bug Description

Binary package hint: gsynaptics

Hi,

After last update something was changed in touchpad response. Now it is not comfortable to use.
When I move finger slow everything ok. But if I moving finger fast mice pointer stay on same place.
Some times I can move finger through all touchpad but mice pointer move just a little. Before last update pointer was more responsive to movement.

ProblemType: Bug
Architecture: amd64
Date: Tue Jul 28 14:07:58 2009
DistroRelease: Ubuntu 9.10
Package: gsynaptics 0.9.16-2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
SourcePackage: gsynaptics
Uname: Linux 2.6.31-4-generic x86_64

max (mikhmv) wrote :
Marc D. (koshy) on 2009-07-29
affects: gsynaptics (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Marc D. (koshy) wrote :

The problem occured with this upgrade:

[UPGRADE] xserver-xorg-input-synaptics 1.1.2-1ubuntu1 -> 1.1.2-1ubuntu2

This is not a problem with X mouse acceleration, as it still occurs after “xset m 1/1 1”

Marc D. (koshy) on 2009-07-29
summary: - decrease responsibility after last update
+ [regression] rapid pointer movements with touchpad ignored
Marc D. (koshy) wrote :

Reason for nomination:

1. Regression: Can be trivially fixed by removing the patch that broke things.

2. Bug is deal breaker for users of affected hardware.

Marc D. (koshy) wrote :
William Grant (wgrant) wrote :

It's probably the over-broad 112_jumpy_cursor_quirks.patch, which I've expressed concerns about before.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Triaged
importance: Undecided → High
Marc D. (koshy) wrote :

Yes, indeed, recompiling without 112_jumpy_cursor_quirks.patch fixes the issue.

Alberto Milone (albertomilone) wrote :

@Marc

Please follow these steps so that I can see what's happening:

1. Enable the "universe" repository and refresh your packages list.

2. Download and install the deb package of "synaptics-report" (which works on hardy, jaunty and karmic) from this PPA: https://launchpad.net/~albertomilone/+archive/ppa

3. Press CTRL-ALT-F1 to go to the 1st terminal (you'll see only the command line) and log in.

4. Type the following command:

sudo synaptics-report

and follow the instructions which the program will give you.

5. Press ALT-F7 to go back to your desktop environment

6. Look for the synaptics_report.log file in the same directory in which you executed the synaptics-report command (usually your home directory) and attach the file.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Triaged → In Progress
Max Bowsher (maxb) wrote :

Confirming these symptoms on Acer Aspire One. I will do a synaptics-report now.

Max Bowsher (maxb) wrote :

Whilst running synaptics-report, there was a shell error message. The line:
        if [ $MAJOR -ge 1 ] && [ $MINOR -ge 4 ]; then
is inadequately quoted. As the line:
    # NOTE: this won't work outside of X
indicates, this part won't work outside of X, in which case $MAJOR and $MINOR will be empty strings. You should defensively quote them. ( [ "$MAJOR" -ge ......)

Also, the logic of the version test is wrong: Should be ( major > 1 || ( major == 1 && minor >= 4 ) ), not ( major >= 1 && minor >= 4 ).

Now, on to the actual attachment....

Max Bowsher (maxb) wrote :

Same deal here on an MSI Wind U100.

Alberto Milone (albertomilone) wrote :

@Max
Yes, that note was written to remind me to remove those lines.

My next patch will detect the name of your laptop/netbook and preserve the default behaviour unless it's dealing with a Dell Mini10v

Sandro Mani (sandromani) wrote :

I suspect this issue could be related with the one I described in bug #414127. Is anyone who is experiencing this issue also experiencing issues like the one I described there?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.1.2-1ubuntu3

---------------
xserver-xorg-input-synaptics (1.1.2-1ubuntu3) karmic; urgency=low

  * debian/patches:
    - 112_jumpy_cursor_quirks.patch: Make sure that the quirk
      affects only the Dell Mini 10v (LP: #405943).
    - 103_enable_cornertapping.patch: Don't trigger middle click
      when tapping on the top right corner button (LP: #386017).

 -- Alberto Milone <email address hidden> Mon, 17 Aug 2009 10:31:14 +0200

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Fix Released

Works for me. Thank you.

nh2 (nh2) wrote :

Works fine for me, too.

@ Alberto Milone:
I don't think disabling the middle click corner tapping completely is the best solution, but let's discuss this in Bug 386017.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers