Acer 6920G touchpad (synaptics) doesn't work anymore after Jaunty update

Bug #366783 reported by gidantribal on 2009-04-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

I have an ACER aspire 6920G and a Synaptic Touchpad. After distribution update (from apt), it stopped working completely. External mouse works properly. It's quite a serious handicap.

____________________________________________
cat /proc/bus/input/devices | grep -B 5 mouse :

H: Handlers=kbd event3
B: EV=3
B: KEY=10000000000000 0

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input4
U: Uniq=
H: Handlers=mouse0 event4
--
I: Bus=0003 Vendor=04d9 Product=0499 Version=0110
N: Name="HID 04d9:0499"
P: Phys=usb-0000:00:1d.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/input/input6
U: Uniq=
H: Handlers=mouse1 event6

gidantribal (aedo999) wrote :
gidantribal (aedo999) wrote :

After purging and reistalling package ' xserver-gsxorg-input-synaptics' it started working unexpectedly (after reboot). At least i think the two thing are strictly linked.

Now

cat /proc/bus/input/devices | grep -B 5 mouse:

H: Handlers=kbd event3
B: EV=3
B: KEY=10000000000000 0

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input4
U: Uniq=
H: Handlers=mouse0 event4
--
I: Bus=0003 Vendor=04d9 Product=0499 Version=0110
N: Name="HID 04d9:0499"
P: Phys=usb-0000:00:1d.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/input/input7
U: Uniq=
H: Handlers=mouse1 event7
--
I: Bus=0011 Vendor=0002 Product=0007 Version=12b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input9
U: Uniq=
H: Handlers=mouse2 event9

ju (clemenzi-santo-gmail) wrote :

I did as you said purging and reinstalling xserver-xorg-input-synaptics, but still no luck.

H: Handlers=kbd event2
B: EV=3
B: KEY=10000000000000 0

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input3
U: Uniq=
H: Handlers=mouse0 event3
--
I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input10
U: Uniq=
H: Handlers=mouse3 event10
--
I: Bus=0003 Vendor=045e Product=009d Version=0111
N: Name="Microsoft Microsoft Wireless Optical Desktop� 2.10"
P: Phys=usb-0000:00:1d.1-1/input1
S: Sysfs=/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/input/input12
U: Uniq=
H: Handlers=kbd mouse1 event6 js0
--
I: Bus=0003 Vendor=046d Product=c00e Version=0110
N: Name="Logitech USB-PS/2 Optical Mouse"
P: Phys=usb-0000:00:1d.2-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/input/input13
U: Uniq=
H: Handlers=mouse2 event7
--
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input14
U: Uniq=
H: Handlers=mouse4 event11

As you can see my touchpad is an Elantech model and has the same bug, but still not working!

affects: ubuntu → xserver-xorg-input-synaptics (Ubuntu)
Marc-André Turcotte (matmat07) wrote :

Try to boot into windows if you still can and enable the touchpad. I've just tried and it worked. I've read something similar for the media touchpad on the side on my laptop. You have to have it enabled to have it work. You can disabled it after and re-enable it. You just need to have it enabled at start.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
ju (clemenzi-santo-gmail) wrote :

No windows on my system :-)

hal2k1 (quiet1) wrote :

This suggestion may (or may not) help.

http://agoranetbook.kayno.net/2009/04/25/oh-my-touchpad-doesnt-work/

"In the file /boot/grub/menu.lst you need to add i8042.nomux to the end of the kernel line:

kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=8fd4r505-1372-4s39-8r3fd3-a4fr56ygdf6063 ro quiet splash i8042.nomux

Now just save and close the file, and reboot the netbook. When it comes back, your touchpad should work."

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Presianbg (presianbg) wrote :

I confirm that the bug still persist in natty :)

Bryce Harrington (bryce) on 2011-04-28
tags: added: natty
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments