Syndaemon -t option not working

Bug #366014 reported by Baptiste Lafontaine on 2009-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
XOrg-Driver-Synaptics
Fix Released
Medium
xserver-xorg-input-synaptics (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xfree86-driver-synaptics

I'm using jaunty, up to date version.

When I start syndaemon with "syndaemon -i 1", syndaemon disable the touchpad for 1 second everytime I type
When I start syndaemon with "syndaemon -i 1 -t", syndaemon doesn't disable the touchpad at all. With the "-t" parameter it is supposed to block only scrolling or taping, but it doesn't work here.

Ask for any extra information necessary.

Is there any way to fix it ?

Thanks

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xserver-xorg-input-synaptics 0.99.3-2ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xfree86-driver-synaptics
Uname: Linux 2.6.28-11-generic i686

Baptiste Lafontaine (magnetik) wrote :
affects: xfree86-driver-synaptics (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)

Binary package hint: xfree86-driver-synaptics

I'm using jaunty, up to date version.

When I start syndaemon with "syndaemon -i 1", syndaemon disable the touchpad for 1 second everytime I type
When I start syndaemon with "syndaemon -i 1 -d", syndaemon doesn't disable the touchpad at all. With the "-t" parameter it is supposed to block only scrolling or taping, but it doesn't work here.

Ask for any extra information necessary.

Is there any way to fix it ?

Thanks

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xserver-xorg-input-synaptics 0.99.3-2ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xfree86-driver-synaptics
Uname: Linux 2.6.28-11-generic i686

I've made a mistake, the second command I've typed is : "syndaemon -i 1 -t" (not -d)

(In reply to comment #0)
> Binary package hint: xfree86-driver-synaptics
>
> I'm using jaunty, up to date version.
>
> When I start syndaemon with "syndaemon -i 1", syndaemon disable the touchpad
> for 1 second everytime I type
> When I start syndaemon with "syndaemon -i 1 -d", syndaemon doesn't disable the
> touchpad at all. With the "-t" parameter it is supposed to block only scrolling
> or taping, but it doesn't work here.
>
> Ask for any extra information necessary.
>
> Is there any way to fix it ?
>
> Thanks
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: xserver-xorg-input-synaptics 0.99.3-2ubuntu4
> ProcEnviron:
> PATH=(custom, user)
> LANG=fr_FR.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3
> (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
> SourcePackage: xfree86-driver-synaptics
> Uname: Linux 2.6.28-11-generic i686
>

Changed in xorg-driver-synaptics:
status: Unknown → Confirmed
Philip Wyett (philwyett) wrote :

What process did you follow to disable the touchpad? If it was a web tutorial, can you provide the link.

description: updated
Baptiste Lafontaine (magnetik) wrote :

I've made a mistake in the description (corrected now), the second command I typed is :
syndaemon -i 1 -t (not -d)

I don't understand your question, syndaemon with the option "-i 1" sould disable the touchpad for 1 sec when I type something. It is working.
But when I add the option "-t", syndaemon should disable only taping or scrolling when typing, but it doesn't disable anything here.
I don't follow any tutorial.. except the man of syndaemon. (??)

Ask for any extra information necessary, or if I'm not clear.

Thanks for the interest

Heh, looks like the -t flag hasn't been hooked up to anything for ages.
Bug confirmed, a patch would be appreciated.

Baptiste Lafontaine (magnetik) wrote :

Confirmed on the official bug tracker

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Changed in xorg-driver-synaptics:
status: Confirmed → In Progress

disregard my last comment, I was just blind.

Bug still confirmed ?

I just tried it here and it seems to work fine with the version in git.
Can you try upgrading to 1.1 and testing with that one? there was a fair bit
of changes between 1.0 and 1.1

Sorry but I don't know how to install this version.

git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-input-synaptics

Then run ./autogen.sh --prefix=/usr, make and make install. This builds and installs the synaptics driver from git. It also installs synclient and syndaemon.

You will need your X sever's devel headers, best to install the xorg-dev package.

Download full text (6.5 KiB)

I have errors during the make part (autogen and make log at the end).
Make version: 3.81
Xorg version : 7.4

Thanks

magnetik@magnetik-laptop:~/bin/xf86-input-synaptics$ ./autogen.sh --prefix=/usr
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --install --copy
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
autoreconf: running: /usr/bin/autoconf
autoreconf: running: /usr/bin/autoheader
autoreconf: running: automake --add-missing --copy --no-force
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC ...

Read more...

looks like the xorg-macros package is missing. just install it and run
again.

can't reproduce and no updates for 3 months. closing as fixed since it works with git.

Changed in xorg-driver-synaptics:
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Changed in xorg-driver-synaptics:
importance: Unknown → Medium
Gursimran singh (simar) on 2010-11-25
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in xorg-driver-synaptics:
importance: Medium → Unknown
Changed in xorg-driver-synaptics:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.