unable to use Apple Wireless Trackpad

Bug #1100586 reported by Brian Murray on 2013-01-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
High
Timo Aaltonen
Quantal
High
Unassigned

Bug Description

[Impact]
not using signal safe logging might make the xserver crashy

[Test Case]
no simple test case

[Regression Potential]
very small, support for signal safe logging has been upstream since June 2012.

--

When I try to use my Apple Wireless Trackpad it works momentarily and then quits. Looking in my /var/log/Xorg.0.log file I found the following:

[ 268.617] (--) synaptics: Apple Wireless Trackpad: touchpad found
(EE) BUG: triggered 'if (inSignalContext)'
(EE) BUG: ../../os/log.c:484 in LogVMessageVerb()
(EE) Warning: attempting to log data in a signal unsafe manner while in signal context.
Please update to check inSignalContext and/or use LogMessageVerbSigSafe() or ErrorFSigSafe().
The offending log format message is:
%s: Read error %s

(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x7f4398324e76]
(EE) 1: /usr/bin/X (LogVMessageVerb+0x195) [0x7f43983301b5]
(EE) 2: /usr/bin/X (xf86MsgVerb+0x82) [0x7f439821c592]
(EE) 3: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f438dc9c000+0xc86d) [0x7f438dca886d]
(EE) 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f438dc9c000+0x6fea) [0x7f438dca2fea]
(EE) 5: /usr/bin/X (0x7f439817c000+0x93837) [0x7f439820f837]
(EE) 6: /usr/bin/X (0x7f439817c000+0xbd018) [0x7f4398239018]
(EE) 7: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f43974a2000+0xfbb0) [0x7f43974b1bb0]
(EE) 8: /lib/x86_64-linux-gnu/libc.so.6 (__select+0x13) [0x7f43961dc273]
(EE) 9: /usr/bin/X (WaitForSomething+0x190) [0x7f4398322290]
(EE) 10: /usr/bin/X (0x7f439817c000+0x55861) [0x7f43981d1861]
(EE) 11: /usr/bin/X (0x7f439817c000+0x4461a) [0x7f43981c061a]
(EE) 12: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0x7f439610dc15]
(EE) 13: /usr/bin/X (0x7f439817c000+0x4495d) [0x7f43981c095d]
(EE)
Apple Wireless Trackpad: Read error No such device

This is repeatable all the time. I tried attaching to the Xorg process using gdb and did not receive any additional information. The device did work in Quantal albeit on another system.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xserver-xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-0.4-generic 3.8.0-rc3
Uname: Linux 3.8.0-0-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Wed Jan 16 18:29:20 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation Device [10de:0fc6] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:2652]
InstallationDate: Installed on 2013-01-16 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130116)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-0-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1106
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z77-V LX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1106:bd07/27/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-VLX:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.9~daily13.01.14-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.41-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.1-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.1-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.1.901-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.18-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu1
xserver.bootTime: Wed Jan 16 17:32:57 2013
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.1.901-0ubuntu1
xserver.video_driver: nouveau

Brian Murray (brian-murray) wrote :
Changed in xorg (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
Timo Aaltonen (tjaalton) wrote :

Oh great, synaptics 1.6.2 doesn't have the change needed to prevent these.. definite SRU material too

Bryce: sorry I'll steal this one from you :)

affects: xorg (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Bryce Harrington (bryce) → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

uploaded to quantal too, precise doesn't need it since sigsafe logging is only available for input ABI 18 (xserver > 1.13)

Changed in xserver-xorg-input-synaptics (Ubuntu Quantal):
importance: Undecided → High
status: New → In Progress
Timo Aaltonen (tjaalton) on 2013-01-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.6.2-1ubuntu6

---------------
xserver-xorg-input-synaptics (1.6.2-1ubuntu6) raring; urgency=low

  * use-sigsafe-logging.patch: Upstream commit from master, use signal
    safe logging with input ABI 18. (LP: #1100586)
 -- Timo Aaltonen <email address hidden> Thu, 17 Jan 2013 10:46:59 +0200

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Fix Released

Hello Brian, or anyone else affected,

Accepted xserver-xorg-input-synaptics into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/1.6.2-1ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-input-synaptics (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for quantal for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Steve Langasek (vorlon) wrote :

This SRU has remained unverified after 280 days in the -proposed queue. I've removed it now from quantal-proposed and am marking this bug 'wontfix'.

Changed in xserver-xorg-input-synaptics (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.