Cursor shakes violently when connected to power source - makes touchpad cursor unusable

Bug #1028617 reported by Brendan Griffin on 2012-07-24
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned

Bug Description

Using Ubuntu 12.04, 64-bit version, installed on Lenovo X220 laptop. Fresh "default" install and settings configuration.

When the laptop is plugged into a power source, the touchpad's onscreen cursor (the white arrow that shows position) shakes excessively when trying to use the touchpad to control the cursor. The shaking is so bad that it essentially makes the touchpad unusable. For example, trying to click the minimize button in a window's upper left corner will routinely result in accidentally clicking the close button because of the cursor's shaking.

The problem is NOT present when Ubuntu is running on battery. But this means I can never have Ubuntu plugged in and charging while I use it, which is very inconvenient at times.

I'm using the power block and cable that came with the X220. But I also tried using a larger power block and cable that came with another Lenovo model - this power block is approved for use with the X220 and is sold on the Lenovo website as an X220 accessory. But this larger power block did not improve the shaking behavior either.

I have no special settings enabled for the touchpad. But changing the settings has no effect on this shaking behavior either. I attached a screenshot of my Touchpad settings [please excuse the HUD's presence - I cannot get the HUD to NOT appear when I press ALT+PrtSc to take a screenshot (I guess this is another bug)].

Brendan Griffin (brenfar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Cathy Koller (cathy-koll) wrote :

This bug also affects GNOME so I reported it to them as well. https://bugzilla.gnome.org/show_bug.cgi?id=680705

Damas (mlabwa) wrote :

Similar behavior on Thinkpad X1 but not as disturbing as on X220

Jakuub (jakuub) wrote :

I don't know, is this is helpfull, but this bug affects me too. But, i have two diferent adapters, one with earthing ( i hope, this is the correct word, one with 3 "cables" go to wall) and one without ( only 2 cables, i buy it for have to adapters, one for home use, one for traveling ).
With one, that is with earthing, this problem don't appear, but with that one without, problem ocurs. One friend of me told me, that there might be problem with touchpad and not earthing adapter.

But, here is another thing. When i plug in adapter which brings problem ( that without earthing ), problem occurs. But, when i connect my USB hub which has own adapter, shaking is smaller, but when i plug in my HDMI monitor, which has cable with earthing, problem totaly disappeared.

So, i hope, i was helpfull somehow... But if I'm right, i don't know, what can software do for removing this problem.

PS.: sorry, if I broke some rules of this bug reporting, but i never do this before and i just wan't to help.

Nirf (quicknir) wrote :

My shake is more moderate than described, and generally mostly occurs when I am staying still. When I actually move around the shaking isn't so bad. It's also very on and off: sometimes it's there, sometimes not. I didn't notice until I read this bug report that unplugging made it go away because it was so inconsistent.

Anselm Zurfluh (zurfluh) wrote :

Hello, yes, must be the charger - same problem with a new charger that I had to buy because I forgot the normal one at home... if I unplug the charger, no shaking... end of story! Thanks

Benoît Legat (blegat) wrote :

I have the exact same problem here.
I have a DELL XPS 14z. I first thought it was an hardware problem and I'm glad to see it isn't.
I didn't think about the charger at first but it is now obviously related. It stops shaking on battery.
Here my `/var/log/Xorg.0.log`.

Benoît Legat (blegat) wrote :

Here the content of my `/proc/bus/input/devices` file

Benoît Legat (blegat) wrote :

And here is the output of `xinput --list`

Benoît Legat (blegat) wrote :

I have reported the bug to the synaptic driver (https://bugs.freedesktop.org/show_bug.cgi?id=64103) and Peter Hutterer replied:
"Not sure how to fix this without some larger rework in the smoothing code.
Play around with the noise cancellation though, maybe you can find a setting that makes it bearable:

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Noise Cancellation" 8 8

8 is the default, increase the numbers (x and y) until you find something useful."

Gumuiyul (gumuiyul) wrote :

There are same problems on Thinkpad x220( 2011 years) 64bit with Ubuntu 13.04 64bit or Mint 13 maya cinnamon.

Gumuiyul (gumuiyul) wrote :

It occurs for me when power adaptor plugged in while I am outside like cafe but works good in my house.

Karel (kaldimar) wrote :

This bug also affects me on Linux Mint 15 Olivia running MATE 1.6.0 as well as previous Mint versions.

I just tried blegat suggestion at #11 quoting Hutterer, and set y-axis noise cancellation to 32 (my pointer shakes uncontrollably in the vertical axis only). So I executed

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Noise Cancellation" 8 32

and the issue virtually disappeared, making my touchpad usable for the first time. I will reboot the system, test it for some time, and if find anything relevant will post back.

I have the same issue. I have a DELL XPS 14z running Ubuntu 13.04 64 bits.

Mary Inteso (tonirazo) wrote :

My Lenovo has the same problem of the arrow shaking. I unplugged the power cord and it stopped shaking. So then I plugged the power cord in again and the arrow starting shaking. I switched power outlets and it still shook. So then for some strange reason I let one corner of the laptop rest on top of the back of my left hand (while the power cord was plugged in) and the shaking stopped. I tried to prop it up with a folded hand towel and then a piece of thick rubber instead of my hand, and the arrow shook. So perhaps the problem has something to do with vibration and electricity, short circuit, bad design in wiring?????

Devendra Kumar Rane (ranedk) wrote :

I have two lenovo laptops and when I used the charger from the T61 into the X220. The mouse start shaking on touching the mouse pad. No idea why this happens, but may be this information helps in diagnosis.

Brendan Griffin, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-synaptics REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
DistUpgraded: Fresh install
DistroCodename: saucy
DistroRelease: Ubuntu 13.10
DistroVariant: ubuntu
InstallationDate: Installed on 2014-01-20 (50 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: LENOVO 4287CTO
MarkForUpload: True
Package: xserver-xorg-input-synaptics 1.7.1-0ubuntu1
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-18-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic 3.11.10.4
Tags: saucy ubuntu
Uname: Linux 3.11.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/05/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET67WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4287CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET67WW(1.37):bd12/05/2012:svnLENOVO:pn4287CTO:pvrThinkPadX220:rvnLENOVO:rn4287CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4287CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Sat Mar 8 09:40:37 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 728
 vendor LGD
xserver.version: 2:1.14.5-1ubuntu2~saucy1

tags: added: apport-collected saucy ubuntu

apport information

Sam (shughes-uk) wrote : BootLog.txt

apport information

apport information

apport information

Sam (shughes-uk) wrote : DpkgLog.txt

apport information

apport information

apport information

apport information

apport information

Sam (shughes-uk) wrote : Lspci.txt

apport information

Sam (shughes-uk) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

Sam (shughes-uk) wrote : UdevDb.txt

apport information

Sam (shughes-uk) wrote : UdevLog.txt

apport information

Sam (shughes-uk) wrote : XorgLog.txt

apport information

apport information

Sam (shughes-uk) wrote : xinput.txt

apport information

apport information

Sam, please do not apport-collect to a report you are not the original reporter of. Despite this, so your hardware and problem may be tracked, please feel free to file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

tags: removed: apport-collected saucy ubuntu
Sam (shughes-uk) wrote :

The original reporter seems to have dissapeared and I have exactly the same laptop and problem!

The problem is related to electrical interference from the power supply (see http://superuser.com/questions/76649/laptop-touchpad-works-incorrectly-when-on-power-supply). As suggested by users here, increasing the noise threshold helps.

In my case, this problem happens because I am using a cheap ebay power supply that was not manufactured by my laptop's maker.

carly (carly2223) wrote :

When i bought a new charger as the oringinal got chewed(stupid dog) i noticed my mouse started to shake but wasn't quite as bad as that, well sometimes it was unusable and quickly figured the charger was causing it as it stopped when taking it out, haven't found a actual permanent solution... but..

 what i found that made it go away is making sure the charger wire and everything as straight as possible, well not having to be straight but the wire not meeting/touching at all itself at all.

Antti Ahti (apaatsio) wrote :

I'm having the same problem on Lenovo Thinkpad Edge E540. I'm using the original Lenovo charger and battery.

xf86-input-synaptics 1.8.3
xorg 1.17.4
kernel 4.4.6
openbox 3.6.1

Antti Ahti (apaatsio) wrote :

I just noticed that the problem exists even when an external display is connected in VGA port and power chord is not connected.

Therefore it cannot be the external power source that is the problem but it's a more generic problem when connected to external devices.

Antti Ahti, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.