Remove obsolete X11 drivers from the archive

Bug #1772588 reported by Timo Aaltonen on 2018-05-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
xf86-input-mtrack (Ubuntu)
Undecided
Timo Aaltonen
xf86-input-xwiimote (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-aiptek (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-elographics (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-keyboard (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-mouse (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-mutouch (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-void (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ast (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-geode (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-mach64 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-neomagic (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-r128 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-savage (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-siliconmotion (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-sisusb (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-tdfx (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-trident (Ubuntu)
Undecided
Unassigned

Bug Description

xserver-xorg-video-all has not depended on these drivers for quite some time now, meaning that installation images didn't have them either nor installed them on the system. Now would be the time to drop them from the archive before next LTS & HWE-18.04 stack and in preparation for xserver 1.20.

Some rationale in detail for future reference:
input:
-aiptek: no upstream release in 7 years
-elographics: no upstream release in 6 years
-evdev: replaced by -libinput (not entirely, see comment #1)
-keyboard: replaced by -libinput
-mtrack: no upstream release in 3 years, should be replaceable by -libinput by now
-mouse: replaced by -libinput
-mutouch: no upstream release in 7 years
-void: xserver can start without an input driver these days
-xwiimote: no upstream release in 5 years
video:
-ast: no upstream release in 3 years, no KMS support
-geode: i386 only, no kernel support since moving to i586 (or i686?)
-mach64: no KMS support
-neomagic: no upstream release in 3 years, no KMS support
-r128: no KMS support
-savage: no KMS support
-siliconmotion: no KMS suppport
-sisusb: no KMS support
-tdfx: no KMS support
-trident: no KMS support

Fedora dropped drivers without KMS (kernel modesetting) support five years ago:
https://lists.fedoraproject.org/pipermail/devel/2013-August/188429.html

one exception to this is -openchrome, which we'll keep since it has some users and might even get KMS support before next LTS.

Timo Aaltonen (tjaalton) on 2018-05-22
Changed in xf86-video-omap (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) on 2018-05-23
summary: - Remove obsolete X11 video drivers from the archive
+ Remove obsolete X11 drivers from the archive
no longer affects: xf86-input-multitouch (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

apparently -evdev has some use still:

11:10 < whot> evdev handles some devices that libinput ignores, mostly the generic button boxes and weird devices

description: updated
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Invalid
Timo Aaltonen (tjaalton) on 2018-05-23
description: updated
Timo Aaltonen (tjaalton) on 2018-05-23
description: updated
Martin-Éric Racine (q-funk) wrote :

> -geode: i386 only, no kernel support since moving to i586 (or i686?)

The Geode LX is an i686 without PAE. It is still supported by the Linux kernel.

However, the Geode KMS driver that someone had started working on was never merged into the kernel tree. This means that xf86-video-geode won't work without the X root wrapper and it cannot be used with GNOME or any other DE that depend upon KSM-enabled drivers. It still works fine with e.g. LXDE however.

Timo Aaltonen (tjaalton) on 2018-05-23
no longer affects: xf86-video-omap (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

please, could this bug get some attention from the archive admins?

Bryan Quigley (bryanquigley) wrote :

Should these removals happen first in Debian? Otherwise we would need to add all these to a blacklist IMU as well.

Steve Langasek (vorlon) wrote :

See Bryan's question. These are syncs from Debian, if they are obsolete, why have they not been removed there first?

Changed in xf86-input-mtrack (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

Yes, the plan was to get rid of these in Debian first, maybe after Buster..

Changed in xf86-input-mtrack (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

all the video drivers could be dropped, since TTBOMK they are not available on any 64bit capable hw except maybe AST which has a kernel KMS driver and doesn't need an obsolete X driver which doesn't support the KMS driver

Changed in xserver-xorg-video-ast (Ubuntu):
status: New → Triaged

There are some computers and configurations I manage which rely on some of these drivers:

evdev: there are some netbooks which have touchscreens that only work with evdev, being detected by libinput but doing nothing. While this is a libinput limitation, removing evdev would limit the netbooks' capabilities: the touchscreen can be greatly beneficial, especially when used with programs which can be centered on this type of interactivity (ArduBlock is one example).

siliconmotion: some years ago, thousands of computers were bought with PCI GPUs that use siliconmotion graphics. While some of these old computers are unusable today, the GPUs aren't and can be installed and used on new computers. These new computers have specifications good enough to allow up to 5 seats for a single computer, greatly reducing costs associated with keeping a laboratory, both by reduced initial investment and reduced power usage.

I am worried: abandoning evdev would make some touchscreens stop working, as libinput does not support those properly. Abandoning siliconmotion would make certain multiseat configurations stop working, making, for example, one laboratories with 8 computers for 22 seats require buying additional 14 computers to replace what is going to stop working.

Bryan Quigley (bryanquigley) wrote :

@leosmuller
evdev was already marked invalid so it's not considered for removal as part of this bug report. See comment #1.

siliconmotion - If they work for you on 18.04 LTS, you can keep running that until 2023. I would be shocked if these are saving you power - and happy to help with an analysis in specifics if you want. Please use the contact this user button on my Launchpad page to discuss further (click my name). We can bring a conclusion back to this bug report if relevant - most of that conversation likely wouldn't be relevant.

Steve Langasek (vorlon) wrote :

Timo, these appear not to have been removed yet in Debian, despite Buster being out. Will you file for removals in Debian, or should we carry these into another Ubuntu LTS?

Timo Aaltonen (tjaalton) wrote :

I was thinking about this bug yesterday, and yes I'll file a bug on Debian to remove these.

Bryan Quigley (bryanquigley) wrote :

@leosmuller - per our discussion your use case for the siliconmotion driver should end in 2024. (1 year too late if removed from 20.04). As we haven't found any other users of though I did offer to try maintaining it in a PPA if needed for 20.04.

In the event it stays for 20.04, there is no reason to not remove it for 20.10.

Timo Aaltonen (tjaalton) wrote :

Bug filed on Debian. It's missing some from our list:

kbd/mouse still needed by hurd/kfreebsd

and xwiimote is not maintained by XSF, and same applies to mtrack which was accidentally included on the list. Both are essentially abandoned by the maintainer too, and I've poked him about these.

Anyway, we can drop these as well.

Download full text (3.7 KiB)

As I have previously commented, the geode driver is NOT obsolete. It
should not be removed at Debian, where i386 is still 686 without PAE.

Please ammend the Debian bug report accordingly.

Martin-Éric

pe 3. huhtik. 2020 klo 10.50 Timo Aaltonen (<email address hidden>) kirjoitti:
>
> ** Bug watch added: Debian Bug tracker #955603
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=955603
>
> ** Also affects: debian via
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=955603
> Importance: Unknown
> Status: Unknown
>
> --
> You received this bug notification because you are subscribed to
> xserver-xorg-video-geode in Ubuntu.
> https://bugs.launchpad.net/bugs/1772588
>
> Title:
> Remove obsolete X11 drivers from the archive
>
> Status in xf86-input-mtrack package in Ubuntu:
> Incomplete
> Status in xf86-input-xwiimote package in Ubuntu:
> New
> Status in xserver-xorg-input-aiptek package in Ubuntu:
> New
> Status in xserver-xorg-input-elographics package in Ubuntu:
> New
> Status in xserver-xorg-input-evdev package in Ubuntu:
> Invalid
> Status in xserver-xorg-input-keyboard package in Ubuntu:
> New
> Status in xserver-xorg-input-mouse package in Ubuntu:
> New
> Status in xserver-xorg-input-mutouch package in Ubuntu:
> New
> Status in xserver-xorg-input-void package in Ubuntu:
> New
> Status in xserver-xorg-video-ast package in Ubuntu:
> Triaged
> Status in xserver-xorg-video-geode package in Ubuntu:
> New
> Status in xserver-xorg-video-mach64 package in Ubuntu:
> New
> Status in xserver-xorg-video-neomagic package in Ubuntu:
> New
> Status in xserver-xorg-video-r128 package in Ubuntu:
> New
> Status in xserver-xorg-video-savage package in Ubuntu:
> New
> Status in xserver-xorg-video-siliconmotion package in Ubuntu:
> New
> Status in xserver-xorg-video-sisusb package in Ubuntu:
> New
> Status in xserver-xorg-video-tdfx package in Ubuntu:
> New
> Status in xserver-xorg-video-trident package in Ubuntu:
> New
> Status in Debian:
> Unknown
>
> Bug description:
> xserver-xorg-video-all has not depended on these drivers for quite
> some time now, meaning that installation images didn't have them
> either nor installed them on the system. Now would be the time to drop
> them from the archive before next LTS & HWE-18.04 stack and in
> preparation for xserver 1.20.
>
> Some rationale in detail for future reference:
> input:
> -aiptek: no upstream release in 7 years
> -elographics: no upstream release in 6 years
> -evdev: replaced by -libinput (not entirely, see comment #1)
> -keyboard: replaced by -libinput
> -mtrack: no upstream release in 3 years, should be replaceable by -libinput by now
> -mouse: replaced by -libinput
> -mutouch: no upstream release in 7 years
> -void: xserver can start without an input driver these days
> -xwiimote: no upstream release in 5 years
> video:
> -ast: no upstream release in 3 years, no KMS support
> -geode: i386 only, no kernel support since moving to i586 (or i686?)
> -mach64: no KMS support
> -neomagic: no upstream release in 3 years, no KMS support
> -r128: no KMS support
> -savage: no KMS support
> -siliconmoti...

Read more...

Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Released
Timo Aaltonen (tjaalton) wrote :

Debian dropped what was on their list.

Changed in xf86-input-mtrack (Ubuntu):
status: Incomplete → Confirmed
Martin-Éric Racine (q-funk) wrote :

Good. Just to emphasize, Geode doesn't make sense on distros where the base level for i386 is 686-PAE, since none of the Geodes have PAE (most Geodes are i586, except for Geode LX which is 686 without PAE).

Timo Aaltonen (tjaalton) wrote :

ping, there's still time to remove these before release

Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal amd64
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal arm64
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal armhf
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal ppc64el
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal riscv64
  xserver-xorg-input-aiptek 1:1.4.1-2build1 in focal s390x
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal amd64
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal arm64
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal armhf
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal ppc64el
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal riscv64
  xserver-xorg-input-aiptek-dbgsym 1:1.4.1-2build1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-input-aiptek (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-input-elographics 1:1.4.1-1build6 in focal
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal amd64
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal arm64
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal armhf
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal ppc64el
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal riscv64
  xserver-xorg-input-elographics 1:1.4.1-1build6 in focal s390x
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal amd64
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal arm64
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal armhf
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal ppc64el
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal riscv64
  xserver-xorg-input-elographics-dbgsym 1:1.4.1-1build6 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-input-elographics (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal amd64
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal arm64
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal armhf
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal ppc64el
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal riscv64
  xserver-xorg-input-mutouch 1:1.3.0-1build9 in focal s390x
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal amd64
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal arm64
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal armhf
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal ppc64el
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal riscv64
  xserver-xorg-input-mutouch-dbgsym 1:1.3.0-1build9 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-input-mutouch (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-ast 1.1.5-1.1build1 in focal
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal amd64
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal arm64
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal armhf
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal ppc64el
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal riscv64
  xserver-xorg-video-ast 1.1.5-1.1build1 in focal s390x
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal amd64
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal arm64
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal armhf
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal ppc64el
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal riscv64
  xserver-xorg-video-ast-dbgsym 1.1.5-1.1build1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-ast (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-mach64 6.9.6-1build1 in focal
  xserver-xorg-video-mach64 6.9.6-1build1 in focal amd64
  xserver-xorg-video-mach64 6.9.6-1build1 in focal arm64
  xserver-xorg-video-mach64 6.9.6-1build1 in focal armhf
  xserver-xorg-video-mach64 6.9.6-1build1 in focal ppc64el
  xserver-xorg-video-mach64 6.9.6-1build1 in focal riscv64
  xserver-xorg-video-mach64 6.9.6-1build1 in focal s390x
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal amd64
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal arm64
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal armhf
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal ppc64el
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal riscv64
  xserver-xorg-video-mach64-dbgsym 6.9.6-1build1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-mach64 (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-neomagic 1:1.3.0-1 in focal
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal amd64
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal arm64
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal armhf
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal ppc64el
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal riscv64
  xserver-xorg-video-neomagic 1:1.3.0-1 in focal s390x
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal amd64
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal arm64
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal armhf
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal ppc64el
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal riscv64
  xserver-xorg-video-neomagic-dbgsym 1:1.3.0-1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-neomagic (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-r128 6.12.0-1 in focal
  xserver-xorg-video-r128 6.12.0-1 in focal amd64
  xserver-xorg-video-r128 6.12.0-1 in focal arm64
  xserver-xorg-video-r128 6.12.0-1 in focal armhf
  xserver-xorg-video-r128 6.12.0-1 in focal ppc64el
  xserver-xorg-video-r128 6.12.0-1 in focal riscv64
  xserver-xorg-video-r128 6.12.0-1 in focal s390x
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal amd64
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal arm64
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal armhf
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal ppc64el
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal riscv64
  xserver-xorg-video-r128-dbgsym 6.12.0-1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-r128 (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal amd64
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal arm64
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal armhf
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal ppc64el
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal riscv64
  xserver-xorg-video-savage 1:2.3.9-2ubuntu1 in focal s390x
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal amd64
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal arm64
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal armhf
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal ppc64el
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal riscv64
  xserver-xorg-video-savage-dbgsym 1:2.3.9-2ubuntu1 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-savage (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal amd64
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal arm64
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal armhf
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal ppc64el
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal riscv64
  xserver-xorg-video-siliconmotion 1:1.7.9-2ubuntu2 in focal s390x
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal amd64
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal arm64
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal armhf
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal ppc64el
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal riscv64
  xserver-xorg-video-siliconmotion-dbgsym 1:1.7.9-2ubuntu2 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-siliconmotion (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal amd64
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal arm64
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal armhf
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal ppc64el
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal riscv64
  xserver-xorg-video-sisusb 1:0.9.7-1build2 in focal s390x
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal amd64
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal arm64
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal armhf
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal ppc64el
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal riscv64
  xserver-xorg-video-sisusb-dbgsym 1:0.9.7-1build2 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-sisusb (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-tdfx 1:1.5.0-2 in focal
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal amd64
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal arm64
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal armhf
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal ppc64el
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal riscv64
  xserver-xorg-video-tdfx 1:1.5.0-2 in focal s390x
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal amd64
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal arm64
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal armhf
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal ppc64el
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal riscv64
  xserver-xorg-video-tdfx-dbgsym 1:1.5.0-2 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-tdfx (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-video-trident 1:1.3.8-1build2 in focal
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal amd64
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal arm64
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal armhf
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal ppc64el
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal riscv64
  xserver-xorg-video-trident 1:1.3.8-1build2 in focal s390x
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal amd64
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal arm64
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal armhf
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal ppc64el
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal riscv64
  xserver-xorg-video-trident-dbgsym 1:1.3.8-1build2 in focal s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-video-trident (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages from focal:
 xserver-xorg-video-geode 2.11.20-1 in focal
Comment: obsolete source package, only builds xserver for i386 which is not supported as a host arch; LP: #1772588
1 package successfully removed.

Changed in xserver-xorg-video-geode (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Removing packages:
 xserver-xorg-input-void 1:1.4.1-1build3 in groovy
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy amd64
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy arm64
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy armhf
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy ppc64el
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy riscv64
  xserver-xorg-input-void 1:1.4.1-1build3 in groovy s390x
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy amd64
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy arm64
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy armhf
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy ppc64el
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy riscv64
  xserver-xorg-input-void-dbgsym 1:1.4.1-1build3 in groovy s390x
Comment: (From Debian) ROM; unmaintained, obsolete, or both; Debian bug #955603
Remove [y|N]? y

Changed in xserver-xorg-input-void (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.