XP Pen Star 03 graphic tablet not running on Ubuntu later than 18.04

Bug #1926860 reported by Tino on 2021-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-libinput (Arch Linux)
New
Undecided
Unassigned
xserver-xorg-input-libinput (Ubuntu)
Undecided
Unassigned

Bug Description

The XP Pen Star 03 graphics tablet worked on Ubuntu 18.04 but is no longer working in any other Version of Ubuntu released afterwards.

I tested 20.04 and am currently running 21.04. it is recognized but in the system settings it says not tablet and not stylus found.

The terminal gives me the info that the UC-Logic TABLET 1060N is plugged in. In the system settings it shows "Wacom Tablet" but says not tablet and stylus pen are recognized.

It works perfectly fine on my 18.04 install.

I found a few reports on the internet with the exact same issue. They installed some evdev driver and somehow managed to resolve. I was not able to do so yet.

If the tablet used to work out of the box with Ubuntu 18.04 I wonder why it is no longer working.

There is also a XP Pen Star 03 V2 by now. The tablet look identical but the hardware or firmware must be different.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: ubuntu-release-upgrader-core 1:21.04.11
ProcVersionSignature: Ubuntu 5.11.0-16.17-generic 5.11.12
Uname: Linux 5.11.0-16-generic x86_64
ApportVersion: 2.20.11-0ubuntu65
Architecture: amd64
CasperMD5CheckResult: pass
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Sun May 2 03:16:00 2021
InstallationDate: Installed on 2021-04-15 (16 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Beta amd64 (20210415)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

Tino (tinoh82) wrote :
Tino (tinoh82) wrote :

Ok so first of. I'm posting some more infos on this in my next comment.

Second I'm unsure if ubuntu-release-upgrader is actually the riht place for this bug. It most likely should be libinput rather. But I am unsure, since I don't know what actually causes this. I'll change it to libinput though. If you know where this should be posted/catergorized let me know.

Tino (tinoh82) wrote :

I think this fits better into xserver-xorg-input-libinput let me know if you know where exactly this is bug is located and coming from.

affects: ubuntu-release-upgrader (Ubuntu) → xserver-xorg-input-libinput (Ubuntu)
Tino (tinoh82) wrote :

Ok the following comments are a bunch of screenshots form my Ubutu 18.04 Setup as well as from my 21.04 setup. I made those with the XP Pen Star 03 attached into each setup.

Also attached are output from lineinput list-devices and lsusb for 18.04 and 21.04.

21.04 does recognize that the device is plugged in, but no stylus pen and tablet are recognized.

18.04 everything work perfectly fine. Plug and play. I can use it perfectly fine in software like Krita as well. -> That is how it should work on any version after 18.04 as well.

However the newer versions I tested all have the same issue like 21.04. I tested 19.04, 20.04 and currently am running 21.04. I also tested 18.04 on that setup and it worked perfectly fine.

I'm not sure why it worked out of the box in 18.04 but not in any newer version. I'm unble to find a working fix btw. It should of course work just like in 18.04.

Tino (tinoh82) wrote :
Tino (tinoh82) wrote :
Tino (tinoh82) wrote :
Tino (tinoh82) wrote :
Tino (tinoh82) wrote :
Tino (tinoh82) wrote :

Also I found two users with the same issue that somehow managed to at least get it to work but I was not able to reproduce it.

Same issue in Ubuntu (20.04):
https://www.linux.org.ru/forum/linux-hardware/15876782
(this one is in Russian, I used Google Translator to understand it, translation seemed to be fine)

Similair bug, same tablet (XP Pen Star 03) in ArchLinux:
https://bbs.archlinux.org/viewtopic.php?id=253659

Hope this helps.

Like I said it was supported fine in 18.04 but then no more starting in 19.04 I think.

Tino (tinoh82) wrote :

Can I fix the title? Sorry have a few typos in there.

Tino (tinoh82) on 2021-05-04
summary: - XP Pen Star 03 Grafiktable not running on Ubuntu later than 18.04
+ XP Pen Star 03 graphic tablet not running on Ubuntu later than 18.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers