[lucid] Keyboard and mouse freeze after grub, usb and PS/2 keyboard not working in X (after upgrade? bad-upgrade to lucid)

Bug #555169 reported by Juan Rivera on 2010-04-04
200
This bug affects 39 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

After an update the mouse and keyboard freeze during boot. The keyboard works in grub and recovery mode, if keys are pressed during boot. Touchpads are also disabled. I am not sure if we deal with only one bug, but all problems started synchronous (with updates that were at the same time with the kernel -18).

An USB Keyboard connected after boot works.

jhansonxi (jhansonxi) wrote :

I am having the same issues with a Dell Inspiron 2650 laptop. Started when I updated 10.04 (Lucid Lynx) last week. I have to plug in a USB keyboard to get anywhere. It also affects tty consoles. The touchpad has also completely stopped working. It was working occasionally (bug #479839) before. Not that it matters much since it just crashes at login anyways (bug #553508).

Sebastian Bator (eremit7) wrote :

Juan do you remember which pakages were updated before the incident? Was there a kernel update?
Alternatively can you upload the log for dpkg (/var/log/dpkg.log) and post the time when you did the updates?

Try to hit Control + Alt + F2 to access tty 2, and if that does not work boot in recovery mode (chosen from grub). Does the latter work for you jhansonxi?
If notthing of the above works boot from a live CD to access the Log (and your data). BTW you shouldn't use a development release on a computer were the only copy of your data is, and make backups in general.

jhansonxi (jhansonxi) wrote :

No keyboard response at all after boot. Can't switch from GDM to any tty. Doesn't work in rescue/friendly recovery mode either. Works in BIOS and GRUB2. Even after booting the system function keys for brightness control, etc. work.

Juan Rivera (jrivera86) wrote :

Hi eremit7:

I can't recall which packages were updated, except that it was a big update and the kernel was updated to the version that ends in 18. I have not been able to upload the log but I remember that those updates were performed on Friday evening if that helps. Also I booted on recovery mode yesterday and performed 209MB worth of updates, and now I have kernel number that ends in 19 (sorry but can't recall the whole kernel version number)

Regarding the data, it's just a couple of videos that were stored in that system that I had not transferred :(

jhansonxi (jhansonxi) wrote :

I was able to resolve my keyboard issue. The i8k module for monitoring sensors on Inspiron laptops was causing the problem (bug #406690). I must have added it to /etc/modules the same time I updated so I didn't realize that was the problem.

jhansonxi (jhansonxi) wrote :

I'm back. Removing the i8k module worked ONCE. After powering off and restarting, the keyboard is not responding again. It might have been coincidental. Manually loading and unloading the module (using a USB keyboard) did not seem to affect anything.

Jason Harman (apollyon-direct) wrote :

Having the same problem - keyboard seems to work during boot but cuts out when gdm launches. Bug could be related to gdm. Plymouth was also part of recent updates an possibly udev.

Jason Harman (apollyon-direct) wrote :

Another update - I found that selecting safeboot option and typing during the boot (random keys) will secure me keyboard access when the safe mode options load. If I don't use the keyboard during boot it will be locked out to like in a regular boot. From the safe mode I can choose options like booting to root console in order to run updates (I am completely up-to-date as of April 5) and do other keyboard tasks from the console. However, returning to normal boot mode still results in a loss of keyboard support requiring hard-reboot.

I can copy out some items from the dpkg log if that'll help.

Jason Harman (apollyon-direct) wrote :

Installed packages include:

ubuntu-desktop 1.195
hal 0.5.14
plymouth 0.8.1 + plymouth-x11 0.8.1
ubuntu-minimal 1.195
udev 151-7
dbus-x11
dbus 1.2.16
initscripts 2.87dsf
upstart 0.6.5-6
mountall 2.10
xserver-org-input-evdev 1:2.3.2-5
usbmuxd 1.0.2-1

Russ Dill (russ-dill) wrote :

This seems to have something to do with udev, if I make an xorg.conf as follows (modify for local config), then keyboard and mouse work:

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "false"
EndSection

Section "Screen"
 Identifier "Default Screen"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "evdev"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
 Option "XkbVariant" "dvorak"
 Option "Device" "/dev/input/event5"
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 screen "Default Screen"
 Inputdevice "Generic Keyboard"
 Inputdevice "Configured Mouse"
 Option "AllowEmptyInput" "false"
EndSection

Jason Harman (apollyon-direct) wrote :

Thanks Russ - maybe I'm experiencing a different bug because I'm not sure its Xorg related.
For example, I suffer this bug when conducting a normal safeboot that ends at the prompt (and doesn't load X). Although I can, as I've mentioned earlier, use the keyboard prior to that point - even to have full keyboard access with a safeboot to root user.

I have added a basic mouse/keyboard config to xorg.conf pointing to the /dev/input/events that correspond to my USB/BT logitech setup and rebooted but with no results.

There is something that loads at the very end of regular boot that disrupts my USB/BT keyboard and mouse.

Sebastian Bator (eremit7) wrote :

OK, let's try to sort out if we are talk about the same bugs or several. I lost the big picture.

Can everybody please give a yes /no list:
Keyboard works in
1. in grub
2. in rescue mode
3. in tty
4. in X

Anybody with the same list as Joan sets the bugs status as confirmed, please.

Are we talking about built in Keyboards in Laptops (all Dell Inspiron 2650?)

Jason Harman (apollyon-direct) wrote :

Keyboard works in:
1. in grub
2. in rescue mode (only if keys pressed during boot-up)

This is with a PC running Lucid Beta 1 updated with late March / early April packages.

The keyboard is a Logitech bluetooth/USB keyboard. Everything worked fine before the last major set of upgrades.

affects: ubuntu → linux (Ubuntu)
Youri Volkov (omgomgomg) wrote :

I have same exact issue, neither keyboard nor mouse work. If I ssh in and kill X, then I can use the keyboard fine in console.

This is on a dell latitude c640 laptop.

Yuv (yuv) wrote :

hi eremit7

my bug #556057 was marked as a duplicate of this bug. I think mistakenly.

To answer your questions with a yes/no list - always the same motherboard (Intel Atom desktop board), using different input devices:

A) Logitech DiNovo Bluetooth USB Keyboard with trackpad
1. Yes
2. No
3. No
4. No

B) PS/2 Keyboard (generic) / USB mouse
1. Yes
2. Yes
3. Yes
4. Yes

C) USB Keyboard/Mouse
1. Yes
2. Yes
3. Yes
4. Yes

additionally, after logging in with the PS/2 or USB keyboard, trying to use the bluetooth keyboard gives me a pop up warning asking if the device should be trusted. Hitting on any of the button of that pop up makes it go away but does not seem to have any effect. When the Keyboard sends signals to the bluetooth dongle again, the pop up reappears. I'm on Kubuntu upgraded via the net when beta1 was announced. The machine is currently used only for testing the latest Kubuntu.

It seems to me that the logical conclusion is that the bug I am experiencing is a bluetooth bug and unrelated to this bug report, hence I've unlinked bug #556057

sorry for answering here.
Yuv

summary: - Can't log in after regular update on Lucid
+ Keyboard and mouse freeze after grub
description: updated
Changed in linux (Ubuntu):
status: New → Confirmed

1. in grub: functions
2. in rescue mode: dead
3. in tty: dead
4. in X: dead

Sebastian Bator (eremit7) wrote :

Has somebody tested to boot an older kernel (-17), so we can be sure it's related to the kernel update? If not can somebody please test it and post the running and not running kernel numbers?

Thanks

Eremit7

tags: added: lucid
jhansonxi (jhansonxi) wrote :

I tried -17, -16, and -15. At first the keyboard worked so I went back to -19. It was working there as well so I powered off the laptop and tried again and it failed. It also was frozen in -17. The -16 and -15 don't boot and end up in initramfs but the keyboard is frozen there as well. I powered off the laptop again then restarted and selected -19 recovery in Grub and the keyboard worked. I power-cycled again and let it start graphical -19 and it was frozen. Tried -19 recovery again and it was frozen. A USB keyboard always works when plugged in. Erratic behavior like this would imply a timing bug of some sort.

I've also noticed that Grub doesn't always respond to the shift key at boot as it doesn't show the menu and I have to restart again to make another attempt. It's possible the problem starts there but I have no way to verify.

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sebastian Bator (eremit7) wrote :

Can one or two of you please provide the infos requested for keyboard debugging (https://wiki.ubuntu.com/DebuggingKeyboardDetection)

We also have https://wiki.ubuntu.com/DebuggingTouchpadDetection and https://wiki.ubuntu.com/DebuggingMouseDetection, but the requested infos are the same.

Sebastian Bator (eremit7) wrote :

Please also run 'apport-collect 555169' for automatic information collection.

affects: linux (Ubuntu) → xserver-xorg-input-keyboard (Ubuntu)

Architecture: i386
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
GdmLog1: Error: command ['cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
MachineType: Dell Computer Corporation Inspiron 2650
Package: xserver-xorg-input-keyboard (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nomodeset
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Tags: lucid lucid
Uname: Linux 2.6.32-19-generic i686
UserGroups:

dmi.bios.date: 03/23/2004
dmi.bios.vendor: PHOENIX TECHNOLOGIES LTD.
dmi.bios.version: A13
dmi.board.name: Inspiron 2650
dmi.board.vendor: Dell Computer Corporation
dmi.board.version: None
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Dell Computer Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPHOENIXTECHNOLOGIESLTD.:bvrA13:bd03/23/2004:svnDellComputerCorporation:pnInspiron2650:pvrRevisionA0:rvnDellComputerCorporation:rnInspiron2650:rvrNone:cvnDellComputerCorporation:ct1:cvrN/A:
dmi.product.name: Inspiron 2650
dmi.product.version: Revision A0
dmi.sys.vendor: Dell Computer Corporation
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-19-generic

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xserver-xorg-input-keyboard (Ubuntu):
status: Incomplete → Confirmed

has a similar bug to me - the only difference is that the mouse works
Keyboard dies when I started Xorg and "alive" when you stop

is a USB keyboard but I test it with the adapter to the PS2 - no change

mcwolf (mcwolf) wrote :

after the abolition of the location of /etc/default/console-setup to me the problem disappeared

applying log files on the system before and after the change if it can be something useful for locating problem

mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :
mcwolf (mcwolf) wrote :

appointed a problem just for me
in XKBVARIANT = "us,phonetic" keyboard stops working - the decision to abolish us
XKBVARIANT = ",phonetic"

so everything works for me

jhansonxi (jhansonxi) wrote :

On my Inspiron 2650 with Ubuntu 10.04 (Lucid Lynx) in /etc/default/console-setup the setting is:
XKBVARIANT = ""

Changing any of the settings did not resolve the issue.

jhansonxi (jhansonxi) wrote :

The keyboard finally decided to function one day in recovery mode. I was able to produce a diff of dmesg when it worked as compared to when it didn't. The primary difference was the error:

i8042.c: Can't read CTR while initializing i8042.

Normal result is:
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12

The error message points to a recurring problem with the kernel (many years according to Google search results) and this device that affects keyboards and pointers. The error message is also associated with USB storage device problems. The only workaround I've found so far is adding "acpi=off" to the kernel line in Grub. While this works it prevents the laptop from shutting itself off and pressing the power button shuts the power off instantly without an orderly shutdown.

jhansonxi (jhansonxi) wrote :
jhansonxi (jhansonxi) wrote :

I tested the solution in bug #334249 (i8042.reset i8042.nomux i8042.nopnp i8042.noloop) but it didn't solve the problem. I also came across bug #534448 which is a recent change to the i8042 driver.

Russ Dill (russ-dill) wrote :

Anything with i8042 problems would be a different bug, as with this bug mouse and keyboard work, but X does not receive input (input works in recovery mode). However, I did removed by xorg.conf today, and at found that at some point this bug has been fixed. I've also noticed a whole bunch of udev messages in my xorg log that I've never seen before, perhaps the problem before was a muck up on the switch between hal and udev?

At least for me, this bug can be closed.

jhansonxi (jhansonxi) wrote :

Russ, there could be more than one bug here. In my case the keyboard and mouse sometimes works but often doesn't which could imply a timing issue. Jaun's original report indicated "if keys are pressed during boot". If that is 100% repeatable behavior for Jaun then maybe that system is closer to the timing threshold than mine and any activity causes enough delay to get it working.

jhansonxi (jhansonxi) wrote :

It would be easy for everyone to verify if they are having i8042 problems. This would help determine if there is more than one bug here. The next time your systems boot without functioning keyboards, just plug in a USB keyboard, open a terminal, then type:

dmesg | grep i8042

If you see the "i8042.c: Can't read CTR while initializing i8042" message (or possibly a timeout message) then you may have the same problem as me. If Jaun doesn't see this message when the problem occurs then I'll open a new bug specifically for the i8042.

For me it's not about update. I just installed fresh Xubuntu 10.04 RC (tried Kubuntu too just to verify it's not about the distribution) using wubi as this one happens to be a windows machine.. This one has Logitech's Bluetooth Desktop MX5000 keyboard + mouse with Logitech's USB Bluetooth tranceiver (it shows as an USB keyboard + USB mouse if I recall correctly). As I can't log in I really can't (or can I?) get any information out of it..

I haven't tried on my workstation (which has Ubuntu 9.10 installed) but I guess I'm not trying to update it just yet.. It has a PS/2 keyboard and USB mouse so maybe I should try live CD.

this bug is also in ubuntu 10.04 stable ...

Dariusz Maciejewski (darekmac) wrote :

I have quite similar problem:

On normal boot keyboard and mouse freeze (few seconds after GDM prompt).
On rescue boot + resume (no X, just console) it freezes too (few seconds after login prompt) => not an X issue
On rescue boot + failsafeX everything works fine
On rescue boot + root / netroot login + manual gdm start everything works fine => not an X issue

With a good timing, when a key is being pressed in the same moment as the freeze happens, this key is repeated infinitely.

I tried to compare ps -A outputs to check what additional process are started on normal/resume boot (via ssh when input has been disabled), but haven't found anything interesting.

Tested keyboard + mouse setups:
Microsoft Wireless Keyboard 3000 v2.0 + Microsoft Wireless Mouse 5000 (shared USB receiver).
Old PSX keyboard + Logitech USB - keyboard freezed, mouse functioned properly.

When I have removed my custom xorg.conf (nvidia driver & tweenview setup), gnome usually works (same xorg.conf works fine during rescue boot + netroot + manual gdm), but it still doesn't fix the rescue+resume console login (no X at this time).

Well, I'll have to stick to rescue + netroot + manual gdm option for some time :/

Dariusz Maciejewski (darekmac) wrote :

forgot to mention, my dist is: ubuntu 10.04 stable

Dave Efflandt (efflandt) wrote :

I have a diNovo Edge which with its Logitech Bluetooth USB dongle is usually totally OS independent (works for BIOS password or without any drivers in any other OS, including Ubuntu 9.10).

This original bug is related to https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/550288 and that solution worked for me.

Apparently /lib/udev/rules.d/70-hid2hci.rules has been mangled in 10.04 LTS as a result of https://bugs.launchpad.net/ubuntu/+source/udev/+bug/444420 possibly making installation impossible unless you have a wired keyboard to use.

The simplest solution that worked for me from live session on 10.04 LTS CD, comment out the following so it looks like this in /lib/udev/rules.d/70-hid2hci.rules:

# Logitech devices
#KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
# RUN+="hid2hci --method=logitech-hid --devpath=%p"

Reinsert your USB dongle and you should be good to go (unless you were playing with the Connect button on the keyboard, then you may need to press that and the button on the dongle).

Dave Efflandt (efflandt) wrote :

I just realized that this is a different original bug than I thought, but my suggestion may help anyone with issues related to Logitech wireless keyboards in 10.04.

Hi there. I'm a complete novice but have resolved a similar problem I had; so I wanted to share in case it helps someone else. I recently made a clean install of 10.04LTS on a Dell Inspiron 2650. Even during the install my trackpad and keyboard did not work, I had to use a USB mouse and keyboard. After install the problem persisted. I looked at my xorg.conf because it was mentioned here or in another forum and this is all it contained:

Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
 Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "nvidia"
 Option "NoLogo" "True"
EndSection

It seems to me that the generation of this file was botched. I installed the NVidia restricted drivers, then went to
System->Administration->X Server Settings->X Server Display Configuration->Save to X Configuration File
I received a message saying it could not parse the current file but gave me the option to preview what the restricted driver had generated. I copied the preview and generated a new xorg.conf. After two reboots the problem was solved.
The attached file is what my xorg.conf now reads.

Hi Christoph,

I tried your suggestion (fellow Inspiron 2650 user here), but it didn't seem to help anything. It seems that the keyboard and trackpad work rather randomly (for me, they seldom work). Could it be that your keyboard just happened to want to work right after you made that change?

Seth Georgson (sethgeorgson) wrote :

I'm pretty sure this is the problem I had.

I installed Lucid from scratch on a multi-boot system. (The upgrade from Karmic botched). Everything seemed perfectly fine except within half an hour, sometimes in only a few minutes, the mouse would freeze. My PS2 keyboard continued working fine, but nothing from the USB mouse. I tried plugging and unplugging and plugging in a different mouse but nothing would happen. There was still power to the USB but no response.

After some searching, I tried adding "acpi=off" to the grub boot options. Now it's working just fine.

Yaron (sh-yaron) wrote :

The acpi=off trick works magically, thanks Seth!

Hey, S. Christian. You are absolutely right. Two days later it stopped working and I have no idea why, but without a kb I couldn't update this thread. Have you had any luck?

I would like to try the acpi=off trick, can someone confirm that I'm doing it right? (Again, this is a stock install of 10.04LTS.) I ran "sudo gedit /etc/default/grub", added the line "acpi=off", saved, then ran "sudo update-grub"

I'm guessing that the acpi option can be toggled on bootup, but I can't seem to get the grub menu up. If I hold shift during bootup I can get the message "starting grub..." but then my system just boots normally.

Hi Christoph,

In /etc/default/grub, make sure you add acpi=off to the line that begins: GRUB_CMDLINE_LINUX_DEFAULT=

So, that line should now read:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

FYI, this works for me on a Dell Inspiron 2650, the only problem being that the laptop never powers off after shutdown. You will hear the fans stop spinning, and the screen will stop animating, and then you'll have to press the power button. Everything else seems to work just fine.

Thanks, S. Christian. My Inspiron is usable again. I appreciate the help.

JoseStefan (josestefan) wrote :

Testing the Dell Inspiron 2650 with a Lucid desktop cd...

Pressing any key to get the boot menu, and then using F6 to set acpi=off seems to do the trick. Of course you loose all the other acpi benefits. So I'm still waiting for a better solution.

Rafal-maj-it (rafal-maj-it) wrote :

Confirmed on 2 computers:
USB keyboard and USB mouse on a PC,
built-in keyboard, and USB mouse on a laptop.

Wtf.

summary: - Keyboard and mouse freeze after grub
+ [lucid] Keyboard and mouse freeze after grub, usb and PS/2 keyboard not
+ working in X

After updating/upgrading the system more (after initial upgrade to 10.04) and after few restarts, now the system appears to be working, on the laptop.

Still not working on the affected PC (usb keyboard and mouse)

Feo (alslovtsov) wrote :

The keyboard and mouse started working for me after I turned off the option "Hyper-Threading" in the BIOS.
Or if I adding "noapic" to the grub boot options.
This is the best solutions that I found for myself.

I have a PS/2 keyboard and mouse,
Chipset - SiS 651/962L

kmself (karsten-m-self) wrote :

Similar problems, resolved with an upgrade to kernel 2.6.32-21-generic.

Initial experience: upgrading from 9.04 to 10.04 resulted in frozen keyboard/mouse on starting X11. Only exit was a hard boot (no serial console or remote system from which to ssh in).

System is a Lenovo T61 laptop.

Experimenting with rescue boot showed that system was responsive to keyboard at BIOS, GRUB, and pre-X system session. Booting single-user root mode it was possible to start X session, at which point recovery from X was not possible. Tricks such as:

startx /usr/bin/xterm -geometry 1680x1050 -- vt12 & sleep 10; chvt 7

(where 1680x1050 is my laptop display geometry)

This would switch back to a non-X virtual console, from which keyboard and mouse were responsive (generally killing X at this point was a Good Thing).

I did manage to get mouse response under a 2.6.27-11-generic kernel by modifying /etc/X11/xorg.conf to specify a mouse device:

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/psaux"
        Option "Protocol" "ImPS/2"
        Option "Emuate3Buttons" "false"
EndSection

... but wasn't successful in specifying a keyboard configuration (what *IS* the default PS2 keyboard device?).

On a suggestion from irc://irc.freenode.net/#xorg, I upgraded to latest available kernel. Keyboard/mouse functioned with a default xorg.conf.

Rafal-maj-it (rafal-maj-it) wrote :

For me it worked after fully finishing upgrade to lucid (9.10 -> 10.04).

I had to manually run again aptitude dist-upgrade and aptitude -f install and so on. Then after reset or two, all works on all 3 computers.

Please try this and write if it helps.

tags: added: bad-upgrade
summary: [lucid] Keyboard and mouse freeze after grub, usb and PS/2 keyboard not
- working in X
+ working in X (after upgrade? bad-upgrade to lucid)
Feo (alslovtsov) wrote :

I found the cause of my problem!
Many people have written that if run the system in single-user mode, and then manually run "gdm" - everything works. I also make this work, and I wanted to find the difference between single- and multi-user modes. And I found the reason - it is a daemon "irqbalance"
When I tried to run it manually - the keyboard would freeze after a few seconds. So I just uninstalled it ("sudo aptitude purge irqbalance"). And the system began working perfectly!!!

I have a motherboard ASUS P4S533MX and processor P4

Dariusz Maciejewski, it certainly should work for you.

Dariusz Maciejewski (darekmac) wrote :

Thanks Feo. Maybe I'll try your solution in the future, but currently I have reverted to 9.10 and don't plan to upgrade in the nearest future. In my opinion 10.04 is uglier and much less usable than 9.10 (are they going the same way the KDE3->KDE4 has gone?)

jhansonxi (jhansonxi) wrote :

@Feo
Removing irqbalance did not solve the problem for me. The workaround for my situation remains as per comment #50.

It would be helpful if everyone attempted your solution to see if it fixes their systems. This would verify your bug and probably be the basis for a separate bug report if Juan's situation is different.

Lars Ola Liavåg (l-liavag) wrote :

I issued bug #590966 but have now marked it as a duplicate of this one. I've been experiencing a lagging mouse and keybord for some time after getting to the login screen. This seems to have been solved by writing a new xorg.conf from the NVIDIA X server settings application and as such, I'm quite happy about things now.

As a side note, though, I now see that the lag has "moved" from before login to after. By this I mean that when I've entered my password and enter has been pressed, there is a lag before there's any evidence of GNOME starting up. I'll be subscribing to this bug to see if anybody else are reporting similar symptoms.

Lars Ola Liavåg (l-liavag) wrote :

Unfortunately, the problem isn't solved after all. I still have the occasional (and rather frequent, it feels) keyboard and mouse lag. Moreover, which might be related, I sometimes don't get to the login screen at all. I'm just left at the splash screen forever and am forced to use the power button to get out. Looking through my log files, I see these three types of warning repeatedly:

gdm-session-worker[1287]: WARNING: Unable to load file '/etc/gdm/custom.conf': Filen eller katalogen finns inte
gdm-binary[880]: WARNING: Unable to find users: no seat-id found
gdm-simple-greeter[1379]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.1/gtk/gtkwidget.c:5636: widget not within a GtkWindow

Could this be a GDM bug?

Lars Ola Liavåg (l-liavag) wrote :

I used gdmsetup to change to automatic login, then rebooted, changed back to multiuser again, and rebooted twice more. I now have the following warnings in my log files:

gdm-binary[902]: WARNING: Unable to find users: no seat-id found

gdm-simple-greeter[1376]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.1/gtk/gtkwidget.c:5636: widget not within a GtkWindow

gdm-session-worker[1378]: GLib-GObject-CRITICAL: g_value_get_boolean: assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed

I.e. the warning about /etc/gdm/custom.conf are now gone. The two other warnings I've had are the same, and I now have a new one; the GLib-GObject-CRITICAL message. I'll keep my eyes up for the mouse/keyboard problems for a while and see over time if it's still around.

mirak (mirak-mirak) wrote :

I have upgraded to lucid on two computers

they both have the same mainboard (GA-E7AUM-DS2H) and same keyboard (logitecg MX3200).
On one computer it worked after the upgrade from karmic.
On the other one the keyboard and mouse are locked at gdm login.

inside both computers I have two dvb-c tuner cards, and a pl3203 smartcard reader

the computer wich fails have in plus a nvidia 9600GT video card

Yaron (sh-yaron) wrote :

Some updated:
I updated the Kernel to 2.6.35-RC1 (via here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/, but be very careful, the 173 drivers from nvidia does not work with this card and I can only use Nouveau, if anyone know anything I'd love to hear...)
The problem still exists (Loading the kernel without acpi=off or noapic makes my computer freeze after a minute or 2, first I cannot use the keyboard, then the mouse and then the load monitor stays still)
So I added them one by one just to find the following conclusions:

Now my problem divides in 2:
1. acpi=off - Everything loads fine and all my keyboard keys are working perfect, the computer won't freeze at all and I can work for hours - much slower, apparently when I use that function one of my CPUs is gone and I use 1300 MHz instead of 2.6 GHz

2. noapic - The computer works fine (almost), no freezes whatsoever and I get my 2 CPUs working, everything is just peachy until I press the Print Screen/SysRq key, then there are 2 options: My keyboard stops working, or my computer halts immediately and restarts or shuts down (the reason I discovered it is the reason I accidently pressed it instead of pressing backspace)
My MacGyver senses guided me into the perfect solution: taking the button out! and now the key is just sitting infront of me, waiting for this bug to be fixed

If you ignore this but just think about the poor little fella' (my Print Screen key) what was pulled out with no mercy and now he is sitting on my desk with no love or friends (although I heard that his wife - the scroll lock key, has cheated on him some times)

Anyways thank you all and I hope we will get to a soultion soon
My motherboard is ASUS P48X-X and my graphics card is GeForce FX 5400 (NV34)

If more info is needed about my system I'd love to add to this discussion

Kind regards,
Yaron Shahrabani

L Schmiedl (lutz-schmiedl) wrote :

The issue sounds like the problem on my notebook Dell D830 with a docking station. I installed a fresh Ubuntu 10.04 four weeks ago. Before I used Ubuntu 9.04 without any problem.
Now I randomize get freezes on GDM Login. Both keyboards, internal and PC/2, also the synaptic touchpad and the external mouse are frozen. All other devices seems to be right. I can shut down the system with the power button and reboot. Or I can switch the external mouse and keyboard on a PS2-USB-Converter. After I plugged this in, I can log in and work with the notebook.
After a reboot the fault is disappeared. Mouses and keyboards on PS/2 and internal devices works fine. The next freeze I'll get 3 or 4 days after.
In case of fault I found the following entries

[27.681159] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input14
[27.881028] psmouse.c: Failed to enable mouse on isa0060/serio1

in /var/log/messages.
I tried the next hints I found in different discussions to this topic, but no result:

1. use option noapi on grub
2. change kernel from 2.6.32-23-generic-pae to 2.6.32-23-generic
3. change compiz to metacity
4. disable KMS
5. use option noapi and nolapic on grub
6. disable irqbalance

Nothing solve the problem.

Jeff Hunt (jeffhunt90) wrote :

When I upgraded my Dell Inspiron 2650 from Hardy Heron to Lucid my onboard keyboard and mousepad died. Appears to be bug 555169.

If I:
sudo gedit /etc/default/grub
then comment out the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to be
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
keyboard and mousepad work again and it has the advantage that I see the reports as the computer boots.

If I leave it uncommented but add acpi=off as follows

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off" it also works but has the disadvantage it turns off the acpi which takes away some functionality.

I found that commenting and uncommenting the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line made the fault reproducible every time. A usb keyboard and mouse always worked so I got the following test result.

with the line uncommented (natural state) using dmesg | grep i8042 I got
[ 0.802963] i8042.c: Can't read CTR while initializing i8042.
[ 1.530601] i8042: probe of i8042 failed with error -5

with the Linux_Default line commented (fixed) and then using dmesg | grep i8042 I got
[ 0.341694] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 0.341845] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 0.368314] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[ 19.906063] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input7

On site http://ubuntuforums.org/showthread.php?t=1474694 someone says it is still a problem on Meerkat
and on the next page http://ubuntuforums.org/showthread.php?t=1474694&page=2 someone says they cured it with a bios update.
Could it be a Dell bios bug? I can't get a bios update into my machine.
I get RBU Bios Update not supported on this system

Hope someone can track this down and fix it permanently.

Philippe Lefevre (ph-l) wrote :

For some time I have a keyboard issue at boot. It is relatively close to what I've read here.
I think this issue appeared after a Lucid Lynx kernel upgrade. Before, it worked fine.

Till GDM is displayed, the keyboard works well (usb Dell keyboard). I can enter my login and password.
X11 starts and the keyboard is not usable anymore (but the mouse is still working).
I have to unplug/replug the usb keyboard and all goes well after that.
There are no errors in the kernel or X11 logs.
While I believed it was a trouble due to the usb dialog, I raised a ticket to launchpad (Bug #82368) where I found some similar cases.
I registers there my logs.

Recently I traced my keyboard inputs with "input_events" (from my laptop connected to my machine), and I can see that, even if apparently nothing happen, the data from the keyboard are well transmitted. So the problem is probably not due neither to the usb dialog nor the keyboard itself. It seems due to the fact that when X starts, it reset the keyboard somewhere but it leaves it in a bad state.

This issue is permanent for me. If I can do some other test for you to help, I'll do it. Just let me know your needs. (I can use gdb and eventually recompile X11)
Is there any documentation that could help me to understand what X11R7 does after startx is launched. (there is a lot of documentation but very old)

Philippe Lefevre (ph-l) wrote :

# Xorg -version
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux phlsys 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-27-generic root=UUID=9e1cecb7-fe02-4f10-8a65-a42521b10c76 ro quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap
Build Date: 10 November 2010 11:25:53AM
xorg-server 2:1.7.6-2ubuntu7.4 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.16.4

Philippe Lefevre (ph-l) wrote :

Just to inform that the bug disapeared for 2 days.
I just ugraded my ubuntu version and do some cleaning old kernel versions
Please find attached the history and term log files.

Philippe Lefevre (ph-l) wrote :
Timo Aaltonen (tjaalton) wrote :

This bug has become impossible to follow. If you can reproduce the problem on a fully updated lucid/maverick/natty, please file a new bug by running 'ubuntu-bug xorg'.

Changed in xserver-xorg-input-keyboard (Ubuntu):
status: Confirmed → Invalid
jhansonxi (jhansonxi) wrote :

@ Timo Aaltonen
Bug #739118 filed against linux for symptoms of:

Keyboard always working in Grub, randomly not functional in both tty and gdm after boot. Failure affects both tty and gdm simultaneously.

Touchpad randomly not functional when gdm loads.

Keyboard may be functional in gdm while touchpad not.

Unable to test in recovery mode due to bug #738501.

Yaron (sh-yaron) wrote :

Upgraded to Maverick and the problem is solved.
Using kernel 2.6.35-28-generic (the one provided by Canonical).

Kind regards,
Yaron Shahrabani.

Gábor Péntek (pentike) wrote :

Hi!

I had the same problem:

After doing a full upgrade from Jaunty keyboard and mouse were disabled under X. I could ssh to the machine and after shutting down gdm I got back to the terminal where the keyboard was working well.

After reading through the comments, I checked the Device entries in xorg.conf
It turned out that udev has some different naming scheme and the old device paths were invalid. So for example:

instead of:
 Option "Device" "/dev/input/mouse"
I had to write
 Option "Device" "/dev/input/by-path/platform-i8042-serio-3-mouse"

and do the same for the keyboard as well.

After this change the system is back on track!

Greets,
pentike

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions