Unmet dependencies

Bug #565540 reported by Jon Arnold on 2010-04-17
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-fpit (Ubuntu)
High
Timo Aaltonen
Lucid
High
Unassigned
Maverick
High
Unassigned
Natty
High
Timo Aaltonen

Bug Description

Binary package hint: xserver-xorg-input-fpit

$ sudo apt-get install xserver-xorg-input-fpit
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xserver-xorg-input-fpit: Depends: xserver-xorg-core (>= 2:1.5.99.901) but it is not going to be installed
E: Broken packages

Jon Arnold (jonarnoldsemail) wrote :

$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.7.6-2ubuntu5
  Candidate: 2:1.7.6-2ubuntu5
  Version table:
 *** 2:1.7.6-2ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Bryce Harrington (bryce) on 2010-04-18
tags: added: lucid

http://uppix.net/4/e/6/ab4f8692730e07bb10191a8be2225.png

$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.7.6-2ubuntu7
  Candidate: 2:1.7.6-2ubuntu7
  Version table:
 *** 2:1.7.6-2ubuntu7 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

/var/log/Xorg.log:
(II) LoadModule: "fpit"
(WW) Warning, couldn't open module fpit
(II) UnloadModule: "fpit"
(EE) Failed to load module "fpit" (module does not exist, 0)
(EE) No input driver matching `fpit'

sm8ps (sm8ps) wrote :

I met the same problem on a HP/Compaq TC1000. So I tried to install the fpit driver regardless of its dependencies. (Before installation through synaptics, it tries to remove ubuntu-desktop, xorg, xserver-core and many more which would not make much sense to me.) I manually copied the appropriate files (/usr/lib/xorg/modules/input/fpit_drv.so and /usr/share/bug/xserver-xorg-input-fpit/script which is a symlink). After that, the X server starts normally but the driver still does not work. Here is the relevant part of Xorg.0.log:
(II) LoadModule: "fpit"
(II) Loading /usr/lib/xorg/modules/input/fpit_drv.so
(II) Module fpit: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.3.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(EE) module ABI major version (4) doesn't match the server's version (7)
(II) UnloadModule: "fpit"
So the driver module seems to be incompatible with the X server's version. Any work-arounds?
Cheers!
Stefan Mueller, Switzerland

There was a patch on the old bug report for jaunty.

sm8ps (sm8ps) wrote :

For everybody's reference, here is the bug report that jkltechninc refers to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-fpit/+bug/327319

I have already tried to apply the deb-package for jaunty. Not much to anybody's surprise that did not work. Yet it was Jon Arnold (the OP) who supplied the patch then. So I put my hope in his genius finding a solution. Others welcome, too! :)

Confirm this bug, please find the solution asap you genius! I own a Gateway CX200X and it worked beautifully under Karmic but Lucy seemed to have lost it. The drivers are shown on the repositories, but they are now way to install them neither manually or through synaptic.

Robert Hooker (sarvatt) wrote :

I have uploaded a version that should work to x-updates in case it helps. It will take a few hours to build though due to the PPA build backlog. The version in lucid does not work and there has been no released version of fpit that works with xserver 1.7+ so it comes from git.

https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates

The source code for the fpit driver in case some genius can do something with it.
http://packages.debian.org/source/sid/xserver-xorg-input-fpit

Jon Arnold (jonarnoldsemail) wrote :

Robert's package should work. All I did before was patch it with fixes from the Xorg GIT, which the Debian GIT seems to have already done.

Perhaps as a fix to the bug in the official repos, a package should actually be released from the Debian GIT?

sm8ps (sm8ps) wrote :

Robert, thank you very much, it does work indeed! Now I my ancient Compaq TC1000 has been turned into a fully functional Linux tablet PC! Thank you so much! Now I need to set the xorg.conf right.
Cheers!

How did you guys make it work? Help me here, I am noob and I don't know what else to do. I just installed all the .deb files out there but it won't let me install the xorg-fpit driver.
THanks in advance.

Thanks a lot Robert. I've got the driver installed now, but I can't make it work. I guess I have to play with the Xorg file and the serial.conf file as well. Thanks a lot anyways.
Fabian

philipp (moenchp) wrote :

I can confirm: it works perfectly on my LG C1 tablet.

Jon Arnold (jonarnoldsemail) wrote :

Robert, your DEB worked for me in getting it up and running.

My question is now a configuration one, which is off the bug topic, but best for here. My old values don't work now for the X axis. When I move the pen from left to right, the cursor gets increasingly far away from the pen, essentially accelerating (in terms of distance) to the right. Any ideas? I tried changing the MaximumX value but it didn't change anything.

sm8ps (sm8ps) wrote :

I can second Jon's finding. (What a relief to find out that it is not just me who cannot make it work. Thanks, Jon!) My HP/Compaq TC1000 also shows that same strange behavior. Changing the Minimum/MaximumX values in xorg.conf does not do anything (!) . However, changing those values for the y-axis does have some peculiar impact: it seems to "accelerate" the x- as well as the y-coordinates much like a dilation factor.
I checked the source code of the fpit driver but did not really understand much, let alone detet any errors. I would be very helpful if somebody more knowledgeable than I would have a look. Thanks a lot!

Jon Arnold (jonarnoldsemail) wrote :

Sm8ps,

What was the Y value that worked as normal, what value made it "accelerate," and what resolution are you using?

sm8ps (sm8ps) wrote :

I am using 1024x768 resolution. The original settings in xorg.conf had been 8600x6458 (Max-values) with some small (~100) offsets (Min-values) each. This gave me perfect y-motion (pointer and pen from 0 to 100% in sync) but the x-motion made the point move to the right-hand edge already if the pen was only at ~75% of the screen width just as you describe. The same for 6250x6458 and 18600x6458.
Yet 6250x4950 gave me ~57% x-motion and ~75% y-motion (which corresponds to 4950/6458). Sub-sequent tests (of which I have not taken notes) made me conclude my previous statement.
Cheers!
Stefan Mueller, Switzerland

Jon Arnold (jonarnoldsemail) wrote :

Your last part intrigued me. It is very odd because the values seem to affect each other. So, I tinkered with mine.

I use a 1280x768 resolution. My old MaxX,MaxY values were 12550,7650. So I switched them, making it 7650,12550 and the motion on the X-axis DEcelerated in the same way that the X Accelerated before, making only ~50 of the vertical screen usable. Very odd....

I could not make my Gateway CX200X to work. I had to install 9.10 back again. Everything looked just fine but it won't work. Installing 9.10 was just a piece of cake and had no trouble making my screen to recognize my stylus.
Fabian

Robert Hooker (sarvatt) on 2010-05-17
Changed in xserver-xorg-input-fpit (Ubuntu):
status: New → Confirmed
sm8ps (sm8ps) wrote :

Don't know if this helps but I just happened to notice a surprisingly similar mis-behavior on a totally different machine (Acer C310 that uses Wacom drivers and works perfectly well). While having a second monitor activated by the nVidia proprietary driver tool (System >Settings >NVIDIA X Server Settings; screens set horizontally adjacent), the pen got dilated just like described in my comment #15 above. This time, the horizontal ratio was 50% (corresponding to two screens of 1024x768, of course) and the vertical ratio had remained 100%.
Cheers!
St. Müller, Switzerland

Jon Arnold (jonarnoldsemail) wrote :

Just upgraded to Maverick on my CX210X, and to no surprise this package hasn't been fixed yet. Thank you, Robert for Ubuntu-X that saved my life for Lucid! But here we are again. I tried using the old fpit deb but it threw some kind of dependency error. I managed to dpkg --force-all -i it, but ran into a wall with Xorg again:

[ 19.299] (II) LoadModule: "fpit"
[ 19.321] (II) Loading /usr/lib/xorg/modules/input/fpit_drv.so
[ 19.331] (II) Module fpit: vendor="X.Org Foundation"
[ 19.331] (II) UnloadModule: "fpit"
[ 19.331] (II) Unloading /usr/lib/xorg/modules/input/fpit_drv.so
[ 19.331] (EE) Failed to load module "fpit" (module requirement mismatch, 0)
[ 21.140] (II) LoadModule: "fpit"
[ 21.140] (II) Loading /usr/lib/xorg/modules/input/fpit_drv.so
[ 21.140] (II) Module fpit: vendor="X.Org Foundation"
[ 21.140] (II) UnloadModule: "fpit"
[ 21.140] (II) Unloading /usr/lib/xorg/modules/input/fpit_drv.so
[ 21.140] (EE) Failed to load module "fpit" (module requirement mismatch, 0)
[ 21.140] (EE) No input driver matching `fpit'

Zhonya (leozhuk) wrote :

I am fairly new to Linux. Just installed Ubuntu 10.4 on my Fujitsu Stylistic ST5031D tablet PC. Got most of it working, except for "on-screen" or virtual keyboard. Searched Ubuntu Software Center for "Fujitsu" and appears that I need FPIT input driver package installed. When I try to install it I get "Package dependencies cannot be resolved" error...
anybody knows what dependencies they are talking about?
Any help greatly appreciated.
Thanks!

Timo Aaltonen (tjaalton) on 2011-02-24
summary: - Unmet dependencies in Lucid
+ Unmet dependencies
Changed in xserver-xorg-input-fpit (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in xserver-xorg-input-fpit (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → High
Changed in xserver-xorg-input-fpit (Ubuntu Lucid):
status: New → In Progress
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

package uploaded to lucid-proposed which fixes this.

Changed in xserver-xorg-input-fpit (Ubuntu Lucid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Please fix this in natty ASAP, otherwise this can't progress to -updates.

tags: added: verification-needed

Accepted xserver-xorg-input-fpit into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

philipp (moenchp) wrote :

It works on my LG C1.

Martin Pitt (pitti) on 2011-02-26
tags: added: verification-done
removed: verification-needed
Changed in xserver-xorg-input-fpit (Ubuntu Lucid):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-fpit - 1:1.3.0-2ubuntu0~lucid1

---------------
xserver-xorg-input-fpit (1:1.3.0-2ubuntu0~lucid1) lucid-proposed; urgency=low

  * Cherry-picked commits from upstream git:
    - Cope with XINPUT ABI 7 (LP: #565540)
    - Fix module unloading.
    - fpit: minX/ maxX get wrongly initialized (LP: #582123)
 -- Timo Aaltonen <email address hidden> Thu, 24 Feb 2011 13:38:07 +0200

Changed in xserver-xorg-input-fpit (Ubuntu Lucid):
status: Fix Committed → Fix Released

I am lost, why the fix for Lucid does not work in Maverick?

Timo Aaltonen (tjaalton) wrote :

Because the driver uploaded to lucid doesn't build against xserver 1.9 on maverick, nor 1.10 on natty. The updates are probably too invasive to push to maverick.

This mean that we will have to wait to Yucky Yak to have this fixed in Maverick? Sorry for my sarcasm, I know this is free and we should not demand anything, but it bugs me..pun intended.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-fpit - 1:1.3.99+git20101206.020c04e2-0ubuntu1

---------------
xserver-xorg-input-fpit (1:1.3.99+git20101206.020c04e2-0ubuntu1) natty; urgency=low

  * New upstream snapshot. (FTBFS, LP: #565540)

xserver-xorg-input-fpit (1:1.3.99+git20101206.020c04e2-1) UNRELEASED; urgency=low

  [ Timo Aaltonen ]
  * Switch to dh:
    - Bump debhelper build-dep, add dh-autoreconf build-dep.
    - Bump xserver-xorg-dev build-dep for dh_xsf_substvars and xsf sequence.
    - Bump compat to 8.
    - Rewrite debian/rules.
    - Pass --fail-missing to dh_install.
    - Stop passing --disable-static to configure, that's the default.
    - Pass --warnings=6 to dh_shlibdeps.
  * Remove xsfbs accordingly.
  * Remove long obsolete Replaces.
  * Use ${xinpdriver:Depends} in debian/control.
  * Bump Standards-Version to 3.9.1 (no changes needed).
  * Merge upstream master as of 2010-12-06, support input ABI 12.
  * Install the manpage in .install, remove obsolete .manpages.

  [ Julien Cristau ]
  * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
    good reason. Thanks, Colin Watson!
  * Remove myself from Uploaders
 -- Timo Aaltonen <email address hidden> Tue, 15 Mar 2011 16:39:03 +0200

Changed in xserver-xorg-input-fpit (Ubuntu Natty):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton) wrote :

No, natty is enough :) And a new version has been uploaded there, but it's too big an update for a maverick SRU. You can try to build it on maverick if you need it, otherwise you'll be able to install it on natty.

Changed in xserver-xorg-input-fpit (Ubuntu Maverick):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers