Horizontal scrolling reversed recently

Bug #932439 reported by Jason Warner on 2012-02-14
52
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev
In Progress
Medium
xserver-xorg-input-evdev (Ubuntu)
High
Chase Douglas

Bug Description

I use an Apple Might Mouse (http://fundapk.com/wp-content/uploads/2011/04/Mighty-Mouse-2005.jpg). The nub in the middle allows for both vertical and horizontal scrolling in the same wheel.

The mouse scroll wheel and/or track pad (my laptop is in the shop so I can't test that) direction changed recently. When I scroll to the right, expecting to move the window (nautilus, say) to the right, it doesn't, it goes left. I think this is called 'natural scrolling'.

Down still scrolls down, up still scrolls up, but left and right seem reversed.

0003:05AC

[ 3.926287] input: Mitsumi Electric Apple Optical USB Mouse as /devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6
[ 3.926392] apple 0003:05AC:0304.0004: input,hidraw3: USB HID v1.10 Mouse [Mitsumi Electric Apple Optical USB Mouse] on usb-0000:00:06.0-4/input0

Bus 004 Device 003: ID 05ac:0304 Apple, Inc. Optical USB Mouse [Mitsumi]

[ 5.872] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/event6)
[ 5.872] (**) Mitsumi Electric Apple Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: Device: "/dev/input/event6"
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Vendor 0x5ac Product 0x304
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found 8 mouse buttons
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found scroll wheel(s)
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found relative axes
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found x and y relative axes
[ 5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Configuring as mouse
[ 5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Adding scrollwheel support
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: YAxisMapping: buttons 4 and 5
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 5.872] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6/event6"
[ 5.872] (II) XINPUT: Adding extended input device "Mitsumi Electric Apple Optical USB Mouse" (type: MOUSE, id 11)
[ 5.873] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/mouse1)

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Mitsumi Electric Apple Optical USB Mouse id=11 [slave pointer (2)]

version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jason Warner (jasoncwarner) wrote :
Bryce Harrington (bryce) wrote :

Try this as a workaround:

  xinput set-button-map 11 1 2 3 4 5 7 6

That should swap the h-scroll axis.

Bryce Harrington (bryce) wrote :

Please see if downgrading to this -evdev package restores the scrolling:

  https://launchpad.net/ubuntu/precise/+source/xserver-xorg-input-evdev/1:2.6.99.901-1ubuntu2

If it does, the regression could be due to 100-evdev-force-x-y-axes.patch.

affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) on 2012-02-15
description: updated
Bryce Harrington (bryce) on 2012-02-16
Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
summary: - Horizontal scrolling feels backwards
+ Horizontal scrolling on Apple Mighty Mouse reversed recently

Jason ruled out the -evdev update by reproducing with 1:2.6.99.901-1ubuntu2.

Attached is the full list of suspects, but it is probably something in the 1.11.99.902 input stack introduced with the 10 Feb xserver that brought the regression.

The kernel change could be ruled out by booting the 3.2.0-12.21 kernel -- hold down left shift during boot, then in grub go into the old kernels section and pick that button. You'll need to move aside your .xsessionrc and reboot to test it.

Download full text (3.9 KiB)

Forwarding this bug from Ubuntu reporter Jason Warner:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/932439

[Problem]
After upgrading from the 1.11.3 to 1.11.99.902 input stack, the horizontal scroll for the Apple Mighty Mouse has reversed.

We tested having him downgrade the -evdev driver (as I noticed it has some recent work with scrolling) back to 2.6.99.901 but that made no difference.

During this timeframe he also upgraded from a v3.2.2 based kernel to v3.2.3.

Manually switching around the buttons worked around the problem locally:
  xinput set-button-map 11 1 2 3 4 5 7 6

[Original Description]
I use an Apple Might Mouse (http://fundapk.com/wp-content/uploads/2011/04/Mighty-Mouse-2005.jpg). The nub in the middle allows for both vertical and horizontal scrolling in the same wheel.

The mouse scroll wheel and/or track pad (my laptop is in the shop so I can't test that) direction changed recently. When I scroll to the right, expecting to move the window (nautilus, say) to the right, it doesn't, it goes left. I think this is called 'natural scrolling'.

Down still scrolls down, up still scrolls up, but left and right seem reversed.

0003:05AC

[ 3.926287] input: Mitsumi Electric Apple Optical USB Mouse as /devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6
[ 3.926392] apple 0003:05AC:0304.0004: input,hidraw3: USB HID v1.10 Mouse [Mitsumi Electric Apple Optical USB Mouse] on usb-0000:00:06.0-4/input0

Bus 004 Device 003: ID 05ac:0304 Apple, Inc. Optical USB Mouse [Mitsumi]

[ 5.872] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/event6)
[ 5.872] (**) Mitsumi Electric Apple Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: Device: "/dev/input/event6"
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Vendor 0x5ac Product 0x304
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found 8 mouse buttons
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found scroll wheel(s)
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found relative axes
[ 5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found x and y relative axes
[ 5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Configuring as mouse
[ 5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Adding scrollwheel support
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: YAxisMapping: buttons 4 and 5
[ 5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 5.872] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6/event6"
[ 5.872] (II) XINPUT: Adding extended input device "Mitsumi Electric Apple Optical USB Mouse" (type: MOUSE, id 11)
[ 5.873] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/mouse1)

 Virtual core pointer id=2 [master pointer (3)]
    Mitsumi Electric Apple Optical USB Mouse id=1...

Read more...

Created attachment 57182
BootDmesg.txt

Created attachment 57183
CurrentDmesg.txt

Created attachment 57184
XorgLog.txt

Created attachment 57185
xinput.txt

Bryce Harrington (bryce) wrote :

Jason Warner - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=46205 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in evdev:
importance: Unknown → Medium
status: Unknown → Confirmed

Bug #45614 may be related to or a dupe of this bug.

*** Bug 45614 has been marked as a duplicate of this bug. ***

Timo Aaltonen (tjaalton) wrote :

I've tried with the oneiric kernel, and it's behaving the same way there.

Actually, now that I'm used to it, the vertical scrolling should be inverted too! :)

Same here for Microsoft Intellimouse Explorer and Logitech Performance MX.

I have the same issue also with a Logitech v450 and a Logitech v100. Horizontal scrolling is reversed ("natural") while vertical scrolling is classic.
The laptop's trackpad works correctly in both directions.

Timo Aaltonen (tjaalton) on 2012-03-07
summary: - Horizontal scrolling on Apple Mighty Mouse reversed recently
+ Horizontal scrolling reversed recently
Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: Bryce Harrington (bryce) → Chase Douglas (chasedouglas)
status: Triaged → Fix Committed
milestone: none → ubuntu-12.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-evdev - 1:2.7.0-0ubuntu1

---------------
xserver-xorg-input-evdev (1:2.7.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - No changes since last git snapshot
  * Fix horizontal scroll direction (LP: #932439)
    - Add 0005-fix-horiz-scrolling.patch from upstream
  * Bump lintian standards version to 3.9.3
 -- Chase Douglas <email address hidden> Thu, 15 Mar 2012 08:40:36 -0700

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Fix Committed → Fix Released
Changed in evdev:
status: Confirmed → In Progress
nerdy_kid (nerdy-kid) wrote :

I have a microsoft 7000 wireless mouse -- my horizontal scrolling shows up as reversed normal scrolling (right is up, left is down). Didn't happen in Oneiric (I'm using Precise) -- perhaps my issue is related to this bug?

Leonard (leonardk-sosdan) wrote :

This may have re-occurred in Vivid.
I just installed 15.04 x64 Desktop, using Nemo in Compact View when just hovering in the directory using the scroll wheel up is right and down is left. This is the reverse of the scroll wheel behaviour in 14.04.

When the mouse is hovered over the scroll bar in Nemo the scroll wheel behaviour is correct (up goes right, down goes left).
I also tested on the scroll bar in Synaptic and found on the non-Unity scroll bar the horizontal direction is reversed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.