Num lock interferes across two keyboards.

Bug #875093 reported by Brian Brunswick on 2011-10-15
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

I have a wireless laptop-style keyboard with no numeric pad, and a separate wireless numeric keypad.

On the keyboard, numlock takes over many of the alphabetic keys to become numerals.
On the keypad, numlock functions to switch between arrow and page nav keys, and numeric keys.

Unfortunately, with oneiric, enabling numlock on the keypad enables it also on the keyboard, preventing me typing many letters. Disabling it on the keyboard doesn't fix this, it needs to be disabled on the keypad.

This use case worked with natty, so this is a regression.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,place,regex,resize,snap,vpswitch,session,imgpng,mousepoll,unitymtgrabhandles,grid,animation,gnomecompat,expo,move,wall,ezoom,workarounds,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sat Oct 15 16:21:08 2011
DistUpgraded: Log time: 2011-10-15 11:42:56.649276
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.881, 2.6.38-11-generic, i686: installed
 fglrx, 8.881, 3.0.0-12-generic, i686: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612] (prog-if 00 [VGA controller])
   Subsystem: ATI Technologies Inc Device [1002:0000]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
JockeyStatus:
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=4db66c39-60c5-41f4-9d1c-837976c7f8b3 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (0 days ago)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: To be filled by O.E.M.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd08/20/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnTobefilledbyO.E.M.:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Brian Brunswick (brian-ithil) wrote :
bugbot (bugbot) on 2011-10-16
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Wouter (passerpunt) wrote :

I hope this can be fixed, I have the same problem on my laptop with a separate numeric keyboard (for data input), does someone have a workaround?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed

Still existing in Ubuntu 12.10 and 13.04

Goran Janković (gogeccc) wrote :

ubuntu 14.04 still has this problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers