Emulate3Buttons option does not work anymore to enable emulation of a middle button

Bug #874237 reported by Susumu Tanimura on 2011-10-14
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

In Oneiric, Emulate3Buttons option is nullified even if setting Emulate3Buttons as true in xorg.conf; however, in Natty, it works with such xorg.conf. The newer evdev driver may be doubtful for this nullification. If not, a nullification against emulation of middle button was added to somewhere in the new Oneiric.
My input device is Kensington Orbit Trackball with Scroll Ring.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 22:33:50 2011
DistUpgraded: Log time: 2011-10-14 11:10:07.154426
DistroCodename: oneiric
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
ProcEnviron:
 PATH=(custom, user)
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=4fefd307-dd58-40e6-9a99-8e15258e5e73 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-input-evdev
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)
dmi.bios.date: 04/14/2010
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BPX5810J.86B.0034.2010.0414.1511
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: WX58BP
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE64643-202
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrBPX5810J.86B.0034.2010.0414.1511:bd04/14/2010:svn:pn:pvr:rvnIntelCorporation:rnWX58BP:rvrAAE64643-202:cvn:ct2:cvr:
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Susumu Tanimura (aruminat) wrote :
Susumu Tanimura (aruminat) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Martin Kopta (martin-kopta) wrote :

I have the same issue. My configuration worked flawlessly on Natty and after upgrade it doesn't work anymore. Well, it actually works, but only for touchpad.

Martin Kopta (martin-kopta) wrote :
Martin Kopta (martin-kopta) wrote :
Lennart Karssen (l.c.karssen) wrote :

Same problem here. In Ubuntu 11.04 I used the attached file (/usr/share/X11/xorg.conf.d/70-logitech-marble-mouse.conf) to get my Logitech trackball to work. On a fresh Ubuntu 11.10 install the scrolling works, but the Emulate3Buttons doesn't.

Ville Ranki (ville-ranki) wrote :

"Me too".
I hope this is fixed on high priority. It is nearly a showstopper, as copy-pasting using ctrl-c ctrl-v is very slow when used to middle button.

SeanK (seank) wrote :

Agreed. This should be a high priority bug. It is a show stopper for me.

lilith (qinjianglei) wrote :

Mine seems working fine.But I'm not sure since I use trackpoint&touchpad most of the time and never paid attention to functions of the middle button. Here's codes in /usr/share/X11/xorg.conf.d/11-evdev-quirks.conf
[code]
Section "InputClass"
 Identifier "Avago Technologies mouse quirks (LP: #746639)"
 MatchIsPointer "on"
 MatchDevicePath "/dev/input/event*"
 Driver "evdev"
 MatchUSBID "192f:0416"
 Option "Emulate3Buttons" "True"
 Option "Emulate3Timeout" "50"
EndSection

Section "InputClass"
 Identifier "Benq m310"
 MatchProduct "HID 0d62:1000"
 Driver "evdev"
 Option "IgnoreAbsoluteAxes" "true"
EndSection

Section "InputClass"

        Identifier "Marble Mouse"

        MatchProduct "Logitech USB Trackball"

        MatchIsPointer "on"

        MatchDevicePath "/dev/input/event*"

        Driver "evdev"

        Option "ButtonMapping" "1 2 3 4 5 6 7 8 9"

        Option "EmulateWheel" "true"

        Option "EmulateWheelButton" "8"

        Option "ZAxisMapping" "4 5"

        Option "XAxisMapping" "6 7"

        Option "Emulate3Buttons" "true"

EndSection
[/code]

Joe Cai (joey-cai) wrote :

@lilith both trackpoint and touchpad work fine, it's the mouse that is not working.

John S (bogustrumper02) wrote :

I'm having the same problem. Emulate3Buttons does not work. I'm using a logitech wheel mouse, part of the MX5500, so pressing the wheel toggles the operation of the wheel itself rather than sending middle-click. With Emulate3Buttons, I was happy enough.

I tried changing the relevant section in /usr/share/X11/xorg.conf.d/10-evdev.conf to:

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
 Option "Emulate3Buttons" "True"
EndSection

...but, no dice. This is what I had to do in 11.04 to make it work; but it doesn't seem like it's working. Very frustrating; I use that copy/paste shortcut all the time.

Anybody have any good workarounds?

Joe Cai (joey-cai) wrote :

It turns out that this is a gnome 3 configuration problem.

[quote from http://who-t.blogspot.com/2011/04/gnome-30-middle-mouse-button-emulation.html ]

GNOME 3.0 has a gsettings key to also trigger this behaviour on a per-user basis (see bug 633863). The default value is off (false). Settings applied from the desktop environment overwrite xorg.conf(.d) settings, so to get middle button emulation in GNOME simply toggle the gsettings key and don't worry about xorg.conf(.d). The command to toggle the key is:

$> gsettings set org.gnome.settings-daemon.peripherals.mouse \
     middle-button-enabled true

[/quote]

Joe Cai (joey-cai) wrote :

btw, the bug 633863 mentioned above should be a gnome one at https://bugzilla.gnome.org/show_bug.cgi?id=633863 , not a launchpad one.

Martin Kopta (martin-kopta) wrote :

I used the proposed command

gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true

and it actually works now. Thank you.

Alison Rowland (alisonrowland) wrote :

The gsettings fix worked for me, as well. Thanks.

Susumu Tanimura (aruminat) wrote :

The gnome-level setting also works for the original reporter. Thank you.

John S (bogustrumper02) wrote :

Wow, thanks joey-cai!

I made a quick bash script for that command in /usr/local/bin. It wasn't obvious to me how to launch it at startup... I found nothing for that in the system settings menu. Then I tried the easy thing... search for startup in the Unity dash. And Startup Applications Preferences came up. Added a call to it there, and it might as well have been set in xorg.conf!

walt (w41ter) wrote :

For future googlers: dconf-editor is an easier way to set the (very stupid) gnome middle-button setting.

Run dconf-editor from a command prompt and navigate to org::gnome::settings-daemon::mouse. You should see the middle-button-enabled checkbox in the right-hand panel.

You should find this 'feature' documented in, um, well, I have NFI where you should find this documented.

This bug report saved me a lot of time, thanks.

Stuart Bishop (stub) on 2013-03-12
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.