mouse pointer disappears in ubuntu (11.04 onwards...)

Bug #774434 reported by Charles Mitchell on 2011-04-30
154
This bug affects 32 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Medium
Unassigned

Bug Description

When hovering mouse over applications, places, or system, on top panel, when the pop up description appears the mouse pointer disappears. If I touch the touchpad, the pointer reappears. Also, when computer boots to desktop the mouse pointer is not shown. again if I touch the touchpad the mouse pointer appears in center of screen. using ubuntu 11.04. This does not happen with ubuntu 10.10. laptop is a gateway 3550GZ. mouse and keyboard preferences are set the same in both instances of ubuntu. Using classic desktop. this computer hardware is not sufficient for Unity.

Jacek Małyszko (jacekmalyszko) wrote :

I am also affected by this bug, after an upgrade to kubuntu 11.04. Exactly the same situation. The situation occurs both with desktop effects switched on and off.

Laptop is lenovo thinkpad r500, video card is some Intel integrated device (Mobile 4 Series Chipset Integrated Graphics Controller). Charles, do you also have an Intel video card? Maybe there's something wrong with the graphics driver or something, since the situation occurs no matter which desktop environment we use...

There is a bug report on exactly the same problem here: https://bugs.launchpad.net/ubuntu/+bug/774510, so these two bug reports probably should be merged.

pzi (pzuyev) wrote :

I have exactly the same issue on my laptop asus n61jv. It also has intel video card.

Unneoetech (nmeuwissen) wrote :

Me too. I have a radeon x300 however. I upgraded from 10.10.

Jacek Małyszko (jacekmalyszko) wrote :

After installation of xserver-xorg-video-intel package, the problem disappeared on my thinkpad. So indeed there's probably something wrong with the default intel video driver. Maybe this will help the other guys with intel video cards - can you check if that solves the problem for you as well, pzi? Still, I don't know why there is also a problem with radeon x3000... :/

pzi (pzuyev) wrote :

yeh, i didn't checked xorg config after ubuntu 10.10 installation because it worked fine out of the box... It was configured to use fbdev driver instead of intel. I just changed line 'Driver "fbdev"' to 'Driver "intel"' in my xorg.config file and this solved my problem. Jacek Małyszko, thank you a lot for your hint :)
P.S. xserver-xorg-video-intel was already installed on my laptop.

Boaz Dodin (bdcomp) wrote :

Me too.

Kubuntu 11.04, 64bit. Upgraded from 10.10.
Nvidia 7300GT.
NVIDIA Driver Version: 270.41.06.

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2011-05-15
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Dhinakar (dhinakar-1989) wrote :

I too face the similar problem...

intel 810 chipset..
intel 82810 graphic card,,
Intel celeron 1.1 Ghz processor
512 RAM...

Please fix this at the earliest....

rojan sinha (rojansinha) wrote :

same problem.

Dave Gilbert (ubuntu-treblig) wrote :

Dual Athlon MP with MGA550 - with hardware or software cursor (see log in 801994).

Was OK on Lucid, went through upgrade to Maverick and then Natty; was ok in Lucid, didn't stay in Maverick long enough to check.

Given the range of hardware I doubt it's a driver issue.

Dave

Timo Aaltonen (tjaalton) wrote :

this is a feature introduced by 'unclutter'

affects: xserver-xorg-input-evdev (Ubuntu) → unclutter (Ubuntu)
Changed in unclutter (Ubuntu):
status: Confirmed → New
Timo Aaltonen (tjaalton) wrote :

hum, apparently unclutter shouldn't be installed by default, so guessing it's gtk doing it?

affects: unclutter (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Dave Gilbert (ubuntu-treblig) wrote :

Timo: I can confirm that the machine I have that's affected by this does NOT have unclutter installed.

Dave

Dave Gilbert (ubuntu-treblig) wrote :

I've been doing some tracing and not reaching many conclusions.

I've been tracing both metacity and the program whose cursor disappears (either soffice or gedit);
I can see a call to gdk_cursor_new_for_display (from the app) when I hit the button to bring up the menu with a cursor type of 14 (bottom right type) that shouldn't cause the cursor to disappear - and anyway I see plenty of calls with 14 at other times and it doesn't disappear. I don't see any calls between the cursor disappearing and it reappearing.

I don't see any calls to XCreatePixmapCursor (usually used to hide the cursor) at the time the cursor disappears - but it might have happened earlier and got cached.

Dave

Dave Gilbert (ubuntu-treblig) wrote :

Some more random bits of data:

1) It doesn't matter which pointer type is in the theme (customised theme, tried DMZ bloack and white and one of the red ones)
2) If I start an X server from the console (sudo Xorg &) and just start metacity, the panel, xterm and then gedit then I can't recreate the problem in the gedit. It still doesn't happen if I start gnome-setting-daemon at that point from the xterm I started.
3) If I start an X server from the console and run gnome-session the session that is started does suffer from the bug.
4) Looking at the debug again I think gdk_cursor_new_for_display is being called with type 68 (gdk_left_ptr) the first time I see it exhibit the bug in gedit (by clicking on Tools)

Dave Gilbert (ubuntu-treblig) wrote :

I broke out xscope to see if I could see anything (not that I'm too familiar with X protocol - it's been a while)
So I had another machine acting as a terminal to control xscope and ran gedit --sync, I breakpointed on ChangeWindowAttribute and clicked the mouse on the menu; when it hit the breakpoint the pointer was still there,
I single stepped and it disappeared on a MapWindow call which I think from the ID and size of the window (found with xwininfo) was the actual popup window.

What I don't quite get is that the pointer is on the menu bar above where that window should popup - so I'm not quite sure why the cursor disappears when it gets mapped.

Dave

Stew (stew-schneider) wrote :

I've got the same problem -- disappearing mouse cursors when hovering. Also an older machine, also running classic for want of sufficient horses to run Unity.

stewart@ubuntu:~$ lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)

Joaquim Arlandis (jarlandi) wrote :

Same problem.

Just to let you know, the only way I've found to recover the mouse pointer while preserving the current user session is by entering the SUSPEND mode and then restarting the computer. This way, after the video driver settings are restored the pointer is visible again.

Jesus M Diaz (jesusm) wrote :

I'm having this problem too. Mouse pointer desappearing randomly and the it appears again ...

I have a freshly installed Ubuntu 11.04, but days ago I had Ubuntu 11.04 upgraded from a 10.04, and never saw the issue ¿?

Changed in gtk+2.0 (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Incomplete
jtl999 (jtl999) wrote :

Happens on custom build with Ati radon hd 6770

Dave Gilbert (ubuntu-treblig) wrote :

I've just:
  1) Added xorg to the bug because I'm also seeing in a KDE session inside a kvm guest on a separate machine - the KDE session is actually built from source, rather than kubuntu. However given it's the same symptoms and gtk shouldn't be involved it sounds like it may be more widespread.
  2) I knocked gtk's state out of 'incomplete' since questions had been answered since it was set.

Dave

affects: gtk+2.0 (Ubuntu) → ubuntu
Changed in ubuntu:
status: Incomplete → New
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2011-09-11
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Changed in ubuntu:
status: New → Confirmed
Lord Delta (lorddefinitia) wrote :

Having this problem as well, just started recently (possibly a recent regression?). Anyways now the pointer likes to disappear when I hover over stuff.

Running an Nvidia card here.

P Cantwall (p-cantwell) wrote :

This just happened to me, after some recent updates.

ATI x200 (I need to upgrade!)

Fredrik Staxäng (fstx01) wrote :

Me too. GeForce 6150 integrated graphics, PS/2 mouse connected through cheap KVM. The machine reacts to
mouse movements with highlights, but it is impossible to use the machine. I upgraded to 11.04 a week or so ago,
and I just noticed the problem.

Is there a better workaround than rebooting? (Or logging out/in, which I don't know how to do without a mouse)

velo (2-tdch-a) wrote :

Ive got the same.

I found a stupid workaround to show the mouse for a short time again:

#!/bin/sh

alltray --notray lxappearance &
sleep 3
pkill -f lxappearance

... It is totally frustrating. (Going to buy a Mac soon - it just works)

Steven Garner (stevenjgarner) wrote :

Any love on this yet? Also affects my Netbook:

eMachines eM250 upgraded to 11-10 from original install of 9.10
Intel Atom CPU N270 1.60GHz
InsydeH20 BIOS

... why would this bug be considered of "low" importance, requiring a system reboot?

Dave Gilbert (ubuntu-treblig) wrote :

Steven; can you explain why this requires a reboot - that's not the behaviour I've seen.
For me, the mouse disappears until you move it and it reappears and then disapears again - reboots
don't help.

Dave

Erin Spiceland (erinspice) wrote :

I am also experiencing this problem the way Dave, previous, describes it. My mouse goes in and out when it is still but never disappears when moving. I also do not have unclutter installed.

Dave Gilbert (ubuntu-treblig) wrote :

I've just encountered this on my Quantul box; it lost the xserver-xorg-video-radeon driver (see separate bugs) - so it seems to be doing it with the FB driver it's dropped back to.

xserver-xorg-core 2:1.12.1.902-1ubuntu1

summary: - mouse pointer disappears in ubuntu 11.04
+ mouse pointer disappears in ubuntu (11.04 onwards...)

I have a similar problem in Ubuntu 12.04 LTS. The mouse pointer disappears in some clickable areas. After touching the pad the pointer appears again... I did not find any bug report for 12.04...

bugbot (bugbot) on 2012-06-28
tags: added: natty
Dave Gilbert (ubuntu-treblig) wrote :

Hi Maurico - what graphics card do you have in your LTS box?

This is the information... (it is a netbook samsung):

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Samsung Electronics Co Ltd Device c629
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at dfc00000 (32-bit, non-prefetchable) [size=1M]
        I/O ports at f100 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>

Paolo Pagano (p-pagano) wrote :

Hi all,
I also face the same problem on a Dell laptop (E4310 model, Latitude series): mouse disappears on windows containing clickable areas and some text.
I attach information about my VGA controller:

$ lspci -vv

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics C
ontroller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0410
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SER
R- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort-
>SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 42
        Region 0: Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 60b0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel modules: i915

cat (netcat-z) wrote :

same for me. It began not long ago. Ubuntu 12.04 upgraded. Intel i915 module.

Martin (ub71-martin) wrote :

Does the issue looks like this ? http://youtu.be/NmRP9S744rk

exactly!
Paolo

On Mon, 2013-01-28 at 10:31 +0000, Martin wrote:
> Does the issue looks like this ? http://youtu.be/NmRP9S744rk
>

--
Paolo Pagano, Experimental Physics PhD
Real Time Networks area leader,
National Laboratory of Photonic Networks - CNIT
Via Moruzzi 1, 56124 Pisa - Italy
Tel. +39 050 882034 Fax. +39 050 882003
http://rtn.sssup.it/

David Weiss (thatstheway) wrote :

Hi, I'm also getting this on 12.04. My machine is a Toshiba Portege R100 with a Trident Microsystems CyberBlade XP4m32 (rev 91) graphics card running on the xserver-xorg-video-trident driver. The desktop defaults to Unity 2D, I think because of the limitations of my graphics card.

I'm not running unclutter.

It SEEMS to only happen with DMZ-White.

For me this issue is intermittent. 90% of the time, restarting and THEN logging out and back in restores the cursor to normal. A simple restart or log out almost never works (By "normal" I mean that it doesn't disappear over icons.) If the cursor is behaving normally, I can reliably "cause" the problem by starting Software Center.

Dave Gilbert (ubuntu-treblig) wrote :

I've just seen this on an openSUSE vm, so whatever it is, it's not just Ubuntu.

ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
MachineType: ASUSTeK Computer Inc. EP121
MarkForUpload: True
Package: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.12.0-7-generic root=UUID=ed47090a-aa26-4a86-b5e2-dddaee9b1a2a ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Tags: trusty ubuntu single-occurrence reproducible
Uname: Linux 3.12.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm lpadmin sambashare sudo
dmi.bios.date: 08/07/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 704
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: EP121
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr704:bd08/07/2012:svnASUSTeKComputerInc.:pnEP121:pvr1.0:rvnASUSTeKComputerInc.:rnEP121:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: EP121
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.50-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Mon Jan 6 13:49:56 2014
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.5-1ubuntu2

tags: added: apport-collected reproducible single-occurrence trusty ubuntu

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tuxiano (tuxiano) wrote : Lspci.txt

apport information

tuxiano (tuxiano) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

tuxiano (tuxiano) wrote : UdevDb.txt

apport information

apport information

apport information

apport information

apport information

tuxiano (tuxiano) wrote : xinput.txt

apport information

no longer affects: ubuntu
tags: added: saucy
Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Jaime Pérez (jaime-91) wrote :

Same problem here. I have uploaded info to bug 1276820 and bug 1238410

Jaime Pérez (jaime-91) wrote :

Well perhaps is not the same problem. I just can't see my pointer in some windows (when using metacity) or in all windows except firefox(when using compiz)

Jaime Pérez (jaime-91) wrote :

apt-get purge kubuntu* plasma-desktop*
fixed the problem

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions