Middle mouse button no longer works

Bug #710762 reported by Tim Cuthbertson on 2011-01-31
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
xserver-xorg-input-evdev (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-evdev

Since the update of xserver-xorg-input-evdev version 1:2.6.0-1ubuntu1, middle mouse button emulation (left and right click together) no longer triggers a middle click in Natty. I have since upgraded to version 1:2.6.0-1ubuntu3, but the middle mouse button still fails to function.

A workaround is to add the following section to /etc/X11/xorg.conf, but workaround should not be necessary to provide standard X11 functionality.

Section "InputClass"
Identifier "middle button emulation class"
MatchIsPointer "on"
Option "Emulate3Buttons" "on"
EndSection

1) Release: 11.04
2) Package version xserver-xorg-input-evdev 1:2.6.0-1ubuntu3
3) Expect middle mouse button to perform Past action
4) Middle mouse button fails to operate

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-input-evdev 1:2.6.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 260.19.29 Wed Dec 8 12:09:09 PST 2010
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-2ubuntu1)
Architecture: i386
Date: Mon Jan 31 10:48:53 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 260.19.29, 2.6.38-1-generic, i686: installed
 nvidia-current, 260.19.29, 2.6.37-12-generic, i686: installed
GraphicsCard:

InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110125)
MachineType: Shuttle Inc SB83V10
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=756673fd-3f0d-437f-92cf-b590e2c5c6c0 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-input-evdev
UnitySupportTest:

dmi.bios.date: 07/13/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: FB83V10
dmi.board.vendor: Shuttle Inc
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd07/13/2005:svnShuttleInc:pnSB83V10:pvr:rvnShuttleInc:rnFB83V10:rvr:cvn:ct3:cvr:
dmi.product.name: SB83V10
dmi.sys.vendor: Shuttle Inc
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Tim Cuthbertson (ratcheer) wrote :
sojourner (itsmealso2) wrote :

when a change is made to basic behavior like this it should be widely announced not just buried in a change log somewhere and preferably it should be discussed with the community first .

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Dylan McCall (dylanmccall) wrote :

Sojourner, did you find a changelog that relates to this bug? I was just looking and I couldn't find anything that sounded related within Ubuntu, though it could be something upstream. (I haven't looked there yet).

If you still have that change and version number handy, I'm sure it would help to figure out what is wrong and resolve it :)

description: updated
Dylan McCall (dylanmccall) wrote :

Okay, this was indeed an intentional upstream change in xf86-input-evdev. The changelog happens to carry some reasoning, too:

commit 21a2ac818e75ef918d320ce1e88b6263e68e598d
Author: Peter Hutterer <email address hidden>
Date: Fri May 28 09:47:17 2010 +1000

    Disable middle mouse button emulation by default.

    The AUTO feature was the default, MB emulation was on until a middle mouse
    button was pressed. MB emulation however results in a delay of the first
    press, causing minor annoyances to the users and being generally confusing
    when the behaviour before a button press is different to after a button
    pres.

    Disable the feature by default instead. There's not a lot of two-button mice
    around anymore though and the inability to detect two-button mice makes for
    non-deterministic detection of when the emulation should be on.

    Middle button emulation can be enabled with a configuration snippet:

    Section "InputClass"
            Identifier "middle button emulation"
            MatchIsPointer "on"
            Option "Emulate3Buttons" "on"
    EndSection

So, this is a little different than I thought. (And it even teaches me something I didn't know: it's hard to detect if a mouse only has two buttons!). We should keep an eye on what other distros do with this change. If Fedora, Debian, etc. choose to revert it, we should probably consider doing the same. Otherwise, it's effectively the new standard.
Another thing to keep in mind is two-button mouses / middle clicking in general / left+right to middle click are kind of power-user features, so we can expect power-users to be happy configuring these things.

I think this should definitely go in the release notes :)

Timo Aaltonen (tjaalton) wrote :

Peter is a Redhat employee, so doubt that Fedora will change it. Likewise, Debian sticks to the defaults so they are not going to change it either, which means that we shouldn't.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Won't Fix
Nerd_bloke (nerd-bloke) wrote :

The vast majority of laptops only have two buttons next to the trackpad, won't this will effect everyone who doesn't connect an external three button mouse?

Bryce Harrington (bryce) wrote :

I think we need to consider this a bit deeper. There is still hardware in the wild that appears to need this emulated functionality to do middle mouse button clicking, for example:

  http://shop.canonical.com/product_info.php?products_id=643

Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → High
status: Won't Fix → Triaged
Bryce Harrington (bryce) wrote :

I've added an entry about this issue to the ReleaseNotes: https://wiki.ubuntu.com/NattyNarwhal/TechnicalOverview

Changed in ubuntu-release-notes:
status: New → Fix Committed
Bryce Harrington (bryce) wrote :

I've discussed this with some of the other Ubuntu-X guys, and we've decided not to revert upstream's change. 2-button mice do not seem to be very common, and it appears to be feasible for us to add special-case quirks via udev for particular ones that people want to have work.

Thus, this particular general request to revert upstream's change I'm closing as a WONTFIX, and I have documented the process for bug reporters to file to request special enablement of their hardware, at https://wiki.ubuntu.com/X/Quirks#2-button%20Mice - if people find these directions incomplete, please update the wiki to clarify.

So in summary, if you have a 2-button mouse with this problem, please file a new bug for that specific HW. See the above link for directions.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Triaged → Won't Fix
JT (spikyjt) wrote :

So two claims here and in the Natty "Known Issues" list that 2 button mice are "quite rare" or "not very common". Yet the point made by an earlier poster is ignored - nearly all laptops (except Macs) have only two buttons. I understand that most developers may use a desktop machine or a mouse connected to their laptop, but those of us who work on the go often don't have space for a rodent. The third button is a key tool in Linux/X and especially important to me. Ignoring users with slightly different hardware to yourself = bad news. Please try to think about other people's use cases, not just those that seem obvious to you.

Patrick Scott (patrickscott52) wrote :

I agree, especially since middle-click is going to be an important feature in Unity as a shortcut to open new instances of an application, there needs to be support for trackpad users. Like a lot of laptop users, I never sit at a desk and hook up a mouse. At the very least, an entry should be added to the mouse settings in the Control Center for non-"power" users to configure.

Jeroen Hoek (mail-jeroenhoek) wrote :

Editing xorg.conf should really never be the only solution for such a rudimentary accessibility feature. As #6 and #11 point out, there are actually a lot of two-button mice out there; on nearly every laptop and netbook sold the past 15 years the track-pad includes only a left and a right mouse button.

In addition to the Unity functionality mentioned above, the middle mouse button also functions as the paste action for selected text; this is often very useful in a terminal where ctrl+c ctrl+v does not work (which is what bit me just now, making me wonder what changed). It would be nice if an option could be added to the mouse configuration tool to allow middle mouse button emulation.

If this only affected a few mice I would agree with Bryce's WONTFIX, but there are millions of built-in two-button track-pad mice out there. I think "quite rare" is a bit of an understatement.

Edmond Dantes (edantes) wrote :

Even supposedly 3-button mice need the emulation. The typical generic ones detect the middle mouse by a click on the scroll wheel. Usually this is very clumsy, making the emulation much easier to use.

Franco (francogpellegrini) wrote :

i have 11.04 final, and my middle button doesnt work after a clean ubuntu installation (if i upgrade from 10.10 it work)

Timo Aaltonen (tjaalton) wrote :

If you have a touchpad using the synaptics driver, then you still have emulation by default. Only the evdev driver default got changed.

In 11.10 there will probably be a GUI for this once the GNOME 3.0 bits land Oneiric, see http://who-t.blogspot.com/2011/04/gnome-30-middle-mouse-button-emulation.html

ZiNk (cserpentis) wrote :

Simulation used to work nicely for Logitech V450 before 11.04 (in V450 middle click is activated by clicking buttons 6 and 7 simultaneously by pressing the tilting wheel), is it possible to re-enable this behavior through xorg.conf or any other way? Wheel click is much more convenient, than trying to time left and right mouse button clicks.

Gantry York (gantry-york) wrote :

I've just upgraded from 10.10 to 11.04 and the traditional select-and-paste of X no longer works. This is to say that I can not hold down the right button to select something then paste it else where with the middle button (the middle button is simulated by pressing both the left and right mouse buttons simultaneously)

I have typical mouse with a right button, scroll wheel, and left button.

I have been using the select-and-paste feature of X since the 90's....as have most X users. I don't think this is going to set well with your users.

Jamie Lokier (jamie-shareable) wrote :

I agree with comment #13 - middle clicking on a mouse's scroll wheel is quite difficult and clicking left+right buttons together is easier. Some mice are worse than others for this (some have too little wheel resistance), but all of them require more care to click on the wheel (without scrolling it) than clicking buttons.

So among other things, this is an accessibility issue.

Also as I mainly use a laptop, I'm used to clicking the two touchpad buttons for pasting text, so it feels more natural to do that with a separate mouse, on the rare occasions when I use one. But that is of course quite personal.

I understand the rationale for upstream's change, but I've never noticed noticed the single button lag or any problems arising from it. But maybe I'm just used to it.

Finally, the obvious thing that seems to be missing is a tick box under System -> Preferences -> Mouse to decide this behaviour. Editing xorg.conf for something like this makes no sense when other basic mouse preferences are configured via the GUI.

The idea that only power users use middle-click to paste and power users can edit xorg.conf (comment #4) is nonsense (as well as being an example of a logical fallacy). Lots of GUI text-pasting users never edit system files or do any system administration at all, and even some casual users learn that way of pasting. Even if that's minority usage, they aren't the same subset as those who are comfortable using sudo and editing config files - or even using the command line.

Benjamin RIOU (benjamin-riou) wrote :

I had this issue. The workaround provided me a solution.
But this is unbeliveable to see that bug is not fixed since the beggining of this year !

Timo Aaltonen (tjaalton) wrote :

On oneiric it's enough to run:

gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true

that'll make it persistent for the current user, and you can argue about adding it to the "mouse and touchpad" settings GUI by filing a bug against gnome-control-center.

The evdev driver will get a quirk table for known devices (mice, trackballs) that only have two buttons, hopefully we'll have something for oneiric.

lazychris2000 (lazychris2000) wrote :

I have a Logitech Revolution MX on both my home and work PCs (both running Natty x64). The mouse wheel is not a button, it lets me switch between "normal" scrolling and "super fast, low friction" scrolling. Just because 2 button mice are hard to come by doesn't mean people don't need to have this functionality. Disable it if you need to, but give us an easy way to reenable it. I don't think it is too much to ask for to have a checkbox or something in the mouse configuration that reenables it. Manually editing the xorg configuration is an unacceptable fix for this.

Peter Silva (peter-bsqt) wrote :

I use a laptop, it has a synaptics trackpad, and there is no middle button emulation. I think a GUI way to turn it off/on is necessary.

Jimmy Guo (mrjyguo) wrote :

I have a Microsoft PS/2 mouse with track wheel. After upgrading from Ubuntu 9.10 to Lubuntu 11.10, I had to apply the evdev Emulate3Buttons change to /usr/share/X11/xorg.conf.d/ to get the middle button back.

There you go ... sameo sameo for Oneiric. Strongly agree with a substantial fix, aka not in the form of release notes. I don't read release notes, but just out of curiosity, it's only in the 11.04 release notes, not 11.10. It may seem old news to maintainers but users do not follow release notes, esp. older releases'. But I guess this brings up another request: verify and carry over known issues from past releases if they are still relevant!

Jimmy Guo (mrjyguo) wrote :

BTW:
# grep -i mouse /var/log/udev
KERNEL[13.617528] add /module/psmouse (module)
DEVPATH=/module/psmouse
KERNEL[13.673889] add /bus/serio/drivers/psmouse (drivers)
DEVPATH=/bus/serio/drivers/psmouse
UDEV [13.921057] add /module/psmouse (module)
DEVPATH=/module/psmouse
UDEV [13.922230] add /bus/serio/drivers/psmouse (drivers)
DEVPATH=/bus/serio/drivers/psmouse
NAME="ImPS/2 Generic Wheel Mouse"
KERNEL[14.735162] add /devices/platform/i8042/serio1/input/input3/mouse0 (input)
DEVPATH=/devices/platform/i8042/serio1/input/input3/mouse0
DEVNAME=input/mouse0
NAME="ImPS/2 Generic Wheel Mouse"
ID_INPUT_MOUSE=1
ID_INPUT_MOUSE=1
DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
UDEV [14.743604] add /devices/platform/i8042/serio1/input/input3/mouse0 (input)
DEVPATH=/devices/platform/i8042/serio1/input/input3/mouse0
DEVNAME=/dev/input/mouse0
ID_INPUT_MOUSE=1
DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-mouse

Adam Conrad (adconrad) on 2012-04-26
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released

Hi, I'm using Ubuntu 14.04.1 LTS on a System 76 laptop, with a two button built-in touch-pad (built into the laptop just below the keyboard). When I click to drag or resize a window there is a half second delay, which annoyingly, causes me to fail to drag or resize the window. What should I do to eliminate that delay? I was lead to believe that it's related to 3-button emulation. If so, how can I turn it off?

Thank you.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/710762

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers